énormes problèmes dans /dev

Le
arenevier
Salut,
j'utilise debian unstable, noyau 2.6.22 recompilé pour désactiver
CONFIG_KEYBOARD_ATKBD. Jusqu'à hier, tout allait bien. Mais en redémarrant ce
matin, mon ordi ne marchait plus très bien. J'ai relevé les problèmes
suivants:

* la clé usb ne marche plus. Ca m'embete vraiment beaucoup vu que je crypte
mon /home, et que je mets la clé dessus. En fait, quand je branche la clé,
j'ai bien ces messages là :

usb 5-1: new high speed USB device using ehci_hcd and address 6
usb 5-1: configuration #1 chosen from 1 choice

Par contre, /dev/sda1 n'est pas créé, j'ai juste des fichiers qui s'appellent
/dev/usbdev5.6_ep00 /dev/usbdev5.6_ep02 /dev/usbdev5.6_ep81, et qui sont de
type "character special" (d'après file).

* Après avoir enfin réussi à booter, j'ai plein d'erreurs qui sont liées au
fait que les permissions de /dev/null sont crw-rw- Résultat: en tant
qu'utilisateur, je n'ai accès ni en écriture, ni en lecture à /dev/null. J'ai
remis ces permissions "à la main" avec chmod en tant que root, ca passe, mais
c'est étrange.

* Ensuite, une fois que ma session s'est lancée, je peux lancer certaines
applications, comme des applications gtk, mais par contre, je ne pas lancer
de xterm. Sinon, en console, la plupart des commandes fonctionnent, mais
certaines non (comme ssh qui dit: PRNG is not seeded).

Et je suis vraiment embeté parceque je sais pas du tout de quel coté chercher.
Je soupconne un peu udev, mais vu qu'il n'a pas été mis à jour hier, je ne
suis pas sur.

La seule bidouille que j'ai faite hier, c'est de désactiver le polling de hal,
en mettant dans /etc/hal/fdi/policy/preferences.fdi
<device>
<match key="storage.hotpluggable" bool="false">
<merge key="storage.media_check_enabled" type="bool">false</merge>
</match>
</device>


A la fin du mail, je vous mettrais la liste des paquets qui ont été mis à jour
hier. J'ai downgradé certains qui me semblaient "louches": dmsetup, lsb-base,
lsb-release, et libblkid1 vers les versions de la veille (avant-hier), mais ca
n'a rien changé. J'ai aussi effectué une nouvelle mise à jour qui a upgradé
des choses comme tor, xserver, sysvinit ou gtk. Mais, ca n'a rien amélioré non
plus.

Dans les logs de /var/log, je ne trouve rien de particulier.

Est-ce que vous avez une idée de la direction dans laquelle commencer à
chercher ?

merci d'avance

arno

[MIS A JOUR] comerr-dev 2.1-1.41.0-2 -> 2.1-1.41.0-3
[MIS A JOUR] cpufrequtils 002-7.2 -> 004-1
[MIS A JOUR] curl 7.18.2-6 -> 7.18.2-7
[MIS A JOUR] devscripts 2.10.33 -> 2.10.34
[MIS A JOUR] djvulibre-desktop 3.5.20-7 -> 3.5.20-8
[MIS A JOUR] dmsetup 2:1.02.27-1 -> 2:1.02.27-2
[MIS A JOUR] e2fslibs 1.41.0-2 -> 1.41.0-3
[MIS A JOUR] e2fsprogs 1.41.0-2 -> 1.41.0-3
[MIS A JOUR] file 4.24-4 -> 4.25-1
[MIS A JOUR] git-doc 1:1.5.6.2-1 -> 1:1.5.6.3-1
[MIS A JOUR] gsfonts 1:8.11+urwcyr1.0.7~pre43-2 -> 1:8.11+urwcyr1.0.7~pre44-2
[MIS A JOUR] iceape 1.1.10-1 -> 1.1.11-1
[MIS A JOUR] iceape-browser 1.1.10-1 -> 1.1.11-1
[MIS A JOUR] iceape-gnome-support 1.1.10-1 -> 1.1.11-1
[MIS A JOUR] iceape-mailnews 1.1.10-1 -> 1.1.11-1
[MIS A JOUR] iceweasel 3.0~rc2-2 -> 3.0.1-1
[MIS A JOUR] libblkid1 1.41.0-2 -> 1.41.0-3
[MIS A JOUR] libcomerr2 1.41.0-2 -> 1.41.0-3
[MIS A JOUR] libcompress-raw-zlib-perl 2.011-2 -> 2.012-1
[MIS A JOUR] libcompress-zlib-perl 2.011-1 -> 2.012-1
[MIS A JOUR] libcpufreq0 002-7.2 -> 004-1
[MIS A JOUR] libcurl3 7.18.2-6 -> 7.18.2-7
[MIS A JOUR] libcurl3-gnutls 7.18.2-6 -> 7.18.2-7
[MIS A JOUR] libcurl4-gnutls-dev 7.18.2-6 -> 7.18.2-7
[MIS A JOUR] libdevmapper1.02.1 2:1.02.27-1 -> 2:1.02.27-2
[MIS A JOUR] libdjvulibre21 3.5.20-7 -> 3.5.20-8
[MIS A JOUR] libdvdnav4 4.1.2-2 -> 4.1.2-3
[MIS A JOUR] libdvdread3 0.9.7-10 -> 0.9.7-11
[MIS A JOUR] libenchant1c2a 1.3.0-5.1 -> 1.4.2-3
[MIS A JOUR] libgif4 4.1.6-4 -> 4.1.6-5
[MIS A JOUR] libhunspell-1.2-0 1.2.5-1 -> 1.2.6-1
[MIS A JOUR] libhunspell-dev 1.2.5-1 -> 1.2.6-1
[MIS A JOUR] libio-compress-base-perl 2.011-1 -> 2.012-1
[MIS A JOUR] libio-compress-zlib-perl 2.011-1 -> 2.012-1
[MIS A JOUR] liblircclient0 0.8.2-2 -> 0.8.3-1
[MIS A JOUR] libmagic1 4.24-4 -> 4.25-1
[MIS A JOUR] libmozjs-dev 1.9~rc2-5 -> 1.9.0.1-1
[MIS A JOUR] libmozjs1d 1.9~rc2-5 -> 1.9.0.1-1
[MIS A JOUR] libncurses5 5.6+20080621-2 -> 5.6+20080713-1
[MIS A JOUR] libncurses5-dev 5.6+20080621-2 -> 5.6+20080713-1
[MIS A JOUR] libncursesw5 5.6+20080621-2 -> 5.6+20080713-1
[MIS A JOUR] libnss3-1d 3.12.0-2 -> 3.12.0-4
[MIS A JOUR] libnss3-dev 3.12.0-2 -> 3.12.0-4
[MIS A JOUR] libpcre3 7.6-2 -> 7.6-2.1
[MIS A JOUR] libperl5.10 5.10.0-11 -> 5.10.0-11.1
[MIS A JOUR] libss2 1.41.0-2 -> 1.41.0-3
[MIS A JOUR] libssl-dev 0.9.8g-10.1 -> 0.9.8g-11
[MIS A JOUR] libssl0.9.8 0.9.8g-10.1 -> 0.9.8g-11
[MIS A JOUR] libstdc++5 1:3.3.6-17 -> 1:3.3.6-18
[MIS A JOUR] libupnp3 1.6.6-1 -> 1:1.6.6-2
[MIS A JOUR] libuuid1 1.41.0-2 -> 1.41.0-3
[MIS A JOUR] lsb-base 3.2-13 -> 3.2-15
[MIS A JOUR] lsb-release 3.2-13 -> 3.2-15
[MIS A JOUR] lynx-cur 2.8.7dev9-1.1 -> 2.8.7dev9-1.2
[MIS A JOUR] manpages 3.02-1 -> 3.03-1
[MIS A JOUR] manpages-dev 3.02-1 -> 3.03-1
[MIS A JOUR] mysql-common 5.0.51a-9 -> 5.0.51a-10
[MIS A JOUR] mysql-server 5.0.51a-9 -> 5.0.51a-10
[MIS A JOUR] ncurses-base 5.6+20080621-2 -> 5.6+20080713-1
[MIS A JOUR] ncurses-bin 5.6+20080621-2 -> 5.6+20080713-1
[MIS A JOUR] ntpdate 1:4.2.4p4+dfsg-6 -> 1:4.2.4p4+dfsg-7
[MIS A JOUR] openssl 0.9.8g-10.1 -> 0.9.8g-11
[MIS A JOUR] perl 5.10.0-11 -> 5.10.0-11.1
[MIS A JOUR] perl-base 5.10.0-11 -> 5.10.0-11.1
[MIS A JOUR] perl-doc 5.10.0-11 -> 5.10.0-11.1
[MIS A JOUR] perl-modules 5.10.0-11 -> 5.10.0-11.1
[MIS A JOUR] perl-suid 5.10.0-11 -> 5.10.0-11.1
[MIS A JOUR] python-crypto 2.0.1+dfsg1-2.2 -> 2.0.1+dfsg1-2.3
[MIS A JOUR] python-xpcom 1.9~rc2-5 -> 1.9.0.1-1
[MIS A JOUR] reportbug 3.42 -> 3.43
[MIS A JOUR] spidermonkey-bin 1.9~rc2-5 -> 1.9.0.1-1
[MIS A JOUR] strace 4.5.15-1.2 -> 4.5.16+cvs20080708-1
[MIS A JOUR] tcl8.5 8.5.3-1 -> 8.5.3-2
[MIS A JOUR] tk8.3 8.3.5-13 -> 8.3.5-14
[MIS A JOUR] tk8.4 8.4.19-1 -> 8.4.19-2
[MIS A JOUR] tk8.5 8.5.3-1 -> 8.5.3-2
[MIS A JOUR] tor 0.1.2.19-3 -> 0.2.0.30-1
[MIS A JOUR] uuid-runtime 1.41.0-2 -> 1.41.0-3
[MIS A JOUR] w3-recs 20070917-1 -> 20080716-1
[MIS A JOUR] whois 4.7.26 -> 4.7.27
[MIS A JOUR] wpasupplicant 0.6.3-2 -> 0.6.4~git20080716.93ef879-1
[MIS A JOUR] xulrunner-1.9 1.9~rc2-5 -> 1.9.0.1-1
[MIS A JOUR] xulrunner-dev 1.9~rc2-5 -> 1.9.0.1-1
[MIS A JOUR] zsh 4.3.6-4 -> 4.3.6-5

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to debian-user-french-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
François Boisson
Le #16368921
Le Sat, 19 Jul 2008 09:22:32 +0000 (UTC)
a écrit:

Salut,
j'utilise debian unstable, noyau 2.6.22 recompilé pour désactiver
CONFIG_KEYBOARD_ATKBD. Jusqu'à hier, tout allait bien. Mais en redémarrant ce
matin, mon ordi ne marchait plus très bien. J'ai relevé les problèmes
suivants:




Mathieu Janin a eu des pbms de cet ordre,du à des changements de droits mal
fait par udev. Rétrograde udev ou bien vire ou rectifie
/etc/udev/rules.d/65_dmsetup.rules

Va jeter un oeil là: http://bugs.debian.org/cgi-bin/bugreport.cgi?bugI1107

François Boisson

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
arenevier
Le #16369571
François Boisson

Mathieu Janin a eu des pbms de cet ordre,du à des changements de droits mal
fait par udev. Rétrograde udev ou bien vire ou rectifie
/etc/udev/rules.d/65_dmsetup.rules



Super, j'ai fait la modif dans /etc/udev/rules.d/65_dmsetup.rules, et ça a
tout réparé :)

merci beaucoup.

a+
arno

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Publicité
Poster une réponse
Anonyme