Enregistrement emission TNT avec mplayer

Le
Geo Cherchetout
Bonjour,

Je voudrais programmer l'enregistrement d'une émission de télévision qui
sera diffusée en mon absence. Mplayer semble tout indiqué pour ça avec son
option -dumpstream mais je n'arrive pas à visionner les enregistrements
produits lors de mes essais. Mplayer joue bien le son mais affiche le
message Video: no video. La taille du fichier produit, environ 5MiB pour 10
secondes d'enregistrement, semble pourtant assez conséquente pour contenir
audio et vidéo.
Pour décomposer le problème, j'essaie de visionner une chaîne en temps réel
et je n'obtiens ni image ni son. Voici ce que ça donne, étant entendu que je
n'ai aucun fichier channels.conf ou équivalent :

$ mplayer dvb://"ARTE"
MPlayer SVN-12.r37337.3.mga5.tainted-4.9.2 (C) 2000-2014 MPlayer Team
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing dvb://ARTE.
dvb_tune Freq: 538167000
TS file format detected.
VIDEO MPEG2(pidr0) AUDIO A52(pids0) NO SUBS (yet)! PROGRAM N. 0


MPlayer interrupted by signal 2 in module: video_read_properties
dvb_streaming_read, attempt N. 6 failed with errno 4 when reading 2668 bytes

(Je dois taper deux fois ctrl+C pour récupérer la main et voir s'éteindre la
LED de mon tuner Terratec Cinergy T2.)

Il est à noter que la fréquence 538167000 n'est pas celle du multiplex qui
supporte ARTE dans mon secteur mais celle du multiplex supportant TF1 et
compagnie, mais ce n'est pas le plus grave. Je serais déjà encouragé si
j'obtenais l'image et le son d'une chaîne quelconque.

Quelqu'un peut-il me mettre sur la voie ?
Vos réponses Page 1 / 3
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Sergio
Le #26426836
Le 20/02/2017 à 15:42, Geo Cherchetout a écrit :
Bonjour,
Je voudrais programmer l'enregistrement d'une émission de télévision qui sera diffusée en mon absence. Mplayer semble tout indiqué
pour ça avec son option -dumpstream mais je n'arrive pas à visionner les enregistrements produits lors de mes essais. Mplayer joue
bien le son mais affiche le message Video: no video. La taille du fichier produit, environ 5MiB pour 10 secondes d'enregistrement,
semble pourtant assez conséquente pour contenir audio et vidéo.

déjà quel message d'erreur te dis Mplayer ? Quel codec essaie-t-il de lire ?
Pour décomposer le problème, j'essaie de visionner une chaîne en temps réel et je n'obtiens ni image ni son. Voici ce que ça donne,
étant entendu que je n'ai aucun fichier channels.conf ou équivalent :
$ mplayer dvb://"ARTE"
MPlayer SVN-12.r37337.3.mga5.tainted-4.9.2 (C) 2000-2014 MPlayer Team
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.
Playing dvb://ARTE.
dvb_tune Freq: 538167000
TS file format detected.
VIDEO MPEG2(pidr0) AUDIO A52(pids0) NO SUBS (yet)! PROGRAM N. 0

"VIDEO MPEG2" ? Il n'y a plus de MPEG2 sur la TNT depuis un certain temps (du moins en France) : Toutes les chaînes sont en MPEG4
(HD ou pas).
As-tu essayé avec un autre lecteur vidéo comme VLC qui a ses propres codecs ?
--
Serge http://leserged.online.fr/
Mon blog: http://cahierdesergio.free.fr/
Soutenez le libre: http://www.framasoft.org
Geo Cherchetout
Le #26426835
Le 20/02/2017 15:42, j'ai écrit :
Pour décomposer le problème, j'essaie de visionner une chaîne en temps réel
et je n'obtiens ni image ni son. Voici ce que ça donne, étant entendu que je
n'ai aucun fichier channels.conf ou équivalent :

Avec un fichier channels.conf fraîchement créé, mplayer se branche bien sur
le bon canal mais le résultat est le même : ni son ni image en temps réel et
seulement le son en lecture d'un enregistrement.
Sergio
Le #26426838
Le 20/02/2017 à 16:27, Sergio a écrit :
Le 20/02/2017 à 15:42, Geo Cherchetout a écrit :
Bonjour,
Je voudrais programmer l'enregistrement d'une émission de télévision qui sera diffusée en mon absence. Mplayer semble tout indiqué
pour ça avec son option -dumpstream mais je n'arrive pas à visionner les enregistrements produits lors de mes essais. Mplayer joue
bien le son mais affiche le message Video: no video. La taille du fichier produit, environ 5MiB pour 10 secondes d'enregistrement,
semble pourtant assez conséquente pour contenir audio et vidéo.

déjà quel message d'erreur te dis Mplayer ? Quel codec essaie-t-il de lire ?

Pour avoir le codec tu peux utiliser la commande mediainfo (à installer éventuellement).
--
Serge http://leserged.online.fr/
Mon blog: http://cahierdesergio.free.fr/
Soutenez le libre: http://www.framasoft.org
Geo Cherchetout
Le #26426837
Le 20/02/2017 16:27, *Sergio* a écrit :
$ mplayer dvb://"ARTE"
MPlayer SVN-12.r37337.3.mga5.tainted-4.9.2 (C) 2000-2014 MPlayer Team
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.
Playing dvb://ARTE.
dvb_tune Freq: 538167000
TS file format detected.
VIDEO MPEG2(pidr0) AUDIO A52(pids0) NO SUBS (yet)! PROGRAM N. 0

"VIDEO MPEG2" ? Il n'y a plus de MPEG2 sur la TNT depuis un certain temps (du moins en France) : Toutes les chaînes sont en MPEG4
(HD ou pas).

Très juste, j'aurais dû m'étonner de ce message. VLC ne commet pas cette erreur.
As-tu essayé avec un autre lecteur vidéo comme VLC qui a ses propres codecs ?

Oui, j'utilise habituellement vlc qui s'accommode aussi bien d'un
channels.conf que d'un playlist.xspf et qui enregistre parfaitement les
émissions, mais je ne sais pas comment, en ligne de commande, lui dire
d'enregistrer et lui préciser la chaîne à enregistrer.
Geo Cherchetout
Le #26426840
Le 20/02/2017 16:42, *Sergio* a écrit :
Pour avoir le codec tu peux utiliser la commande mediainfo (à installer éventuellement).

$ mediainfo stream.ts
General
ID : 4 (0x4)
Complete name : stream.ts
Format : MPEG-TS
File size : 4.22 MiB
Nicolas George
Le #26426843
Geo Cherchetout , dans le message écrit :
Mplayer semble tout indiqué pour ça avec son
option -dumpstream

Bof, un peu lourd. Pour cet usage, j'utilise plutôt gnutv.
mais je n'arrive pas à visionner les enregistrements
produits lors de mes essais. Mplayer joue bien le son mais affiche le
message Video: no video.

La sortie de MPlayer sur ce fichier serait utile. Celle de ffprobe
aussi.
Il est à noter que la fréquence 538167000 n'est pas celle du multiplex qui
supporte ARTE dans mon secteur mais celle du multiplex supportant TF1 et
compagnie, mais ce n'est pas le plus grave.

Probablement que si. Je ne comprends pas tout ce qui se passe, mais j'ai
l'impression que la fréquence n'est pas du tout le seul paramètre
pertinent. D'ailleurs, s'il l'était, il n'y aurait pas plein d'autres
par chaîne. Commence par t'assurer que MPlayer (ou gnutv) utilise un
channels.conf à jour et adapté à ta zone de réception.
Geo Cherchetout
Le #26426847
Le 20/02/2017 17:30, *Nicolas George* a écrit :
Geo Cherchetout , dans le message écrit :
Mplayer semble tout indiqué pour ça avec son
option -dumpstream

Bof, un peu lourd. Pour cet usage, j'utilise plutôt gnutv.

J'essaierais bien mais gnutv n'est pas proposé par ma distribution Mageia5.
Ce sera donc pour plus tard, si je n'y arrive pas avec mplayer ou vlc.
mais je n'arrive pas à visionner les enregistrements
produits lors de mes essais. Mplayer joue bien le son mais affiche le
message Video: no video.

La sortie de MPlayer sur ce fichier serait utile. Celle de ffprobe
aussi.

$ ffprobe stream.ts
ffprobe version 2.4.13 Copyright (c) 2007-2016 the FFmpeg developers
built on Feb 4 2016 15:46:57 with gcc 4.9.2 (GCC)
configuration: --prefix=/usr --enable-shared --libdir=/usr/lib64
--shlibdir=/usr/lib64 --incdir=/usr/include --disable-stripping
--enable-postproc --enable-gpl --enable-pthreads --enable-libtheora
--enable-libvorbis --disable-encoder=vorbis --enable-libvpx --enable-x11grab
--enable-runtime-cpudetect --enable-libdc1394 --enable-libschroedinger
--enable-librtmp --enable-libspeex --enable-libfreetype --enable-libnut
--enable-libgsm --enable-libcelt --enable-libopus --disable-libopencv
--enable-libopenjpeg --enable-libtwolame --enable-libxavs --enable-frei0r
--enable-libmodplug --enable-libass --enable-gnutls --enable-libcdio
--enable-libpulse --enable-libv4l2 --enable-libmp3lame
--enable-libopencore-amrnb --enable-libopencore-amrwb --enable-version3
--enable-libx264 --enable-libvo-aacenc --enable-libvo-amrwbenc --enable-libxvid
libavutil 54. 7.100 / 54. 7.100
libavcodec 56. 1.100 / 56. 1.100
libavformat 56. 4.101 / 56. 4.101
libavdevice 56. 0.100 / 56. 0.100
libavfilter 5. 1.100 / 5. 1.100
libswscale 3. 0.100 / 3. 0.100
libswresample 1. 1.100 / 1. 1.100
libpostproc 53. 0.100 / 53. 0.100
[NULL @ 0xddd100] non-existing PPS 0 referenced
[h264 @ 0xddd100] non-existing PPS 0 referenced
[h264 @ 0xddd100] decode_slice_header error
[h264 @ 0xddd100] no frame!
[h264 @ 0xddd100] non-existing PPS 0 referenced
Last message repeated 1 times
[h264 @ 0xddd100] decode_slice_header error
[h264 @ 0xddd100] no frame!
[h264 @ 0xddd100] non-existing PPS 0 referenced
Last message repeated 1 times
[h264 @ 0xddd100] decode_slice_header error
[h264 @ 0xddd100] no frame!
[h264 @ 0xddd100] non-existing PPS 0 referenced
Last message repeated 1 times
[h264 @ 0xddd100] decode_slice_header error
[h264 @ 0xddd100] no frame!
[h264 @ 0xddd100] non-existing PPS 0 referenced
Last message repeated 1 times
[h264 @ 0xddd100] decode_slice_header error
[h264 @ 0xddd100] no frame!
[h264 @ 0xddd100] non-existing PPS 0 referenced
Last message repeated 1 times
[h264 @ 0xddd100] decode_slice_header error
[h264 @ 0xddd100] no frame!
[h264 @ 0xddd100] non-existing PPS 0 referenced
Last message repeated 1 times
[h264 @ 0xddd100] decode_slice_header error
[h264 @ 0xddd100] no frame!
[h264 @ 0xddd100] non-existing PPS 0 referenced
Last message repeated 1 times
[h264 @ 0xddd100] decode_slice_header error
[h264 @ 0xddd100] no frame!
[h264 @ 0xddd100] non-existing PPS 0 referenced
Last message repeated 1 times
[h264 @ 0xddd100] decode_slice_header error
[h264 @ 0xddd100] no frame!
[h264 @ 0xddd100] non-existing PPS 0 referenced
Last message repeated 1 times
[h264 @ 0xddd100] decode_slice_header error
[h264 @ 0xddd100] no frame!
[h264 @ 0xddd100] non-existing PPS 0 referenced
Last message repeated 1 times
[h264 @ 0xddd100] decode_slice_header error
[h264 @ 0xddd100] no frame!
[h264 @ 0xddd100] non-existing PPS 0 referenced
Last message repeated 1 times
[h264 @ 0xddd100] decode_slice_header error
[h264 @ 0xddd100] no frame!
[h264 @ 0xddd100] non-existing PPS 0 referenced
Last message repeated 1 times
[h264 @ 0xddd100] decode_slice_header error
[h264 @ 0xddd100] no frame!
[h264 @ 0xddd100] non-existing PPS 0 referenced
Last message repeated 1 times
[h264 @ 0xddd100] decode_slice_header error
[h264 @ 0xddd100] no frame!
[h264 @ 0xddd100] non-existing PPS 0 referenced
Last message repeated 1 times
[h264 @ 0xddd100] decode_slice_header error
[h264 @ 0xddd100] no frame!
[h264 @ 0xddd100] non-existing PPS 0 referenced
Last message repeated 1 times
[h264 @ 0xddd100] decode_slice_header error
[h264 @ 0xddd100] no frame!
[h264 @ 0xddd100] non-existing PPS 0 referenced
Last message repeated 1 times
[h264 @ 0xddd100] decode_slice_header error
[h264 @ 0xddd100] no frame!
[h264 @ 0xddd100] non-existing PPS 0 referenced
Last message repeated 1 times
[h264 @ 0xddd100] decode_slice_header error
[h264 @ 0xddd100] no frame!
[h264 @ 0xddd100] non-existing PPS 0 referenced
Last message repeated 1 times
[h264 @ 0xddd100] decode_slice_header error
[h264 @ 0xddd100] no frame!
[h264 @ 0xddd100] non-existing PPS 0 referenced
Last message repeated 1 times
[h264 @ 0xddd100] decode_slice_header error
[h264 @ 0xddd100] no frame!
[h264 @ 0xddd100] non-existing PPS 0 referenced
Last message repeated 1 times
[h264 @ 0xddd100] decode_slice_header error
[h264 @ 0xddd100] no frame!
[h264 @ 0xddd100] non-existing PPS 0 referenced
Last message repeated 1 times
[h264 @ 0xddd100] decode_slice_header error
[h264 @ 0xddd100] no frame!
[h264 @ 0xddd100] non-existing PPS 0 referenced
Last message repeated 1 times
[h264 @ 0xddd100] decode_slice_header error
[h264 @ 0xddd100] no frame!
[h264 @ 0xddd100] mmco: unref short failure
Last message repeated 1 times
[mpegts @ 0xd8c920] PES packet size mismatch
Input #0, mpegts, from 'stream.ts':
Duration: 00:00:07.56, start: 17470.216211, bitrate: 4685 kb/s
Program 1025
Program 1026
Program 1031
Program 1045
Program 1046
No Program
Stream #0:0[0x14a]: Audio: eac3, 48000 Hz, stereo, fltp, 128 kb/s
Stream #0:1[0x140]: Video: h264 (High), yuv420p(tv, bt709), 1920x1080
[SAR 1:1 DAR 16:9], 24.75 fps, 25 tbr, 90k tbn, 50 tbc
$ mplayer stream.ts
MPlayer SVN-12.r37337.3.mga5.tainted-4.9.2 (C) 2000-2014 MPlayer Team
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.
Playing stream.ts.
libavformat version 56.4.101 (external)
TS file format detected.
VIDEO MPEG2(pid20) AUDIO A52(pid30) NO SUBS (yet)! PROGRAM N. 0
TS_PARSE: COULDN'T SYNC
MPEG: FATAL: EOF while searching for sequence header.
Video: Cannot read properties.
Load subtitles in ./
========================================================================= Trying to force audio codec driver family libmad...
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
libavcodec version 56.1.100 (external)
AUDIO: 48000 Hz, 2 ch, floatle, 128.0 kbit/4.17% (ratio: 16000->384000)
Selected audio codec: [ffac3] afm: ffmpeg (FFmpeg AC-3)
========================================================================= AO: [pulse] 48000Hz 2ch floatle (4 bytes per sample)
Video: no video
Starting playback...
A:17477.1 ( 4:51:17.1) of 274.8 (04:34.7) 0.2%
[ac3 @ 0x7f6d55cba2c0]Block start info is not implemented. Update your
FFmpeg version to the newest one from Git. If the problem still occurs, it
means that your file has a feature which has not been implemented.
[ac3 @ 0x7f6d55cba2c0]If you want to help, upload a sample of this file to
ftp://upload.ffmpeg.org/incoming/ and contact the ffmpeg-devel mailing list.
()
[ac3 @ 0x7f6d55cba2c0]incomplete frame
A:17477.5 ( 4:51:17.4) of 274.8 (04:34.7) 0.2%
Exiting... (End of file]
Geo Cherchetout
Le #26426849
Le 20/02/2017 18:08, j'ai écrit une bêtise :
Le 20/02/2017 17:30, *Nicolas George* a écrit :
Geo Cherchetout , dans le message écrit :
Mplayer semble tout indiqué pour ça avec son option -dumpstream

Bof, un peu lourd. Pour cet usage, j'utilise plutôt gnutv.

J'essaierais bien mais gnutv n'est pas proposé par ma distribution
Mageia5. Ce sera donc pour plus tard, si je n'y arrive pas avec mplayer
ou vlc.

Pardon, cette commande existe bien puisque j'ai les dvb-apps. Voilà de quoi
m'amuser pour un bon moment...
Nicolas George
Le #26426851
Geo Cherchetout , dans le message écrit :
$ ffprobe stream.ts
Stream #0:0[0x14a]: Audio: eac3, 48000 Hz, stereo, fltp, 128 kb/s
Stream #0:1[0x140]: Video: h264 (High), yuv420p(tv, bt709), 1920x1080

Donc il voit bien les deux flux.
$ mplayer stream.ts
MPlayer SVN-12.r37337.3.mga5.tainted-4.9.2 (C) 2000-2014 MPlayer Team

C'est un peu vieux.
TS file format detected.

Essaie « -demuxer lavf ».
Geo Cherchetout
Le #26426863
Le 20/02/2017 19:12, *Nicolas George* a écrit :
Essaie « -demuxer lavf ».

Impec, merci !
[geo 19:40:22 ~]$ mplayer -dumpstream -dumpfile stream.ts -demuxer lavf
dvb://"France 2(GR1 A)"
MPlayer SVN-12.r37337.3.mga5.tainted-4.9.2 (C) 2000-2014 MPlayer Team
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.
Playing dvb://France 2(GR1 A).
dvb_tune Freq: 642332000
dump: 8970240 bytes written
MPlayer interrupted by signal 2 in module: dumpstream
dvb_streaming_read, attempt N. 6 failed with errno 4 when reading 3432 bytes
dump: 9351168 bytes written to 'stream.ts'.
Core dumped ;)
Exiting... (End of file)
[geo 19:42:46 ~]$ mplayer -demuxer lavf stream.ts
MPlayer SVN-12.r37337.3.mga5.tainted-4.9.2 (C) 2000-2014 MPlayer Team
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.
Playing stream.ts.
libavformat version 56.4.101 (external)
libavformat file format detected.
[NULL @ 0x7f01ce0522c0]non-existing PPS 0 referenced
[h264 @ 0x7f01ce0522c0]non-existing PPS 0 referenced
[h264 @ 0x7f01ce0522c0]decode_slice_header error
[h264 @ 0x7f01ce0522c0]no frame!
[h264 @ 0x7f01ce0522c0]non-existing PPS 0 referenced
[h264 @ 0x7f01ce0522c0]non-existing PPS 0 referenced
[h264 @ 0x7f01ce0522c0]non-existing PPS 0 referenced
[h264 @ 0x7f01ce0522c0]decode_slice_header error
[h264 @ 0x7f01ce0522c0]no frame!
[h264 @ 0x7f01ce0522c0]non-existing PPS 0 referenced
[h264 @ 0x7f01ce0522c0]decode_slice_header error
[h264 @ 0x7f01ce0522c0]no frame!
[h264 @ 0x7f01ce0522c0]non-existing PPS 0 referenced
[h264 @ 0x7f01ce0522c0]non-existing PPS 0 referenced
[h264 @ 0x7f01ce0522c0]non-existing PPS 0 referenced
[h264 @ 0x7f01ce0522c0]decode_slice_header error
[h264 @ 0x7f01ce0522c0]no frame!
[h264 @ 0x7f01ce0522c0]non-existing PPS 0 referenced
[h264 @ 0x7f01ce0522c0]decode_slice_header error
[h264 @ 0x7f01ce0522c0]no frame!
[h264 @ 0x7f01ce0522c0]non-existing PPS 0 referenced
[h264 @ 0x7f01ce0522c0]non-existing PPS 0 referenced
[h264 @ 0x7f01ce0522c0]non-existing PPS 0 referenced
[h264 @ 0x7f01ce0522c0]decode_slice_header error
[h264 @ 0x7f01ce0522c0]no frame!
[h264 @ 0x7f01ce0522c0]non-existing PPS 0 referenced
[h264 @ 0x7f01ce0522c0]decode_slice_header error
[h264 @ 0x7f01ce0522c0]no frame!
[h264 @ 0x7f01ce0522c0]non-existing PPS 0 referenced
[h264 @ 0x7f01ce0522c0]non-existing PPS 0 referenced
[h264 @ 0x7f01ce0522c0]non-existing PPS 0 referenced
[h264 @ 0x7f01ce0522c0]decode_slice_header error
[h264 @ 0x7f01ce0522c0]no frame!
[h264 @ 0x7f01ce0522c0]non-existing PPS 0 referenced
[h264 @ 0x7f01ce0522c0]decode_slice_header error
[h264 @ 0x7f01ce0522c0]no frame!
[h264 @ 0x7f01ce0522c0]non-existing PPS 0 referenced
[h264 @ 0x7f01ce0522c0]non-existing PPS 0 referenced
[h264 @ 0x7f01ce0522c0]non-existing PPS 0 referenced
[h264 @ 0x7f01ce0522c0]decode_slice_header error
[h264 @ 0x7f01ce0522c0]no frame!
[h264 @ 0x7f01ce0522c0]non-existing PPS 0 referenced
[h264 @ 0x7f01ce0522c0]decode_slice_header error
[h264 @ 0x7f01ce0522c0]no frame!
[h264 @ 0x7f01ce0522c0]non-existing PPS 0 referenced
[h264 @ 0x7f01ce0522c0]non-existing PPS 0 referenced
[h264 @ 0x7f01ce0522c0]non-existing PPS 0 referenced
[h264 @ 0x7f01ce0522c0]decode_slice_header error
[h264 @ 0x7f01ce0522c0]no frame!
[h264 @ 0x7f01ce0522c0]non-existing PPS 0 referenced
[h264 @ 0x7f01ce0522c0]decode_slice_header error
[h264 @ 0x7f01ce0522c0]no frame!
[h264 @ 0x7f01ce0522c0]non-existing PPS 0 referenced
[h264 @ 0x7f01ce0522c0]non-existing PPS 0 referenced
[h264 @ 0x7f01ce0522c0]non-existing PPS 0 referenced
[h264 @ 0x7f01ce0522c0]decode_slice_header error
[h264 @ 0x7f01ce0522c0]no frame!
[h264 @ 0x7f01ce0522c0]non-existing PPS 0 referenced
[h264 @ 0x7f01ce0522c0]decode_slice_header error
[h264 @ 0x7f01ce0522c0]no frame!
[h264 @ 0x7f01ce0522c0]non-existing PPS 0 referenced
[h264 @ 0x7f01ce0522c0]non-existing PPS 0 referenced
[h264 @ 0x7f01ce0522c0]non-existing PPS 0 referenced
[h264 @ 0x7f01ce0522c0]decode_slice_header error
[h264 @ 0x7f01ce0522c0]no frame!
[h264 @ 0x7f01ce0522c0]non-existing PPS 0 referenced
[h264 @ 0x7f01ce0522c0]decode_slice_header error
[h264 @ 0x7f01ce0522c0]no frame!
[h264 @ 0x7f01ce0522c0]non-existing PPS 0 referenced
[h264 @ 0x7f01ce0522c0]non-existing PPS 0 referenced
[h264 @ 0x7f01ce0522c0]non-existing PPS 0 referenced
[h264 @ 0x7f01ce0522c0]decode_slice_header error
[h264 @ 0x7f01ce0522c0]no frame!
[h264 @ 0x7f01ce0522c0]non-existing PPS 0 referenced
[h264 @ 0x7f01ce0522c0]decode_slice_header error
[h264 @ 0x7f01ce0522c0]no frame!
[h264 @ 0x7f01ce0522c0]non-existing PPS 0 referenced
[h264 @ 0x7f01ce0522c0]non-existing PPS 0 referenced
[h264 @ 0x7f01ce0522c0]non-existing PPS 0 referenced
[h264 @ 0x7f01ce0522c0]decode_slice_header error
[h264 @ 0x7f01ce0522c0]no frame!
[h264 @ 0x7f01ce0522c0]non-existing PPS 0 referenced
[h264 @ 0x7f01ce0522c0]decode_slice_header error
[h264 @ 0x7f01ce0522c0]no frame!
[h264 @ 0x7f01ce0522c0]non-existing PPS 0 referenced
[h264 @ 0x7f01ce0522c0]non-existing PPS 0 referenced
[h264 @ 0x7f01ce0522c0]non-existing PPS 0 referenced
[h264 @ 0x7f01ce0522c0]decode_slice_header error
[h264 @ 0x7f01ce0522c0]no frame!
[h264 @ 0x7f01ce0522c0]non-existing PPS 0 referenced
[h264 @ 0x7f01ce0522c0]decode_slice_header error
[h264 @ 0x7f01ce0522c0]no frame!
[h264 @ 0x7f01ce0522c0]non-existing PPS 0 referenced
[h264 @ 0x7f01ce0522c0]non-existing PPS 0 referenced
[h264 @ 0x7f01ce0522c0]non-existing PPS 0 referenced
[h264 @ 0x7f01ce0522c0]decode_slice_header error
[h264 @ 0x7f01ce0522c0]no frame!
[h264 @ 0x7f01ce0522c0]non-existing PPS 0 referenced
[h264 @ 0x7f01ce0522c0]decode_slice_header error
[h264 @ 0x7f01ce0522c0]no frame!
[h264 @ 0x7f01ce0522c0]non-existing PPS 0 referenced
[h264 @ 0x7f01ce0522c0]non-existing PPS 0 referenced
[h264 @ 0x7f01ce0522c0]non-existing PPS 0 referenced
[h264 @ 0x7f01ce0522c0]decode_slice_header error
[h264 @ 0x7f01ce0522c0]no frame!
[h264 @ 0x7f01ce0522c0]non-existing PPS 0 referenced
[h264 @ 0x7f01ce0522c0]decode_slice_header error
[h264 @ 0x7f01ce0522c0]no frame!
[h264 @ 0x7f01ce0522c0]non-existing PPS 0 referenced
[h264 @ 0x7f01ce0522c0]non-existing PPS 0 referenced
[h264 @ 0x7f01ce0522c0]non-existing PPS 0 referenced
[h264 @ 0x7f01ce0522c0]decode_slice_header error
[h264 @ 0x7f01ce0522c0]no frame!
[h264 @ 0x7f01ce0522c0]non-existing PPS 0 referenced
[h264 @ 0x7f01ce0522c0]decode_slice_header error
[h264 @ 0x7f01ce0522c0]no frame!
[h264 @ 0x7f01ce0522c0]non-existing PPS 0 referenced
[h264 @ 0x7f01ce0522c0]non-existing PPS 0 referenced
[h264 @ 0x7f01ce0522c0]non-existing PPS 0 referenced
[h264 @ 0x7f01ce0522c0]decode_slice_header error
[h264 @ 0x7f01ce0522c0]no frame!
[h264 @ 0x7f01ce0522c0]non-existing PPS 0 referenced
[h264 @ 0x7f01ce0522c0]decode_slice_header error
[h264 @ 0x7f01ce0522c0]no frame!
[h264 @ 0x7f01ce0522c0]non-existing PPS 0 referenced
[h264 @ 0x7f01ce0522c0]non-existing PPS 0 referenced
[h264 @ 0x7f01ce0522c0]non-existing PPS 0 referenced
[h264 @ 0x7f01ce0522c0]decode_slice_header error
[h264 @ 0x7f01ce0522c0]no frame!
[h264 @ 0x7f01ce0522c0]non-existing PPS 0 referenced
[h264 @ 0x7f01ce0522c0]decode_slice_header error
[h264 @ 0x7f01ce0522c0]no frame!
[h264 @ 0x7f01ce0522c0]non-existing PPS 0 referenced
[h264 @ 0x7f01ce0522c0]non-existing PPS 0 referenced
[h264 @ 0x7f01ce0522c0]non-existing PPS 0 referenced
[h264 @ 0x7f01ce0522c0]decode_slice_header error
[h264 @ 0x7f01ce0522c0]no frame!
[h264 @ 0x7f01ce0522c0]non-existing PPS 0 referenced
[h264 @ 0x7f01ce0522c0]decode_slice_header error
[h264 @ 0x7f01ce0522c0]no frame!
[h264 @ 0x7f01ce0522c0]non-existing PPS 0 referenced
[h264 @ 0x7f01ce0522c0]non-existing PPS 0 referenced
[h264 @ 0x7f01ce0522c0]non-existing PPS 0 referenced
[h264 @ 0x7f01ce0522c0]decode_slice_header error
[h264 @ 0x7f01ce0522c0]no frame!
[h264 @ 0x7f01ce0522c0]non-existing PPS 0 referenced
[h264 @ 0x7f01ce0522c0]decode_slice_header error
[h264 @ 0x7f01ce0522c0]no frame!
[h264 @ 0x7f01ce0522c0]non-existing PPS 0 referenced
[h264 @ 0x7f01ce0522c0]non-existing PPS 0 referenced
[h264 @ 0x7f01ce0522c0]non-existing PPS 0 referenced
[h264 @ 0x7f01ce0522c0]decode_slice_header error
[h264 @ 0x7f01ce0522c0]no frame!
[h264 @ 0x7f01ce0522c0]non-existing PPS 0 referenced
[h264 @ 0x7f01ce0522c0]decode_slice_header error
[h264 @ 0x7f01ce0522c0]no frame!
[h264 @ 0x7f01ce0522c0]non-existing PPS 0 referenced
[h264 @ 0x7f01ce0522c0]non-existing PPS 0 referenced
[h264 @ 0x7f01ce0522c0]non-existing PPS 0 referenced
[h264 @ 0x7f01ce0522c0]decode_slice_header error
[h264 @ 0x7f01ce0522c0]no frame!
[h264 @ 0x7f01ce0522c0]non-existing PPS 0 referenced
[h264 @ 0x7f01ce0522c0]decode_slice_header error
[h264 @ 0x7f01ce0522c0]no frame!
[h264 @ 0x7f01ce0522c0]non-existing PPS 0 referenced
[h264 @ 0x7f01ce0522c0]non-existing PPS 0 referenced
[h264 @ 0x7f01ce0522c0]non-existing PPS 0 referenced
[h264 @ 0x7f01ce0522c0]decode_slice_header error
[h264 @ 0x7f01ce0522c0]no frame!
[h264 @ 0x7f01ce0522c0]non-existing PPS 0 referenced
[h264 @ 0x7f01ce0522c0]decode_slice_header error
[h264 @ 0x7f01ce0522c0]no frame!
[h264 @ 0x7f01ce0522c0]non-existing PPS 0 referenced
[h264 @ 0x7f01ce0522c0]non-existing PPS 0 referenced
[h264 @ 0x7f01ce0522c0]non-existing PPS 0 referenced
[h264 @ 0x7f01ce0522c0]decode_slice_header error
[h264 @ 0x7f01ce0522c0]no frame!
[h264 @ 0x7f01ce0522c0]non-existing PPS 0 referenced
[h264 @ 0x7f01ce0522c0]decode_slice_header error
[h264 @ 0x7f01ce0522c0]no frame!
[h264 @ 0x7f01ce0522c0]non-existing PPS 0 referenced
[h264 @ 0x7f01ce0522c0]non-existing PPS 0 referenced
[h264 @ 0x7f01ce0522c0]decode_slice_header error
[h264 @ 0x7f01ce0522c0]no frame!
[h264 @ 0x7f01ce0522c0]mmco: unref short failure
[h264 @ 0x7f01ce0522c0]mmco: unref short failure
[h264 @ 0x7f01ce0522c0]mmco: unref short failure
[h264 @ 0x7f01ce0522c0]reference picture missing during reorder
[h264 @ 0x7f01ce0522c0]Missing reference picture, default is 65311
[h264 @ 0x7f01ce0522c0]reference picture missing during reorder
[h264 @ 0x7f01ce0522c0]Missing reference picture, default is 65303
[h264 @ 0x7f01ce0522c0]mmco: unref short failure
[h264 @ 0x7f01ce0522c0]mmco: unref short failure
[h264 @ 0x7f01ce0522c0]number of reference frames (0+5) exceeds max (4;
probably corrupt input), discarding one
[mpegts @ 0x7f01cea90180]PES packet size mismatch
[lavf] stream 0: video (h264), -vid 0
[lavf] stream 1: audio (eac3), -aid 0
LAVF: Program 257
LAVF: Program 260
LAVF: Program 261
LAVF: Program 262
LAVF: Program 292
VIDEO: [H264] 1920x1080 0bpp 25.000 fps 0.0 kbps ( 0.0 kbyte/s)
Load subtitles in ./
========================================================================= Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
libavcodec version 56.1.100 (external)
Selected video codec: [ffh264] vfm: ffmpeg (FFmpeg H.264)
========================================================================= ========================================================================= Trying to force audio codec driver family libmad...
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
AUDIO: 48000 Hz, 2 ch, floatle, 128.0 kbit/4.17% (ratio: 16000->384000)
Selected audio codec: [ffeac3] afm: ffmpeg (FFmpeg E-AC-3)
========================================================================= AO: [pulse] 48000Hz 2ch floatle (4 bytes per sample)
Starting playback...
[h264 @ 0x7f01ce0522c0]reference picture missing during reorder
[h264 @ 0x7f01ce0522c0]Missing reference picture, default is 65766
[h264 @ 0x7f01ce0522c0]reference picture missing during reorder
[h264 @ 0x7f01ce0522c0]Missing reference picture, default is 65767
Movie-Aspect is 1.78:1 - prescaling to correct movie aspect.
VO: [xv] 1920x1080 => 1920x1080 Planar YV12 [zoom]
A:88642.1 V:88642.5 A-V: -0.432 ct: 0.000 0/ 0 ??% ??% ??,?% 0 0
[h264 @ 0x7f01ce0522c0]mmco: unref short failure
[h264 @ 0x7f01ce0522c0]mmco: unref short failure
[h264 @ 0x7f01ce0522c0]number of reference frames (0+5) exceeds max (4;
probably corrupt input), discarding one
A:88642.2 V:88642.7 A-V: -0.527 ct: -0.016 0/ 0 ??% ??% ??,?% 2 0
[h264 @ 0x7f01ce0522c0]reference picture missing during reorder
[h264 @ 0x7f01ce0522c0]reference picture missing during reorder
[h264 @ 0x7f01ce0522c0]reference picture missing during reorder
[h264 @ 0x7f01ce0522c0]Missing reference picture, default is 65772
[h264 @ 0x7f01ce0522c0]Missing reference picture, default is 65772
[h264 @ 0x7f01ce0522c0]Missing reference picture, default is 65772
[h264 @ 0x7f01ce0522c0]reference picture missing during reorder
[h264 @ 0x7f01ce0522c0]reference picture missing during reorder
[h264 @ 0x7f01ce0522c0]reference picture missing during reorder
[h264 @ 0x7f01ce0522c0]Missing reference picture, default is 65767
[h264 @ 0x7f01ce0522c0]Missing reference picture, default is 65767
[h264 @ 0x7f01ce0522c0]Missing reference picture, default is 65767
A:88642.5 V:88643.0 A-V: -0.515 ct: -0.020 0/ 0 40% 3% 1.2% 2 0
[h264 @ 0x7f01ce0522c0]reference picture missing during reorder
[h264 @ 0x7f01ce0522c0]Missing reference picture, default is 65791
A:88642.6 V:88643.1 A-V: -0.519 ct: -0.024 0/ 0 42% 3% 1.1% 2 0
[h264 @ 0x7f01ce0522c0]reference picture missing during reorder
[h264 @ 0x7f01ce0522c0]Missing reference picture, default is 65783
[h264 @ 0x7f01ce0522c0]mmco: unref short failure
[h264 @ 0x7f01ce0522c0]mmco: unref short failure
A:88650.6 V:88650.6 A-V: 0.000 ct: -0.539 0/ 0 55% 3% 0.8% 9 0
[mpegts @ 0x7f01cea90180]PES packet size mismatch
A:88650.8 V:88650.8 A-V: 0.000 ct: -0.539 0/ 0 55% 3% 0.8% 9 0
[eac3 @ 0x7f01ce0522c0]incomplete frame
A:88651.0 V:88651.9 A-V: -0.858 ct: -0.625 0/ 0 55% 3% 0.7% 9 0
[h264 @ 0x7f01ce0522c0]error while decoding MB 20 8, bytestream -14
[h264 @ 0x7f01ce0522c0]concealing 7229 DC, 7229 AC, 7229 MV errors in B frame
A:88651.0 V:88652.0 A-V: -0.978 ct: -0.637 0/ 0 54% 3% 0.7% 9 0
No pts value from demuxer to use for frame!
pts after filters MISSING
A:88651.0 V:88652.0 A-V: -0.978 ct: -0.645 0/ 0 54% 3% 0.7% 9 0
Exiting... (End of file)
Enregistrement bien lu par mplayer mais vlc aurait probablement lui aussi
besoin d'une option dans le genre -demuxer lavf.
Publicité
Poster une réponse
Anonyme