Envoi de message avec telnet

Le
geo cherchetout
Bonjour,

Je suis toto@orange.fr et je veux envoyer un message à titi@laposte.net.
Voici le dialogue entre moi et le serveur smtp d'Orange :

$ telnet smtp.orange.fr 25
Trying 80.12.242.16
Connected to smtp.orange.fr (80.12.242.16).
Escape character is '^]'.
220 mwinf5d46 ME ESMTP server ready
EHLO Polo.lan
250-mwinf5d46 hello [www.xxx.yyy.z], pleased to meet you
250-HELP
250-AUTH LOGIN PLAIN
250-SIZE 44000000
250-ENHANCEDSTATUSCODES
250-8BITMIME
250 OK
MAIL FROM:<toto@orange.fr>
250 2.1.0 <toto@orange.fr> sender ok
RCPT TO:<titi@laposte.net>
250 2.1.5 <titi@laposte.net> recipient ok
DATA
354 enter mail, end with "." on a line by itself
from: Toto <toto@orange.fr>, subject: Bonjour
Au revoir
.
250 2.0.0 JfMy1i00L07HmdZ03fNEqf mail accepted for delivery
QUIT
221 2.0.0 mwinf5d46 ME closing connection
Connection closed by foreign host.

Mais voilà le message d'erreur qui me revient peu après :

This is the mail system at host mwinf8512.laposte.net.
I'm sorry to have to inform you that your message could not
be delivered to one or more recipients.

The mail system

<titi@laposte.net>: host back62-mail02-03.meplus.info[10.98.54.97] said: 554
5.6.0 Message contains invalid header

Quelqu'un peut me dire ce qui ne va pas dans mon message ?
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Pascal Hambourg
Le #24139201
Salut,

geo cherchetout a écrit :

DATA
354 enter mail, end with "." on a line by itself
from: Toto Au revoir


[...]
Mais voilà le message d'erreur qui me revient peu après :


[...]
5.6.0 Message contains invalid header

Quelqu'un peut me dire ce qui ne va pas dans mon message ?



Je dirais :

from: Toto
qui devrait plutôt être :

from: Toto subject: Bonjour
geo cherchetout
Le #24139241
Le 07/01/2012 16:57, *Pascal Hambourg* a écrit fort à propos :

Je dirais :

from: Toto
qui devrait plutôt être :

from: Toto subject: Bonjour



J'avais commencé de cette façon mais avec le même résultat.
geo cherchetout
Le #24139531
Exactement le même message d'erreur quand toto s'envoie le même message à
lui-même. Quand toto envoie un message avec son courrieleur habituel, il
utilise le serveur smtpauth.orange.fr. Ça a peut-être quelque chose à voir
avec le problème ?
Pascal Hambourg
Le #24139621
geo cherchetout a écrit :
Le 07/01/2012 16:57, *Pascal Hambourg* a écrit fort à propos :

Je dirais :

from: Toto
qui devrait plutôt être :

from: Toto subject: Bonjour



J'avais commencé de cette façon mais avec le même résultat.



Il faudrait aussi une ligne vide entre la fin des en-têtes et le début
du corps.

from: Toto subject: Bonjour

Au revoir
.
geo cherchetout
Le #24142821
Le 07/01/2012 19:03, *Pascal Hambourg* a écrit fort à propos :

Il faudrait aussi une ligne vide entre la fin des en-têtes et le début
du corps.

from: Toto subject: Bonjour

Au revoir
..



C'est mieux puisque Toto ne reçoit plus d'avis de non transmission mais, 23
heures plus tard, Titi n'a toujours pas reçu le message. Il n'y a
probablement plus qu'une ou deux petites retouches de forme à faire. Merci
de nous avoir montré le chemin.
Bruno Tréguier
Le #24143301
Le 08/01/2012 à 18:49, geo cherchetout a écrit :
Le 07/01/2012 19:03, *Pascal Hambourg* a écrit fort à propos :

Il faudrait aussi une ligne vide entre la fin des en-têtes et le début
du corps.

from: Toto subject: Bonjour

Au revoir
..



C'est mieux puisque Toto ne reçoit plus d'avis de non transmission mais, 23
heures plus tard, Titi n'a toujours pas reçu le message. Il n'y a
probablement plus qu'une ou deux petites retouches de forme à faire. Merci
de nous avoir montré le chemin.



Bonsoir,

Vérifiez auprès de "" que votre message n'a pas abouti
dans son filtre à spam... Typiquement, ces messages que l'on "fabrique"
à la main ont des caractéristiques (certains en-têtes manquants, comme
ceux relatifs à l'encodage MIME) qui les font passer pour des spams...

Cordialement,

--
Bruno Tréguier
geo cherchetout
Le #24143611
Le 08/01/2012 21:26, *Bruno Tréguier* a écrit fort à propos :

Bonsoir,

Vérifiez auprès de "" que votre message n'a pas abouti
dans son filtre à spam... Typiquement, ces messages que l'on "fabrique"
à la main ont des caractéristiques (certains en-têtes manquants, comme
ceux relatifs à l'encodage MIME) qui les font passer pour des spams...

Cordialement,



Merci, c'est bien ce qui est arrivé ! Le message a été reconnu comme spam
par laposte.net et non distribué. Pour le retrouver, il a fallu utiliser le
webmail, ce que Titi ne fait jamais. (Pas plus qu'il n'a créé de filtre à ce
niveau.)
Dans les en-têtes du message exhumé, on trouve notamment ces champs :

X-me-spamrating: 67.00
X-me-spamcause: (139)(1000)gggrugg-et-une-longue-chaîne-de-caractères
X-me-spamlevel: low

subject: *** SPAM *** Bonjour

Bon, je crois qu'il ne reste plus qu'à recommencer en ajoutant quelques
champs, jusqu'à ce que ça passe...
Bruno Tréguier
Le #24143881
Le 08/01/2012 à 22:52, geo cherchetout a écrit :
Le 08/01/2012 21:26, *Bruno Tréguier* a écrit fort à propos :

Bonsoir,

Vérifiez auprès de "" que votre message n'a pas abouti
dans son filtre à spam... Typiquement, ces messages que l'on "fabrique"
à la main ont des caractéristiques (certains en-têtes manquants, comme
ceux relatifs à l'encodage MIME) qui les font passer pour des spams...

Cordialement,



Merci, c'est bien ce qui est arrivé ! Le message a été reconnu comme spam
par laposte.net et non distribué. Pour le retrouver, il a fallu utiliser le
webmail, ce que Titi ne fait jamais. (Pas plus qu'il n'a créé de filtre à ce
niveau.)
Dans les en-têtes du message exhumé, on trouve notamment ces champs :

X-me-spamrating: 67.00
X-me-spamcause: (139)(1000)gggrugg-et-une-longue-chaîne-de-caractères
X-me-spamlevel: low

subject: *** SPAM *** Bonjour

Bon, je crois qu'il ne reste plus qu'à recommencer en ajoutant quelques
champs, jusqu'à ce que ça passe...



Le plus simple est vraisemblablement pour vous de reprendre certains
en-têtes d'un message légitime par copier/coller. Ce qui concerne MIME:
Mime-Version, Content-Type, Content-Transfer-Encoding, éventuellement le
User-Agent, déjà ça devrait calmer l'anti-spam, mais il se peut que cela
vienne aussi du texte un peu court: "Au revoir" tout court, ça peut
sembler curieux, voire suspect, à certains outils de lutte anti-spam.

Cordialement,

--
Bruno Tréguier
LeLapin
Le #24144411
Bruno Tréguier a tapoté du bout de ses petites papattes :
mais il se peut que cela vienne aussi du texte un peu court: "Au revoir" tout
court, ça peut sembler curieux, voire suspect, à certains outils de lutte
anti-spam.



N'importe quoi ! Depuis les emails sur smartphones et tablettes, on
dirait presque que la mode sms a migré d'appli.

--
LeLapin
Bruno Tréguier
Le #24144721
Le 09/01/2012 09:55, LeLapin a écrit :
Bruno Tréguier a tapoté du bout de ses petites papattes :
mais il se peut que cela vienne aussi du texte un peu court: "Au
revoir" tout court, ça peut sembler curieux, voire suspect, à certains
outils de lutte anti-spam.



N'importe quoi ! Depuis les emails sur smartphones et tablettes, on
dirait presque que la mode sms a migré d'appli.



Pourquoi "n'importe quoi" ? Vous connaissez tous les systèmes
d'anti-spam du marché et êtes capable de dire qu'aucun d'entre eux ne
juge sur ce critère ? Vous remarquerez également que je n'ai pas porté
de jugement sur sa pertinence.

Exemple de truc qui peut "foirer": un analyseur bayesien insuffisamment
entraîné peut tout à fait prendre une décision "à l'emporte-pièce" sur
des petits messages comportant seulement quelques mots.

Cordialement,

--
Bruno Tréguier
Publicité
Poster une réponse
Anonyme