Erreur 29013 sous Access 97

Le
Dom
Bonjour,

Dans une base et lors de l'envoi via OE et par SendObject d'un état au
format de sortie "FormatSnapshot(*.snp)", j'obtiens une erreur numéro 29013

Ma syntaxe est la suivante :

DoCmd.SendObject acReport, "EBudget", "FormatSnapshot(*.snp)", Mail, , ,
"Etat des contrôles budgétaires" & " " & Mail1, Message1, False

Précisions :

Mail = variable contenant l'adresse e-mail du destinataire
Etat des contrôles budgétaires = objet du message
Mail1 = variable contenant un nom lamdda
Message1 = Variable contenant le corps du message

Si je fais le même envoi avec un format de sortie en HTML, cela fonctionne
sans problème, et le plus curieux, c'est que dans une autre base,l'envoi au
format SnapShot fonctionne nickel avec la même syntaxe

Si l'un ou l'une d'entre vous pouvait m'éclairer, cela m'arrangerait bien
:-)))

Bien cordialement à tout le monde, et bon dimanche.

Dominique.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Raymond [mvp]
Le #6296061
Bonsoir.

access 97 est si loin. es-tu sûr que l'option FormatSnapshot(*.snp) était
disponible sous 97 ? je pencherais pour une prise en charge par la version
2000 seulement (à vérifier).
l'autre système qui fonctionne bien est-il en access 97 ou en access 2000 ou
plus ?

--
@+
Raymond Access MVP http://www.OfficeSystemAccess.com/
http://officesystem.access.over-blog.com/
http://officesystem.access.free.fr/wiki/
Pour débuter sur le forum: http://www.mpfa.info/

Venez découvrir Open XML, le nouveau format de fichier de la suite Office !
http://www.comscamp.com/Tracker/Redirect.ashx?linkidÿ71c7f3-78e8-4371-abaf-b73c259e58db


"Dom" 468773a1$0$2221$
| Bonjour,
|
| Dans une base et lors de l'envoi via OE et par SendObject d'un état au
| format de sortie "FormatSnapshot(*.snp)", j'obtiens une erreur numéro
29013
|
| Ma syntaxe est la suivante :
|
| DoCmd.SendObject acReport, "EBudget", "FormatSnapshot(*.snp)", Mail, , ,
| "Etat des contrôles budgétaires" & " " & Mail1, Message1, False
|
| Précisions :
|
| Mail = variable contenant l'adresse e-mail du destinataire
| Etat des contrôles budgétaires = objet du message
| Mail1 = variable contenant un nom lamdda
| Message1 = Variable contenant le corps du message
|
| Si je fais le même envoi avec un format de sortie en HTML, cela fonctionne
| sans problème, et le plus curieux, c'est que dans une autre base,l'envoi
au
| format SnapShot fonctionne nickel avec la même syntaxe...
|
| Si l'un ou l'une d'entre vous pouvait m'éclairer, cela m'arrangerait bien
| :-)))
|
| Bien cordialement à tout le monde, et bon dimanche.
|
| Dominique.
|
|
Dom
Le #6296031
Bonjour Raymond,

Oui, oui, l'option est disponible sous 97 (sr2)et mon autre base est aussi
sous 97 (sr2).
Je penche donc pour un bug aléatoire d'Access 97 (mais sans en être sûr) ou
alors peut-être que dans ma base qui ne fonctionne pas, y'a un bout de code
quelque part qui coince...

Je vais re-creuser le problème, et si je trouve, je n'en manquerai d'en
informer le forum.

Merci et bonne journée.

Dominique.

"Raymond [mvp]" de news:
Bonsoir.

access 97 est si loin. es-tu sûr que l'option FormatSnapshot(*.snp) était
disponible sous 97 ? je pencherais pour une prise en charge par la version
2000 seulement (à vérifier).
l'autre système qui fonctionne bien est-il en access 97 ou en access 2000
ou
plus ?

--
@+
Raymond Access MVP http://www.OfficeSystemAccess.com/
http://officesystem.access.over-blog.com/
http://officesystem.access.free.fr/wiki/
Pour débuter sur le forum: http://www.mpfa.info/

Venez découvrir Open XML, le nouveau format de fichier de la suite Office
!
http://www.comscamp.com/Tracker/Redirect.ashx?linkidÿ71c7f3-78e8-4371-abaf-b73c259e58db


"Dom" 468773a1$0$2221$
| Bonjour,
|
| Dans une base et lors de l'envoi via OE et par SendObject d'un état au
| format de sortie "FormatSnapshot(*.snp)", j'obtiens une erreur numéro
29013
|
| Ma syntaxe est la suivante :
|
| DoCmd.SendObject acReport, "EBudget", "FormatSnapshot(*.snp)", Mail, , ,
| "Etat des contrôles budgétaires" & " " & Mail1, Message1, False
|
| Précisions :
|
| Mail = variable contenant l'adresse e-mail du destinataire
| Etat des contrôles budgétaires = objet du message
| Mail1 = variable contenant un nom lamdda
| Message1 = Variable contenant le corps du message
|
| Si je fais le même envoi avec un format de sortie en HTML, cela
fonctionne
| sans problème, et le plus curieux, c'est que dans une autre base,l'envoi
au
| format SnapShot fonctionne nickel avec la même syntaxe...
|
| Si l'un ou l'une d'entre vous pouvait m'éclairer, cela m'arrangerait
bien
| :-)))
|
| Bien cordialement à tout le monde, et bon dimanche.
|
| Dominique.
|
|




Raymond [mvp]
Le #6296001
Bonjour.

OK, sr2.
J'ai trouvé le même genre de problème mais aucune solution n'a été apporté.
je te donne le lien, si tu sais mieux lire que moi
http://groups.google.fr/group/microsoft.public.fr.access/search?hl=fr&group=microsoft.public.fr.access&q=snapshot+97+export
--
@+
Raymond Access MVP http://www.OfficeSystemAccess.com/
http://officesystem.access.over-blog.com/
http://officesystem.access.free.fr/wiki/
Pour débuter sur le forum: http://www.mpfa.info/

Venez découvrir Open XML, le nouveau format de fichier de la suite Office !
http://www.comscamp.com/Tracker/Redirect.ashx?linkidÿ71c7f3-78e8-4371-abaf-b73c259e58db


"Dom" 4688828f$0$3222$
| Bonjour Raymond,
|
| Oui, oui, l'option est disponible sous 97 (sr2)et mon autre base est aussi
| sous 97 (sr2).
| Je penche donc pour un bug aléatoire d'Access 97 (mais sans en être sûr)
ou
| alors peut-être que dans ma base qui ne fonctionne pas, y'a un bout de
code
| quelque part qui coince...
|
| Je vais re-creuser le problème, et si je trouve, je n'en manquerai d'en
| informer le forum.
|
| Merci et bonne journée.
|
| Dominique.
|
Dom
Le #6295801
Merci Raymond.

Tu as bien lu, et ayant parcouru les liens, cela m'apparaît aussi clair que
du jus de chique ! Je sens que cela va être galère, mais bon, si tout
fonctionnait nickel tout le temps, qu'est-ce qu'on s'e.......... non ?

Allez hop, je me remets au taf ;-))) J'aurais sa peau à ce snp...

Amitiés.

Dominique.



"Raymond [mvp]" de news: %
Bonjour.

OK, sr2.
J'ai trouvé le même genre de problème mais aucune solution n'a été
apporté.
je te donne le lien, si tu sais mieux lire que moi
http://groups.google.fr/group/microsoft.public.fr.access/search?hl=fr&group=microsoft.public.fr.access&q=snapshot+97+export
--
@+
Raymond Access MVP http://www.OfficeSystemAccess.com/
http://officesystem.access.over-blog.com/
http://officesystem.access.free.fr/wiki/
Pour débuter sur le forum: http://www.mpfa.info/

Venez découvrir Open XML, le nouveau format de fichier de la suite Office
!
http://www.comscamp.com/Tracker/Redirect.ashx?linkidÿ71c7f3-78e8-4371-abaf-b73c259e58db


"Dom" 4688828f$0$3222$
| Bonjour Raymond,
|
| Oui, oui, l'option est disponible sous 97 (sr2)et mon autre base est
aussi
| sous 97 (sr2).
| Je penche donc pour un bug aléatoire d'Access 97 (mais sans en être sûr)
ou
| alors peut-être que dans ma base qui ne fonctionne pas, y'a un bout de
code
| quelque part qui coince...
|
| Je vais re-creuser le problème, et si je trouve, je n'en manquerai d'en
| informer le forum.
|
| Merci et bonne journée.
|
| Dominique.
|




Dom
Le #6294941
Bonjour,

J'ai trouvé la solution :-))))

En comparant mes deux états, je me suis aperçu que l'un (celui qui peut être
transmis au format snp) avait une image jpg dans l'entête de page alors que
l'autre (celui qui faisait l'objet de l'erreur 29013) avait deux images :
l'une dans l'entête de page, l'autre dans le pied de page. Les trois images
des deux états sont strictement identique

J'ai supprimé l'image du pied de page puis ai relancé mon code, et là...,
plus aucun problème. L'état est converti au format snp et peut être transmis
via OE.

Curieux non ?

Cordialement,

Dominique.


"Dom" 46892a97$0$21966$
Merci Raymond.

Tu as bien lu, et ayant parcouru les liens, cela m'apparaît aussi clair
que du jus de chique ! Je sens que cela va être galère, mais bon, si tout
fonctionnait nickel tout le temps, qu'est-ce qu'on s'e.......... non ?

Allez hop, je me remets au taf ;-))) J'aurais sa peau à ce snp...

Amitiés.

Dominique.



"Raymond [mvp]" message de news: %
Bonjour.

OK, sr2.
J'ai trouvé le même genre de problème mais aucune solution n'a été
apporté.
je te donne le lien, si tu sais mieux lire que moi
http://groups.google.fr/group/microsoft.public.fr.access/search?hl=fr&group=microsoft.public.fr.access&q=snapshot+97+export
--
@+
Raymond Access MVP http://www.OfficeSystemAccess.com/
http://officesystem.access.over-blog.com/
http://officesystem.access.free.fr/wiki/
Pour débuter sur le forum: http://www.mpfa.info/

Venez découvrir Open XML, le nouveau format de fichier de la suite Office
!
http://www.comscamp.com/Tracker/Redirect.ashx?linkidÿ71c7f3-78e8-4371-abaf-b73c259e58db


"Dom" 4688828f$0$3222$
| Bonjour Raymond,
|
| Oui, oui, l'option est disponible sous 97 (sr2)et mon autre base est
aussi
| sous 97 (sr2).
| Je penche donc pour un bug aléatoire d'Access 97 (mais sans en être
sûr)
ou
| alors peut-être que dans ma base qui ne fonctionne pas, y'a un bout de
code
| quelque part qui coince...
|
| Je vais re-creuser le problème, et si je trouve, je n'en manquerai d'en
| informer le forum.
|
| Merci et bonne journée.
|
| Dominique.
|








Raymond [mvp]
Le #6294811
Bonjour.

En voila une erreur qu'elle est bonne ! dix ans après sa sortie, le bug qui
tue !
c'est toujours bon à savoir et maintenant qu'elle est référencée dans les
archives, servira-t-elle au moins à quelqu'un ?
pourrais-tu me passer un exemplaire expurgé de ta base avec le fameux état
ne fonctionnant pas et le formulaire pour que je puisse tester sur la
version 2007, si ça se trouve on a le même bug.
prends l'adresse et enlève les xyz de protection. merci.

--
@+
Raymond Access MVP http://www.OfficeSystemAccess.com/
http://officesystem.access.over-blog.com/
http://officesystem.access.free.fr/wiki/
Pour débuter sur le forum: http://www.mpfa.info/

Venez découvrir Open XML, le nouveau format de fichier de la suite Office !
http://www.comscamp.com/Tracker/Redirect.ashx?linkidÿ71c7f3-78e8-4371-abaf-b73c259e58db


"Dom" 468c73db$0$13208$
| Bonjour,
|
| J'ai trouvé la solution :-))))
|
| En comparant mes deux états, je me suis aperçu que l'un (celui qui peut
être
| transmis au format snp) avait une image jpg dans l'entête de page alors
que
| l'autre (celui qui faisait l'objet de l'erreur 29013) avait deux images :
| l'une dans l'entête de page, l'autre dans le pied de page. Les trois
images
| des deux états sont strictement identique
|
| J'ai supprimé l'image du pied de page puis ai relancé mon code, et là...,
| plus aucun problème. L'état est converti au format snp et peut être
transmis
| via OE.
|
| Curieux non ?
|
| Cordialement,
|
| Dominique.
Publicité
Poster une réponse
Anonyme