Erreur 800A0007 sur Windows Update

Le
Gloops
Bonjour tout le monde,

Hier j'ai vu qu'une vingtaine de mises à jour étaient signalées par=
une
icône dans la zone de notification de la session administrateur.

Aujourd'hui, plus rien. Alors je charge le site de mise à jour dans IE,=

et là je vois pas moyen démerdez-vous avec les newsgroups. Euh, bon, =

d'accord. Et en tout petit dans un coin, parce que je cherchais un
numéro d'erreur, je vois 0x800A0007.

Alors donc j'ai trouvé ça
http://www.theinternetpatrol.com/0x800a0007-windows-update-error/

où on me signale deux sources possibles de l'erreur :
- un problème de langue par défaut
- une horloge pas à l'heure, de façon disproportionnée.

J'écarte la deuxième hypothèse car mon horloge est synchronisée t=
outes
les deux heures, et qu'hier j'ai été très impressionné de la voir=
avec
presque cinq secondes d'écart, c'est bien la première fois depuis que=

j'ai la machine que l'écart en moins de 24 heures dépasse la seconde,=

il est de nouveau sous la seconde.

En revanche, pour ce qui est des questions de langues, je me sens
concerné. J'ai réinstallé mon environnement de développement, ce =
qui m'a
occupé deux à trois semaines durant, et la dernière étape c'éta=
it SQL
Express 2008 R2.

Le site de téléchargement Microsoft propose deux téléchargements =
:
- un en plusieurs langues dont le Français avec seulement la base de do=
nnées
- un seulement en Anglais avec aussi les outils, dont Sql Server
Management Studio, qui sert à administrer et utiliser la base.

Alors je me suis dit qu'à cela ne tienne, j'ai installé les deux, dan=
s
cet ordre. Lourde erreur. Premièrement, en installant les outils, on m'=
a
affiché l'instance déjà créée dans une liste déroulante, avec=
le nom qui
lui avait été attribué, et quand j'ai demandé de mettre les outil=
s
dessus, on m'a dit pas possible, l'id de l'instance est nécessaire et
n'est pas connu. J'ai eu beau me gratter la tête, il n'en est rien sort=
i.

J'ai créé l'outil sur une nouvelle instance, et il fonctionnait avec,=

mais du coup, le développement ASP ne fonctionnait guère. Alors j'ai =

désinstallé les deux, plus exactement je suis revenu à un point de =

restauration d'avant, et quand j'ai voulu installer la britannisante
version avec outils, on m'a dit pas possible, il y a des incohérences
dans les compteurs de performances.

Je n'ai pas trop su pourquoi c'était plus facile pour l'utilisateur que=

pour Microsoft de corriger les compteurs de performances, mais je me
suis attelé à la tâche.

Les manipulations sophistiquées indiquées par la fiche Microsoft
proposée en lien ont semblé ne rien changer à l'affaire. En revanch=
e,
ensuite, cette page m'a sorti d'affaire :
http://blog.developpez.com/mikedavem/p9275/sql-server-2008/installation-d=
e-sql-server-2008-avec-le/
(qui redonne aussi le lien sur la fiche Microsoft, d'ailleurs)

Je résume, pour corriger les compteurs de performance il a fallu copier=

le contenu de la valeur consacrée à une langue, dans celle consacré=
e à
une autre. D'où, tilt quand on m'a dit que les problèmes de mises à=
jour
pouvaient être liés au choix de la langue par défaut.

ça a remis les compteurs d'aplomb, mais malheureusement pas la doc
Microsoft du site de téléchargement, puisqu'elle propose toujours des=

outils dans deux langues, ne se recouvrant que partiellement, et sans
mettre en garde contre la tentation d'utiliser les deux sur la même mac=
hine.


Voilà. Alors donc j'ai fini le téléchargement, et l'outil de
configuration ASP.Net fonctionne de nouveau comme une horloge.

Mais, les mises à jour Microsoft ne fonctionnent plus, et quand la
première réponse m'a parlé de conflits entre plusieurs langues, il =
m'a
semblé à propos de raconter les dernières installations effectuée=
s.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Gloops
Le #24747012
Gloops a écrit, le 02/09/2012 13:41 :
Mais, les mises à jour Microsoft ne fonctionnent plus, et quand la
première réponse m'a parlé de conflits entre plusieurs langues, i l m'a
semblé à propos de raconter les dernières installations effectué es.



J'ai d'ailleurs été un peu surpris de voir le site de mise à jour
s'afficher en Français, car j'ai paramétré IE pour afficher d'abord en
Anglais, puis à défaut en Français, cela pour m'éviter d'être c onfronté
à des titres comme celui de cette fiche :
http://support.microsoft.com/kb/237536/fr

qui augure que le texte doit être du même tonneau.

J'ai sélectionné explicitement l'Anglais en corrigeant l'URL
manuellement, et on m'a redit la même chose en Anglais.
Gloops
Le #24748492
Gloops a écrit, le 02/09/2012 14:01 :
Gloops a écrit, le 02/09/2012 13:41 :
Mais, les mises à jour Microsoft ne fonctionnent plus, et quand la
première réponse m'a parlé de conflits entre plusieurs langues, il m'a
semblé à propos de raconter les dernières installations effectué es.



J'ai d'ailleurs été un peu surpris de voir le site de mise à jour
s'afficher en Français, car j'ai paramétré IE pour afficher d'abo rd en
Anglais, puis à défaut en Français, cela pour m'éviter d'être confronté
à des titres comme celui de cette fiche :
http://support.microsoft.com/kb/237536/fr

qui augure que le texte doit être du même tonneau.

J'ai sélectionné explicitement l'Anglais en corrigeant l'URL
manuellement, et on m'a redit la même chose en Anglais.





Comme j'ai mentionné sur Answers, je me suis rendu compte depuis que la
sélection de la langue est propre au site Microsoft Update, et se fait à
l'aide du bouton de paramètres, sur la gauche de la page d'accueil.
Là aussi j'ai essayé le Français et l'Anglais.
Gloops
Le #24756682
Gloops a écrit, le 02/09/2012 13:41 :
Mais, les mises à jour Microsoft ne fonctionnent plus, et quand la
première réponse m'a parlé de conflits entre plusieurs langues, i l m'a
semblé à propos de raconter les dernières installations effectué es.





ça y est c'est réparé, après exécution d'un outil Microsoft de réparation :
http://answers.microsoft.com/fr-fr/windows/forum/windows_xp-windows_updat e/erreur-800a0007-sur-mises-%C3%A0-jour-windows/9a68d3bc-f39b-417c-8ab9-9 851d8dfc04a?tm46835125085&lc36&auth=1

Mais il a fallu le ré-exécuter après avoir désinstallé la barre d'outils
AVG, qui s'était invitée avec un autre programme.
Gloops
Le #24757232
Gloops a écrit, le 05/09/2012 11:02 :
Gloops a écrit, le 02/09/2012 13:41 :
Mais, les mises à jour Microsoft ne fonctionnent plus, et quand la
première réponse m'a parlé de conflits entre plusieurs langues, il m'a
semblé à propos de raconter les dernières installations effectué es.





ça y est c'est réparé, après exécution d'un outil Microsoft d e réparation :
http://answers.microsoft.com/fr-fr/windows/forum/windows_xp-windows_upd ate/erreur-800a0007-sur-mises-%C3%A0-jour-windows/9a68d3bc-f39b-417c-8ab9 -9851d8dfc04a?tm46835125085&lc36&auth=1


Mais il a fallu le ré-exécuter après avoir désinstallé la bar re d'outils
AVG, qui s'était invitée avec un autre programme.






Donc avant cette correction, MBSA avait accès aux mises à jour, mais pas
le site update.microsoft.com. Maintenant, c'est le contraire. Mais je me
dis que c'est peut-être normal, sachant qu'il n'y a pas de mise à jou r
en attente.

En revanche MBSA a un problème d'accès au registre.
Dans l'aide en ligne locale, de MBSA tel que téléchargé depuis Same di,
je vois qu'on peut poser des questions sur un newsgroup dédié sur
msnews.microsoft.com

J'ai vérifié, le compte où je consultais windowsxp et consor il y a
maintenant ... quelques années il me semble, était sur
news.microsoft.com, mais en faisant cette correction je me fais jeter
avec le même message d'erreur, pas de serveur à cette adresse.

Faut-il comprendre que c'est l'aide en ligne de MBSA qui n'est pas à
jour, ou il y a quelque chose que j'ai mal transposé ?
Gloops
Le #24757312
Gloops a écrit, le 05/09/2012 13:44 :
Dans l'aide en ligne locale, de MBSA tel que téléchargé depuis Sa medi,
je vois qu'on peut poser des questions sur un newsgroup dédié sur
msnews.microsoft.com

J'ai vérifié, le compte où je consultais windowsxp et consor il y a
maintenant ... quelques années il me semble, était sur
news.microsoft.com, mais en faisant cette correction je me fais jeter
avec le même message d'erreur, pas de serveur à cette adresse.

Faut-il comprendre que c'est l'aide en ligne de MBSA qui n'est pas à
jour, ou il y a quelque chose que j'ai mal transposé ?




En fait il semble bien que ce soit l'aide en ligne qui ne soit pas à
jour : j'ai trouvé le newsgroup
microsoft.public.safety.baseline_analyzer sur pasdenom.info où je poste
ce fil : il contient un seul fil de Juin et Juillet, et qui est
totalement hors sujet me semble-t-il. Il est vrai que ce n'est pas le
genre d'outil qu'on lance tous les matins en service normal, donc il
justifie moins de flux de questions, et motive moins de visites.

Est-ce qu'ici quelqu'un se sent de taille à répondre ?
Gloops
Le #24757502
Gloops a écrit, le 05/09/2012 13:44 :
Donc avant cette correction, MBSA avait accès aux mises à jour, mai s pas
le site update.microsoft.com. Maintenant, c'est le contraire. Mais je m e
dis que c'est peut-être normal, sachant qu'il n'y a pas de mise à j our
en attente.

En revanche MBSA a un problème d'accès au registre.




En relisant je me suis dit que ça serait pas mal de réinstaller MBSA,
maintenant qu'AVG Toolbar a été viré.

Pas de changement.
Publicité
Poster une réponse
Anonyme