#erreur - Champ de calcul avec cet affichage aléatoire

Le
platypus
Bonjour,
J'ai inséré sur l'entête de mon formulaire un champ avec une formule de
calcul.
C'est une somme "dynamique" où je multiplie deux champs d'une même table
avec une condition sur d'autres champs. Pourquoi "dynamique" ? Parce que en
fonction de la saisie sur le formulaire, j'affiche le résultat évoluant sur
la somme totale pour un critère choisi. Somme de l'ensemble des données de
cette table.

Le problème, c'est que je ne peux pas afficher ce résultat très longtemps !
En effet, j'obtiens bien le résultat, il s'affiche puis après quelques temps
ou bien action ? Le champ calculé me retourne la valeur #erreur ?
J'ai reformuler mon calcul plusieurs fois et aléatoirement j'affiche le
résultat ou non ?

Quelqu'un a t il déjà rencontré cette anomalie ?

Merci de votre aide.

Nota : j'utilise access 2003 et les données de ma table sont importées
d'excel 2002
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Tisane
Le #6321621
Bonjour "platypus",

J'ai inséré sur l'entête de mon formulaire un champ avec une formule de
calcul.
C'est une somme "dynamique" où je multiplie deux champs d'une même table
avec une condition sur d'autres champs. Pourquoi "dynamique" ? Parce que
en
fonction de la saisie sur le formulaire, j'affiche le résultat évoluant
sur
la somme totale pour un critère choisi. Somme de l'ensemble des données de
cette table.
Le problème, c'est que je ne peux pas afficher ce résultat très longtemps
!
En effet, j'obtiens bien le résultat, il s'affiche puis après quelques
temps
ou bien action ? Le champ calculé me retourne la valeur #erreur ?
J'ai reformuler mon calcul plusieurs fois et aléatoirement j'affiche le
résultat ou non ?
Quelqu'un a t il déjà rencontré cette anomalie ?


L'anomalie vient sans doute de toi, et "l'aléatoire", je n'y crois pas trop
en informatique ;-)
Donne-nous donc une copie de ta formule avec le contexte un peu plus
concret.
Cela facilitera la recherche du "bug".

--
Tisane

platypus
Le #6321481
Bonsoir Tisane,
Merci pour ton assistance... Le bug est souvent situé entre l'écran et le
clavier.
La solution me paraîtra certainement plus évidente quand elle éclatera à mes
yeux !


Bonjour "platypus",

J'ai inséré sur l'entête de mon formulaire un champ avec une formule de
calcul.
C'est une somme "dynamique" où je multiplie deux champs d'une même table
avec une condition sur d'autres champs. Pourquoi "dynamique" ? Parce que
en
fonction de la saisie sur le formulaire, j'affiche le résultat évoluant
sur
la somme totale pour un critère choisi. Somme de l'ensemble des données de
cette table.
Le problème, c'est que je ne peux pas afficher ce résultat très longtemps
!
En effet, j'obtiens bien le résultat, il s'affiche puis après quelques
temps
ou bien action ? Le champ calculé me retourne la valeur #erreur ?
J'ai reformuler mon calcul plusieurs fois et aléatoirement j'affiche le
résultat ou non ?
Quelqu'un a t il déjà rencontré cette anomalie ?


L'anomalie vient sans doute de toi, et "l'aléatoire", je n'y crois pas trop
en informatique ;-)
Donne-nous donc une copie de ta formule avec le contexte un peu plus
concret.
Cela facilitera la recherche du "bug".

--
Tisane


Voici plus d'informations

Les champs utilisés :
[Sales Price EA] et [Champ10] sont des données "numériques Réel double"
[Choix 24 M] et [Choix 750 FH] sont des données "textes"

et les deux formules sur mes champs de formulaires posées en en tête :
=Somme([Champ10]*[Sales Price EA])

=Somme(VraiFaux([Choix 24 M]="X" Ou [Choix 750 FH]="X";[Champ10]*[Sales
Price EA];0))

Lorsque je resaisie les formules et que je les valide (via le menu propriété
et avec le formulaire actif) les valeurs s'affichent. Je peux modifier mes
paramètres et consulter mes données sans soucis. Si je ferme le formulaire et
qu'ensuite je l'ouvre à nouveau... Le problème réapparaît ?

Est ce un contrôle à l'ouverture du formulaire qui pose le problème ? J'ai
peut être fait une mauvaise manipulation dans les proprités de mon formulaire
?

En espèrant avoir communiqué suffisamment d'informations
@+


platypus
Le #6319071
L'erreur sur les formules posées en en-tête de formulaire est résolue.
J'ai appliqué une méthode qui consiste à encadrer les champs par la fonction
nz(). ce qui donne pour mon cas :
=Somme(nz([Champ10]*[Sales Price EA]))
ou cela
=Somme(VraiFaux([Choix 24 M]="X" Ou [Choix 750
FH]="X";(nz([Champ10])*[AIRBUS Sales Price EA]);0))

Pour résoudre le problème, il a fallut que je réalise cette action sur les
deux champs de calculs concernés ?
Bref, plus de message d'erreur. C'est génial !
L'accès aux archives de ce newsgroup m'a grandement aidé.
@+


Bonjour,
J'ai inséré sur l'entête de mon formulaire un champ avec une formule de
calcul.
C'est une somme "dynamique" où je multiplie deux champs d'une même table
avec une condition sur d'autres champs. Pourquoi "dynamique" ? Parce que en
fonction de la saisie sur le formulaire, j'affiche le résultat évoluant sur
la somme totale pour un critère choisi. Somme de l'ensemble des données de
cette table.

Le problème, c'est que je ne peux pas afficher ce résultat très longtemps !
En effet, j'obtiens bien le résultat, il s'affiche puis après quelques temps
ou bien action ? Le champ calculé me retourne la valeur #erreur ?
J'ai reformuler mon calcul plusieurs fois et aléatoirement j'affiche le
résultat ou non ?

Quelqu'un a t il déjà rencontré cette anomalie ?

Merci de votre aide.

Nota : j'utilise access 2003 et les données de ma table sont importées
d'excel 2002


Publicité
Poster une réponse
Anonyme