Erreur dans formule

Le
Dédé260
Bonjour a tous, mes bons voeux
je m'explique,dans un fichier (assez long) seulement 4 colonnes (nom preno=
m vile)
la 1ere colonne est une numerotation automatique " =SI($B4<>"";$A3+"1";""=
)) "
qui fonctionne bien
seulement lorsque je supprime une ligne ou (s) j'ai #REF a la place de la c=
ellule
(normal) bien sur je prends la poignée de recopie et tout rentre dans l'o=
rdre
mais peut on eviter cette erreur soit par la formule ou en vba
merci de vos lumieres
Andre
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
MichD
Le #25926852
Bonjour,

En supposant que tu inscris la formule en A1 :
=SI(B1<>"";NBVAL(INDIRECT("$B$1:B"&LIGNE(A1)));"")
l'incrémentation se fait seulement si la cellule Bx de la ligne n'est pas
vide.

Tu peux supprimer des lignes et le tout s'ajuste automatiquement sans #ref!
Dédé260
Le #25926952
Le vendredi 10 janvier 2014 15:24:19 UTC+1, MichD a écrit :
Bonjour,



En supposant que tu inscris la formule en A1 :

=SI(B1<>"";NBVAL(INDIRECT("$B$1:B"&LIGNE(A1)));"")

l'incr�mentation se fait seulement si la cellule Bx de la ligne n 'est pas

vide.



Tu peux supprimer des lignes et le tout s'ajuste automatiquement sans #re f!



Bonjour Mich
merci pour la rapidité de ta reponse
c'est impeccable
bonne fin de journée
Publicité
Poster une réponse
Anonyme