Erreur db Access 2003 sur Windows 7

Le
Marie-Claire
Bonjour à tous,
J'étais entrai de développer une petite base de données lorsque mon vieux pc
Windows XP Pro a lâché.
J'ai été en urgence acheté un nouveau qui tourne sur Windows 7 Famille
Premium.
J'ai installé Access 2003, créé un base vierge et importé la base de données
que j'avais sauvegardé sur un disque externe.
Voici le problème lorsque j'essai d'ouvrir la base de données j'ai le
message d'erreur suivant:

D:Devbd1mdb
Une erreur s'est produite lors de l'envoi d'une commande au programme.

Les références sont toutes sélectionnées alors je suppose que cela vient du
système d'exploitation qui est différent.
Est-ce que quelqu'un peut m'aider à résoudre ce problème, s'il-vous plaît?
Marie-Claire

--
Marie-Claire
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
3stone
Le #20672001
Salut,

Marie-Claire wrote:
Bonjour à tous,
J'étais entrai de développer une petite base de données lorsque mon
vieux pc Windows XP Pro a lâché.
J'ai été en urgence acheté un nouveau qui tourne sur Windows 7 Famille
Premium.
J'ai installé Access 2003, créé un base vierge et importé la base de
données que j'avais sauvegardé sur un disque externe.
Voici le problème lorsque j'essai d'ouvrir la base de données j'ai le
message d'erreur suivant:

D:Devbd1mdb
Une erreur s'est produite lors de l'envoi d'une commande au programme.




Commencer par regarder si la bse compile correctement et si tu arrive
à la compacter - après avoir regardé si tout est bien importé...


Les références sont toutes sélectionnées alors je suppose que cela
vient du système d'exploitation qui est différent.



"toutes les références" ???
c'est affolant, cela ! de quelles références as tu besoin ?

--
A+
Pierre (3stone) Access MVP
Perso: http://www.3stone.be/
MPFA: http://www.mpfa.info/ (infos générales)
Marie-Claire
Le #20675551
Bonjour,

Commencer par regarder si la bse compile correctement et si tu arrive
à la compacter - après avoir regardé si tout est bien importé...



Tout est bien importé.
La compile se passe parfaitement.
Par contre lors du compactage, Windows annonce qu'Access a cessé de
fonctionner.

"toutes les références" ???
c'est affolant, cela ! de quelles références as tu besoin ?



Les 5 habituelles.

Voilà le résumé.
Marie-Claire

--
Marie-Claire


"3stone" a écrit :

Salut,

Marie-Claire wrote:
> Bonjour à tous,
> J'étais entrai de développer une petite base de données lorsque mon
> vieux pc Windows XP Pro a lâché.
> J'ai été en urgence acheté un nouveau qui tourne sur Windows 7 Famille
> Premium.
> J'ai installé Access 2003, créé un base vierge et importé la base de
> données que j'avais sauvegardé sur un disque externe.
> Voici le problème lorsque j'essai d'ouvrir la base de données j'ai le
> message d'erreur suivant:
>
> D:Devbd1mdb
> Une erreur s'est produite lors de l'envoi d'une commande au programme.


Commencer par regarder si la bse compile correctement et si tu arrive
à la compacter - après avoir regardé si tout est bien importé...


> Les références sont toutes sélectionnées alors je suppose que cela
> vient du système d'exploitation qui est différent.

"toutes les références" ???
c'est affolant, cela ! de quelles références as tu besoin ?

--
A+
Pierre (3stone) Access MVP
Perso: http://www.3stone.be/
MPFA: http://www.mpfa.info/ (infos générales)

.



3stone
Le #20675641
Salut,

Marie-Claire wrote:
Commencer par regarder si la bse compile correctement et si tu arrive
à la compacter - après avoir regardé si tout est bien importé...



Tout est bien importé.
La compile se passe parfaitement.
Par contre lors du compactage, Windows annonce qu'Access a cessé de
fonctionner.



Il y a peut-être un couac dans ta base...

Au lieu de tout importer d'un coup, importe :
- uniquement les tables => compacte
- les requêtes => compacte
- un formulaire à la fois => compacte
- un état à la fois => compacte
tu devrais mettre le doigt sur ce qui coince...

Mais avant cela, assure toi que tu as tous les droits sur le répertoire,
que la "sécurité" des macros est désactivée...
Ne pas installer, si possible dans la branche "Programme", ni même sur le "C:"


"toutes les références" ???
c'est affolant, cela ! de quelles références as tu besoin ?



Les 5 habituelles.



Ah bon ;-)

--
A+
Pierre (3stone) Access MVP
Perso: http://www.3stone.be/
MPFA: http://www.mpfa.info/ (infos générales)
Marie-Claire
Le #20682101
Bonjour,
Au fait le problème survient même avec une base vierge sans tables, ni
requêtes, ni formulaires, ni rien de , vide.
Le même problème korsque j'ouvre les comptoirs, base exemple d'office.
J'ai pensé qu'Access était mal installé alors je l'ai desinstallé et
réinstallé.
Rien n'a changé toujours les mêmes symtomes.
Il y a peut-être un façon pour faire une installation autrement-
Marie-Claire
--
Marie-Claire


"3stone" a écrit :

Salut,

Marie-Claire wrote:
>> Commencer par regarder si la bse compile correctement et si tu arrive
>> à la compacter - après avoir regardé si tout est bien importé...
>
> Tout est bien importé.
> La compile se passe parfaitement.
> Par contre lors du compactage, Windows annonce qu'Access a cessé de
> fonctionner.

Il y a peut-être un couac dans ta base...

Au lieu de tout importer d'un coup, importe :
- uniquement les tables => compacte
- les requêtes => compacte
- un formulaire à la fois => compacte
- un état à la fois => compacte
tu devrais mettre le doigt sur ce qui coince...

Mais avant cela, assure toi que tu as tous les droits sur le répertoire,
que la "sécurité" des macros est désactivée...
Ne pas installer, si possible dans la branche "Programme", ni même sur le "C:"


>> "toutes les références" ???
>> c'est affolant, cela ! de quelles références as tu besoin ?
>
> Les 5 habituelles.

Ah bon ;-)

--
A+
Pierre (3stone) Access MVP
Perso: http://www.3stone.be/
MPFA: http://www.mpfa.info/ (infos générales)

.



Marie-Claire
Le #20684171
Bonjour 3stone,
Je pense à une chose, lorsque j'ai acheté le nouveau pc il y avait office
2007 préinstallé que j'ai desinstallé avant d'installer office 2003. Après
avoir désinstallé office 2007 et avant d'installer office 2003 j'ai supprimé
office12 dans program file.
Est-ce que le problème vient de laà?
Et que faut-il faire ?
Merci pour tes conseils.
Marie-Claire
--
Marie-Claire


"Marie-Claire" a écrit :

Bonjour,
Au fait le problème survient même avec une base vierge sans tables, ni
requêtes, ni formulaires, ni rien de , vide.
Le même problème korsque j'ouvre les comptoirs, base exemple d'office.
J'ai pensé qu'Access était mal installé alors je l'ai desinstallé et
réinstallé.
Rien n'a changé toujours les mêmes symtomes.
Il y a peut-être un façon pour faire une installation autrement-
Marie-Claire
--
Marie-Claire


"3stone" a écrit :

> Salut,
>
> Marie-Claire wrote:
> >> Commencer par regarder si la bse compile correctement et si tu arrive
> >> à la compacter - après avoir regardé si tout est bien importé...
> >
> > Tout est bien importé.
> > La compile se passe parfaitement.
> > Par contre lors du compactage, Windows annonce qu'Access a cessé de
> > fonctionner.
>
> Il y a peut-être un couac dans ta base...
>
> Au lieu de tout importer d'un coup, importe :
> - uniquement les tables => compacte
> - les requêtes => compacte
> - un formulaire à la fois => compacte
> - un état à la fois => compacte
> tu devrais mettre le doigt sur ce qui coince...
>
> Mais avant cela, assure toi que tu as tous les droits sur le répertoire,
> que la "sécurité" des macros est désactivée...
> Ne pas installer, si possible dans la branche "Programme", ni même sur le "C:"
>
>
> >> "toutes les références" ???
> >> c'est affolant, cela ! de quelles références as tu besoin ?
> >
> > Les 5 habituelles.
>
> Ah bon ;-)
>
> --
> A+
> Pierre (3stone) Access MVP
> Perso: http://www.3stone.be/
> MPFA: http://www.mpfa.info/ (infos générales)
>
> .
>


3stone
Le #20692891
Bonjour,

Marie-Claire wrote:
Je pense à une chose, lorsque j'ai acheté le nouveau pc il y avait
office
2007 préinstallé que j'ai desinstallé avant d'installer office 2003.
Après
avoir désinstallé office 2007 et avant d'installer office 2003 j'ai
supprimé
office12 dans program file.
Est-ce que le problème vient de laà?



C'est possible, et un retour à une version précédente peut être
particulièrement pénible...

Regarde ceci : http://support.microsoft.com/kb/928218/fr

--
A+
Pierre (3stone) Access MVP
Perso: http://www.3stone.be/
MPFA: http://www.mpfa.info/ (infos générales)
Marie-Claire
Le #20698501
Bonjour,
J'ai pensé à ce problème, quand office 2007 était sorti je l'avais installé
sur un pc où il y avait office XP et tout s'était passé parfaitement les deux
offices travaillaient en bonne commanderie sauf Outlook qui avait été
remplacé par la dernière version. Visiblement dans le sens assenant tout se
passe bien mais Microsoft ne supporte pas la nostalgie.
Alors forte de cette expérience sur mon nouvel ordinateur, j'ai réinstallé
Windows 7 et ensuite Office 2003 et mon problème a été réglé, j'en conviens
c'est un peu radical mais mon nouveau pc était encore vide donc pas de risque
de perte de données.
Je viens de finir toutes ces pérégrinations et je n'ai pas pensé à ta
solution qui est bien plus pratique.

Je te remercie infiniment.
Marie-Claire
--
Marie-Claire


"3stone" a écrit :

Bonjour,

Marie-Claire wrote:
> Je pense à une chose, lorsque j'ai acheté le nouveau pc il y avait
> office
> 2007 préinstallé que j'ai desinstallé avant d'installer office 2003.
> Après
> avoir désinstallé office 2007 et avant d'installer office 2003 j'ai
> supprimé
> office12 dans program file.
> Est-ce que le problème vient de laà?

C'est possible, et un retour à une version précédente peut être
particulièrement pénible...

Regarde ceci : http://support.microsoft.com/kb/928218/fr

--
A+
Pierre (3stone) Access MVP
Perso: http://www.3stone.be/
MPFA: http://www.mpfa.info/ (infos générales)

.



Publicité
Poster une réponse
Anonyme