Erreur d'initialisation du pilote audio : comment le redémarrer ?

Le
Strange Fruit
--Boundary-00=_d7PUIuJEu4AqLgi
Content-Type: text/plain;
charset="iso-8859-1"
Content-Transfer-Encoding: 8bit
Content-Disposition: inline

Bonjour,

Avec Debian Etch, de temps en temps (1 fois sur 10 ? sur 20 ?), quand je
démarre la machine et lance ma session KDE, j'obtiens le message suivant
Information - artsmessage
Sound server informational message:
Error while initializing the sound driver:
device: default can't be opened for playback (Invalid argument)
The sound server will continue, using the null output device.
et ensuite, évidemment, plus de son.

Aller dans la configuration de kde pour relancer arts ne sert à rien ; pas
étonnant, le message d'erreur indique que le problème n'est pas à ce niveau.

La seule solution que j'ai actuellement est de tout redémarrer parce que je ne
sais pas comment relancer le pilote audio : c'est vraiment trop con, il doit
bien y avoir un moyen plus intelligent et plus rapide de relancer le son.
Pouvez-vous m'aider pour le connaître ?

Merci.

PS

Je joins la sortie triée de lsmod lorsque je n'ai pas de son.
Quand il y a du son, j'ai deux lignes supplémentaires :
inet_diag 11208 5 tcp_diag
tcp_diag 1888 0
et seules les deux lignes snd et snd_hda_intel sont modidiées pour devenir
snd 47012 10
snd_hda_intel,snd_hda_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer
et
snd_hda_intel 17332 2


--
Strange Fruit

--Boundary-00=_d7PUIuJEu4AqLgi
Content-Type: text/plain;
charset="iso-8859-1";
name="trilsmod_sans.txt"
Content-Transfer-Encoding: 7bit
Content-Disposition: attachment;
filename="trilsmod_sans.txt"

ac 5188 0
agpgart 29896 2 nvidia,intel_agp
ahci 17924 7
battery 9636 0
bluetooth 46020 4 rfcomm,l2cap
button 6672 0
cdrom 32544 1 ide_cd
cpufreq_ondemand 6636 1
cpufreq_powersave 1920 0
cpufreq_userspace 4448 0
dm_mirror 19152 0
dm_mod 50232 2 dm_snapshot,dm_mirror
dm_snapshot 15552 0
e1000 108480 0
ehci_hcd 28136 0
eth1394 18212 0
evdev 9088 2
ext3 119240 5
fan 4804 0
firmware_class 9600 2 ipw3945,r5u870
freq_table 4576 1 speedstep_centrino
generic 4868 0 [permanent]
i2c_core 19680 2 nvidia,i2c_i801
i2c_i801 7468 0
ide_cd 36064 0
ide_core 110504 3 ide_cd,generic,piix
ieee1394 86904 3 sbp2,eth1394,ohci1394
ieee80211 29480 1 ipw3945
ieee80211_crypt 5952 1 ieee80211
intel_agp 22204 0
ipv6 226272 16
ipw3945 179972 1
jbd 52456 1 ext3
joydev 9088 0
l2cap 21760 5 rfcomm
libata 89396 1 ahci
loop 15048 0
lp 11012 0
mbcache 8356 1 ext3
mmc_core 23168 1 sdhci
Module Size Used by
nls_iso8859_1 4256 1
ntfs 192564 1
nvidia 4549908 12
ohci1394 30800 0
parport 33256 3 ppdev,parport_pc,lp
parport_pc 32132 0
pcspkr 3072 0
piix 9444 0 [permanent]
ppdev 8676 0
processor 28840 2 speedstep_centrino,thermal
psmouse 35016 0
r5u870 60164 0
rfcomm 34712 0
rtc 12372 0
sbp2 20840 0
scsi_mod 124168 4 sbp2,sd_mod,ahci,libata
sdhci 16844 0
sd_mod 19040 8
serio_raw 6660 0
snd 47012 8 snd_hda_intel,snd_hda_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer
snd_hda_codec 137856 1 snd_hda_intel
snd_hda_intel 17332 1
snd_mixer_oss 15200 1 snd_pcm_oss
snd_page_alloc 10184 2 snd_hda_intel,snd_pcm
snd_pcm 68676 3 snd_hda_intel,snd_hda_codec,snd_pcm_oss
snd_pcm_oss 38368 0
snd_timer 20996 1 snd_pcm
soundcore 9248 1 snd
speedstep_centrino 8384 2
thermal 13608 0
tsdev 7520 0
uhci_hcd 21164 0
usbcore 112644 4 r5u870,ehci_hcd,uhci_hcd
v4l1_compat 12036 2 r5u870,videodev
v4l2_common 20448 2 r5u870,videodev
video_buf 23012 1 r5u870
videodev 21120 1 r5u870

--Boundary-00=_d7PUIuJEu4AqLgi--

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to debian-user-french-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
David Prévot
Le #9661171
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Strange Fruit a écrit :
Bonjour,



Bonjour,

Avec Debian Etch, de temps en temps (1 fois sur 10 ? sur 20 ?), quand je
démarre la machine et lance ma session KDE, j'obtiens le message suivant
Information - artsmessage
Sound server informational message:
Error while initializing the sound driver:
device: default can't be opened for playback (Invalid argument)
The sound server will continue, using the null output device.
et ensuite, évidemment, plus de son.

Aller dans la configuration de kde pour relancer arts ne sert à rien ; pas
étonnant, le message d'erreur indique que le problème n'est pas à ce niveau.

La seule solution que j'ai actuellement est de tout redémarrer parce que je ne
sais pas comment relancer le pilote audio : c'est vraiment trop con, il doit
bien y avoir un moyen plus intelligent et plus rapide de relancer le son.
Pouvez-vous m'aider pour le connaître ?



Décharger puis recharger les modules du son avant de redémarrer arts
peut-être ?

Amicalement

David

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)

iEYEARECAAYFAkhRCbgACgkQ18/WetbTC/qSRACeJpnzthH3uS+t2Wz3QZDUgIR3
DNcAn2Azkk8p/T0JGLHnT9HuUUMaAMD9
qZ
-----END PGP SIGNATURE-----

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Strange Fruit
Le #9659831
Le jeudi 12 juin 2008 13:34, David Prévot a écrit :
Strange Fruit a écrit :
> La seule solution que j'ai actuellement est de tout redémarrer parce que
> je ne sais pas comment relancer le pilote audio : c'est vraiment trop
> con, il doit bien y avoir un moyen plus intelligent et plus rapide de
> relancer le son. Pouvez-vous m'aider pour le connaître ?

Décharger puis recharger les modules du son avant de redémarrer arts
peut-être ?

Amicalement

David



Merci David, mais je ne sais pas trop comment.

Dois-je essayer tous les modules snd* et soundcore ? C'est que ça ne se laisse
pas enlever facilement ces affaires-là :
sudo rmmod snd snd_hda_codec snd_hda_intel snd_mixer_oss snd_page_alloc
snd_pcm snd_pcm_oss snd_timer soundcore

ERROR: Module snd is in use by
snd_hda_intel,snd_hda_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer
ERROR: Module snd_hda_codec is in use by snd_hda_intel
ERROR: Module snd_hda_intel is in use
ERROR: Module snd_mixer_oss is in use by snd_pcm_oss
ERROR: Module snd_page_alloc is in use by snd_hda_intel,snd_pcm
ERROR: Module snd_pcm is in use by snd_hda_intel,snd_hda_codec,snd_pcm_oss
ERROR: Module snd_timer is in use by snd_pcm
ERROR: Module soundcore is in use by snd

et avec l'option -f ce n'est pas beaucoup mieux :
ERROR: Removing 'snd': Resource temporarily unavailable
ERROR: Removing 'snd_hda_codec': Resource temporarily unavailable
(et le term semble figé maintenant)

Ne me dites pas de ne pas utilliser rmmod mais modprobe -r, ce n'est pas
mieux : FATAL: Module snd is in use.

Évidemment je viens de tester à un moment où le son fonctionnait. Je verrai ce
qui se passera quand la panne se reproduira ; peut-être demain, peut-être
dans un mois... Mais j'ai des doutes.

--
Strange Fruit

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Publicité
Poster une réponse
Anonyme