erreur lors de l'upload de fichier par $file

Le
Paskal
Bonjour

Je m'arrache les cheveux à essayer de résoudre un pb que je ne rencontre pas
en local mais qui, chez OVH ne se déroule pas bien :

Je propose au visiteur de m'envoyer un document, je le charge (à priori
correctement car je le vérifie par la tableau $files) puis je le déplace
dans un dossier de mon site (un upload en php, banal).

Je n'ai aucun message d'erreur, mais lorsque je veux regarder la photo, je
m'aperçois qu'elle n'est pas complète.

J'ai essayé en rajoutant dans le script de chargement :
ini_set("memory_limit" , "48M");

Egalement en ajoutant dans le .htaccess :
<IfModule mod_php4.c>
php_value upload_max_filesize 50M
php_value post_max_size 50M
</IfModule>


Ca parait être un pb de limitation de taille de fichier, mais où modifier ça
?


Merci,
Pascal
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Mickael Wolff
Le #1682843

Ca parait être un pb de limitation de taille de fichier, mais où
modifier ça ?


As-tu posé la question à leur support ?
As-tu posé la question sur le forum web d'OVH ?
Quelle offre disposes-tu chez OVH ? (mutualisé, dédié)
As-tu lu la documentation associée ?

--
Mickaël Wolff aka Lupus Michaelis
http://lupusmic.org

Paskal
Le #2204231
Bonjour Mickael


Désolé de ne pas t'avoir répondu plus tôt : passé les quelques premiers
jours, je croyais que je n'aurai pas de réponse..et je découvre par hasard
aujourd'hui ta réponse.

Non, je n'ai pas posé la question à OVH. Je suis allé dans mon 'espace
personnel' et j'ai vu que j'avais presque atteint la taille limite liée à
mon abonnement. Je me suis dit que peut-être....
J'ai donc fais du ménage, et en réessayant, j'ai vu que cela fonctionnait à
nouveau, mais avec une image horrible (toute rouge). Comme je n'ai pas le
même jour, je ne suis pas sûr que le ménage soit lié (d'ailleurs, je ne
pense pas).

Aujourdh'ui, je n'ai rien touché et ça fonctionne impeccable.

C'était manifestement un problème chez eux.

Mais merci de ta réponse,

Pascal




"Mickael Wolff" 47e07a99$0$1633$

Ca parait être un pb de limitation de taille de fichier, mais où
modifier ça ?


As-tu posé la question à leur support ?
As-tu posé la question sur le forum web d'OVH ?
Quelle offre disposes-tu chez OVH ? (mutualisé, dédié)
As-tu lu la documentation associée ?

--
Mickaël Wolff aka Lupus Michaelis
http://lupusmic.org



Publicité
Poster une réponse
Anonyme