Erreur non spécifiée sur le pages contenant des filtres

Le
Claude Schneegans
Bonjour,

J'ai une application qui contient quelques utilisations simples de
filtres et transitions Microsoft.
Ça marche sur deux de mes ordinateurs, sous MSIE 6 et 7, mais sur un
troisième sous MSIE 7,
tout ce que j'obtiens, c'est un message « d'erreur non spécifiée »,
et ce même sur les pages d'exemples chez microsoft, comme :
http://samples.msdn.microsoft.com/workshop/samples/author/dhtml/DXTidemo/DXTidemo.htm
(reconstituer l'adresse si elle a été coupée en deux lignes)

Je supute quelque paramètre de sécurité trop sévère, en particulier en
ce qui a trait
aux ActiveX, mais lesquels ?

Qqun aurait-il une idée ?
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
MCI \(ex do ré Mi chel la si do\) [MVP]
Le #1964522
Bonjour !


Le lien que tu cites contient des D.A. (Direct Animation ; en gros,
Direct-X par HTML).
A cause de soit-disant "risques potentiels" (le pléonasme n'est pas de
moi), certaines fonctions ont été bloquées.

Perso, j'ai pu rétablir plusieurs fonctions avec le truc suivant :

1 - en invite de commande, taper regsvr32 danim.dll [Entrée]

2 - lancer Regedit,
- aller à la clef :
HKEY_LOCAL_MACHINESOFTWAREMicrosoftInternet ExplorerActiveX
Compatibility{B6FFC24C-7E13-11D0-9B47-00C04FC2F51D}
- supprimer l'entrée : "Compatibility Flags" =
dword:00000400

Mais, je ne suis pas sûr que ça rétablisse la situation chez toi.
D'ailleurs, parmi mes messages (sur ce site
http://mclaveau.com/mailart/liste.htm) qui fonctionnaient sous IE-6 ;
1/3 ne fonctionnent plus sous IE-7.



Sinon, y a pas de raison que ça ne marche pas chez toi ; car, moi, je
vois les filtres, les transitions, etc.



@-salutations

Michel Claveau
Claude Schneegans
Le #1965295
Perso, j'ai pu rétablir plusieurs fonctions avec le truc suivant :



Merci, j'ai essayé, mais ça n'a pas suffit.

D'ailleurs, parmi mes messages (sur ce site
http://mclaveau.com/mailart/liste.htm) qui fonctionnaient sous IE-6 ;


1/3 ne fonctionnent plus sous IE-7.

Effectivement, dans mon cas, les filtres causent la même erreur.

J'ai fini par laisser bon nombre de permissions dans la sécurité, et
pouuuf ! Ça marche !
C'est donc bien là qu'est le problème, il me reste maintenant à essayer
ces permissions
ou restriction une par une, pour vérifier laquelle est responsable.
Et ce n'est pas simple, car il y en a !

Merci.


Claude Schneegans
Le #1965294
Et ce n'est pas simple, car il y en a !



En fait, j'arrive à causer exactement la même erreur, même sous IE 6,
simplement
en désactivant carrément tous les Active-X.

C'est assez débile de la part de Microsoft de ne pas mieux documenter ce
comportement
des filtres, parmis nos utilisateurs, combien savent que les filtres
dépendent des Active-X,
combien savent seulement ce que c'est que les Active-X ?

La solution, c'est de dectecter dans un premier temps si les filtres
fonctionnent,
sans doute à l'aide d'une instruction try... catch, et de remplacer
l'exécution du filtre
par la transformation directe dans l'état final. Au moins comme ça, la
page peut
quand même être visitée, tant pis pour ceux qui ne voient pas les
transitions.

Par exemple :
Avant :
tableau.style.top = wh-225 - tableau.offsetHeight;
if(tableau.filters)tableau.filters[0].Apply();
tableau.style.visibility = "visible";
if(tableau.filters)tableau.filters[0].Play();

Après :
try
{
tableau.style.top = wh-225 - tableau.offsetHeight;
if(tableau.filters)tableau.filters[0].Apply();
tableau.style.visibility = "visible";
if(tableau.filters)tableau.filters[0].Play();
}
catch(e)
{
tableau.style.visibility = "visible";
}


MCI \(ex do ré Mi chel la si do\) [MVP]
Le #1968930
Re !

Ton idée est bonne... pour les sites web en ligne sur Internet.
Mais, il y a beaucoup d'autres cas d'utilisation. Par exemple :
- dans les messages en HTML (notamment pour l'e-mail-art) ; et, là,
on estime généralement que TOUS les lecteurs sont configurés pour
apprécier les messages.
- lors d'une utilisation purement locale (dans les .HTA =
HTml-Applications) ; je fais cela très souvent. Mais, là, on est dans
une autre zone d'exécution, "Poste de Travail", qui est cachée par
défaut, dans Vista/XP. Avec une configuration à part, mais permissive
par défaut. Ce genre d'utilisation est courante avec les applications
"Clients riches".
- dans un Intranet ; là aussi, les machines peuvent être considérées
comme pré-configurées.
- via les versions Active-X d'Internet-Explorer ; pour beaucoup
d'applications qui intègrent cette version d'IE dans leurs propres
écrans.

Pour tous ces cas, il peut être plus intéressant de (re)-configurer les
postes, via le Registre (chaque élément que tu as coché correspond à une
clef/entrée du registre), plutôt que de tester dans toutes les pages
HTML.

Surtout que certaines fonctionnalités ont disparues corps et biens...

@-salutations

Michel Claveau
Claude Schneegans
Le #1971121
Ton idée est bonne... pour les sites web en ligne sur Internet.
Mais, il y a beaucoup d'autres cas d'utilisation. Par exemple :



Tout à fait, mais il y a alors deux cas :
- ceux pour lesquels on tient à ce que ça marche, c'était mon cas pour
un module de présentation de diaporama;
- ceux pour lesquels le visiteur parano a trop estropié son navigateur,
pour ceux-là, je les laisse avec leur problème.
(Je mets dans cette catégorie ceux qui désactivent Javascrip ou les cookies)


MCI \(ex do ré Mi chel la si do\) [MVP]
Le #1983801
Re !

On est d'accord.
Sinon, une solution qui passe (presque) partout :
http://www.mclaveau.com/gvrac/infoa.html

@-salutations
--
Michel Claveau
Claude Schneegans
Le #1991651
Sinon, une solution qui passe (presque) partout :



Aaaarghhh ! ;-)


Publicité
Poster une réponse
Anonyme