#erreur pour le calcul du total d'un sous-formulaire

Le
ThunderBirds
Bonjour à tous,

J'ai un petit souci avec un champ indpendant pour calculer le total d'un
sous-formulaire.
Mon sform est attaché à mon form via la clé primaire et étrangère.
Dans la zone détail de mon sform je saisie des montants
Dans le pied de mon sform, j'ai inséré un champ TOTMT ayant pour source
=Somme([Montants])
Lorsque je passe en mode formulaire, je visualise bien le montant total des
montants saisie dans mon sform.
Dans mon form, j'ai donc inséré un champ ayant pour source
sform.formulaire!TOTMT

Mon souci est que ce champ affiche #erreur lorsque mon sform ne contient
aucun enregistrement. J'ai essayé des combinaisons avec VraiFaux, EstNull,
EstVide, etc.
Je n'y arrive pas.

Comment faire pour afficher 0 si aucun enregistrement dans mon sform ou le
montant approprié?

Merci d'avance
Questions / Réponses high-tech
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Tisane
Le #6271201
Bonjour "ThunderBirds",

J'ai un petit souci avec un champ indpendant pour calculer le total d'un
sous-formulaire.
Mon sform est attaché à mon form via la clé primaire et étrangère.
Dans la zone détail de mon sform je saisie des montants
Dans le pied de mon sform, j'ai inséré un champ TOTMT ayant pour source
=Somme([Montants])
Lorsque je passe en mode formulaire, je visualise bien le montant total
des
montants saisie dans mon sform.
Dans mon form, j'ai donc inséré un champ ayant pour source
sform.formulaire!TOTMT
Mon souci est que ce champ affiche #erreur lorsque mon sform ne contient
aucun enregistrement. J'ai essayé des combinaisons avec VraiFaux, EstNull,
EstVide, etc.
Comment faire pour afficher 0 si aucun enregistrement dans mon sform ou le
montant approprié?


Pour afficher 0 lorsqu'il n'y a pas d'enregistrements dans le
sous-formulaire, tu peux essayer ceci :
=VraiFaux([sform].Formulaire.RecordSet.RecordCount=0;0;[sform].[formulaire]!TOTMT)

--
Tisane

ThunderBirds
Le #6270641
Bonsoir
Merci beaucoup
@+


Bonjour "ThunderBirds",

J'ai un petit souci avec un champ indpendant pour calculer le total d'un
sous-formulaire.
Mon sform est attaché à mon form via la clé primaire et étrangère.
Dans la zone détail de mon sform je saisie des montants
Dans le pied de mon sform, j'ai inséré un champ TOTMT ayant pour source
=Somme([Montants])
Lorsque je passe en mode formulaire, je visualise bien le montant total
des
montants saisie dans mon sform.
Dans mon form, j'ai donc inséré un champ ayant pour source
sform.formulaire!TOTMT
Mon souci est que ce champ affiche #erreur lorsque mon sform ne contient
aucun enregistrement. J'ai essayé des combinaisons avec VraiFaux, EstNull,
EstVide, etc.
Comment faire pour afficher 0 si aucun enregistrement dans mon sform ou le
montant approprié?


Pour afficher 0 lorsqu'il n'y a pas d'enregistrements dans le
sous-formulaire, tu peux essayer ceci :
=VraiFaux([sform].Formulaire.RecordSet.RecordCount=0;0;[sform].[formulaire]!TOTMT)

--
Tisane





Publicité
Poster une réponse
Anonyme