Erreur Userenv

Le
Sniper
Amis du jour, bonjour.
Depuis quelques jours, j'ai à chaque démarrage une erreur enregistrée
dans le journal d'événements:
Type de l'événement : Erreur
Source de l'événement : Userenv
Catégorie de l'événement : Aucun
ID de l'événement : 1090
Date : 29/11/2008
Heure : 16:19:38
Utilisateur : AUTORITE NTSYSTEM
Ordinateur : DIRECTEUR
Description :
Windows n'a pas pu enregistrer le statut de la session RSoP (Jeu de
stratégies résultant). Une tentative de connexion à WMI a échoué. Aucun
enregistrement RSoP, ne sera effectué pour cette application de
stratégie.

Après le dernier démarrage, j'ai fouillé les fichiers log.
J'ai trouvé dans C:WINDOWSsystem32wbemLogswbemcore.log :
(Sat Nov 29 16:20:24 2008.138296) : GetUserDefaultLCID failed,
restorting to system verion

dans C:WINDOWSsystem32wbemLogswbemess.log :
(Sat Nov 29 16:19:41 2008.96375) : NT Event Log Consumer: could not
retrieve sid, 0x80041002
(Sat Nov 29 16:19:41 2008.96421) : NT Event Log Consumer: could not
retrieve sid, 0x80041002
(Sat Nov 29 16:19:41 2008.96421) : NT Event Log Consumer: could not
retrieve sid, 0x80041002
(Sat Nov 29 16:19:41 2008.96421) : NT Event Log Consumer: could not
retrieve sid, 0x80041002
(Sat Nov 29 16:19:42 2008.96625) : NT Event Log Consumer: could not
retrieve sid, 0x80041002
(Sat Nov 29 16:19:46 2008.101218) : NT Event Log Consumer: could not
retrieve sid, 0x80041002
(Sat Nov 29 16:19:49 2008.104265) : NT Event Log Consumer: could not
retrieve sid, 0x80041002
(Sat Nov 29 16:22:26 2008.259593) : NT Event Log Consumer: could not
retrieve sid, 0x80041002

dans C:WINDOWSsystem32wbemLogswbemprox.log:
(Sat Nov 29 16:19:37 2008.92359) : NTLMLogin resulted in hr =
0x8004100e
(Sat Nov 29 16:19:38 2008.92625) : NTLMLogin resulted in hr =
0x8004100e
(Sat Nov 29 16:19:38 2008.92671) : NTLMLogin resulted in hr =
0x8004100e

et dans C:WINDOWSsystem32wbemLogswmiprov.log :
(Sat Nov 29 16:19:43 2008.97734) : WDM call returned error: 4200
(Sat Nov 29 16:23:30 2008.323500) : WDM call returned error: 4200
(Sat Nov 29 16:27:48 2008.582203) : Impersonation failed - Access
denied

Comme d'hab', le service proposé par Microsoft ne donne aucune info. Et
les proposition de solution trouvées sur d'autres sites (la tanière de
PN et Malekal) ne m'ont pas dépanné.
Si un spécialiste d'XP ici peut me suggérer une solution ou une piste à
explorer, je le remercie d'avance.

--
Sniper

Tous les mots employés dans ce post sont entièrement composés de
lettres, chiffres et signes typographiques libres de droit.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
jackr13
Le #17997161
Bonjour,

Sniper wrote:
Amis du jour, bonjour.
Depuis quelques jours, j'ai à chaque démarrage une erreur enregistrée
dans le journal d'événements:
Type de l'événement : Erreur
Source de l'événement : Userenv
Catégorie de l'événement : Aucun
ID de l'événement : 1090
Date : 29/11/2008
Heure : 16:19:38
Utilisateur : AUTORITE NTSYSTEM
Ordinateur : DIRECTEUR
Description :
Windows n'a pas pu enregistrer le statut de la session RSoP (Jeu de
stratégies résultant). Une tentative de connexion à WMI a échoué.
Aucun enregistrement RSoP, ne sera effectué pour cette application de
stratégie.

Après le dernier démarrage, j'ai fouillé les fichiers log.
J'ai trouvé dans C:WINDOWSsystem32wbemLogswbemcore.log :
(Sat Nov 29 16:20:24 2008.138296) : GetUserDefaultLCID failed,
restorting to system verion

dans C:WINDOWSsystem32wbemLogswbemess.log :
(Sat Nov 29 16:19:41 2008.96375) : NT Event Log Consumer: could not
retrieve sid, 0x80041002
(Sat Nov 29 16:19:41 2008.96421) : NT Event Log Consumer: could not
retrieve sid, 0x80041002
(Sat Nov 29 16:19:41 2008.96421) : NT Event Log Consumer: could not
retrieve sid, 0x80041002
(Sat Nov 29 16:19:41 2008.96421) : NT Event Log Consumer: could not
retrieve sid, 0x80041002
(Sat Nov 29 16:19:42 2008.96625) : NT Event Log Consumer: could not
retrieve sid, 0x80041002
(Sat Nov 29 16:19:46 2008.101218) : NT Event Log Consumer: could not
retrieve sid, 0x80041002
(Sat Nov 29 16:19:49 2008.104265) : NT Event Log Consumer: could not
retrieve sid, 0x80041002
(Sat Nov 29 16:22:26 2008.259593) : NT Event Log Consumer: could not
retrieve sid, 0x80041002

dans C:WINDOWSsystem32wbemLogswbemprox.log:
(Sat Nov 29 16:19:37 2008.92359) : NTLMLogin resulted in hr > 0x8004100e
(Sat Nov 29 16:19:38 2008.92625) : NTLMLogin resulted in hr > 0x8004100e
(Sat Nov 29 16:19:38 2008.92671) : NTLMLogin resulted in hr > 0x8004100e

et dans C:WINDOWSsystem32wbemLogswmiprov.log :
(Sat Nov 29 16:19:43 2008.97734) : WDM call returned error: 4200
(Sat Nov 29 16:23:30 2008.323500) : WDM call returned error: 4200
(Sat Nov 29 16:27:48 2008.582203) : Impersonation failed - Access
denied

Comme d'hab', le service proposé par Microsoft ne donne aucune info.
Et les proposition de solution trouvées sur d'autres sites (la
tanière de PN et Malekal) ne m'ont pas dépanné....
Si un spécialiste d'XP ici peut me suggérer une solution ou une piste
à explorer, je le remercie d'avance.



A tout hasard voir :
http://technet.microsoft.com/en-us/library/cc727339.aspx

Dans un premier temps vérifiez si le chemin %Systemroot%System32Wbem
est toujours dans chemin environnement . Testez par set ou set path
sous invite de commandes.

Cordialement,
jackr13
Herser
Le #17997141
Sniper wrote:
Amis du jour, bonjour.
Depuis quelques jours, j'ai à chaque démarrage une erreur enregistrée
dans le journal d'événements:
Type de l'événement : Erreur
Source de l'événement : Userenv
Catégorie de l'événement : Aucun
ID de l'événement : 1090
Date : 29/11/2008
Heure : 16:19:38
Utilisateur : AUTORITE NTSYSTEM
Ordinateur : DIRECTEUR
Description :
Windows n'a pas pu enregistrer le statut de la session RSoP (Jeu de
stratégies résultant). Une tentative de connexion à WMI a échoué.
Aucun enregistrement RSoP, ne sera effectué pour cette application de
stratégie.

Après le dernier démarrage, j'ai fouillé les fichiers log.
J'ai trouvé dans C:WINDOWSsystem32wbemLogswbemcore.log :
(Sat Nov 29 16:20:24 2008.138296) : GetUserDefaultLCID failed,
restorting to system verion

dans C:WINDOWSsystem32wbemLogswbemess.log :
(Sat Nov 29 16:19:41 2008.96375) : NT Event Log Consumer: could not
retrieve sid, 0x80041002
(Sat Nov 29 16:19:41 2008.96421) : NT Event Log Consumer: could not
retrieve sid, 0x80041002
(Sat Nov 29 16:19:41 2008.96421) : NT Event Log Consumer: could not
retrieve sid, 0x80041002
(Sat Nov 29 16:19:41 2008.96421) : NT Event Log Consumer: could not
retrieve sid, 0x80041002
(Sat Nov 29 16:19:42 2008.96625) : NT Event Log Consumer: could not
retrieve sid, 0x80041002
(Sat Nov 29 16:19:46 2008.101218) : NT Event Log Consumer: could not
retrieve sid, 0x80041002
(Sat Nov 29 16:19:49 2008.104265) : NT Event Log Consumer: could not
retrieve sid, 0x80041002
(Sat Nov 29 16:22:26 2008.259593) : NT Event Log Consumer: could not
retrieve sid, 0x80041002

dans C:WINDOWSsystem32wbemLogswbemprox.log:
(Sat Nov 29 16:19:37 2008.92359) : NTLMLogin resulted in hr > 0x8004100e
(Sat Nov 29 16:19:38 2008.92625) : NTLMLogin resulted in hr > 0x8004100e
(Sat Nov 29 16:19:38 2008.92671) : NTLMLogin resulted in hr > 0x8004100e

et dans C:WINDOWSsystem32wbemLogswmiprov.log :
(Sat Nov 29 16:19:43 2008.97734) : WDM call returned error: 4200
(Sat Nov 29 16:23:30 2008.323500) : WDM call returned error: 4200
(Sat Nov 29 16:27:48 2008.582203) : Impersonation failed - Access
denied

Comme d'hab', le service proposé par Microsoft ne donne aucune info.
Et les proposition de solution trouvées sur d'autres sites (la
tanière de PN et Malekal) ne m'ont pas dépanné....
Si un spécialiste d'XP ici peut me suggérer une solution ou une piste
à explorer, je le remercie d'avance.



Salut
Tu as vu cette page de MS in english :
http://www.microsoft.com/technet/support/ee/transform.aspx?ProdName=Windows+Operating+System&ProdVer=5.2&EvtID90&EvtSrc=Userenv&LCID33

Vérifier que le service WMI est démarré
démarrer Executer et taper wbemtest.exe
Ce qui ouvre le testeur WMI (aide intégrée) et vérifier que "connexion"
marche
etc...
Mais ce n'est pas très clair pour moi ce service WMI
http://laurent-dardenne.developpez.com/articles/wmi-p1/

Herser
Jean-Claude BELLAMY
Le #17997271
"Sniper" news:
Amis du jour, bonjour.
Depuis quelques jours, j'ai à chaque démarrage une erreur enregistrée dans
le journal d'événements: [...]
Windows n'a pas pu enregistrer le statut de la session RSoP (Jeu de
stratégies résultant). Une tentative de connexion à WMI a échoué.



Vraisemblablement c'est WMI (Windows Management Instrumentation) qui a du
avoir des "vapeurs" !

Très probablement il faut réinstaller WMI.
N'aies crainte, c'est facile et sans danger !

Cela consiste à effacer puis recréer le dossier "Repository" de WMI

La méthode (décrite dans le MSDN) est la suivante :

1) Arrêter le service WMI (s'il tourne!)
Commande :
NET STOP winmgmt

Pour info : sous XP SP2 (et +), cela va entrainer l'arrêt du centre de
sécurité et du pare-feu (sauf si on les a volontairement arrêtés).
Pour éviter des injurebox, on peut donc prévoir ces arrêts auparavant par
les commandes :
NET STOP wscsvc
NET STOP SharedAccess

2) Supprimer le dossier "WMI repository"
Commande :
RD %systemroot%system32wbemRepository /S /Q

3) Redémarrer le service WMI :
Commande :
NET START winmgmt
Le dossier "Repository" est alors recréé et WMI devrait (normalement!)
refonctionner.


--
May the Force be with You!
La Connaissance s'accroît quand on la partage
----------------------------------------------------------
Jean-Claude BELLAMY [MVP] - http://www.bellamyjc.org
Sniper
Le #17998171
Jean-Claude BELLAMY a exposé le 29/11/2008, Saint Saturnin :

Le dossier "Repository" est alors recréé et WMI devrait (normalement!)
refonctionner.



Tout fait comme tu m'as écrit, sans résultat :-(
Désolé Jean-Claude... ;-)
Je me demande si mon XP ne cherche pas un utilisateur fantôme du genre
ASP ou .NET... je gratterai ça après manger.
Merci JC ;-)

--
Sniper

Il est des cas fortuits où les personnes les plus perspicaces
sont soumises à des vicissitudes indubitablement aléatoires.
© D.S.
jackr13
Le #17998431
Re,

Sniper wrote:
Jean-Claude BELLAMY a exposé le 29/11/2008, Saint Saturnin :

Le dossier "Repository" est alors recréé et WMI devrait
(normalement!) refonctionner.



Tout fait comme tu m'as écrit, sans résultat :-(
Désolé Jean-Claude... ;-)
Je me demande si mon XP ne cherche pas un utilisateur fantôme du genre
ASP ou .NET... je gratterai ça après manger.
Merci JC ;-)



Vu le résultat .

Une autre possibilité est une incompatibilité entre un driver et WMI
mais ce problème devrait exister depuis longtemps .. à moins que
récemment il n'y ait eu une mise à jour.
WDM Call returned error : 4200. ( Windows Driver Model )
Si c'est le cas le fichier wmiprov.log devrait donner .. plus de
renseignementssur ce pilote.

Pour Information : La recherche sur google montre qu'un bug est signalé
pour le driver Réseau Intel si version 8.4, 11.2 ou 12.2 repertorié en
2007. voir article
http://www.archivum.info/intel.network.adapters/2007-09/msg00001.html
dans lequel on retrouve un certain nombre des erreurs du message initial
Un driver Intel version 13.3 est publié pour tenir compte de ce bug ....
voir
http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldIdB75&lang=fra
fichier à télécharger : PRO2KXP_v13_3.exe ( ang , 12323 Kb )

et voir fichier Notes de Mises à jour de cette page ( en anglais )
dans lequel il est précisé
<CITATION>

WinMgmt warning messages in Event Viewer
----------------------------------------
Several warning messages are displayed in the Event Viewer after
installing
Intel PROSet. This occurs because Intel PROSet installs WMI classes.
Intel PROSet has installed correctly.

</CITATION>

Si cela peut être utile...
Nous dire..


Cordialement,
jackr13
Sniper
Le #17998981
En ce samedi, jackr13 a gentiment clavioté de ses petits doigts musclés
:

Une autre possibilité est une incompatibilité entre un driver et WMI
mais ce problème devrait exister depuis longtemps .. à moins que
récemment il n'y ait eu une mise à jour.



Peut-être une piste.... j'ai installé récemment des drivers pour une
clé USB Bluetooth... avec difficulté d'ailleurs...

WDM Call returned error : 4200. ( Windows Driver Model )
Si c'est le cas le fichier wmiprov.log devrait donner .. plus de
renseignementssur ce pilote.



Non, rien de plus que j'ai donné dans les logs.

Pour Information : La recherche sur google montre qu'un bug est signalé
pour le driver Réseau Intel si version 8.4, 11.2 ou 12.2 repertorié en
2007. voir article



Ça ne semble pas me concerner (ou j'ai mal compris...) ma carte réseau
est une ADMtek AN983.

Je vais piocher la piste de la clé BT/USB.... merciJack ;-)

--
Sniper

Si vous ne faites pas aujourd'hui ce que vous avez dans la tête,
demain vous l'aurez dans le cul .
Coluche 1944-1986
jackr13
Le #18003371
Bonjour,

Sniper wrote:
En ce samedi, jackr13 a gentiment clavioté de ses petits doigts
musclés




Une autre possibilité est une incompatibilité entre un driver et WMI
mais ce problème devrait exister depuis longtemps .. à moins que
récemment il n'y ait eu une mise à jour.



Peut-être une piste.... j'ai installé récemment des drivers pour une
clé USB Bluetooth... avec difficulté d'ailleurs...

WDM Call returned error : 4200. ( Windows Driver Model )
Si c'est le cas le fichier wmiprov.log devrait donner .. plus de
renseignementssur ce pilote.



Non, rien de plus que j'ai donné dans les logs.

Pour Information : La recherche sur google montre qu'un bug est
signalé pour le driver Réseau Intel si version 8.4, 11.2 ou 12.2
repertorié en 2007. voir article



Ça ne semble pas me concerner (ou j'ai mal compris...) ma carte réseau
est une ADMtek AN983.

Je vais piocher la piste de la clé BT/USB.... merciJack ;-)




il se peut que ce problème de WDM soit plutôt une conséquence. .. Donc
si pas autre voie.
J'ai trouvé çà à partir de Google
1.Tutorial: How To Fix WMI Corruption
http://www.djkaty.com/wmicorruption
Plusieurs solutions sont envisagées dont celle du Repository corruption
proposée par JCB. Une autre solution parle de rétablir les permissions
de sécurité.
Cette solution rappelle une solution proposée après installation de XP
sp3 pour réaliser les nouvelles mises à jour ou pour installer IE7et qui
a fonctionnée avec succès plusieurs fois .
voir site http://fspsa.free.fr/mises-a-jour.htm#reinitialiser-registre
Il s'agit de télécharger et installer SubInAcl et ensuite appliquer le
batch reset-permissions.cmd
Suivre lle mode opératoire du site.Cette opération prend environ 15
minutes. cela n'engage à rien de l'appliquer.
Quand opération est terminée relancer le poste de travail et voir le
résultat dans journal évènements.
Attention dans la méthode du tutorial il est indiqué administrators pour
la version française c'est administrateurs qui est à utiliser. Dans le
batch cmd de JF la correction est effectuée.
2. http://www.d2i.ch/pn/az/r.html

Nous dire..

Cordialement,

jackr13






.
Sniper
Le #18004411
jackr13 nous a énoncé ce dimanche 30/11/2008, Avent :

Nous dire..



Merci Jack ;-)
je mets ça au frais pour m'y attaquer à tête reposée et avec du temps
devant moi. Je vais devoir déjà me traduire la page en anglais sans
erreur... mais ça devrait le faire. :-)

--
Sniper

On ne dit pas il est chétif, mais il est chez le coiffeur.
jackr13
Le #18012251
Bonjour Sniper,

Sniper wrote:
jackr13 nous a énoncé ce dimanche 30/11/2008, Avent :

Nous dire..



Merci Jack ;-)
je mets ça au frais pour m'y attaquer à tête reposée et avec du temps
devant moi. Je vais devoir déjà me traduire la page en anglais sans
erreur... mais ça devrait le faire. :-)



Quelques compléments pour faire avancer le problème :

Apparemment il faut dissocier l'erreur 1090 ( RSoP .. ) des erreurs
contenues dans les journaux du dossier logs.

Une observation de deux machines fonctionnelles DELL ( les modèles
sont différents ) montre :

-pas d'erreur 1090 dans les journaux d'évènements,

-contiennent dans les journaux les mêmes erreurs observées par Sniper
sur sa machine à savoir :
-0x80044100e dans wbemprox.log,
-0x800441002 dans wbemess.log ,
-GetUserDefaultLCID failed restorting to system verion dans
wbemcore.log,
ainsi que
-WDM call returned error : 4200 dans wmiprov.log ,

à plusieurs reprises et pour différentes dates.

Ces informations ne semblent donc pas pertinentes pour résoudre le
problème RSoP .. Erreur 1090 ( Variable Userenv ).

PS : Pour les deux machines .. une est restée en SP2 l'autre est en SP3
et le service UPHClean est actif sur les deux..

Si çà peut faire avancer le Schmilblick .

Cordialement,
jackr13
Publicité
Poster une réponse
Anonyme