erreurs config spamassassin

Le
Olivier Masson
Bonjour,

suite à mon passage à lenny, j'ai fait divers vérifications, donc un
spamassassin -D --lint.
Ce dernier me sort :
Errno architecture (i486-linux-gnu-thread-multi-2.6.18-6-686) does not
match executable architecture (i486-linux-gnu-thread-multi-2.6.26-1-686)
at /usr/local/share/perl/5.8.8/Errno.pm line 11.
Compilation failed in require at
/usr/share/perl5/Mail/SpamAssassin/Util.pm line 65.
BEGIN failed--compilation aborted at
/usr/share/perl5/Mail/SpamAssassin/Util.pm line 65.
Compilation failed in require at
/usr/share/perl5/Mail/SpamAssassin/Conf.pm line 79.
BEGIN failed--compilation aborted at
/usr/share/perl5/Mail/SpamAssassin/Conf.pm line 79.
Compilation failed in require at /usr/share/perl5/Mail/SpamAssassin.pm
line 69.
BEGIN failed--compilation aborted at
/usr/share/perl5/Mail/SpamAssassin.pm line 69.
Compilation failed in require at /usr/local/bin/spamassassin line 79.
BEGIN failed--compilation aborted at /usr/local/bin/spamassassin line 79.

Je fais un aptitude reinstall spamassassin, au cas où, et j'obtiens :
Errno architecture (i486-linux-gnu-thread-multi-2.6.18-6-686) does not
match executable architecture (i486-linux-gnu-thread-multi-2.6.26-1-686)
at /usr/local/share/perl/5.8.8/Errno.pm line 11.
Compilation failed in require at /usr/lib/perl/5.10/IO/Socket.pm line 17.
BEGIN failed--compilation aborted at /usr/lib/perl/5.10/IO/Socket.pm
line 17.
Compilation failed in require at
/usr/local/lib/perl/5.10.0/Net/DNS/Resolver/Base.pm line 21.
BEGIN failed--compilation aborted at
/usr/local/lib/perl/5.10.0/Net/DNS/Resolver/Base.pm line 21.
Compilation failed in require at
/usr/local/lib/perl/5.10.0/Net/DNS/Resolver/UNIX.pm line 9.
BEGIN failed--compilation aborted at
/usr/local/lib/perl/5.10.0/Net/DNS/Resolver/UNIX.pm line 9.
Compilation failed in require at
/usr/local/lib/perl/5.10.0/Net/DNS/Resolver.pm line 19.
BEGIN failed--compilation aborted at
/usr/local/lib/perl/5.10.0/Net/DNS/Resolver.pm line 22.
Compilation failed in require at /usr/local/lib/perl/5.10.0/Net/DNS.pm
line 91.
BEGIN failed--compilation aborted at
/usr/local/lib/perl/5.10.0/Net/DNS.pm line 91.
Compilation failed in require at /usr/local/bin/sa-update line 78.
BEGIN failed--compilation aborted at /usr/local/bin/sa-update line 78.

Il n'y pas pas d'upgrade dispo sous perl -MCPAN -e shell et je n'ose pas
virer manuellement Net::DNS (pour ne parler que du dernier) parce qu'en
faisant ça sur un serveur de test, il m'a sorti des erreurs à la compil
que je ne sais pas du tout comment résoudre !

Savez-vous pourquoi j'ai ça et comment le réparer ?

Merci.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
steve
Le #19219851
> Bonjour,



Salut,

suite à mon passage à lenny, j'ai fait divers vérifications, donc un
spamassassin -D --lint.
Ce dernier me sort :
Errno architecture (i486-linux-gnu-thread-multi-2.6.18-6-686) does not
match executable architecture (i486-linux-gnu-thread-multi-2.6.26-1-686)



Je crois que tout est là : problème de versions, 2.6.26 (lenny) et 2.6.18 (etch)

Compilation failed in require at /usr/local/bin/sa-update line 78.
BEGIN failed--compilation aborted at /usr/local/bin/sa-update line 78.



Pourquoi est-ce que sa-update se trouve dans /usr/local/bin/* plutôt que
/usr/bin/ ?

Il n'y pas pas d'upgrade dispo sous perl -MCPAN -e shell et je n'ose pas
virer manuellement Net::DNS (pour ne parler que du dernier) parce qu'en
faisant ça sur un serveur de test, il m'a sorti des erreurs à la compil
que je ne sais pas du tout comment résoudre !

Savez-vous pourquoi j'ai ça et comment le réparer ?



Installer la version de Debian de spamassassin ?

steve

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Olivier Masson
Le #19221061
steve a écrit :
Bonjour,



Salut,

suite à mon passage à lenny, j'ai fait divers vérifications, donc un
spamassassin -D --lint.
Ce dernier me sort :
Errno architecture (i486-linux-gnu-thread-multi-2.6.18-6-686) does not
match executable architecture (i486-linux-gnu-thread-multi-2.6.26-1-686)



Je crois que tout est là : problème de versions, 2.6.26 (lenny) et 2.6.18 (etch)




Et pourquoi est-ce que je n'arrive pas à recompiler certains modules
perl alors ?

Compilation failed in require at /usr/local/bin/sa-update line 78.
BEGIN failed--compilation aborted at /usr/local/bin/sa-update line 78.



Pourquoi est-ce que sa-update se trouve dans /usr/local/bin/* plutôt que
/usr/bin/ ?

Il n'y pas pas d'upgrade dispo sous perl -MCPAN -e shell et je n'ose pas
virer manuellement Net::DNS (pour ne parler que du dernier) parce qu'en
faisant ça sur un serveur de test, il m'a sorti des erreurs à la compil
que je ne sais pas du tout comment résoudre !

Savez-vous pourquoi j'ai ça et comment le réparer ?



Installer la version de Debian de spamassassin ?




Pourquoi, je l'aurais compilé moi-même ? Me souviens pas.
Mais quoiqu'il en soit, que fait aptitude reinstall ?

Merci.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Olivier Masson
Le #19221771
Olivier Masson a écrit :
steve a écrit :
Bonjour,



Salut,

suite à mon passage à lenny, j'ai fait divers vérifications, donc un
spamassassin -D --lint.
Ce dernier me sort :
Errno architecture (i486-linux-gnu-thread-multi-2.6.18-6-686) does
not match executable architecture
(i486-linux-gnu-thread-multi-2.6.26-1-686)



Je crois que tout est là : problème de versions, 2.6.26 (lenny) et
2.6.18 (etch)







Bon, le truc à chercher était bien Errno.pm mais rien à faire avec le
package de spamassassin : il restait un errno.pm dans perl 5.8.8
(répertoire qui n'a pas été purgé au passage à perl 5.10)
J'ai donc tout simplement virer ce errno.pm pour ne laisser que celui de
perl 5.10.
Ensuite un reinstall de spamassassin qui prend en considération le
nouveau errno.pm et tout roule :)

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Publicité
Poster une réponse
Anonyme