Où est passé mon /home ??

Le
Comte de Niouzes
Bonjour les gens !

J'ai un PC avec Windows XP et Ubuntu 9.04 (2.6.28.15). Et soudain
quand je veux démarrer sur Ubuntu, après avoir saisi mon identifiant et
mon mot de passe, je vois apparaître un message qui me dit : "votre
dossier personnel est censé être "/home/machin" mais il ne semble pas
exister. "

Or quand je démarre sur un CD Live, je le vois mon /home à moi, avec des
dossiers divers et variés (Mozilla, Nautilus, ). Je n'ai rien fait de
particulier comme bidouille ou installation (à part 3 extensions pour
Firefox : ScrapBook, Autopager, et Lightning - suite au dossier vu sur
Clubic.com pour des programmes facilitant la recherche d'emploi)

Que s'est-il passé ? comment rétablir la situation ?
J'imagine que je peux réinstaller Ubuntu mais que faut-il
sauvegarder au préalable ? mon dossier /home et les divers dossiers que
j'y ai vus ? et après réinstallation, quelle est la manipulation
pour les restaurer ?

Je ne suis pas très à l'aise avec Linux

Si vous avez des conseils je suis preneur ! avec un grand merci
d'avance !!

Bisous les copines ! et salut les copains !

Claude
^_^
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 3
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
jp willm
Le #20155751
Hello,

Comte de Niouzes a écrit :

J'ai un PC avec Windows XP et Ubuntu 9.04 (2.6.28.15). Et soudain ...
quand je veux démarrer sur Ubuntu, après avoir saisi mon identifiant et
mon mot de passe, je vois apparaître un message qui me dit : "votre
dossier personnel est censé être "/home/machin" mais il ne semble pas
exister. ..."

Or quand je démarre sur un CD Live, je le vois mon /home à moi, avec des
dossiers divers et variés (Mozilla, Nautilus, ...).



Si tu vois tes documents perso (photos, vidéos etc.) tu les sauvegardes
déjà ainsi que le dossier contenant ta messagerie (par exemple :
.mozilla-thunderbird, dossier caché qui commence par un point)



Ensuite si tu veux, tu peux créer un nouvel utilisateur :

tu démarres ta ubuntu même si elle bloque sur la fenêtre de connexion
tu presses Ctrl + Alt + F1 pour te retrouver devant une console
tu donnes ton login et ton mdp (que tu ne vois pas)

tu lances la commande sudo adduser suivi de ton mdp
tu donnes le mdp et les renseignements utiles pour ce compte

tu presses Ctrl + Alt + F7

tu entres dans ton compte utilisateur

tu lui donnes le droit admin


Tu redémarres le liveCD tu ouvres le fichier /etc/group mais pas celui
du liveCD celui sur ta partition ubuntu et là tu ajoutes le login de ton
nouvel utilisateur à la ligne admin (tu regardes comment sont faites les
autres lignes)


tu redémarres sur ta ubuntu et tu entres dans ton nouveau compte.


Ce n'est pas la meilleure solution, ni la plus rapide. Je laisse les
spécialistes me corriger s'il faut.


@+ jp
Cumbalero
Le #20160381
Comte de Niouzes a écrit :

dossier personnel est censé être "/home/machin" mais il ne semble pas
exister. ..."




Tu nous envoie le résultat d'un cat /etc/fstab et d'un sudo mount ?

A+
JF
Comte de Niouzes
Le #20160371
Cumbalero a écrit :
Comte de Niouzes a écrit :

dossier personnel est censé être "/home/machin" mais il ne semble pas
exister. ..."




Tu nous envoie le résultat d'un cat /etc/fstab et d'un sudo mount ?

A+
JF


Ah que coucou !

Les commandes que tu m'indiques, je les lance à partir d'un CD Live ?
(parce que sinon, je n'arrive pas à entrer dans linux : je n'arrive pas
jusqu'au bureau)
Autrement, quand j'arrive à ce message d'insultes, ça me dit que je peux
lancer une session gnome de secours, mais je ne connais pas les
commandes que ça me propose ...

Merci de t'intéresser à mon cas ! ;-)

Claude
Cumbalero
Le #20160731
Comte de Niouzes a écrit :

Les commandes que tu m'indiques, je les lance à partir d'un CD Live ?




Non, depuis le Linux que tu as installé. Le fichier /etc/fstab contient
la liste des partitions (pour simplifier à mort) et les options avec
lesquelles ellles doivent être utilisées par le système.


(parce que sinon, je n'arrive pas à entrer dans linux : je n'arrive pas
jusqu'au bureau)



Linux n'est pas un bureau. Les commandes indiquées peuvent être lancées
dans un terminal, une console...

Quand tu te connectes, le système lit le fichier /etc/passwd (entre
autres, encore une fois je simplifie parce que ton problème semble assez
trivial) pour y trouver ton "homedir". S'il n'arrive pas à y accéder (ce
qui est ton cas), il prend /, et effectivement, tous les fichiers de
configuration de ton interface graphique ne sont pas dispo. Peu importe,
en fait, ton problème devrait être résolu en 3 lignes de commandes.


Autrement, quand j'arrive à ce message d'insultes, ça me dit que je peux
lancer une session gnome de secours, mais je ne connais pas les
commandes que ça me propose ...




Je pense qu'il te suggère au boot de choisir l'option "rescue mode" ou
un truc qui ressemble, mais on devrait pouvoir s'en sortir sans.

Le liveCD peut aussi t'aider, mais ce sera moins simple, dans la mesure
où il faudrait monter la partition / (ou /etc) de ton installation
"normale" dans un espace temporaire pour modifier le fichier suspect...

A+
JF
yamo'
Le #20160871
Salut,

Comte de Niouzes a tapoté, le 16/09/2009 18:46:
Les commandes que tu m'indiques, je les lance à partir d'un CD Live ?



Non, il faut aller sur une console, par exemple en tapant Ctrl Alt F1
cf
Pour evenir à un écran "normal" c'est Ctrl ALt F7 ou dans certains cas
Ctrl ALt F8



--
Stéphane
http://pasdenom.info/fortune
Comte de Niouzes
Le #20162651
Cumbalero a écrit :
Comte de Niouzes a écrit :

dossier personnel est censé être "/home/machin" mais il ne semble pas
exister. ..."




Tu nous envoie le résultat d'un cat /etc/fstab et d'un sudo mount ?

A+
JF


re bonjour !

je recopie stoïquement ce que je vois à l'écran quand je tape ces
commandes (je passe ce qui me semble être des commentaires ...)


Donc pour le "cat /etc/fstab" on obtient:
# / was on /dev/sdb1 during installation
UUID7b4ed8-f9c5-4eae-87e7-6b5f37cac9c2 / ext3
relatime,errors=remount-ro 0 1

# /home was on /dev/sdb7 during installation
UUID)9b65dd-2ca7-40a0-bc8c-762cf3d593aa /home ext3
relatime 0 2

# swap was on /dev/sdb6 during installation
UUID°71b5ed-8680-4561-9fee-7d3bc12a9be1 none swap
sw 0 0

/dev/sdc0 /media/cdrom0 udf,iso9660
user,noauto,exec,utf8 0 0

/dev/fd0 /media/floppy auto
rw,user,noauto,exec,utf8 0 0


Par contre, pour le "sudo mount" c'est la version intégrale :
/dev/sdb1 on / type ext3
(rw,relatime,errors=remount-ro)

tmpfs on /lib/init/rw type tmpfs
(rw,nosuid,mode55)

proc on /proc type proc
(rw,noexec,nosuid,nodev)

sysfs on /sys type sysfs
(rw,noexec,nosuid,nodev)

varrun on /var/run type tmpfs
(rw,nosuid,mode55)

varlock on /var/lock type tmpfs
(rw,noexec,nosuid,nodev,mode77)

udev on /dev type tmpfs
(rw,mode55)

tmpfs on /dev/shm type tmpfs
(rw,nosuid,nodev)

devpts on /dev/pts type devpts
(rw,noexec,nosuid,gid=5,modeb0)

fusectl on /sys/fs/fuse/connections type fusectl
(rw)

lrm on /lib/modules/2.6.28-15-generic/volatile type tmpfs
(rw,modeu5)

securityfs on /sys/kernel/security type securityfs
(rw)

binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc
(rw,noexec,nosuid,nodev)

Voilà ! j'espère que ça te dit quelque chose parce moi ... ça ne me
cause pas du tout (je suis plus à l'aise avec un AS400 ... d'ailleurs si
quelqu'un connaît une boîte qui recherche un analyste d'exploitation
AS400, je suis preneur !!)

Un grand merci d'avance si tu peux m'aider avec tout ça !

Claude

^_^
YBM
Le #20162721
Comte de Niouzes a écrit :
Cumbalero a écrit :
Comte de Niouzes a écrit :

dossier personnel est censé être "/home/machin" mais il ne semble pas
exister. ..."




Tu nous envoie le résultat d'un cat /etc/fstab et d'un sudo mount ?

A+
JF


re bonjour !

je recopie stoïquement ce que je vois à l'écran quand je tape ces
commandes (je passe ce qui me semble être des commentaires ...)



voila ce qui compte :

# /home was on /dev/sdb7 during installation
UUID)9b65dd-2ca7-40a0-bc8c-762cf3d593aa /home ext3
relatime 0 2


...
[pas de home dans la sortie de mount]



Bref, /dev/sdb7 devrait être monté sur /home sur le critère que
l'UUID de son système de fichies est
299b65dd-2ca7-40a0-bc8c-762cf3d593aa, or il n'est pas monté au
démarrage.

Alors soit son UUID a changé, et on se demande bien pourquoi,
et ça peut se vérifier par :
sudo tune2fs -l /dev/sdb7 | grep UUID

soit il n'est plus montable, auquel cas, un test du système de
fichier s'impose :

tune2fs -f -y /dev/sdb7

Une question quand même : sdb est supposé représenter le *second*
disque sur la plupart des configurations. Est-ce le cas ?




Voilà ! j'espère que ça te dit quelque chose parce moi ... ça ne me
cause pas du tout (je suis plus à l'aise avec un AS400 ... d'ailleurs si
quelqu'un connaît une boîte qui recherche un analyste d'exploitation
AS400, je suis preneur !!)


YBM
Le #20162711
Comte de Niouzes a écrit :
Voilà ! j'espère que ça te dit quelque chose parce moi ... ça ne me
cause pas du tout (je suis plus à l'aise avec un AS400 ... d'ailleurs si
quelqu'un connaît une boîte qui recherche un analyste d'exploitation
AS400, je suis preneur !!)



Bah, un analyste AS400 devrait comprendre assez vite la logique d'UNIX,
non ?

J'oubliais un petit :

cat /proc/partitions

histoire de voir si tes partitions logiques se seraient pas fait la
malle...
Sergio
Le #20163851
YBM a écrit :

Une question quand même : sdb est supposé représenter le *second*
disque sur la plupart des configurations. Est-ce le cas ?



Moi, mon / c'est bien sdc3, hein...
sda -> disque IDE, avec Windows
sdb -> lecteur ZIP en IDE
sdc -> disque SATA avec Linux et partitions de données

d'où l'intérêt d'utiliser les UUID, si je débranche le lecteur ZIP, ça marchera quand même...

--
Serge http://leserged.online.fr/
Mon blog: http://cahierdesergio.free.fr/
Soutenez le libre: http://www.framasoft.org
Cumbalero
Le #20164011
Comte de Niouzes a écrit :

# /home was on /dev/sdb7 during installation
UUID)9b65dd-2ca7-40a0-bc8c-762cf3d593aa /home ext3
relatime 0 2



Je ne sais pas si l'option realtime inclue auto.

Tu peux tenter de modifier la ligne comme suit:

UUID)9b65dd-2ca7-40a0-bc8c-762cf3d593aa /home ext3
relatime,auto 0 2

ou remplacer "relatime" par "defaults".


Mais avant un sudo mount /home devrait soit monter ta partition, soit
t'indiquer un message d'erreur. La dernière fois que j'ai vu ce genre d e
souci, c'était que le fs était en ext2 mais renseigné en ext3 dans le fstab.

Voilà ! j'espère que ça te dit quelque chose parce moi ... ça n e me
cause pas du tout (je suis plus à l'aise avec un AS400 ... d'ailleurs si
quelqu'un connaît une boîte qui recherche un analyste d'exploitatio n
AS400, je suis preneur !!)



J'en connais, en région Nord.


A+
JF
Publicité
Poster une réponse
Anonyme