Etat sans enregistrement

Le
Loïc V.
Bonjour!

J'ai un stûûûût avec un de mes états.
Lorsque qu'l n'y a rien dans la section "détail", l'état ne se crée pas.
Vous me direz que c'est normal et qu'il en est mieux ainsi, et vous aurez
tout à fait raison! lol!

Mais, mon hic, c'est que j'ai un sous-état qui comprend des enregistrements
qui doivent être affichés.

Donc, si j'ai rien dans la section détail, mon état ne se crée pas alors
qu'il a des données vu qu'il y a un sous-état.

comme lu sur ce forum, mon sous-état a été placé en "en-tête de groupe" (si
je le mets dans détail, il me fait un truc affreux qui duplique tous les
enregistrements).

Bref, qu'est ce qu'il faut que je fasse pour que mon état se crée même si il
n'y a pas d'enregistrement lié dans la zone détail mais qu'il y en a dans mon
sous-état?

Merci beaucoup.

Loïc V.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
3stone
Le #17573191
Salut,

"Loïc V."
| J'ai un stûûûût avec un de mes états.
| Lorsque qu'l n'y a rien dans la section "détail", l'état ne se crée pas.
| Vous me direz que c'est normal et qu'il en est mieux ainsi, et vous aurez
| tout à fait raison! lol!
|
| Mais, mon hic, c'est que j'ai un sous-état qui comprend des enregistrements
| qui doivent être affichés.
|
| Donc, si j'ai rien dans la section détail, mon état ne se crée pas alors
| qu'il a des données vu qu'il y a un sous-état.
|
| comme lu sur ce forum, mon sous-état a été placé en "en-tête de groupe" (si
| je le mets dans détail, il me fait un truc affreux qui duplique tous les
| enregistrements).
|
| Bref, qu'est ce qu'il faut que je fasse pour que mon état se crée même si il
| n'y a pas d'enregistrement lié dans la zone détail mais qu'il y en a dans mon
| sous-état?


Bizarre, ton explication...

Un état sans données se crée sans problème - le problème étant
plutôt de l'éviter...

Un sous-état se place effectivement dans la section détail de l'état
principal - à condition que l'on parle bien d'un "sous-état" et non
d'un simple état inclu...

Bref... tu peux aller regarder ceci :
http://homepage.bluewin.ch/wstucki//Etats.htm#EtatsVides

--
A+
Pierre (3stone) Access MVP
Perso: http://www.3stone.be/
MPFA: http://www.mpfa.info/ (infos générales)
Loïc V.
Le #17589551
Ben, en fait, c'est assez simple.
Si j'ai rien dans la section détail, il me m'imprime un état sans donnée,
malgré le fait que le sous-état en contient, lui, des données.

Par contre, il suffit qu'il y ait une donnée à afficher dans le détail,
alors, il accepte de me montrer ce que contient le sous-état.

Donc, pour faire court, les données de mon sous-état n'apparaisseront sur
mon état QUE SI il y a des données dans le détail de l'état principal.

solusse en vue ?

(Le lien que tu proposes ne me donne pas de solution, dommach')

bien à toi,

Loïc




"3stone" a écrit :

Salut,

"Loïc V."
| J'ai un stûûûût avec un de mes états.
| Lorsque qu'l n'y a rien dans la section "détail", l'état ne se crée pas.
| Vous me direz que c'est normal et qu'il en est mieux ainsi, et vous aurez
| tout à fait raison! lol!
|
| Mais, mon hic, c'est que j'ai un sous-état qui comprend des enregistrements
| qui doivent être affichés.
|
| Donc, si j'ai rien dans la section détail, mon état ne se crée pas alors
| qu'il a des données vu qu'il y a un sous-état.
|
| comme lu sur ce forum, mon sous-état a été placé en "en-tête de groupe" (si
| je le mets dans détail, il me fait un truc affreux qui duplique tous les
| enregistrements).
|
| Bref, qu'est ce qu'il faut que je fasse pour que mon état se crée même si il
| n'y a pas d'enregistrement lié dans la zone détail mais qu'il y en a dans mon
| sous-état?


Bizarre, ton explication...

Un état sans données se crée sans problème - le problème étant
plutôt de l'éviter...

Un sous-état se place effectivement dans la section détail de l'état
principal - à condition que l'on parle bien d'un "sous-état" et non
d'un simple état inclu...

Bref... tu peux aller regarder ceci :
http://homepage.bluewin.ch/wstucki//Etats.htm#EtatsVides

--
A+
Pierre (3stone) Access MVP
Perso: http://www.3stone.be/
MPFA: http://www.mpfa.info/ (infos générales)




Jac
Le #17594221
... et si tu ramenais, dans la requête de ton état principal un champ
du sous-état que tu mettrais dans la section détail. Bien sûr ce champ
serait non visible. Donc s'il y a quelque chose dans le sous état, il y
aura aussi systématiquement quelque chose dans l'état principal.

Pourquoi pas ?

Jac

Ben, en fait, c'est assez simple.
Si j'ai rien dans la section détail, il me m'imprime un état sans donnée,
malgré le fait que le sous-état en contient, lui, des données.

Par contre, il suffit qu'il y ait une donnée à afficher dans le détail,
alors, il accepte de me montrer ce que contient le sous-état.

Donc, pour faire court, les données de mon sous-état n'apparaisseront sur
mon état QUE SI il y a des données dans le détail de l'état principal.

solusse en vue ?

(Le lien que tu proposes ne me donne pas de solution, dommach')

bien à toi,

Loïc




"3stone" a écrit :

Salut,

"Loïc V."
J'ai un stûûûût avec un de mes états.
Lorsque qu'l n'y a rien dans la section "détail", l'état ne se crée pas.
Vous me direz que c'est normal et qu'il en est mieux ainsi, et vous aurez
tout à fait raison! lol!

Mais, mon hic, c'est que j'ai un sous-état qui comprend des enregistrements
qui doivent être affichés.

Donc, si j'ai rien dans la section détail, mon état ne se crée pas alors
qu'il a des données vu qu'il y a un sous-état.

comme lu sur ce forum, mon sous-état a été placé en "en-tête de groupe" (si
je le mets dans détail, il me fait un truc affreux qui duplique tous les
enregistrements).

Bref, qu'est ce qu'il faut que je fasse pour que mon état se crée même si
il n'y a pas d'enregistrement lié dans la zone détail mais qu'il y en a
dans mon sous-état?




Bizarre, ton explication...

Un état sans données se crée sans problème - le problème étant
plutôt de l'éviter...

Un sous-état se place effectivement dans la section détail de l'état
principal - à condition que l'on parle bien d'un "sous-état" et non
d'un simple état inclu...

Bref... tu peux aller regarder ceci :
http://homepage.bluewin.ch/wstucki//Etats.htm#EtatsVides

--
A+
Pierre (3stone) Access MVP
Perso: http://www.3stone.be/
MPFA: http://www.mpfa.info/ (infos générales)






Loïc V.
Le #17621211
Ben, en fait, c'est au niveau de ma requête que cela foire. Il y a quelque
chse dans l'état que lorsqu'il y a un résultat de la requête. Le hic, c'est
que dans mon état, j'ai une deuxième requête (qui n'est pas en en-tête) qui
forme le sous-état.

Si la première requête donne un résultat vierge, j'ai un état vierge, logique.

Donc, ca vient de la requête. Celle-ci est composée comme suit:

Nom client
N°Bordereau
Plaquette

Nom client et N°Bordereau font partie de la même table, Plaquette dans une
autre. donc, si pas de plaquette se référant à un N°bordereau, ma requête ne
donne pas de résultat (re-logique).

Y a pas une astuce pour que Nom client et N°Bordereau s'affiche même si il y
a n'y a pas de plaquette associée ? Le probmème réside là.

si vous avez une solution,je suis preneur.

Merci beaucoup,

Loïc

"Jac" a écrit :

.... et si tu ramenais, dans la requête de ton état principal un champ
du sous-état que tu mettrais dans la section détail. Bien sûr ce champ
serait non visible. Donc s'il y a quelque chose dans le sous état, il y
aura aussi systématiquement quelque chose dans l'état principal.

Pourquoi pas ?

Jac

> Ben, en fait, c'est assez simple.
> Si j'ai rien dans la section détail, il me m'imprime un état sans donnée,
> malgré le fait que le sous-état en contient, lui, des données.
>
> Par contre, il suffit qu'il y ait une donnée à afficher dans le détail,
> alors, il accepte de me montrer ce que contient le sous-état.
>
> Donc, pour faire court, les données de mon sous-état n'apparaisseront sur
> mon état QUE SI il y a des données dans le détail de l'état principal.
>
> solusse en vue ?
>
> (Le lien que tu proposes ne me donne pas de solution, dommach')
>
> bien à toi,
>
> Loïc
>
>
>
>
> "3stone" a écrit :
>
>> Salut,
>>
>> "Loïc V."
>>> J'ai un stûûûût avec un de mes états.
>>> Lorsque qu'l n'y a rien dans la section "détail", l'état ne se crée pas.
>>> Vous me direz que c'est normal et qu'il en est mieux ainsi, et vous aurez
>>> tout à fait raison! lol!
>>>
>>> Mais, mon hic, c'est que j'ai un sous-état qui comprend des enregistrements
>>> qui doivent être affichés.
>>>
>>> Donc, si j'ai rien dans la section détail, mon état ne se crée pas alors
>>> qu'il a des données vu qu'il y a un sous-état.
>>>
>>> comme lu sur ce forum, mon sous-état a été placé en "en-tête de groupe" (si
>>> je le mets dans détail, il me fait un truc affreux qui duplique tous les
>>> enregistrements).
>>>
>>> Bref, qu'est ce qu'il faut que je fasse pour que mon état se crée même si
>>> il n'y a pas d'enregistrement lié dans la zone détail mais qu'il y en a
>>> dans mon sous-état?
>>
>>
>> Bizarre, ton explication...
>>
>> Un état sans données se crée sans problème - le problème étant
>> plutôt de l'éviter...
>>
>> Un sous-état se place effectivement dans la section détail de l'état
>> principal - à condition que l'on parle bien d'un "sous-état" et non
>> d'un simple état inclu...
>>
>> Bref... tu peux aller regarder ceci :
>> http://homepage.bluewin.ch/wstucki//Etats.htm#EtatsVides
>>
>> --
>> A+
>> Pierre (3stone) Access MVP
>> Perso: http://www.3stone.be/
>> MPFA: http://www.mpfa.info/ (infos générales)
>>
>>





3stone
Le #17627561
Salut,

"Loïc V."
| Si j'ai rien dans la section détail, il me m'imprime un état sans donnée,
| malgré le fait que le sous-état en contient, lui, des données.
|
| Par contre, il suffit qu'il y ait une donnée à afficher dans le détail,
| alors, il accepte de me montrer ce que contient le sous-état.
|
| Donc, pour faire court, les données de mon sous-état n'apparaisseront sur
| mon état QUE SI il y a des données dans le détail de l'état principal.


Tu ne dois pas être à ton coup d'essai ;-)
Ici, un sous-état qui contient données, alors que l'état est vide... et plus
loin, un sous-formulaire qui contient des données fantômes et qui ne
se laisse plus fermer !

Tu devrais te poser des questions... sur les méthodes utilisées.

--
A+
Pierre (3stone) Access MVP
Perso: http://www.3stone.be/
MPFA: http://www.mpfa.info/ (infos générales)
Loïc V.
Le #17628611
Ben, tu te doutes bien que j'essaie par essai/erreur avant de venir ici.
Le problème, dans cet état, c'est que si je dois modifier la conception,
cela représente beacoup de travail (car il faut que je revienne en arrière
pour toute une série de choses). Donc, avant de me lancer dans ce foutoir
désespéré, j'aurais espérer qu'il y avait une autre solution.

Il y a aussi le fait que je ne connaissais pratiquement rien à Access il y
a deux mois et que certaines choses ont, de fait, été conçue de manière
folklorique. Maintenant que j'arrive au bout du projet, je vais le regretter.

Tant pis, je vais recommencer à partir de là où cela coince.

Merci quand-même.

Loïc


"3stone" a écrit :
Tu ne dois pas être à ton coup d'essai ;-)
Ici, un sous-état qui contient données, alors que l'état est vide... et plus
loin, un sous-formulaire qui contient des données fantômes et qui ne
se laisse plus fermer !

Tu devrais te poser des questions... sur les méthodes utilisées.

--
A+
Pierre (3stone) Access MVP
Perso: http://www.3stone.be/
MPFA: http://www.mpfa.info/ (infos générales)




Loïc V.
Le #17631261
Bon, et bien comme dit le dicton, qui cherche, trouve...

Pas mal de chipoteries, mais j'arrive au résultat escompté.

Pour les zeusses qui auront fait les mêmes boulettes que moi et qui n'auront
la flemme de tout recommencer, j'ai simplement utilisé l'évènement
"formatage" sur le détail de l'état. J'ai insérer une variable dans la table
concernée qui peut être "null". Lorsque l'item a cette valeur "null" (à
n'utiliser que lorsqu'il n'y a pas d'enregistrement dans l'état principal),
j'ai écrit un code qui me dit simplement de ne pas afficher cet item dans
l'état si la variable est Null.

Le seul hic, c'est qu'il faut noter sur un bout de papier le stock d'items
avec cette variable "Null" pour qu'en encodant le formulaire, on puisse
insérer cette donnée, et donc générer un état (vu qu'il y a une valeur qui
fait enfin le lien entre les données de la requête et celles de la requête
fantôme).

Merci à tous.
Publicité
Poster une réponse
Anonyme