[etch] postgresql ne démarre pas automatiquement

Le
Frédéric Moinard
Bonjour/Bonsoir

Sur un serveur un etch, postgresql n'avait pas servi depuis quelques
mois. La dernière vérification montre que le service n'est pas lancé

Après un petit tour, postgresql semble installé en version 7.4 et 8.1.
/etc/init.d/postgresql start
et
/etc/init.d/postgresql-7.4 start
ne font *rien* (pas de log dans dmesg ni dans /var/log/postgresql/*
/etc/init.d/postgresql-8.1 start
dit (de mémoire) "paquet incomplet" et démarre, mais sans moyen trivial
de retrouver les bases précédentes

Les bases marchaient en juillet, j'ai dû faire un dist-upgrade inconsidéré.

Je désinstalle 8.1 ; même motif, même punition.

Si je fais:
# su postgres
$ /usr/lib/postgresql/7.4/bin/postmaster -D /var/lib/postgresql/7.4/main/

Le serveur remarche, apparemment

J'ai dû rater un rtfm majeur, mais étant particulièrement inculte en
postgresql, et google n'aimant pas les questions floues, je me sens un
peu démuni

Une lumière ?

--
Cordialement,

Frédéric MOinard


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to debian-user-french-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Stephane Bortzmeyer
Le #9743011
On Wed, Nov 07, 2007 at 09:22:56PM +0400,
Frédéric Moinard a message of 34 lines which said:

Sur un serveur un etch, postgresql n'avait pas servi depuis quelques
mois. La dernière vérification montre que le service n'est pas
lancé...



etch a tout changé, question PostgreSQL. Cela permet d'installer
plusieurs versions simultanément mais cela rend les choses un peu plus
compliquées (/usr/share/doc/postgresql-common/architecture.html).

/etc/init.d/postgresql start
et
/etc/init.d/postgresql-7.4 start
ne font *rien*



sh -x /etc/init.d/postgresql start et vous verrez pourquoi. Il leur
manque leur configuration.

/usr/share/doc/postgresql-common/README.Debian.gz contient toutes les
explications. Les commandes à la fin ("pg_createcluster 8.1 main")
devraient vous aider.


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Publicité
Poster une réponse
Anonyme