etch/wifi/rt61pci (carte dwl-g510) : pas de résolution dns, plantage au redémarrage interface

Le
Bulot Grégory
bonjour,

j'utilise rt61pci et wpasuplicant pour ma carte wifi :
module version 2.0.12 (je pense via m-a a-i rtx2000)

1)
lorsque je ping mon routeur (freebox : 192.168.0.254) : ping ok
lorsque je ping -c 1 www.google.fr : ping nok (ping: unknow host
www.google.fr)



2)
s'il m'arrive malencontreusement de faire un /etc/init/networking restart, =
il
semblerait que je ne puissse plus me connecter à mon AP jusqu'a ce que je=

reboot le pc : wlan0 authentification with ap timed out


savez-vous comment s'en sortir (après je vais ajouter du bonding .)


/etc/network/interface:
auto wlan0
#iface wlan0 inet dhcp
iface wlan0 inet static
address 192.168.0.26
netmask 255.255.255.0
gateway 192.168.0.254

pre-up iwconfig wlan0 essid "mon essid"
wpa-conf /etc/wpa_supplicant.conf
wpa-driver wext
(j'ai aussi eth0 de configurer, mais je fais un ifdown eth0 pendant les tes=
ts)


/etc/wpa_supplicant.conf
network={
ssid="mon essid"
scan_ssid=1
proto=WPA
key_mgmt=WPA-PSK
psk="ma clef en clair"
}


mon /etc/resolv.conf :
nameserver 192.168.0.254
nameserver 192.168.1.1

(eth0 est en 192.168.1.0, routeur 192.168.1.1)
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Thierry Chatelet
Le #9701481
On Tuesday 11 March 2008 16:07, Thierry Chatelet wrote:
On Tuesday 11 March 2008 16:00, Bulot Grégory wrote:
> bonjour,
>
> j'utilise rt61pci et wpasuplicant pour ma carte wifi :
> module version 2.0.12 (je pense via m-a a-i rtx2000...)
>
> 1)
> lorsque je ping mon routeur (freebox : 192.168.0.254) : ping ok
> lorsque je ping -c 1 www.google.fr : ping nok (ping: unknow host
> www.google.fr)
>
>
>
> 2)
> s'il m'arrive malencontreusement de faire un /etc/init/networking
> restart, il semblerait que je ne puissse plus me connecter à mon AP
> jusqu'a ce que je reboot le pc : wlan0 authentification with ap timed o ut
>
>
> savez-vous comment s'en sortir (après je vais ajouter du bonding ....)
>
>
> /etc/network/interface:
> auto wlan0
> #iface wlan0 inet dhcp
> iface wlan0 inet static
> address 192.168.0.26
> netmask 255.255.255.0
> gateway 192.168.0.254
>
> pre-up iwconfig wlan0 essid "mon essid"
> wpa-conf /etc/wpa_supplicant.conf
> wpa-driver wext
> (j'ai aussi eth0 de configurer, mais je fais un ifdown eth0 pendant les
> tests)
>
>
> /etc/wpa_supplicant.conf
> network={
> ssid="mon essid"
> scan_ssid=1
> proto=WPA
> key_mgmt=WPA-PSK
> psk="ma clef en clair"
> }
>
>
> mon /etc/resolv.conf :
> nameserver 192.168.0.254
> nameserver 192.168.1.1
>
> (eth0 est en 192.168.1.0, routeur 192.168.1.1)

Que donne un iwconfig?
Et ta FB est-elle bien configurée pour te donner des adresse staitiques?
Thierry



J'ajoute: j'utilise ce pilote:
http://www.ralinktech.com.tw/data/drivers/2007_1210_RT61_Linux_STA_v1.1.2.0 .tar.bz2
Bulot Grégory
Le #9701471
Le mardi 11 mars 2008 16:12, Thierry Chatelet a écrit :


> Que donne un iwconfig?



wmaster0 no wireless extensions.

wlan0 IEEE 802.11g ESSID:"mon essid"
Mode:Managed Frequency:2.462 GHz Access Point: xx:xx:....
Retry min limit:7 RTS thr:off Fragment thr#46 B
Encryption key:xxx-xxxx-....
Link Qualityh/100 Signal level=-64 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

la qualité varie entre 49 et 68/100
> Et ta FB est-elle bien configurée pour te donner des adresse staitiqu es?



la plage dhcp va de 10 à 20 (y'a pas grand chose à configurer sur
l'interface !)


> Thierry

J'ajoute: j'utilise ce pilote:
http://www.ralinktech.com.tw/data/drivers/2007_1210_RT61_Linux_STA_v1.1.2 .0
.tar.bz2



j'y suis jamais arrivé (c) (parfois fallait mettre des trucs
dans /etc/Wireless.../rt61dat, parfois c'était dans /etc/network/interfac e :
ça me soulait en fait).
Ensuite, cela m'a même posé des soucis avec le rt61pci, car même en
blacklistant rt61 il se chargeait quand même ! du coup
rm /lib/modules/2.6.22-3-686/extra/rt61.ko
Thierry Chatelet
Le #9701461
On Tuesday 11 March 2008 16:30, Bulot Grégory wrote:
Le mardi 11 mars 2008 16:12, Thierry Chatelet a écrit :
> > Et ta FB est-elle bien configurée pour te donner des adresse
> > staitiques?

la plage dhcp va de 10 à 20 (y'a pas grand chose à configurer sur
l'interface !)




Pour avoir des IP statics, il faut configurer la box en mode routeur, et en
bas de la page mettre dans les baux permanents l'adresse MAC de ta carte
wifi. Si tu veux rester en dhcp, alors il faut changer
ton /etc/network/interfaces avec
...Ouaaaa
Je viens de regarder ton fichier interface! La est l'erreur, je crois.
Tu as
auto wlan0
#iface wlan0 inet dhcp
iface wlan0 inet static
        address 192.168.0.26
        netmask 255.255.255.0
        gateway 192.168.0.254

Donc tu demandes à la fois une IP dynamique et une static.
Tu devrais avoir:

auto wlan0
#iface wlan0 inet dhcp
      pre-up iwconfig wlan0 essid "mon essid"
        wpa-conf /etc/wpa_supplicant.conf
        wpa-driver wext

uniquement.
Thierry
Bulot Grégory
Le #9701421
Le mardi 11 mars 2008 16:54, Thierry Chatelet a écrit :


Pour avoir des IP statics, il faut configurer la box en mode routeur, et en
bas de la page mettre dans les baux permanents l'adresse MAC de ta carte
wifi. Si tu veux rester en dhcp, alors il faut changer





Dans mon fichier de conf le dhcp est en commentaire

Par contre pour le mode routeur freebox, tant que l'adresse ip static de ma
machine (192.168.0.26) n'est pas dans la plage dhcp (192.168.0.10 à
192.168.0.20 ) y'a pas besoin de réserver de baux ! (enfin on m'a toujour s
appris comme ça, après je peux me tromper)
Thierry Chatelet
Le #9701411
On Tuesday 11 March 2008 19:09, Bulot Grégory wrote:
Le mardi 11 mars 2008 16:54, Thierry Chatelet a écrit :
> Pour avoir des IP statics, il faut configurer la box en mode routeur, et
> en bas de la page mettre dans les baux permanents l'adresse MAC de ta
> carte wifi. Si tu veux rester en dhcp, alors il faut changer

Dans mon fichier de conf le dhcp est en commentaire

Par contre pour le mode routeur freebox, tant que l'adresse ip static de ma
machine (192.168.0.26) n'est pas dans la plage dhcp (192.168.0.10 à
192.168.0.20 ) y'a pas besoin de réserver de baux ! (enfin on m'a toujo urs
appris comme ça, après je peux me tromper)



La, je ne sais plus. Je laisse la place à qq' un de plus calé que moi p our t'
aider.
Thierry
Vincent Danjean
Le #9699671
Thierry Chatelet wrote:
On Tuesday 11 March 2008 19:09, Bulot Grégory wrote:
Le mardi 11 mars 2008 16:54, Thierry Chatelet a écrit :
Pour avoir des IP statics, il faut configurer la box en mode routeur, et
en bas de la page mettre dans les baux permanents l'adresse MAC de ta
carte wifi. Si tu veux rester en dhcp, alors il faut changer


Dans mon fichier de conf le dhcp est en commentaire

Par contre pour le mode routeur freebox, tant que l'adresse ip static de ma
machine (192.168.0.26) n'est pas dans la plage dhcp (192.168.0.10 à
192.168.0.20 ) y'a pas besoin de réserver de baux ! (enfin on m'a toujours
appris comme ça, après je peux me tromper)



La, je ne sais plus. Je laisse la place à qq' un de plus calé que moi pour t'
aider.



La config réseau me paraît ok à première vue.
Pour Thierry, même si le serveur DHCP est configurer pour donner toujours la
même adresse, on parle dans ce cas d'adresse dynamique (car servie par DHCP)
fixe.
Dans le cas static, il n'y a pas de DHCP qui intervient (donc rien à faire
sur la freebox, tout à faire sur l'ordi). C'est ce qui est fait ici. Et c'est
à l'admin réseau de vérifier qu'il n'y a pas plusieurs machines avec la même IP
sur le réseau local (que l'IP soit obtenue de manière statique (ie configurée à
la main) ou dynamique (ie par DHCP, IP fixe ou pas)).
Quand on a un réseau local avec un mélange des deux types de config (static et
dynamique), l'admin préfère généralement découper la place d'adresse en 2 :
une gérée par le serveur DHCP, l'autre gérée (attribuée) manuellement par l'admin.


Pour revenir au problème initial, je te conseillerais bien d'essayer avec un
noyau plus récent (2.6.24). Je pense que ta carte wifi est maintenant supportée
directement par le noyau upstream. Il y a eu vraiment beaucoup d'améliorations
dans le support de ces cartes récemment.
NB: il est possible qu'il faille installer des fichiers de firmware sur ton ordi
pour que les nouveaux drivers se chargent bien. Voir les messages dans
/var/log/syslog au cas où.

Vincent

Thierry





--
Vincent Danjean Adresse: Laboratoire d'Informatique de Grenoble
Téléphone: +33 4 76 61 20 11 ENSIMAG - antenne de Montbonnot
Fax: +33 4 76 61 20 99 ZIRST 51, avenue Jean Kuntzmann
Email: 38330 Montbonnot Saint Martin

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Bulot Grégory
Le #9699641
Le vendredi 14 mars 2008 11:18, Vincent Danjean a écrit :

Pour revenir au problème initial, je te conseillerais bien d'essay er avec
un noyau plus récent (2.6.24). Je pense que ta carte wifi est mainte nant
supportée directement par le noyau upstream. Il y a eu vraiment beau coup
d'améliorations dans le support de ces cartes récemment.
NB: il est possible qu'il faille installer des fichiers de firmware sur t on
ordi pour que les nouveaux drivers se chargent bien. Voir les messages da ns
/var/log/syslog au cas où.

Vincent

> Thierry



pour les firmwares, il sont chargés depuis /lib/firmare correctement d 'après
syslog
la machine n'est pas dispo pour l'instant (copie de disque pour 3 install l a
semaine prochaine)

sur le 2.6.18 (stable) j'utilisais les pilotes proprio, la suis passé en etch
(à reculons, les machines sont chez des clients géographiquement répartit
dans l'hexagone) pour gérer la carte graphique interne (g33)
Bulot Grégory
Le #9699621
Le vendredi 14 mars 2008 13:52, vous (alain) avez écrit :
Eh ben si tu es passé en etch, tu es resté en "stable"!



erf je voulais dire lenny
Publicité
Poster une réponse
Anonyme