EVENEMENT SUR LA TOUCHE ESC

Le
e-pluriel
Bonjour, je veux mettre un événement sur la touche ESC sur une
fenêtre.
Voici mon code. Où me suis-je trompé ?
Merci

EXTERNE "KeyConst.WL"

Evénement("EvtFinImpression","*.*", VK_ESCAPE)

PROCEDURE EvtFinImpression()

SI _EVE.wParam = VK_ESCAPE
Info("stop")
FIN
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
frederic.gandre
Le #18791591
Bonjour,
Voici comment j'utilise cette fonction :

VK_DELETE est un entier = 0x2e
nTouche est un entier = VK_DELETE // Touche Suppr.

// Vérifie si la touche Suppr. a été appuyée
SI ToucheEnfoncée(nTouche) ALORS
// Insérer ici le traitement à effectuer
info("Coucou")
FIN

Cordialement





On 1 mar, 08:53, e-pluriel
Bonjour, je veux mettre un événement sur la touche ESC sur une
fenêtre.
Voici mon code. Où me suis-je trompé ?
Merci

EXTERNE "KeyConst.WL"

Evénement("EvtFinImpression","*.*", VK_ESCAPE)

PROCEDURE EvtFinImpression()

SI _EVE.wParam = VK_ESCAPE
      Info("stop")
FIN


Pascal ROY
Le #18799701
e-pluriel a écrit :
Bonjour, je veux mettre un événement sur la touche ESC sur une
fenêtre.
Voici mon code. Où me suis-je trompé ?
Merci

EXTERNE "KeyConst.WL"

Evénement("EvtFinImpression","*.*", VK_ESCAPE)

PROCEDURE EvtFinImpression()

SI _EVE.wParam = VK_ESCAPE
Info("stop")
FIN


Bonjour,

Vous placez l'évènement sur VK_ESCAPE qui est la touche à tester !
L'évènement doit être sur l'appui sur un touche (WM_KEYDOWN) ou la
libération de la touche (WM_KEYUP)
La suite me parait correcte.

--
Pascal ROY
(Service Informatique - SODALEC)
Publicité
Poster une réponse
Anonyme