Excel et les heures, un poème

Le
Michel69
Bonjour à toutes et à tous,
Je dois compter le nb de d'heures comprises entre 3 valeurs:
en D1 8h30, E1 10h30, F1 14h30
En C3 j'ai une heure ex: 8h45
connaissez vous une formule qui me permettrait de calculer le nb d'heure(s)
séparant C3 si > D1 (sans dépasser E1) ; la même chose pour C3 si > E1 sans
dépasser F1, et (le pire) C3 si > F1 et < D1. Pb du passage de 0h00.
Merci pour vos efforts
Michel69
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
garnote
Le #4678111
Salut Michel,

=SI(ET(C3>D1;C3<á);C3-D1;SI(ET(C3>E1;C3<ñ);C3-E1;SI(ET(C3>F1;C3<D1);C3-F1;"")))

Est-ce bien ça que tu veux obtenir ? (pas sûr)

Serge

"Michel69"
Bonjour à toutes et à tous,
Je dois compter le nb de d'heures comprises entre 3 valeurs:
en D1 8h30, E1 10h30, F1 14h30
En C3 j'ai une heure ex: 8h45
connaissez vous une formule qui me permettrait de calculer le nb d'heure(s)
séparant C3 si > D1 (sans dépasser E1) ; la même chose pour C3 si > E1 sans
dépasser F1, et (le pire) C3 si > F1 et < D1. Pb du passage de 0h00.
Merci pour vos efforts
Michel69


JP25
Le #4678101
Bonjour,
=SI(ET(C3>D1;C3<á);C3-celxx;SI(ET(C3>E1;C3<F1);C3-celxx;SI(ET(C3>F1;C3<D1);C3-celxx;"")))
Celxx pour à remplacer par cellules réelles sur lesquelles tu veux calculer

--
Cordialement
JP25




"Michel69" news:
Bonjour à toutes et à tous,
Je dois compter le nb de d'heures comprises entre 3 valeurs:
en D1 8h30, E1 10h30, F1 14h30
En C3 j'ai une heure ex: 8h45
connaissez vous une formule qui me permettrait de calculer le nb
d'heure(s)
séparant C3 si > D1 (sans dépasser E1) ; la même chose pour C3 si > E1
sans
dépasser F1, et (le pire) C3 si > F1 et < D1. Pb du passage de 0h00.
Merci pour vos efforts
Michel69


Trirème
Le #4678061
Yo tous !
=SI(C3<D1;C3-F1+1;SI(C3<E1;C3-D1;SI(C3<F1;C3-E1;C3-F1)))
=SI(C3<Ñ;C3-F1+1;SI(C3<á;C3-D1;SI(C3<ñ;C3-E1;C3-F1)))
Selon la prise en compte des bornes

Trirème

Bonjour à toutes et à tous,
Je dois compter le nb de d'heures comprises entre 3 valeurs:
en D1 8h30, E1 10h30, F1 14h30
En C3 j'ai une heure ex: 8h45
connaissez vous une formule qui me permettrait de calculer le nb d'heure(s)
séparant C3 si > D1 (sans dépasser E1) ; la même chose pour C3 si > E1 sans
dépasser F1, et (le pire) C3 si > F1 et < D1. Pb du passage de 0h00.
Merci pour vos efforts
Michel69


Michel69
Le #4756731
Bonjour Garnote,
Merci pour ta réponse.
J'ai testé, celà convient mais celà ne calcule que par rapport à la 1ère
borne (8h30).
Merci à toi
Michel


Salut Michel,

=SI(ET(C3>D1;C3<á);C3-D1;SI(ET(C3>E1;C3<ñ);C3-E1;SI(ET(C3>F1;C3<D1);C3-F1;"")))

Est-ce bien ça que tu veux obtenir ? (pas sûr)

Serge

"Michel69"
Bonjour à toutes et à tous,
Je dois compter le nb de d'heures comprises entre 3 valeurs:
en D1 8h30, E1 10h30, F1 14h30
En C3 j'ai une heure ex: 8h45
connaissez vous une formule qui me permettrait de calculer le nb d'heure(s)
séparant C3 si > D1 (sans dépasser E1) ; la même chose pour C3 si > E1 sans
dépasser F1, et (le pire) C3 si > F1 et < D1. Pb du passage de 0h00.
Merci pour vos efforts
Michel69







Publicité
Poster une réponse
Anonyme