excel total contenants chiffres et lettres

Le
durlesenegal
faire le total de plusieurs cellules contenant des chiffres et lettres, merci
d'avancespour les reposes.
@+
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Jacky
Le #18703661
Bonsoir,

Si les cellules ne sont pas simultanément chiffres+lettres
A priori la fonction Somme()
=SOMME(plage)

Un petit coup de F1 sur la fonction Somme
--
Salutations
JJ


"durlesenegal" message de news:
faire le total de plusieurs cellules contenant des chiffres et lettres,
merci
d'avancespour les reposes.
@+


durlesenegal
Le #18704141
pas de chance elle sont silmutanement dans la meme cellule.
Merci d'avoir repondu.
@+

"Jacky" a écrit :

Bonsoir,

Si les cellules ne sont pas simultanément chiffres+lettres
A priori la fonction Somme()
=SOMME(plage)

Un petit coup de F1 sur la fonction Somme
--
Salutations
JJ


"durlesenegal" message de news:
> faire le total de plusieurs cellules contenant des chiffres et lettres,
> merci
> d'avancespour les reposes.
> @+





Jacky
Le #18704351
Re...
Peut-on voir un extrait des données sur:
http://www.cjoint.com/

--
Salutations
JJ


"durlesenegal" message de news:
pas de chance elle sont silmutanement dans la meme cellule.
Merci d'avoir repondu.
@+

"Jacky" a écrit :

Bonsoir,

Si les cellules ne sont pas simultanément chiffres+lettres
A priori la fonction Somme()
=SOMME(plage)

Un petit coup de F1 sur la fonction Somme
--
Salutations
JJ


"durlesenegal" message de news:
> faire le total de plusieurs cellules contenant des chiffres et lettres,
> merci
> d'avancespour les reposes.
> @+







JB
Le #18704631
Bonsoir,

Une fonction perso dans un module (Alt+F11 puis insertio module):

Function SommeChaine(champ As Range)
Application.Volatile
t = 0
For Each c In champ
TempChaine = Trim(Application.Substitute(c.Text, ",", "."))
Temp = ""
For i = 1 To Len(TempChaine)
c = Mid(TempChaine, i, 1)
If c >= "0" And c <= "9" Or c = "." Then Temp = Temp & c
Next i
t = t + Val(Temp)
Next c
SommeChaine = t
End Function

Dans le tableur +sommeChaine(champ)

JB
http://boisgontierjacques.free.fr/


On 18 fév, 17:55, durlesenegal
faire le total de plusieurs cellules contenant des chiffres et lettres, m erci
d'avancespour les reposes.
@+


michdenis
Le #18704611
Dans un module standard, tu insères cette fonction
et pour l'appeler de la feuille de calcul, tu insères

en faisant attention à syntaxe :
la formule : ­dAlpha("A1:C10")
'pour insérer une plage de cellules discontinues
(la virgule et non le point-virgule entre les plages.
Ou = AddAlpha("A1:A5,C1:C5")
'----------------------------------
Function AddAlpha(Plg As String)
Dim V As Long, Rg As Range
Set Rg = Range(Plg)
For Each c In Rg
For A = 1 To Len(c)
If IsNumeric(Mid(c, A, 1)) Then
V = V & Mid(c, A, 1)
End If
Next
AddAlpha = AddAlpha + CLng(V)
V = 0
Next
End Function
'----------------------------------



"durlesenegal" de discussion :
faire le total de plusieurs cellules contenant des chiffres et lettres, merci
d'avancespour les reposes.
@+
durlesenegal
Le #18704901
Bonsoir Jacky,
J'ai envoye un fichier Excel comme exemple par l'adresse que tu as communique.
J'espere que je l'ais fais correctement.
Merci pour ton aide.
@+

"Jacky" a écrit :

Re...
Peut-on voir un extrait des données sur:
http://www.cjoint.com/

--
Salutations
JJ


"durlesenegal" message de news:
> pas de chance elle sont silmutanement dans la meme cellule.
> Merci d'avoir repondu.
> @+
>
> "Jacky" a écrit :
>
>> Bonsoir,
>>
>> Si les cellules ne sont pas simultanément chiffres+lettres
>> A priori la fonction Somme()
>> =SOMME(plage)
>>
>> Un petit coup de F1 sur la fonction Somme
>> --
>> Salutations
>> JJ
>>
>>
>> "durlesenegal" >> message de news:
>> > faire le total de plusieurs cellules contenant des chiffres et lettres,
>> > merci
>> > d'avancespour les reposes.
>> > @+
>>
>>
>>





Jacky
Le #18705371
Re..
J'espere que je l'ais fais correctement.


Ben j'ai bien peur que non

Fonctionnement de cjoint

1-Cliquer sur "parcourir" et sélectionner le fichier à joindre
2-Cliquer sur "créer le lien cjoint"
**Le lien est copier automatiquement**
3-Coller le lien dans la réponse à ce message

--
Salutations
JJ


"durlesenegal" message de news:
Bonsoir Jacky,
J'ai envoye un fichier Excel comme exemple par l'adresse que tu as
communique.
J'espere que je l'ais fais correctement.
Merci pour ton aide.
@+

"Jacky" a écrit :

Re...
Peut-on voir un extrait des données sur:
http://www.cjoint.com/

--
Salutations
JJ


"durlesenegal" message de news:
> pas de chance elle sont silmutanement dans la meme cellule.
> Merci d'avoir repondu.
> @+
>
> "Jacky" a écrit :
>
>> Bonsoir,
>>
>> Si les cellules ne sont pas simultanément chiffres+lettres
>> A priori la fonction Somme()
>> =SOMME(plage)
>>
>> Un petit coup de F1 sur la fonction Somme
>> --
>> Salutations
>> JJ
>>
>>
>> "durlesenegal" >> le
>> message de news:
>> > faire le total de plusieurs cellules contenant des chiffres et
>> > lettres,
>> > merci
>> > d'avancespour les reposes.
>> > @+
>>
>>
>>







Publicité
Poster une réponse
Anonyme