Excel-VBA : Automatisation de calculs

Le
EmanuelL
Bonjour à Tous,

Je suis à la recherche d'une solution qui peut me permettre de calculer
automatique les céllules selon un certain critère, en l'occurence la
somme de toutes les céllules "Tot_heures" qui contiennent les valeurs
identiques dans la colonne "No_collab", ainsi de suite.

Si No_collab = 2, total = 3.50, selon l'exemple ci-dessous.

J'ai mis un fichier Excel comme exemple ici :
http://www.cijoint.fr/cjlink.php?file=cj200807/cijfmcODDc.xls

Exemple:

No_collab No_site Tot_heures
2 100 2.25
2 300 0.50
2 400 0.50
2 580 0.25
Total: 3.50

3 100 115.75
3 200 5.75
3 300 1.00

Merci d'avance. ;-)

--

*!* --
EmanuelL
Membre d'AtoutFox
www.atoutfox.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 3
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Jacky
Le #11181371
Bonsoir,
Par la fonction SOUS.TOTAL(9;...)
=SOUS.TOTAL(9;C2:C5)
ou SOMMEPROD()
=SOMMEPROD(($A$2:$A$100â)*$C$2:$D$100)
Voir ici
http://cjoint.com/?hdsppUkoOd
--
Salutations
JJ


"EmanuelL"
Bonjour à Tous,

Je suis à la recherche d'une solution qui peut me permettre de calculer
automatique les céllules selon un certain critère, en l'occurence la somme
de toutes les céllules "Tot_heures" qui contiennent les valeurs identiques
dans la colonne "No_collab", ainsi de suite.

Si No_collab = 2, total = 3.50, selon l'exemple ci-dessous.

J'ai mis un fichier Excel comme exemple ici :
http://www.cijoint.fr/cjlink.php?file=cj200807/cijfmcODDc.xls

Exemple:

No_collab No_site Tot_heures
2 100 2.25
2 300 0.50
2 400 0.50
2 580 0.25
Total: 3.50

3 100 115.75
3 200 5.75
3 300 1.00

Merci d'avance. ;-)

--

*!* -----------------------------------
EmanuelL
Membre d'AtoutFox
www.atoutfox.org




EmanuelL
Le #11181521
Merci Jacky,

Je pense que c'est un bon piste.

;-)

Jacky avait écrit le 03.07.2008 :
Bonsoir,
Par la fonction SOUS.TOTAL(9;...)
=SOUS.TOTAL(9;C2:C5)
ou SOMMEPROD()
=SOMMEPROD(($A$2:$A$100â)*$C$2:$D$100)
Voir ici
http://cjoint.com/?hdsppUkoOd
--
Salutations
JJ


"EmanuelL"
Bonjour à Tous,

Je suis à la recherche d'une solution qui peut me permettre de calculer
automatique les céllules selon un certain critère, en l'occurence la somme
de toutes les céllules "Tot_heures" qui contiennent les valeurs identiques
dans la colonne "No_collab", ainsi de suite.

Si No_collab = 2, total = 3.50, selon l'exemple ci-dessous.

J'ai mis un fichier Excel comme exemple ici :
http://www.cijoint.fr/cjlink.php?file=cj200807/cijfmcODDc.xls

Exemple:

No_collab No_site Tot_heures
2 100 2.25
2 300 0.50
2 400 0.50
2 580 0.25
Total: 3.50

3 100 115.75
3 200 5.75
3 300 1.00

Merci d'avance. ;-)

--

*!* -----------------------------------
EmanuelL
Membre d'AtoutFox
www.atoutfox.org





--

*!* -----------------------------------
EmanuelL
Membre d'AtoutFox
www.atoutfox.org
Modeste
Le #11181511
Bonsour® EmanuelL avec ferveur ;o))) vous nous disiez :

Je pense que c'est un bon piste.



oui ???
alors faites aussi le bare-prise et la bression des bneus
;o)))

--
@+
;o)))
michdenis
Le #11181681
| la bression des bneus

La Pression des Bleus -> ils en ont bien besoin !
;-))


"Modeste"
Bonsour® EmanuelL avec ferveur ;o))) vous nous disiez :

Je pense que c'est un bon piste.



oui ???
alors faites aussi le bare-prise et la bression des bneus
;o)))

--
@+
;o)))
EmanuelL
Le #11182201
Sincèrement je n'ai pas compris vos sens d'humour, :-(!

Il se trouve que michdenis a formulé :
| la bression des bneus

La Pression des Bleus -> ils en ont bien besoin !
;-))


"Modeste"
Bonsour® EmanuelL avec ferveur ;o))) vous nous disiez :

Je pense que c'est un bon piste.



oui ???
alors faites aussi le bare-prise et la bression des bneus
;o)))



--

*!* -----------------------------------
EmanuelL
Membre d'AtoutFox
www.atoutfox.org
Jacky
Le #11182481
> La Pression des Bleus -> ils en ont bien besoin !



En terme de pression, j'ai une préférence pour celle de la bière, c'est plus
sûr.
;o)

--
Salutations
JJ


"michdenis" %
| la bression des bneus

La Pression des Bleus -> ils en ont bien besoin !
;-))


"Modeste"
Bonsour® EmanuelL avec ferveur ;o))) vous nous disiez :

Je pense que c'est un bon piste.



oui ???
alors faites aussi le bare-prise et la bression des bneus
;o)))

--
@+
;o)))




Jacky
Le #11182471
> Sincèrement je n'ai pas compris vos sens d'humour, :-(!



Cherche pas EmanuelL....ce sont les grands du forum, et ils n'ont pas grand
chose à ce mettre sous la dent.
Alors ils s'amusent un peu.
Ils sont jaloux parce que je t'ai donné "une bonne piste"
;o)))))
--
Salutations
JJ


"EmanuelL"
Sincèrement je n'ai pas compris vos sens d'humour, :-(!

Il se trouve que michdenis a formulé :
| la bression des bneus

La Pression des Bleus -> ils en ont bien besoin !
;-))


"Modeste"
Bonsour® EmanuelL avec ferveur ;o))) vous nous disiez :

Je pense que c'est un bon piste.



oui ???
alors faites aussi le bare-prise et la bression des bneus
;o)))



--

*!* -----------------------------------
EmanuelL
Membre d'AtoutFox
www.atoutfox.org




Modeste
Le #11182631
Bonsour® EmanuelL avec ferveur ;o))) vous nous disiez :

Sincèrement je n'ai pas compris vos sens d'humour, :-(!



Evidement sans l'accent de Jacky , c'est quelque peu hermétique ...
;o)))

--
@+
;o)))
michdenis
Le #11182801
| En terme de pression, j'ai une préférence pour celle de la bière, c'est
plus
| sûr.

Tu dois avoir raison, je n'y connais rien à la bière !
;-)
Jacky
Le #11182791
Accent, quel accent , Ch'ai un n'accent moi ???
giftschlang
;o))
--
Salutations
JJ


"Modeste" %
Bonsour® EmanuelL avec ferveur ;o))) vous nous disiez :

Sincèrement je n'ai pas compris vos sens d'humour, :-(!



Evidement sans l'accent de Jacky , c'est quelque peu hermétique ...
;o)))

--
@+
;o)))
Publicité
Poster une réponse
Anonyme