Exclure certaines cellules d'une formule ?

Le
Oliv'
Bonjour !
J'ai une formule concernant un mois (du 1er au 31) allant de D3 à AH3
Je voudrais que chaque fois que j'écris "CP" dans une cellule ça me compte
7,8 heures en B3, tout en excluant les dimanches et jours fériés (connus
dans mon exemple comme étant dans les colonnes J3, Q3, X3, AB3, et AE3

Ma formule actuelle est :
=SOMMEPROD((D3:AH3={""})*10/24)+SOMMEPROD((D3:AH3={2})*12/24)+SOMMEPROD((D3:AH3={3})*9/24)+SOMMEPROD((D3:I3={"CP"})*7,8/24)+SOMMEPROD((K3:P3={"CP"})*7,8/24)+SOMMEPROD((R3:W3={"CP"})*7,8/24)+SOMMEPROD((Y3:AA3={"CP"})*7,8/24)+SOMMEPROD((AC3:AD3={"CP"})*7,8/24)+SOMMEPROD((AF3:AH3={"CP"})*7,8/24)

(il y a d'autres conditions au début, mais je ne pense pas qu'elles influent
sur vos réponses)
Les dim et JF, on doit pouvoir écrire "CP", mais sans compter d'heure dans
B3.

Y a-t-il un moyen de simplifier ma formule, par exemple en excluant
simplement lesdits dim et JF ?
Message d'erreur #VALEUR ou #N/A à toutes mes tentatives

Merci par avance
Olivier
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Sam
Le #17622841
Bonjour, sans tenir compte des jours fériés
en mettant les dates en lignes 2 et le CP en ligne 3
=SOMMEPROD((D3:AH3="CP")*(JOURSEM(D2:AH2;2)<6)*7,8/24)

pour les jours fériés, il faut rajouter une ligne 4 avec un 0 quand c'est
férié
et ça ferait
=SOMMEPROD((D3:AH3="CP")*(JOURSEM(D2:AH2;2)<6)*(D4:AH4=1)*7,8/24)

On pourrait aussi créer cette ligne 4 avec des 0 pour les WE et jours fériés
avec une formule du type
=ESTNA(RECHERCHEV(D2;$AJ$3:$AJ$14;1;0))*(JOURSEM(D2;2)<6)
(la liste des jours fériés est en $AJ$3:$AJ$14)

et faire en B3 =SOMMEPROD((D3:AH3="CP")*(D4:AH4)*7,8/24)

Cordialement
Michel dit "Sam"

"Oliv'" 490079f1$0$9577$
Bonjour !
J'ai une formule concernant un mois (du 1er au 31) allant de D3 à AH3...
Je voudrais que chaque fois que j'écris "CP" dans une cellule ça me compte
7,8 heures en B3, tout en excluant les dimanches et jours fériés (connus
dans mon exemple comme étant dans les colonnes J3, Q3, X3, AB3, et AE3...

Ma formule actuelle est :
=SOMMEPROD((D3:AH3={""})*10/24)+SOMMEPROD((D3:AH3={2})*12/24)+SOMMEPROD((D3:AH3={3})*9/24)+SOMMEPROD((D3:I3={"CP"})*7,8/24)+SOMMEPROD((K3:P3={"CP"})*7,8/24)+SOMMEPROD((R3:W3={"CP"})*7,8/24)+SOMMEPROD((Y3:AA3={"CP"})*7,8/24)+SOMMEPROD((AC3:AD3={"CP"})*7,8/24)+SOMMEPROD((AF3:AH3={"CP"})*7,8/24)

(il y a d'autres conditions au début, mais je ne pense pas qu'elles
influent
sur vos réponses...)
Les dim et JF, on doit pouvoir écrire "CP", mais sans compter d'heure dans
B3.

Y a-t-il un moyen de simplifier ma formule, par exemple en excluant
simplement lesdits dim et JF ?
Message d'erreur #VALEUR ou #N/A à toutes mes tentatives...

Merci par avance...
Olivier



Publicité
Poster une réponse
Anonyme