exécutable ne fonctionnant pas su aux un autre PC.

Le
Dan
Bonjour à tous.
J'ai développé sur mon PC équipé de Vista une application VB.NET 2008.
C'est application fonctionne très bien sur mon PC.
Elle fonctionne également très bien sûr un autre PC disposant de Windows XP.
Je sais maintenant de l'installer sur un autre ordinateur équipé de Vista
est malheureusement le programme ne démarre pas et je n'ai pas d'autre
indication que :
une erreur à empêcher l'exécution
Auriez-vous une piste à m'indiquer, je ne sais vraiment pas comment procéder
pour trouver la solution à ce problème.
D'avance merci de votre aide
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
gillardg
Le #19480331
dans le form_load
try

' ton code

catch ex as exception

debug.fail(ex.message)

end try

avant regarde que le framework est bien installé sur la machine cible

une autre possibilité mais c'est dur chez un client
c'est d'installer visual studio et debugger sur place:(


"Dan" : 4a269c8f$0$293$
Bonjour à tous.
J'ai développé sur mon PC équipé de Vista une application VB.NET 2008.
C'est application fonctionne très bien sur mon PC.
Elle fonctionne également très bien sûr un autre PC disposant de Windows
XP.
Je sais maintenant de l'installer sur un autre ordinateur équipé de Vista
est malheureusement le programme ne démarre pas et je n'ai pas d'autre
indication que :
une erreur à empêcher l'exécution...
Auriez-vous une piste à m'indiquer, je ne sais vraiment pas comment
procéder pour trouver la solution à ce problème.
D'avance merci de votre aide


Le #19480321
Bonjour Dan,

Je suppose que le Framework est bien installé sur l'autre PC, ou à défaut,
les DLL requises sont disponibles avec l'application.

Il est possible que l'erreur surviennent à n'importe quelle étape
d'initialisation dont l'erreur n'est pas gérée.

Par exemple, si tu accèdes à la base de registre et que les droits d'accès
ne sont pas suffisant sur ce PC, il y aura 1 erreur.
J'ai eu le cas sur 1 PC à 1 message d'erreur qui ressemblait comme 2 gouttes
d'eau au message signalant que le Framework n'était pas correctement
installé.
'Titre :
'.NET Framework Initialization Error
'Message :
'Please set registry key
HKMLSoftwareMicrosoft.NETFrameworkInstallRoot to point to the .NET
Framework install location.
La base de registre était correcte et le Framework pourtant bien installé.
Le problème était en fait tout autre et avait fort heureusement été
rapidement détecté par 1 administrateur réseau :
le Membre Administrateur ne faisait pas parti du Groupe Administrateurs.
C'est 1 exemple, je rappelle.

En espérant que d'autres personnes puissent t'aider mieux que moi.

Bon courage,
Stéphane



"Dan" 4a269c8f$0$293$
Bonjour à tous.
J'ai développé sur mon PC équipé de Vista une application VB.NET 2008.
C'est application fonctionne très bien sur mon PC.
Elle fonctionne également très bien sûr un autre PC disposant de Windows
XP.
Je sais maintenant de l'installer sur un autre ordinateur équipé de Vista
est malheureusement le programme ne démarre pas et je n'ai pas d'autre
indication que :
une erreur à empêcher l'exécution...
Auriez-vous une piste à m'indiquer, je ne sais vraiment pas comment
procéder pour trouver la solution à ce problème.
D'avance merci de votre aide


Dan
Le #19486101
Merci bien,j'ai mis le code que tu m'as indiqué sans résultat
suplémentaire...
La framwork 3.5 est bien installée.
mais sur ma machine j'ai en plus la
la 1.0 hotfx
et la franch 1.03705....
il doit en tout cas me manquer qq chose mais je ne trouve pas quoi


"gillardg" news:
dans le form_load
try

' ton code

catch ex as exception

debug.fail(ex.message)

end try

avant regarde que le framework est bien installé sur la machine cible

une autre possibilité mais c'est dur chez un client
c'est d'installer visual studio et debugger sur place:(


"Dan" discussion : 4a269c8f$0$293$
Bonjour à tous.
J'ai développé sur mon PC équipé de Vista une application VB.NET 2008.
C'est application fonctionne très bien sur mon PC.
Elle fonctionne également très bien sûr un autre PC disposant de Windows
XP.
Je sais maintenant de l'installer sur un autre ordinateur équipé de Vista
est malheureusement le programme ne démarre pas et je n'ai pas d'autre
indication que :
une erreur à empêcher l'exécution...
Auriez-vous une piste à m'indiquer, je ne sais vraiment pas comment
procéder pour trouver la solution à ce problème.
D'avance merci de votre aide





Dan
Le #19486091
merci de tes conseils mais je suis plustot perdu la.
il me manque certainement qq chose mais quoi?*

<Stéphane> a écrit dans le message de
news:%
Bonjour Dan,

Je suppose que le Framework est bien installé sur l'autre PC, ou à défaut,
les DLL requises sont disponibles avec l'application.

Il est possible que l'erreur surviennent à n'importe quelle étape
d'initialisation dont l'erreur n'est pas gérée.

Par exemple, si tu accèdes à la base de registre et que les droits d'accès
ne sont pas suffisant sur ce PC, il y aura 1 erreur.
J'ai eu le cas sur 1 PC à 1 message d'erreur qui ressemblait comme 2
gouttes d'eau au message signalant que le Framework n'était pas
correctement installé.
'Titre :
'.NET Framework Initialization Error
'Message :
'Please set registry key
HKMLSoftwareMicrosoft.NETFrameworkInstallRoot to point to the .NET
Framework install location.
La base de registre était correcte et le Framework pourtant bien installé.
Le problème était en fait tout autre et avait fort heureusement été
rapidement détecté par 1 administrateur réseau :
le Membre Administrateur ne faisait pas parti du Groupe Administrateurs.
C'est 1 exemple, je rappelle.

En espérant que d'autres personnes puissent t'aider mieux que moi.

Bon courage,
Stéphane



"Dan" 4a269c8f$0$293$
Bonjour à tous.
J'ai développé sur mon PC équipé de Vista une application VB.NET 2008.
C'est application fonctionne très bien sur mon PC.
Elle fonctionne également très bien sûr un autre PC disposant de Windows
XP.
Je sais maintenant de l'installer sur un autre ordinateur équipé de Vista
est malheureusement le programme ne démarre pas et je n'ai pas d'autre
indication que :
une erreur à empêcher l'exécution...
Auriez-vous une piste à m'indiquer, je ne sais vraiment pas comment
procéder pour trouver la solution à ce problème.
D'avance merci de votre aide






Patrice
Le #19487321
Le message d'erreur réel n'est pas un peu plus complet que cela ???

--
Patrice

"Dan" : 4a27cf11$0$291$
merci de tes conseils mais je suis plustot perdu la.
il me manque certainement qq chose mais quoi?*

<Stéphane> a écrit dans le message de
news:%
Bonjour Dan,

Je suppose que le Framework est bien installé sur l'autre PC, ou à
défaut, les DLL requises sont disponibles avec l'application.

Il est possible que l'erreur surviennent à n'importe quelle étape
d'initialisation dont l'erreur n'est pas gérée.

Par exemple, si tu accèdes à la base de registre et que les droits
d'accès ne sont pas suffisant sur ce PC, il y aura 1 erreur.
J'ai eu le cas sur 1 PC à 1 message d'erreur qui ressemblait comme 2
gouttes d'eau au message signalant que le Framework n'était pas
correctement installé.
'Titre :
'.NET Framework Initialization Error
'Message :
'Please set registry key
HKMLSoftwareMicrosoft.NETFrameworkInstallRoot to point to the .NET
Framework install location.
La base de registre était correcte et le Framework pourtant bien
installé.
Le problème était en fait tout autre et avait fort heureusement été
rapidement détecté par 1 administrateur réseau :
le Membre Administrateur ne faisait pas parti du Groupe Administrateurs.
C'est 1 exemple, je rappelle.

En espérant que d'autres personnes puissent t'aider mieux que moi.

Bon courage,
Stéphane



"Dan" 4a269c8f$0$293$
Bonjour à tous.
J'ai développé sur mon PC équipé de Vista une application VB.NET 2008.
C'est application fonctionne très bien sur mon PC.
Elle fonctionne également très bien sûr un autre PC disposant de Windows
XP.
Je sais maintenant de l'installer sur un autre ordinateur équipé de
Vista est malheureusement le programme ne démarre pas et je n'ai pas
d'autre indication que :
une erreur à empêcher l'exécution...
Auriez-vous une piste à m'indiquer, je ne sais vraiment pas comment
procéder pour trouver la solution à ce problème.
D'avance merci de votre aide









Dan
Le #19492711
le message est :
un probleme a fait que le programme a cessé de fonctionner.....

"Patrice" news:
Le message d'erreur réel n'est pas un peu plus complet que cela ???

--
Patrice

"Dan" discussion : 4a27cf11$0$291$
merci de tes conseils mais je suis plustot perdu la.
il me manque certainement qq chose mais quoi?*

<Stéphane> a écrit dans le message de
news:%
Bonjour Dan,

Je suppose que le Framework est bien installé sur l'autre PC, ou à
défaut, les DLL requises sont disponibles avec l'application.

Il est possible que l'erreur surviennent à n'importe quelle étape
d'initialisation dont l'erreur n'est pas gérée.

Par exemple, si tu accèdes à la base de registre et que les droits
d'accès ne sont pas suffisant sur ce PC, il y aura 1 erreur.
J'ai eu le cas sur 1 PC à 1 message d'erreur qui ressemblait comme 2
gouttes d'eau au message signalant que le Framework n'était pas
correctement installé.
'Titre :
'.NET Framework Initialization Error
'Message :
'Please set registry key
HKMLSoftwareMicrosoft.NETFrameworkInstallRoot to point to the .NET
Framework install location.
La base de registre était correcte et le Framework pourtant bien
installé.
Le problème était en fait tout autre et avait fort heureusement été
rapidement détecté par 1 administrateur réseau :
le Membre Administrateur ne faisait pas parti du Groupe Administrateurs.
C'est 1 exemple, je rappelle.

En espérant que d'autres personnes puissent t'aider mieux que moi.

Bon courage,
Stéphane



"Dan" 4a269c8f$0$293$
Bonjour à tous.
J'ai développé sur mon PC équipé de Vista une application VB.NET 2008.
C'est application fonctionne très bien sur mon PC.
Elle fonctionne également très bien sûr un autre PC disposant de
Windows XP.
Je sais maintenant de l'installer sur un autre ordinateur équipé de
Vista est malheureusement le programme ne démarre pas et je n'ai pas
d'autre indication que :
une erreur à empêcher l'exécution...
Auriez-vous une piste à m'indiquer, je ne sais vraiment pas comment
procéder pour trouver la solution à ce problème.
D'avance merci de votre aide












Patrice
Le #19494261
Ah oui Vista ;-)

Je n'ai pas ce dialogue en tête mais il n'y a pas un bouton "Détails" ou qq
chose de semblable qui afficherait un message plus adapté aux développeurs
???!!!

Ce n'est pas un problème style 3.5 d'un côté et 3.5 SP1 de l'autre ? (je
vois que tu parles de hotfix, c'est le SP ou vraiment une hotfix ?)

--
Patrice

"Dan" : 4a290538$0$293$
le message est :
un probleme a fait que le programme a cessé de fonctionner.....

"Patrice" news:
Le message d'erreur réel n'est pas un peu plus complet que cela ???

--
Patrice





[coupé]
Dan
Le #19497961
Voici le probleme que j'ai constaté:
mon projet se nome VBNET
dans VBNET
j'ai un repertoir nomé:
WindowsApplication1
dans WindowsApplication1 j'ai un second repertoir
WindowsApplication1
qui contien mes repertoirs BIN,obj....
et toute mon appli vb soit Form2
form3...
je viens de me renfre compte que form1 qui fait parti de mon appli se
trouve dans le premier repertoir WindowsApplication1 et non pas dans le
second avec form2 form3
dans mon appli form1 apparait dans le volet de droite avec un triangle
jaine.
j'ai fait un click droit sur Form1 dans mon appli et supprimé form1
puis physiquement j'ai fait copier coller de form1 depuis le premier
WindowsApplication1
vers le second puis dans mon application j'ai fait ajouter un element
existant pour selectionner form1
pas d'erreur de compilation mais au lancement je recupere l'erreur :
Une erreur s'est produite lors de la création du formulaire. Pour plus
d'informations, consultez Exception.InnerException. L'erreur est : Le module
spécifié est introuvable. (Exception de HRESULT : 0x8007007E)
que pencez vous de tout cela et que devrais je faire pour reparet tout ca
j'espere avoir ete assez precis pour vous permetre d'apprecier la situation
et j'attends vos conseils avec impatience
d'avance merci de votre aide

de news:
Ah oui Vista ;-)

Je n'ai pas ce dialogue en tête mais il n'y a pas un bouton "Détails" ou
qq chose de semblable qui afficherait un message plus adapté aux
développeurs ???!!!

Ce n'est pas un problème style 3.5 d'un côté et 3.5 SP1 de l'autre ? (je
vois que tu parles de hotfix, c'est le SP ou vraiment une hotfix ?)

--
Patrice

"Dan" discussion : 4a290538$0$293$
le message est :
un probleme a fait que le programme a cessé de fonctionner.....

"Patrice" news:
Le message d'erreur réel n'est pas un peu plus complet que cela ???

--
Patrice





[coupé]



Dan
Le #19511491
Bonjour a tous.
J'ai trouvé!
bon je vous explique.
j'utilise le composant MCI32.OCX
mais ce composant se trouvait dans un repertoir sur D non sur dans
C:windowssystem32 de ce fait en lancant mon appli sur une autre machine
le composant ne pouvait etre chargé d'ou l'erreur.
maintenant coment proceder pour installer ce composant (MCI32.OCX) dans
C:windowssystem32 automatiquement lors du déploiement de mon appli dans
un autre pc?
et d'autres composants eventuelement?
avec VB6 j'avaus une petite appli qui traitauit un fichier ini contenant
le code :
[COPY]
Mode Src = MCI32.OCX
RepDest = SYSTEM32
SousRep

COPY]
Mode Src = RICHTX32.OCX
RepDest = SYSTEM32
SousRep .....
mais cela fonctionnais sous Win XP et plus sous Vista
si vous aviez une solution je pourai cesser de cogiter ...
D'avance merci de votre aide.



"Dan" news:4a2987d9$0$298$
Voici le probleme que j'ai constaté:
mon projet se nome VBNET
dans VBNET
j'ai un repertoir nomé:
WindowsApplication1
dans WindowsApplication1 j'ai un second repertoir
WindowsApplication1
qui contien mes repertoirs BIN,obj....
et toute mon appli vb soit Form2
form3...
je viens de me renfre compte que form1 qui fait parti de mon appli se
trouve dans le premier repertoir WindowsApplication1 et non pas dans le
second avec form2 form3
dans mon appli form1 apparait dans le volet de droite avec un triangle
jaine.
j'ai fait un click droit sur Form1 dans mon appli et supprimé form1
puis physiquement j'ai fait copier coller de form1 depuis le premier
WindowsApplication1
vers le second puis dans mon application j'ai fait ajouter un element
existant pour selectionner form1
pas d'erreur de compilation mais au lancement je recupere l'erreur :
Une erreur s'est produite lors de la création du formulaire. Pour plus
d'informations, consultez Exception.InnerException. L'erreur est : Le
module spécifié est introuvable. (Exception de HRESULT : 0x8007007E)
que pencez vous de tout cela et que devrais je faire pour reparet tout ca
j'espere avoir ete assez precis pour vous permetre d'apprecier la
situation et j'attends vos conseils avec impatience
d'avance merci de votre aide

de news:
Ah oui Vista ;-)

Je n'ai pas ce dialogue en tête mais il n'y a pas un bouton "Détails" ou
qq chose de semblable qui afficherait un message plus adapté aux
développeurs ???!!!

Ce n'est pas un problème style 3.5 d'un côté et 3.5 SP1 de l'autre ? (je
vois que tu parles de hotfix, c'est le SP ou vraiment une hotfix ?)

--
Patrice

"Dan" discussion : 4a290538$0$293$
le message est :
un probleme a fait que le programme a cessé de fonctionner.....

"Patrice" news:
Le message d'erreur réel n'est pas un peu plus complet que cela ???

--
Patrice





[coupé]






Publicité
Poster une réponse
Anonyme