Exécution automatique...

Le
Laurent Jumet
Hello !

Sur mon XPHome SP2, j'ai beau décocher les drives G: et H: correspondant à mon disque dur USB ainsi que la case globale "Removable drives" en ce qui concerne l'Autoplay dans TweakUI 2.10, l'exécution automatique est toujours là quand je rebranche mon HD USB.
Une idée?
J'ai lu il y a deux ou trois jours que quelqu'un avait résolu son problème comme ça, et chez moi ça ne va pas: pourquoi?

--
Laurent Jumet - Point de Chat, Liège, BELGIUM
KeyID: 0xCFAF704C
[Restore address to laurent.jumet for e-mail reply.]
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Leonid
Le #1173736
Même chose chez moi aussi Laurent..!
Tout ça pour dire que vos conseils seront bienvenus...

"Laurent Jumet" news:
Hello !

Sur mon XPHome SP2, j'ai beau décocher les drives G: et H:
correspondant à mon disque dur USB ainsi que la case globale "Removable
drives" en ce qui concerne l'Autoplay dans TweakUI 2.10, l'exécution
automatique est toujours là quand je rebranche mon HD USB.
Une idée?
J'ai lu il y a deux ou trois jours que quelqu'un avait résolu son
problème comme ça, et chez moi ça ne va pas: pourquoi?

--
Laurent Jumet - Point de Chat, Liège, BELGIUM
KeyID: 0xCFAF704C
[Restore address to laurent.jumet for e-mail reply.]


Le Yéti
Le #1173727
Hello !

Sur mon XPHome SP2, j'ai beau décocher les drives G: et H:
correspondant à mon disque dur USB ainsi que la case globale
"Removable drives" en ce qui concerne l'Autoplay dans
TweakUI 2.10, l'exécution automatique est toujours là quand
je rebranche mon HD USB. Une idée?
J'ai lu il y a deux ou trois jours que quelqu'un avait résolu son
problème comme ça, et chez moi ça ne va pas: pourquoi ?

Laurent Jumet - Point de Chat, Liège, BELGIUM


Même chose chez moi aussi Laurent..!
Tout ça pour dire que vos conseils seront bienvenus...



Salut à vous deux,

voici : http://www.sos-pc.fr/fichiers/non-autoplay-2.jpg à visualiser.
Ne pas confondre deux rubriques dans My computer;
c'est dans My computer/Autoplay qu'on invalide les "démarrages
automatiques". Peut-être avez-vous confondu (et la version francisée
de TweakUI 2.10 n'est pas vraiment au point, quelle quelle soit.)

Amicalement, Tonio :-)


JF
Le #1173240
*Bonjour Leonid* !

Sur mon XPHome SP2, j'ai beau décocher les drives G: et H: correspondant
à mon disque dur USB ainsi que la case globale "Removable drives" en ce qui
concerne l'Autoplay dans TweakUI 2.10, l'exécution automatique est toujours
là quand je rebranche mon HD USB.
J'ai lu il y a deux ou trois jours que quelqu'un avait résolu son
problème comme ça, et chez moi ça ne va pas: pourquoi?


Même chose chez moi aussi Laurent..!
Tout ça pour dire que vos conseils seront bienvenus...


Ça fonctionne bien ici.
TweakUI existe en français :
TweakUI version 2.10.00 fr
www.gratilog.net/xoops/modules/mydownloads/viewcat.php?op=&cid"2
www.gratilog.net/xoops/modules/mydownloads/singlefile.php?cid"2&lid73

Dans TweakUI :
Poste de Travail>Exécution automatique>Lecteurs
Modifie la variable NoDriveAutoRun dans cette clé :
HKCUSoftwareMicrosoftWindowsCurrentVersionPoliciesExplorer

Plus d'infos sur NoDriveAutoRun :
www.microsoft.com/technet/prodtechnol/windows2000serv/reskit/regentry/58886.mspx
Détermine pour chaque lecteur si l'AutoPlay est activé.
Les 26 bits faibles désignent un lecteur
La position du bit identifie le lecteur, et sa valeur 0/1 l'AutoPlay
Le bit le plus faible (à droite) désigne le lecteur A
Le bit 26 à partir de la droite désigne le lecteur Z
Le bit à 0 ==> l'AutoPlay est actif pour ce lecteur
Le bit à 1 ==> l'AutoPlay est désactivé pour ce lecteur

Si aucun lecteur n'a l'AutoPlay désactivé
NoDriveAutoRun = 00 00 00 00 (défaut)

Exemples détaillés : Z est la 26ème lettre
ZYXWVUTSRQPONMLKJIHGFEDCBA
a 01 00 00 00 ==> 00000001 ==> 00000000000000000000000001
b 02 00 00 00 ==> 00000002 ==> 00000000000000000000000010
c 04 00 00 00 ==> 00000004 ==> 00000000000000000000000100
d 08 00 00 00 ==> 00000008 ==> 00000000000000000000001000
e 10 00 00 00 ==> 00000010 ==> 00000000000000000000010000
ZYXWVUTSRQPONMLKJIHGFEDCBA
u 00 00 10 00 ==> 00010000 ==> 00000100000000000000000000
v 00 00 20 00 ==> 00200000 ==> 00001000000000000000000000
w 00 00 40 00 ==> 00400000 ==> 00010000000000000000000000
x 00 00 80 00 ==> 00800000 ==> 00100000000000000000000000
y 00 00 00 01 ==> 01000000 ==> 01000000000000000000000000
z 00 00 00 02 ==> 02000000 ==> 10000000000000000000000000
ZYXWVUTSRQPONMLKJIHGFEDCBA
Désactivation des lecteurs J M R ==> R M J
00 12 02 00 ==> 00021200 ==> 00000000100001001000000000
ZYXWVUTSRQPONMLKJIHGFEDCBA

--
Salutations, Jean-François
Index du site de PN : www.d2i.ch/pn/az
Outlook Express : Suivez vos fils avec [CTL+H]
Montrez-nous ce que vous voyez : http://fspsa.free.fr/copiecran.htm


Laurent Jumet
Le #1173236
Hello JF !

JF wrote:

Sur mon XPHome SP2, j'ai beau décocher les drives G: et H:
correspondant à mon disque dur USB ainsi que la case globale "Removable
drives" en ce qui concerne l'Autoplay dans TweakUI 2.10, l'exécution
automatique est toujours là quand je rebranche mon HD USB.
J'ai lu il y a deux ou trois jours que quelqu'un avait résolu son
problème comme ça, et chez moi ça ne va pas: pourquoi?


Même chose chez moi aussi Laurent..!
Tout ça pour dire que vos conseils seront bienvenus...


Ça fonctionne bien ici.
TweakUI existe en français :
TweakUI version 2.10.00 fr


J'ai tout cela, mais je puis t'assurer que quelque chose ne va pas, et en plus quand je mets 0x95 ça se retransforme tout seul en 0xB4.
Soit j'ai plusieurs clés (au moins quatre et peut-être une dizaine qui sont interdépendantes, soit j'ai un programme qui en se lançant, change les valeurs.

--
Laurent Jumet - Point de Chat, Liège, BELGIUM
KeyID: 0xCFAF704C
[Restore address to laurent.jumet for e-mail reply.]



JF
Le #1173097
Poste de Travail>Exécution automatique>Lecteurs
Modifie la variable NoDriveAutoRun dans cette clé :
HKCUSoftwareMicrosoftWindowsCurrentVersionPoliciesExplorer


J'ai tout cela, mais je puis t'assurer que quelque chose ne va pas, et en
plus quand je mets 0x95 ça se retransforme tout seul en 0xB4.


On ne doit pas parler de la même chose.
Sois plus précis.
0x95 me fais furieusement penser à la valeur NoDriveTypeAutoRun
de la même clé
HKCUSoftwareMicrosoftWindowsCurrentVersionPoliciesExplorer
http://support.microsoft.com/kb/330135/fr
www.bellamyjc.org/fr/windowsnt.html#insertionCD
www.microsoft.com/technet/prodtechnol/windows2000serv/reskit/regentry/93502.mspx
NoDriveTypeAutoRun désactive l'Autorun par type de volume.
Le nombre hexadécimal est à transcrire en binaire.
La position du 1 détermine le type de lecteur désactivé.

Selon sa valeur, cette variable désactive l'Autorun pour :
HEXA BINAIRE TYPE
0x00000001 00000001 type inconnu
0x00000004 00000100 disque amovible
0x00000008 00001000 disque fixe
0x00000010 00010000 disque réseau
0x00000020 00100000 CDROM
0x00000040 01000000 RAMDISK
0x00000080 10000000 type inconnu
0x000000FF 11111111 tous les types

Remarquer que 00000001 et 10000000 = type inconnu, réf:
www.microsoft.com/technet/prodtechnol/windows2000serv/reskit/regentry/93502.mspx

0x00000095 10010101 est la combinaison de :
10000000 types inconnus
00010000 disque réseau
00000100 disques amovibles (disquettes)
00000001 type inconnu

0x00000091 10010001 est la combinaison de :
10000000 types inconnus
00010000 disque réseau
00000001 type inconnu

La valeur par défaut de NoDriveTypeAutoRun varie selon les systèmes
http://support.microsoft.com/kb/895108
Pour convertit hexa et binaire :
Démarrer>Exécuter>calc
0xB4 = 10110100 voir ci-dessus






Soit j'ai plusieurs clés (au moins quatre
et peut-être une dizaine qui sont interdépendantes,


C'est loin d'être impossible.
Précise un peu, donne des exemples.
Pour copier le nom d'une clé utiliser le clic droit.
Pour montrer plus de détails utiliser l'exportation ou faire des
captures d'écran.


soit j'ai un programme qui en se lançant, change les valeurs.


C'est facile de faire la démonstration. Tu sais faire je pense.
Donne la liste des programmes du Démarrage avec msinfo32.
Ce disque externe est-il un disque vendu tout monté avec une
installation ? Il y a un logiciel de vidéo ou de sauvegarde ?

--
Salutations, Jean-François
Index du site de PN : www.d2i.ch/pn/az
Outlook Express : Suivez vos fils avec [CTL+H]
Montrez-nous ce que vous voyez : http://fspsa.free.fr/copiecran.htm


JF
Le #1171441
*Bonjour Laurent Jumet* !

Sur mon XPHome SP2, j'ai beau décocher les drives G: et H:
correspondant à mon disque dur USB ainsi que la case globale "Removable
drives" en ce qui concerne l'Autoplay dans TweakUI 2.10, l'exécution
automatique est toujours là quand je rebranche mon HD USB.
J'ai lu il y a deux ou trois jours que quelqu'un avait résolu son
problème comme ça, et chez moi ça ne va pas: pourquoi?


Même chose chez moi aussi Laurent..!
Tout ça pour dire que vos conseils seront bienvenus...



je puis t'assurer que quelque chose ne va pas, et en
plus quand je mets 0x95 ça se retransforme tout seul en 0xB4.


Vous en êtres où tous les deux ?
Pas de réponse = c'est soldé ?

--
Salutations, Jean-François
Index du site de PN : www.d2i.ch/pn/az
Outlook Express : Suivez vos fils avec [CTL+H]
Montrez-nous ce que vous voyez : http://fspsa.free.fr/copiecran.htm




Publicité
Poster une réponse
Anonyme