Exercice de calendrier

Le
garnote
Bonsoir, Bonsoir,

1. En C3, je choisis dans une liste déroulante un mois (janvier décembre).
2. En E3, je choisis une année (1900 2100).
3. Pour le mois et l'année choisis, je veux connaître le numéro (de 1 à 7) du
premier jour du mois (en D15) ainsi que le nombre de jours dudit mois (en E15).
4. Pour ce faire, j'ai utilsé les formules suivantes :
a) En B15 : =TEXTE(C3 & " " & E3;"mmmm aaaa")
b) En C15 : ÚTE(ANNEE(B15);MOIS(B15);1)
c) En D15 : =JOURSEM(C15;1)
d) En E15 : =JOUR(DATE(ANNEE(C15);MOIS(C15)+1;0))

Questions :
Ces formules sont-elles vraiment compétentes et peut-on obtenir c) et d) autrement ?

Bonne fin de soirée et j'ose espérer que vous avez bien quatorzejuilletté ;-)

Serge
P.-S. : Vous êtes de sacré(e)s gaillard(e)s !
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
JB
Le #4869751
Bonjour,

=JOUR(DATE(E3;MOIS("01-"&C3)+1;0))
=JOURSEM("01-"&C3&"-"&E3;1)

JB

On 15 juil, 21:25, "garnote"
Bonsoir, Bonsoir,

1. En C3, je choisis dans une liste déroulante un mois (janvier ... d écembre).
2. En E3, je choisis une année (1900 ... 2100).
3. Pour le mois et l'année choisis, je veux connaître le numéro (de 1 à 7) du
premier jour du mois (en D15) ainsi que le nombre de jours dudit mois (en E15).
4. Pour ce faire, j'ai utilsé les formules suivantes :
a) En B15 : =TEXTE(C3 & " " & E3;"mmmm aaaa")
b) En C15 : ÚTE(ANNEE(B15);MOIS(B15);1)
c) En D15 : =JOURSEM(C15;1)
d) En E15 : =JOUR(DATE(ANNEE(C15);MOIS(C15)+1;0))

Questions :
Ces formules sont-elles vraiment compétentes et peut-on obtenir c) et d ) autrement ?

Bonne fin de soirée et j'ose espérer que vous avez bien quatorzejuill etté ;-)

Serge
P.-S. : Vous êtes de sacré(e)s gaillard(e)s !


garnote
Le #4869391
Salut JB,

Merci bien.
J'ai simplifié un tipeu :
=JOUR(DATE(E3;MOIS("01"&C3)+1;0))
=JOURSEM("01"&C3&E3;1)

Serge


"JB"
Bonjour,

=JOUR(DATE(E3;MOIS("01-"&C3)+1;0))
=JOURSEM("01-"&C3&"-"&E3;1)

JB

On 15 juil, 21:25, "garnote"
Bonsoir, Bonsoir,

1. En C3, je choisis dans une liste déroulante un mois (janvier ... décembre).
2. En E3, je choisis une année (1900 ... 2100).
3. Pour le mois et l'année choisis, je veux connaître le numéro (de 1 à 7) du
premier jour du mois (en D15) ainsi que le nombre de jours dudit mois (en E15).
4. Pour ce faire, j'ai utilsé les formules suivantes :
a) En B15 : =TEXTE(C3 & " " & E3;"mmmm aaaa")
b) En C15 : ÚTE(ANNEE(B15);MOIS(B15);1)
c) En D15 : =JOURSEM(C15;1)
d) En E15 : =JOUR(DATE(ANNEE(C15);MOIS(C15)+1;0))

Questions :
Ces formules sont-elles vraiment compétentes et peut-on obtenir c) et d) autrement ?

Bonne fin de soirée et j'ose espérer que vous avez bien quatorzejuilletté ;-)

Serge
P.-S. : Vous êtes de sacré(e)s gaillard(e)s !


Publicité
Poster une réponse
Anonyme