Exim4 et spamassassin

Le
Nicolas Pechon
Bonjour,
J'utilise actuellement exim4. Je souhaite aussi utiliser spamassassin.

Hors, si je suis le tuto:
https://www.crashdump.fr/debian/installer-spamassasin-pour-exim4-sous-debian-58/

il m'indique de modifier:
/etc/exim4/conf.d/main/02_exim4-config_options

en dé-commentant la ligne 'spamd_address = 127.0.0.1 783'

Le soucis et que si je fait cela, exim4 ce met en panique et m'indique:
main option "spamd_address" unknown

En cherchant sur le web, il semble qu'il faut compiler exim avec l'option:
WITH_CONTENT_SCAN=yes
WITH_OLD_DEMIME=yes

Le problème et que je souhaite n'utiliser que des package de debian afin
de faciliter les taches de maintenances.

De plus, il semble étonnant qu'exim ne soit pas préparer pour utiliser
spam

Non?

D'avance merci de vos suggestions

--
Je suis contre l'avortement.
Tuer un être humain avant qu'il ne soit né est impardonnable.
C'est une preuve d'impatience.
-+- Bernard Shaw -+-


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Archive: http://lists.debian.org/1805ae490b4ab9f840bbe0b25889e6d7.squirrel@bureau
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
JF Straeten
Le #25149792
LO,

On Fri, Jan 18, 2013 at 10:50:36AM +0100, Nicolas Pechon wrote:

[...]

Le soucis et que si je fait cela, exim4 ce met en panique et m'indique:
main option "spamd_address" unknown

En cherchant sur le web, il semble qu'il faut compiler exim avec l'option:
WITH_CONTENT_SCAN=yes
WITH_OLD_DEMIME=yes

Le problème et que je souhaite n'utiliser que des package de debian afin
de faciliter les taches de maintenances.

De plus, il semble étonnant qu'exim ne soit pas préparer pour utiliser
spam...

Non?



Non ;)

Tu as probablement installé le paquet exim4-daemon-light alors qu'il
te faut exim4-daemon-heavy pour l'interfacer avec spamassassin.

Description : Démon MTA Exim (v4) avec des fonctions étendues,
incluant exiscan-acl Exim (v4) est un agent de transport de
courrier. Ce paquet contient le démon exim4 avec des
fonctionnalités étendues. En plus des fonctionnalités supportées
par exim4-daemon-light, exim4-daemon-heavy inclut la recherche de
données LDAP, sqlite, PostgreSQL et MySQL, l'authentification SMTP
SASL et SPA, un interpréteur Perl embarqué et l'extension de
balayage de contenu (connue avant sous le nom de exiscan-acl) pour
l'intégration avec les scanneurs de virus et spamassassin.


Remplace un par l'autre et ça devrait aller mieux.

Hih,


--

JFS.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Publicité
Poster une réponse
Anonyme