expertise en FFMPEG

Le
Stephane Legras-Decussy
bonjour,

j'enrage un peu avec ffmpeg qui a des comportements
disons pas simples

le but est de convertir un 720p mjpeg mov
en 720p mjpeg avi

déja le simple changement de conteneur -vcodec copy
ne marche pas, image noire.

je réencode donc en mjpeg comme ceçi :

ffmpeg -i source.mov -r 29.97 -s 1280x720 -aspect 1.7777 -vcodec mjpeg
-b:v 50000k -an -y out.avi

-r 29,97 -s 1280x720 -aspect 1.777 ne font aucune modif mais ça ne
marche pas si on ne les indique pas (pas glop)

-an zappe le son, ça c'est ok.

cette commande me donne un avi mjpeg ok dans media player classic, ok
dans avidemux mais ne s'ouvre pas dans virtualdub ! ni dans Vegas 7.0 !

image noire.

ça commence à m'enerver et je perd confiance dans ce soft, quelqu'un
a une idée ?

merci.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 7
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
jean-daniel dodin
Le #24307071
Le 09/03/2012 02:24, Stephane Legras-Decussy a écrit :

ça commence à m'enerver et je perd confiance dans ce soft, quelqu'un
a une idée ?



on ne peut pas faire n'importe quoi avec n'importe quoi.

C'est quoi, le but définitif??

jdd
Stephane Legras-Decussy
Le #24308061
Le 09/03/2012 08:48, jean-daniel dodin a écrit :

Le 09/03/2012 02:24, Stephane Legras-Decussy a écrit :

ça commence à m'enerver et je perd confiance dans ce soft, quelqu'un
a une idée ?



on ne peut pas faire n'importe quoi avec n'importe quoi.

C'est quoi, le but définitif??

jdd



simplement changer le conteneur de cette video issue
d'un LUMIX.

je veux pouvoir l'ouvrir dans mes softs habituels, rien de plus ...


le fait que ça s'ouvre dans certains et pas d'autres, indique
un mauvais ficher, j'aime pas ça du tout...
jean-daniel dodin
Le #24308181
Le 09/03/2012 14:10, Stephane Legras-Decussy a écrit :

simplement changer le conteneur de cette video issue
d'un LUMIX.

je veux pouvoir l'ouvrir dans mes softs habituels, rien de plus ...



je ne vois pas en quoi le changement de *conteneur* va modifier ca.

jdd
Stephane Legras-Decussy
Le #24309631
Le 09/03/2012 14:59, jean-daniel dodin a écrit :
Le 09/03/2012 14:10, Stephane Legras-Decussy a écrit :

simplement changer le conteneur de cette video issue
d'un LUMIX.

je veux pouvoir l'ouvrir dans mes softs habituels, rien de plus ...



je ne vois pas en quoi le changement de *conteneur* va modifier ca.




?

virtualdub n'ouvre pas le mov.

Vegas n'ouvre le mov qu'en ayant installé quicktime, je ne veux pas.

en sortant le mjpeg du mov et en le mettant dans un avi, ça
règle le problème.

sauf là çà coince avec ffmpeg...
gerard guenin
Le #24309811
Le Fri, 09 Mar 2012 22:34:45 +0100, Stephane Legras-Decussy écrit:

virtualdub n'ouvre pas le mov.



Dans les versions récentes de virtualdub il y a de nouveaux plugins (32 et 64
bits) qui permettent d'ouvrir un peu n'importe quoi.

http://www.videohelp.com/tools/Virtualdub

Voir la liste des plugins dans la page.

--
Enlever la pub pour me répondre
jean-daniel dodin
Le #24309861
Le 09/03/2012 22:34, Stephane Legras-Decussy a écrit :


en sortant le mjpeg du mov et en le mettant dans un avi, ça
règle le problème.



renommer le fichier?

jdd
Stephane Legras-Decussy
Le #24310141
Le 09/03/2012 23:19, gerard guenin a écrit :

Dans les versions récentes de virtualdub il y a de nouveaux plugins (32 et 64
bits) qui permettent d'ouvrir un peu n'importe quoi.




bonne idée... installé, ouverture fichier mov ok...

mais toujours cette satanée image noire.


ce serait quand même pas un bug des mov de panasonic ?

voilà un sample video du lumix ZX-1 qui donne aussi image
noire ... au moins l'erreur est constante!

http://img.photographyblog.com/reviews/panasonic_lumix_dmc_zx1/sample_images/panasonic_lumix_dmc_zx1_01.mov


chez moi seul avidemux arrive à lire correctement ce fichier.

grrrr...
Philippe Naudin
Le #24310361
Le sam. 10 mars 2012 02:52:07 CET, Stephane Legras-Decussy a écrit:

Le 09/03/2012 23:19, gerard guenin a écrit :
>
> Dans les versions récentes de virtualdub il y a de nouveaux plugins ( 32 et 64
> bits) qui permettent d'ouvrir un peu n'importe quoi.
>

bonne idée... installé, ouverture fichier mov ok...

mais toujours cette satanée image noire.


ce serait quand même pas un bug des mov de panasonic ?

voilà un sample video du lumix ZX-1 qui donne aussi image
noire ... au moins l'erreur est constante!

http://img.photographyblog.com/reviews/panasonic_lumix_dmc_zx1/sample_ima ges/panasonic_lumix_dmc_zx1_01.mov


chez moi seul avidemux arrive à lire correctement ce fichier.

grrrr...



Je n'ai pas suivi toute la discussion mais chez moi au moins vlc et
xine lisent cette vidéo, à ce hiatus près qu'ils l'affichent en mode
paysage (normal, quoi) : ce n'est plus la tour penchée, c'est carrément
la tour couchée. Il doit y avoir une option pour corriger ça, mais j'ai
la flemme de chercher.

--
Philippe
Philippe Naudin
Le #24310501
Le sam. 10 mars 2012 08:35:33 CET, Philippe Naudin a écrit:

Le sam. 10 mars 2012 02:52:07 CET, Stephane Legras-Decussy a écrit:
>
> mais toujours cette satanée image noire.
>
>
> ce serait quand même pas un bug des mov de panasonic ?
>
> voilà un sample video du lumix ZX-1 qui donne aussi image
> noire ... au moins l'erreur est constante!
>
> http://img.photographyblog.com/reviews/panasonic_lumix_dmc_zx1/sample_i mages/panasonic_lumix_dmc_zx1_01.mov



J'ai testé avec ffmpeg :
$ ffmpeg -i panasonic_lumix_dmc_zx1_01.mov -vcodec copy toto.avi

Visualisation avec xine :
$ xine --verbose=1 toto.avi
...
gui_xine_open_and_play():
mrl: 'toto.avi',
sub 'NONE',
start_pos 0, start_time 0, av_offset 0, spu_offset 0.
xine: plugin d'entré trouvé : file input plugin
ebml: invalid master element
failed to read 8 bytes at pos 72478200
xine: found demuxer plugin: AVI/RIFF demux plugin
av_offset=0 pts
spu_offset=0 pts
audio_oss_out: audio rate : 16000 requested, 16000 provided by device
audio_oss_out: 1 channels output
...
demux_avi: video and audio streams are ended

Ce toto.avi est lu sans problème par xine, mais vlc (une vieille
version) plante vers la moitié de la lecture. Donc je ne suis pas sûr
qu'un simple changement de conteneur suffise à régler ton problème.

--
Philippe Naudin
jp willm
Le #24310791
Le 10/03/2012 02:52, Stephane Legras-Decussy a écrit :

chez moi seul avidemux arrive à lire correctement ce fichier.



J'ai un APN Panasonic et je suis obligé de passer les vidéos (sans les
réencoder) par :

avidemux > Vidéo > Images par seconde = 25


--
jp willm
http://perso.orange.fr/willms/index.html
Publicité
Poster une réponse
Anonyme