Exploiter des données pour en extraire des statistiques en fonction d'une colonne

Le
Greg
Bonsoir,

Voici le fichier sur lequel je travaille et là je sèche sur la dernière
manouvre.

http://cjoint.com/?3dounsldJxE

En fait, je voudrais exploiter les données de la feuille 1. Il est assez
facile de faire les statistiques d'une colonne, mais je souhaite extraire
seulement les données en fonction de la classe des élèves en colonne A.

J'ai écrit dans la feuille "Stats" ce que je souhaite faire exactement.



Pour généraliser le problème, il s'agit de faire la stat suivante :

C1 C2 C3 C4 C5

CM2 Gérard x x x x x

CM2 Albert x x x

CM1 Gilberte x x x


Comment connaitre le pourcentage d'élèves de CM2 qui ont validé la C3 (soit
50% dans l'exemple)

Merci à vous pour votre aide.

Greg
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
michel ou sam
Le #23204771
Bonjour,
avec un sommeprod :
=SOMMEPROD((Competences!$A$4:$A$99=Stats!$A4)*(Competences!J$4:J$99="."))/NBVAL(Competences!$C$4:$C$99)

http://cjoint.com/?1dovu4BqsaK

Michel

"Greg" illq2o$ogd$
Bonsoir,

Voici le fichier sur lequel je travaille... et là je sèche sur la dernière
manouvre....

http://cjoint.com/?3dounsldJxE

En fait, je voudrais exploiter les données de la feuille 1. Il est assez
facile de faire les statistiques d'une colonne, mais je souhaite extraire
seulement les données en fonction de la classe des élèves en colonne A.

J'ai écrit dans la feuille "Stats" ce que je souhaite faire exactement.



Pour généraliser le problème, il s'agit de faire la stat suivante :

C1 C2 C3 C4 C5

CM2 Gérard x x x x x

CM2 Albert x x x

CM1 Gilberte x x x


Comment connaitre le pourcentage d'élèves de CM2 qui ont validé la C3
(soit 50% dans l'exemple)

Merci à vous pour votre aide.

Greg
DanielCo
Le #23204801
Bonsoir,
Pour éviter les cellules fusionnéesz, j'ai mis en B12, C12, D12 : C1,
en E12, F12, G12 : C2 etc. La ligne peut être masquée.
En C4, la formule est :
=SOMMEPROD((DECALER(Competences!$A$4:$A$75;;EQUIV(Stats!B$12;Competences!$C$1:$X$1;0)+Stats!B$3)=".")*(Competences!$A$4:$A$75=Stats!$A4))/NB.SI(Competences!$A$4:$A$75;Stats!$A4)
à recopier en bas et à droite.
Daniel


Bonsoir,

Voici le fichier sur lequel je travaille... et là je sèche sur la dernière
manouvre....

http://cjoint.com/?3dounsldJxE

En fait, je voudrais exploiter les données de la feuille 1. Il est assez
facile de faire les statistiques d'une colonne, mais je souhaite extraire
seulement les données en fonction de la classe des élèves en colonne A.

J'ai écrit dans la feuille "Stats" ce que je souhaite faire exactement.



Pour généraliser le problème, il s'agit de faire la stat suivante :

C1 C2 C3 C4 C5

CM2 Gérard x x x x x

CM2 Albert x x x

CM1 Gilberte x x x


Comment connaitre le pourcentage d'élèves de CM2 qui ont validé la C3 (soit
50% dans l'exemple)

Merci à vous pour votre aide.

Greg
Greg
Le #23204871
J'adore cette fonction! J'adore ce forum!

Merci Michel ou Sam.

Greg

"michel ou sam" de discussion : 4d7e78ce$0$7721$

Bonjour,
avec un sommeprod :
=SOMMEPROD((Competences!$A$4:$A$99=Stats!$A4)*(Competences!J$4:J$99="."))/NBVAL(Competences!$C$4:$C$99)

http://cjoint.com/?1dovu4BqsaK

Michel

"Greg" illq2o$ogd$
Bonsoir,

Voici le fichier sur lequel je travaille... et là je sèche sur la
dernière manouvre....

http://cjoint.com/?3dounsldJxE

En fait, je voudrais exploiter les données de la feuille 1. Il est assez
facile de faire les statistiques d'une colonne, mais je souhaite extraire
seulement les données en fonction de la classe des élèves en colonne A.

J'ai écrit dans la feuille "Stats" ce que je souhaite faire exactement.



Pour généraliser le problème, il s'agit de faire la stat suivante :

C1 C2 C3 C4 C5

CM2 Gérard x x x x x

CM2 Albert x x x

CM1 Gilberte x x x


Comment connaitre le pourcentage d'élèves de CM2 qui ont validé la C3
(soit 50% dans l'exemple)

Merci à vous pour votre aide.

Greg




Greg
Le #23205011
J'essaye depuis tout à l'heure de revoir la formule (en C4 par exemple) :

=SOMMEPROD((Competences!$A$4:$A$99=Stats!$A4)*(Competences!E$4:E$99="."))/NBVAL(Competences!$C$4:$C$99)

En fait, il ne faudrait pas diviser par :

NBVAL(Competences!$C$4:$C$99)

Il faudrait diviser par le nombre de cellules qui réunit cette condition
(nombres de cellules non vides de C4 à C99) +
Competences!$A$4:$A$99=Stats!$A4

J'ai donc essayé


=SOMMEPROD((Competences!$A$4:$A$99=Stats!$A4)*(NBVAL(Competences!$C$4:$C$99)))

Mais ça ne fonctionne pas...... Il me sort un nombre énorme.

Pouvez-vous me donner ce dernier coup de pouce?




"Greg" discussion : illve5$8ds$
J'adore cette fonction! J'adore ce forum!

Merci Michel ou Sam.

Greg

"michel ou sam" groupe de discussion : 4d7e78ce$0$7721$

Bonjour,
avec un sommeprod :
=SOMMEPROD((Competences!$A$4:$A$99=Stats!$A4)*(Competences!J$4:J$99="."))/NBVAL(Competences!$C$4:$C$99)

http://cjoint.com/?1dovu4BqsaK

Michel

"Greg" illq2o$ogd$
Bonsoir,

Voici le fichier sur lequel je travaille... et là je sèche sur la
dernière manouvre....

http://cjoint.com/?3dounsldJxE

En fait, je voudrais exploiter les données de la feuille 1. Il est assez
facile de faire les statistiques d'une colonne, mais je souhaite
extraire seulement les données en fonction de la classe des élèves en
colonne A.

J'ai écrit dans la feuille "Stats" ce que je souhaite faire exactement.



Pour généraliser le problème, il s'agit de faire la stat suivante :

C1 C2 C3 C4 C5

CM2 Gérard x x x x x

CM2 Albert x x x

CM1 Gilberte x x x


Comment connaitre le pourcentage d'élèves de CM2 qui ont validé la C3
(soit 50% dans l'exemple)

Merci à vous pour votre aide.

Greg




Greg
Le #23205041
De: "Greg" Objet: Re: Exploiter des données pour en extraire des statistiques en
fonction d'une colonne
Date: lundi 14 mars 2011 23:07

Désolé Daniel, je ne comprends pas ta proposition. Avais-tu un fichier
joint?

Greg
michel ou sam
Le #23205461
Bonjour,
le pb est de savoir ce que tu veux trouver !

=SOMMEPROD((Competences!$A$4:$A$99=Stats!$A4)*(Competences!E$4:E$99="."))/NBVAL(Competences!$C$4:$C$99)
permet de retrouver ton pourcentage que tu avais calculé sur la feuille
compétence : =NB.SI(E4:E197;".")/NBVAL($C$4:$C$197)

Autrement en mettant un peu de ma formule, un peu de la formule de Daniel,
un peu de sel et un peu de poivre tu peux obtenir :

=SOMMEPROD((Competences!$A$4:$A$99=Stats!$A4)*(Competences!E$4:E$99="."))/NB.SI(Competences!E$4:E$99;".")
qui te donnera un total de 100% mais ça revient à comparer les CE1 avec les
CM2.

ou aussi ceci
=SOMMEPROD((Competences!$A$4:$A$99=Stats!$A4)*(Competences!J$4:J$99="."))/NB.SI(Competences!$A$4:$A$99;Stats!$A4)
qui te donne un pourcentage par classe mais bien sûr le total ne correspond
plus à rien

j'ai fais un test sur la PJ mais attention j'ai changé quelques ".." dans
"Compétences"
http://cjoint.com/?1dpjfpSM7r

Michel

"Greg" ilm29l$h4p$
J'essaye depuis tout à l'heure de revoir la formule (en C4 par exemple) :

=SOMMEPROD((Competences!$A$4:$A$99=Stats!$A4)*(Competences!E$4:E$99="."))/NBVAL(Competences!$C$4:$C$99)

En fait, il ne faudrait pas diviser par :

NBVAL(Competences!$C$4:$C$99)

Il faudrait diviser par le nombre de cellules qui réunit cette condition
(nombres de cellules non vides de C4 à C99) +
Competences!$A$4:$A$99=Stats!$A4

J'ai donc essayé


=SOMMEPROD((Competences!$A$4:$A$99=Stats!$A4)*(NBVAL(Competences!$C$4:$C$99)))

Mais ça ne fonctionne pas...... Il me sort un nombre énorme.

Pouvez-vous me donner ce dernier coup de pouce?




"Greg" discussion : illve5$8ds$
J'adore cette fonction! J'adore ce forum!

Merci Michel ou Sam.

Greg

"michel ou sam" groupe de discussion : 4d7e78ce$0$7721$

Bonjour,
avec un sommeprod :
=SOMMEPROD((Competences!$A$4:$A$99=Stats!$A4)*(Competences!J$4:J$99="."))/NBVAL(Competences!$C$4:$C$99)

http://cjoint.com/?1dovu4BqsaK

Michel

"Greg" illq2o$ogd$
Bonsoir,

Voici le fichier sur lequel je travaille... et là je sèche sur la
dernière manouvre....

http://cjoint.com/?3dounsldJxE

En fait, je voudrais exploiter les données de la feuille 1. Il est
assez facile de faire les statistiques d'une colonne, mais je souhaite
extraire seulement les données en fonction de la classe des élèves en
colonne A.

J'ai écrit dans la feuille "Stats" ce que je souhaite faire exactement.



Pour généraliser le problème, il s'agit de faire la stat suivante :

C1 C2 C3 C4 C5

CM2 Gérard x x x x x

CM2 Albert x x x

CM1 Gilberte x x x


Comment connaitre le pourcentage d'élèves de CM2 qui ont validé la C3
(soit 50% dans l'exemple)

Merci à vous pour votre aide.

Greg




DanielCo
Le #23205451
Bonjour,
http://cjoint.com/?1dpjhtjS47d
Daniel
Greg a couché sur son écran :
De: "Greg" Objet: Re: Exploiter des données pour en extraire des statistiques en
fonction d'une colonne
Date: lundi 14 mars 2011 23:07

Désolé Daniel, je ne comprends pas ta proposition. Avais-tu un fichier
joint?

Greg
Publicité
Poster une réponse
Anonyme