extension Firefox paquet non valide

Le
jacques.montier
Bonjour,

J'utilise Firefox-3.6 sous Gentoo Linux.
Je n'arrive plus à installer certaines extensions qui sont pourtant
compatibles firefox-3.6.
Par exemple : l'extension Xmarks.
J'ai droit au message :
Firefox n'a pas pu installer le fichier situé à
https://addons.mozilla.org/downloads/file/81860/xmarks-3.5.10-fx.xpi?src=api
raison : Paquet à installer non valide -207

J'ai pourtant installé sans problème cette extension sur un pc portable
(Gentoo linux) avec Firefox-3.6.

Avez-vous une idée sur le sujet ?

Merci d'avance


--
Jacques
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Maurice
Le #21356611
jacques.montier a formulé ce mercredi :
Bonjour,

J'utilise Firefox-3.6 sous Gentoo Linux.
Je n'arrive plus à installer certaines extensions qui sont pourtant
compatibles firefox-3.6.
Par exemple : l'extension Xmarks.
J'ai droit au message :
Firefox n'a pas pu installer le fichier situé à
https://addons.mozilla.org/downloads/file/81860/xmarks-3.5.10-fx.xpi?src=api
raison : Paquet à installer non valide -207

J'ai pourtant installé sans problème cette extension sur un pc portable
(Gentoo linux) avec Firefox-3.6.

Avez-vous une idée sur le sujet ?

Merci d'avance



Bonsoir,

Je viens de l'installer sur Ubuntu Firefox 3.5.8 à partir de cette
adresse : http://download.xmarks.com/download , sans le moindre
problème... Un petit mélange entre entre version Windows et Linux
peut-être ?

A+
Maurice
Jacques
Le #21357591
Le 10/03/2010 19:32, Maurice a gentiment tapote:
jacques.montier a formulé ce mercredi :
Bonjour,

J'utilise Firefox-3.6 sous Gentoo Linux.
Je n'arrive plus à installer certaines extensions qui sont pourtant
compatibles firefox-3.6.
Par exemple : l'extension Xmarks.
J'ai droit au message :
Firefox n'a pas pu installer le fichier situé à
https://addons.mozilla.org/downloads/file/81860/xmarks-3.5.10-fx.xpi?src=api

raison : Paquet à installer non valide -207

J'ai pourtant installé sans problème cette extension sur un pc portable
(Gentoo linux) avec Firefox-3.6.

Avez-vous une idée sur le sujet ?

Merci d'avance



Bonsoir,

Je viens de l'installer sur Ubuntu Firefox 3.5.8 à partir de cette
adresse : http://download.xmarks.com/download , sans le moindre
problème... Un petit mélange entre entre version Windows et Linux
peut-être ?

A+
Maurice






Oui, j'ai aussi essayé ce lien sans succès et c'est très étrange.
Pour voir, j'ai bêtement copié le répertoire .mozilla de mon portable
sur lequel toutes les installations des extensions (dont Xmarks) se sont
déroulées normalement dans le répertoire utilisateur de mon pc de bureau.
Ça marche et les extensions (dont Xmarks) fonctionnent.
Un test ; j'ai retenté de ré-installer Xmarks sur ce pc et
..échec...Paquet à installer non valide !
Je ne comprends pas...

Merci en tout cas de ta réponse,

Jacques
yamo'
Le #21364211
Salut,

jacques.montier a tapoté le message
Bonjour,

J'utilise Firefox-3.6 sous Gentoo Linux.
Je n'arrive plus à installer certaines extensions qui sont pourtant
compatibles firefox-3.6.
Par exemple : l'extension Xmarks.
J'ai droit au message :
Firefox n'a pas pu installer le fichier situé à
https://addons.mozilla.org/downloads/file/81860/xmarks-3.5.10-fx.xpi?src=api
raison : Paquet à installer non valide -207




C'est étrange, j'ai regardé le fichier install.rdf il paraît correct
(un xpi est un simple zip) ; peut-être peux tu modifier ce fichier en remplaçant :

<RDF:Description RDF:about="rdf:#$cvwsF2"
em:id="{ec8030f7-c20a-464f-9b0e-13a3a9e97384}"
em:minVersion="3.0"
em:maxVersion="3.6.*" />

par :

<RDF:Description RDF:about="rdf:#$cvwsF2"
em:id="{ec8030f7-c20a-464f-9b0e-13a3a9e97384}"
em:minVersion="3.0"
em:maxVersion="3.6" />


Je n'ai pas firefox 3.6 sous la main, ma machine est
tellement lente que mon navigateur est Dillo 2.2!

--
Stéphane
Jacques
Le #21369711
Le 12/03/2010 10:26, yamo' a gentiment tapote:
Salut,

jacques.montier a tapoté le message
Bonjour,

J'utilise Firefox-3.6 sous Gentoo Linux.
Je n'arrive plus à installer certaines extensions qui sont pourtant
compatibles firefox-3.6.
Par exemple : l'extension Xmarks.
J'ai droit au message :
Firefox n'a pas pu installer le fichier situé à
https://addons.mozilla.org/downloads/file/81860/xmarks-3.5.10-fx.xpi?src=api
raison : Paquet à installer non valide -207




C'est étrange, j'ai regardé le fichier install.rdf il paraît correct
(un xpi est un simple zip) ; peut-être peux tu modifier ce fichier en remplaçant :

<RDF:Description RDF:about="rdf:#$cvwsF2"
em:id="{ec8030f7-c20a-464f-9b0e-13a3a9e97384}"
em:minVersion="3.0"
em:maxVersion="3.6.*" />

par :

<RDF:Description RDF:about="rdf:#$cvwsF2"
em:id="{ec8030f7-c20a-464f-9b0e-13a3a9e97384}"
em:minVersion="3.0"
em:maxVersion="3.6" />


Je n'ai pas firefox 3.6 sous la main, ma machine est
tellement lente que mon navigateur est Dillo 2.2!





Bonjour,

J'ai fait la modif, mais rien n'y fait, même message d'erreur.
Le plus étonnant est que l'installation sur un autre ordinateur
(portable) se fait sans souci...
Je me suis dit que cela venait d'un problème de config sur mon pc.
J'ai donc viré le .mozilla, désinstallé firefox, ré-installé le tout.
Mais toujours ce problème...
En copiant le .config du portable sur ce pc, l'addon fonctionne très
bien (synchronisation des marque-pages), mais il m'est interdit d'en
refaire une installation...

Merci en tout cas pour vos réponses.

--
Jacques
Maxime Guéry
Le #21523392
Je crois qu'il faut aller sur le site Français pour que ça
fonctionne ;)

https://addons.mozilla.org/fr/firefox/personas/
Alcovia
Le #21523642
Le 10/03/2010 17:08, jacques.montier a écrit :
Bonjour,

J'utilise Firefox-3.6 sous Gentoo Linux.
Je n'arrive plus à installer certaines extensions qui sont pourtant
compatibles firefox-3.6.
Par exemple : l'extension Xmarks.
J'ai droit au message :
Firefox n'a pas pu installer le fichier situé à
https://addons.mozilla.org/downloads/file/81860/xmarks-3.5.10-fx.xpi?src=api
raison : Paquet à installer non valide -207

J'ai pourtant installé sans problème cette extension sur un pc portable
(Gentoo linux) avec Firefox-3.6.

Avez-vous une idée sur le sujet ?



c'est peut-être le moment de passer à Weave ;-)
Publicité
Poster une réponse
Anonyme