Extraire la lettre sans le chiffre

Le
Bruno RCSC
Bonsoir,

Win XP, Excel 2002

Je voudrais connaitre la formule qui me permettrait d'extraire suivant les
conditions suivantes :
Je voudrais les deux premiers caractères de gauche de la cellule si ce sont
des lettres. Si il y a une lettre et un chiffre je ne veux que la lettre
Exemple :
NR19 1 je veux NR (Gauche(A1;2) convient parfaitement
B24 9 je veux B

Merci pour votre aide.

BH
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
tissot.emmanuel
Le #4397971
Bonjour,

En A1 la cellule contenant les donnees a extraire:

=SI(ESTNUM(CNUM(DROITE(GAUCHE(A1;2);1)));GAUCHE(GAUCHE(A1;2);1);GAUCHE(A1;2))

Un peu alambiqué mais semble fonctionner,

Cordialement,
Manu

"Bruno RCSC" 4616e065$0$27408$
Bonsoir,

Win XP, Excel 2002

Je voudrais connaitre la formule qui me permettrait d'extraire suivant les
conditions suivantes :
Je voudrais les deux premiers caractères de gauche de la cellule si ce
sont des lettres. Si il y a une lettre et un chiffre je ne veux que la
lettre
Exemple :
NR19 1 je veux NR (Gauche(A1;2) convient parfaitement
B24 9 je veux B

Merci pour votre aide.

BH



JB
Le #4397881
Bonjour,

=GAUCHE(A1;EQUIV(FAUX;ESTERREUR(STXT(A1;LIGNE(INDIRECT("1:"&NBCAR(A1)));
1)*1);0)-1)
Valider avec Maj+Ctrl+Entrée

JB
On 7 avr, 02:06, "Bruno RCSC"
Bonsoir,

Win XP, Excel 2002

Je voudrais connaitre la formule qui me permettrait d'extraire suivant les
conditions suivantes :
Je voudrais les deux premiers caractères de gauche de la cellule si ce sont
des lettres. Si il y a une lettre et un chiffre je ne veux que la lettre
Exemple :
NR19 1 je veux NR (Gauche(A1;2) convient parfaitement
B24 9 je veux B

Merci pour votre aide.

BH


Modeste
Le #4397791
Bonsour® Bruno RCSC avec ferveur ;o))) vous nous disiez :

suivantes :
Je voudrais les deux premiers caractères de gauche de la cellule si ce sont
des lettres. Si il y a une lettre et un chiffre je ne veux que la lettre
Exemple :
NR19 1 je veux NR (Gauche(A1;2) convient parfaitement
B24 9 je veux B


=SI(ESTNUM(--GAUCHE(A1;1));"";GAUCHE(A1;1))&SI(ESTNUM(--STXT(A1;2;1));"";STXT(A1;2;1))
4 cas possibles :
AB12345 AB
A1B2345 A
1AB2345 A
12AB2345


--
--
@+
;o)))

Bruno RCSC
Le #4397671
Merci à vous deux.
Les deux formules donnent le résultat attendu.

Bonne journée.

BH

--
Bonjour,

=GAUCHE(A1;EQUIV(FAUX;ESTERREUR(STXT(A1;LIGNE(INDIRECT("1:"&NBCAR(A1)));
1)*1);0)-1)
Valider avec Maj+Ctrl+Entrée

JB
On 7 avr, 02:06, "Bruno RCSC"
Bonsoir,

Win XP, Excel 2002

Je voudrais connaitre la formule qui me permettrait d'extraire suivant les
conditions suivantes :
Je voudrais les deux premiers caractères de gauche de la cellule si ce
sont
des lettres. Si il y a une lettre et un chiffre je ne veux que la lettre
Exemple :
NR19 1 je veux NR (Gauche(A1;2) convient parfaitement
B24 9 je veux B

Merci pour votre aide.

BH


Bruno RCSC
Le #4397651
Merci Modeste, cela fonctionne également parfaitement et cela me permet
d'anticiper d'éventuels autres cas.

BH

--
"Modeste"
Bonsour® Bruno RCSC avec ferveur ;o))) vous nous disiez :

suivantes :
Je voudrais les deux premiers caractères de gauche de la cellule si ce
sont
des lettres. Si il y a une lettre et un chiffre je ne veux que la lettre
Exemple :
NR19 1 je veux NR (Gauche(A1;2) convient parfaitement
B24 9 je veux B


=SI(ESTNUM(--GAUCHE(A1;1));"";GAUCHE(A1;1))&SI(ESTNUM(--STXT(A1;2;1));"";STXT(A1;2;1))
4 cas possibles :
AB12345 AB
A1B2345 A
1AB2345 A
12AB2345


--
--
@+
;o)))




Modeste
Le #4397591
Bonsour® Bruno RCSC avec ferveur ;o))) vous nous disiez :

Merci à vous deux.
Les deux formules donnent le résultat attendu.


heu ....????
Je voudrais les deux premiers caractères de gauche de la cellule si ce sont
des lettres. Si il y a une lettre et un chiffre je ne veux que la lettre
Exemple :
NR19 1 je veux NR (Gauche(A1;2) convient parfaitement
B24 9 je veux B



qu'affiche-t-on s'il y a un chiffre et une lettre ?

3 solutions dont une non concluante ;o)))
http://cjoint.com/?ehngIBzmME


--
--
@+
;o)))


Publicité
Poster une réponse
Anonyme