extration année et format

Le
jipeache
bonjour
j'ai mis ici un extrait de fichier excel 2003
http://cjoint.com/?0ldnReVCO5r
je n'arrive pas à extraire l'année sans avoir soit des 20250 ou je ne
sais plus que chiffre, soit des 1905.
J'ai (presque) tout essayé dans les formats de date, les formules
"droite", "texte", etcle format des cellules en colonne bje
rends mon tablier
Quelqu'un a-t-il une méthode qui fonctionne pour extraire l'année sur
4 chiffres, permettant ensuite de trier (je ne veux plus de la date
complète suite à modification du boulot). J'ai 4 colonnes à traiter d=
e
800 lignes environ.
Question subsidiaire : un site qui en parle "complètement" de ces
foutus formats de date ?
Merci
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
DanielCo
Le #22753901
Bonjour.
On fait quoi avec les cellules contenant deux dates ?
Cordialement.
Daniel


bonjour
j'ai mis ici un extrait de fichier excel 2003
http://cjoint.com/?0ldnReVCO5r
je n'arrive pas à extraire l'année sans avoir soit des 20250 ou je ne
sais plus que chiffre, soit des 1905.
J'ai (presque) tout essayé dans les formats de date, les formules
"droite", "texte", etc...le format des cellules en colonne b...je
rends mon tablier
Quelqu'un a-t-il une méthode qui fonctionne pour extraire l'année sur
4 chiffres, permettant ensuite de trier (je ne veux plus de la date
complète suite à modification du boulot). J'ai 4 colonnes à traiter de
800 lignes environ.
Question subsidiaire : un site qui en parle "complètement" de ces
foutus formats de date ?
Merci
DanielCo
Le #22754031
Sinon, pour les autres cellules :
en B3:
=SI(ESTNUM(A3);SI(NBCAR(A3)=4;A3;ANNEE(A3));"")
à recopier vers le bas.
Daniel


Bonjour.
On fait quoi avec les cellules contenant deux dates ?
Cordialement.
Daniel


bonjour
j'ai mis ici un extrait de fichier excel 2003
http://cjoint.com/?0ldnReVCO5r
je n'arrive pas à extraire l'année sans avoir soit des 20250 ou je ne
sais plus que chiffre, soit des 1905.
J'ai (presque) tout essayé dans les formats de date, les formules
"droite", "texte", etc...le format des cellules en colonne b...je
rends mon tablier
Quelqu'un a-t-il une méthode qui fonctionne pour extraire l'année sur
4 chiffres, permettant ensuite de trier (je ne veux plus de la date
complète suite à modification du boulot). J'ai 4 colonnes à traiter de
800 lignes environ.
Question subsidiaire : un site qui en parle "complètement" de ces
foutus formats de date ?
Merci
jipeache
Le #22754121
On 3 nov, 14:00, DanielCo
Bonjour.
On fait quoi avec les cellules contenant deux dates ?
Cordialement.
Daniel



Si possible la même chose, sinon seront traitées en "manuel"
(Des fois il y a 3 dates).
Merci
jipeache
Le #22754291
On 3 nov, 14:09, DanielCo
Sinon, pour les autres cellules :
en B3:
=SI(ESTNUM(A3);SI(NBCAR(A3)=4;A3;ANNEE(A3));"")
à recopier vers le bas.
Daniel



j'obtiens 1900 partout ?
DanielCo
Le #22754281
Regarde ton fichier mmodifié avec les formules en colonne B :
http://www.cijoint.fr/cjlink.php?file=cj201011/cijKw8fb6Y.xls
Daniel


On 3 nov, 14:09, DanielCo
Sinon, pour les autres cellules :
en B3:
=SI(ESTNUM(A3);SI(NBCAR(A3)=4;A3;ANNEE(A3));"")
à recopier vers le bas.
Daniel



j'obtiens 1900 partout ?
jipeache
Le #22754271
On 3 nov, 14:34, jipeache
On 3 nov, 14:09, DanielCo > en B3:
> =SI(ESTNUM(A3);SI(NBCAR(A3)=4;A3;ANNEE(A3));"")
> à recopier vers le bas.
> Daniel

j'obtiens 1900 partout ?



non, non, c'est bon, je me suis mélangé dans mes fichiers.
Merci beaucoup
Publicité
Poster une réponse
Anonyme