Faire la moyenne d'après le jour de la semaine

Le
PLG
Bonjour à tous

Voilà mon soucis et ma formule qui me donne. rien !!
=SOMME.SI(RecJ!$A$4:$A$255;JOURSEM(5);RecJ!$F$4:$F$255)/NB.SI(RecJ!$A$4:$A$255;">0")

En fait, je souhaite faire la moyenne des valeurs de la colonne F, d'après
les jours situés en colonne A.
Je souhaite la moyenne par lundi, mardi, mercredi, jeudi et vendredi.
Voici donc l'affaire.
Merci d'avance à celui ou celle qui me dépannera.
Pat
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Caetera
Le #19109621
> En fait, je souhaite faire la moyenne des valeurs de la colonne F, d'après
les jours situés en colonne A.
Je souhaite la moyenne par lundi, mardi, mercredi, jeudi et vendredi.



Pour les lundis (adapter pour les autres jours)
Matricielle
=MOYENNE(SI(JOURSEM(RecJ!$A$4:$A$255)=2;RecJ!$F$4:$F$255))

Etc
Sam
Le #19109501
Bonjour, j'ai fait ça sur un espace plus restreint
=SOMMEPROD(((JOURSEM($A$5:$A$16;1)=2)*($F$5:$F$16)))/SOMMEPROD((JOURSEM($A$5:$A$16;1)=2)*1)
tu pourrais t'en inspirer
Cordialement
Michel dit "Sam"
"PLG"
Bonjour à tous

Voilà mon soucis et ma formule qui me donne.... rien !!
=SOMME.SI(RecJ!$A$4:$A$255;JOURSEM(5);RecJ!$F$4:$F$255)/NB.SI(RecJ!$A$4:$A$255;">0")

En fait, je souhaite faire la moyenne des valeurs de la colonne F, d'après
les jours situés en colonne A.
Je souhaite la moyenne par lundi, mardi, mercredi, jeudi et vendredi.
Voici donc l'affaire....
Merci d'avance à celui ou celle qui me dépannera.
Pat


PLG
Le #19110031
Merci beaucoup à tous les deux et bonne soirée.
Pat

"PLG" a écrit :

Bonjour à tous

Voilà mon soucis et ma formule qui me donne.... rien !!
=SOMME.SI(RecJ!$A$4:$A$255;JOURSEM(5);RecJ!$F$4:$F$255)/NB.SI(RecJ!$A$4:$A$255;">0")

En fait, je souhaite faire la moyenne des valeurs de la colonne F, d'après
les jours situés en colonne A.
Je souhaite la moyenne par lundi, mardi, mercredi, jeudi et vendredi.
Voici donc l'affaire....
Merci d'avance à celui ou celle qui me dépannera.
Pat


PLG
Le #19110381
Bonsoir Caetera

En fait ta formule est fort bonne, mais tu n'as pas tenu compte des cellules
vides ou = 0.
Ce qui fait que quelque soit l'époque à laquelle on se trouve elle divise
par 50 ( en gros)

C'est pour cela que je divisais par nb.si() dans ma formule à la noix.


"Caetera" a écrit :

> En fait, je souhaite faire la moyenne des valeurs de la colonne F, d'après
> les jours situés en colonne A.
> Je souhaite la moyenne par lundi, mardi, mercredi, jeudi et vendredi.

Pour les lundis (adapter pour les autres jours)
Matricielle
=MOYENNE(SI(JOURSEM(RecJ!$A$4:$A$255)=2;RecJ!$F$4:$F$255))

Etc





PLG
Le #19110361
Bonsoir Sam
Désolé pas mieux que Caetera....
Dans ma formule ( qui ne sert à rien ), je divisais le résultat d'une somme
par un nb.si() avec comme condition ">0" ( ce qui, je viens de m'en
apercevoir, est débile de toutes façons vu que c'est le nbre total de jours >
à 0...! )
J'ai des données à 0, car formules à l'intèrieur.
Tous les jours après le 13 avril 2009 sont à 0.
Bon...???
merci tout de même

"Sam" a écrit :


Bonjour, j'ai fait ça sur un espace plus restreint
=SOMMEPROD(((JOURSEM($A$5:$A$16;1)=2)*($F$5:$F$16)))/SOMMEPROD((JOURSEM($A$5:$A$16;1)=2)*1)
tu pourrais t'en inspirer
Cordialement
Michel dit "Sam"
"PLG"
> Bonjour à tous
>
> Voilà mon soucis et ma formule qui me donne.... rien !!
> =SOMME.SI(RecJ!$A$4:$A$255;JOURSEM(5);RecJ!$F$4:$F$255)/NB.SI(RecJ!$A$4:$A$255;">0")
>
> En fait, je souhaite faire la moyenne des valeurs de la colonne F, d'après
> les jours situés en colonne A.
> Je souhaite la moyenne par lundi, mardi, mercredi, jeudi et vendredi.
> Voici donc l'affaire....
> Merci d'avance à celui ou celle qui me dépannera.
> Pat





Caetera
Le #19111151
> En fait ta formule est fort bonne, mais tu n'as pas tenu compte des cellules
vides ou = 0.



Est-ce que tu n'inverserais pas les roles ?
Ne serait-ce pas toi qui aurais oublié de préciser le contenu et la disposition
de tes valeurs ?

http://www.cijoint.fr/cjlink.php?file=cj200904/cij5H5n6zK.xls

Etc
PLG
Le #19120861
Bonjour Caetera

En fait j'avais pas vu que tu m'avais répondu... j'attendais les réponses en
dessous de mes dernières....
Tu disais donc, que j'inverserais les rôles....!?
Ben, vu ma question, telle qu'elle est posée.... t'aurais pas tort !!!!!
Toutes mes excuses... En fait comme je divisais par NB.VAL(trucmuche) et que
ça servait à rien d'ailleurs.... je pensais que la science infuse des St
Bernard du site ferait le reste... (O:}. Non je plaisante...!
Toujours est-il, merci de m'avaoir répondu malgré mon outrecuidance et mon
impertinence...
En plus cela me convient parfaitement !!!

Allez à++
Pat


"Caetera" a écrit :

> En fait ta formule est fort bonne, mais tu n'as pas tenu compte des cellules
> vides ou = 0.

Est-ce que tu n'inverserais pas les roles ?
Ne serait-ce pas toi qui aurais oublié de préciser le contenu et la disposition
de tes valeurs ?

http://www.cijoint.fr/cjlink.php?file=cj200904/cij5H5n6zK.xls

Etc





Publicité
Poster une réponse
Anonyme