Faire reference aux differentes feuilles d'un classeur ??

Le
Philibert13
Bonjour,

J'ai créé un classeur pour gérer ma comptabilité.

Douze feuilles, une par mois, dans chaque feuille je comptabilise les
dépenses du mois par rubrique et je fais aussi le cumul de l'année.

J'utilise donc la formule suivante =K3+SOMME(Fevrier!K3) pour additionner la
cellule du mois et celle du mois précédent.

Comment faire pour remplacer automatiquement le nom du mois dans chaque
cellule de chaque feuille, est-ce possible? ou dois-je corriger manuellement
toutes les cellules concernées de chaque feuille?

Merci pour vos conseils !!

J'utilise Excel 2007

Philibert
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
JB
Le #5283361
Bonjour,

http://cjoint.com/?cfnCy8VqBR

=INDIRECT(TEXTE(DATEVAL("01/"&STXT(CELLULE("filename";A1);TROUVE("]";CELLU LE("filename";A1))
+1;99))-1;"mmmm")&"!c"&LIGNE())+A5

http://boisgontierjacques.free.fr/fichiers/jb-formulesonglets.zip

JB
http://boisgontierjacques.free.fr

On 5 fév, 13:19, "Philibert13"
Bonjour,

J'ai créé un classeur pour gérer ma comptabilité.

Douze feuilles, une par mois, dans chaque feuille je comptabilise les
dépenses du mois par rubrique et je fais aussi le cumul de l'année.

J'utilise donc la formule suivante =K3+SOMME(Fevrier!K3) pour additionne r la
cellule du mois et celle du mois précédent.

Comment faire pour remplacer automatiquement le nom du mois dans chaque
cellule de chaque feuille, est-ce possible? ou dois-je corriger manuelleme nt
toutes les cellules concernées de chaque feuille?

Merci pour vos conseils !!

J'utilise Excel 2007

Philibert


Philibert13
Le #5283301
Salut

Merci pour ton aide et tes fichiers.

Un peu compliqué pour moi mais j'ai compris celui-ci
"=INDIRECT(B6&"!k4")+K3"

Dans la cellule B6, je mets le nom du mois précédent, K4 est la cellule
cumul du mois et K3 la cellule du mois en cours !!

et ça fonctionne

merci encore

Philibert
Philibert13
Le #5283201
Re bonjour,

"Philibert13" discussion : 47a86336$0$6843$
Salut

Merci pour ton aide et tes fichiers.

Un peu compliqué pour moi mais j'ai compris celui-ci
"=INDIRECT(B6&"!k4")+K3"

Dans la cellule B6, je mets le nom du mois précédent, K4 est la cellule
cumul du mois et K3 la cellule du mois en cours !!

et ça fonctionne

merci encore

Philibert



Maintenant pour parfaire l'automatisation, comment faire pour que la cellule
A1 (qui contient "Janvier") de la feuille Janvier devienne Fevrier dans la
cellule A1 de la feuille Fevrier ??

Merci

Philibert

JB
Le #5283081
Donne le mois précédent:

=TEXTE(DATEVAL("01/"&STXT(CELLULE("filename";A1);TROUVE("]";CELLULE("filen ame";A1))
+1;99))-1;"mmmm")

http://cjoint.com/?cfq5RV4ziU

JB



On 5 fév, 15:05, "Philibert13"
Re bonjour,

"Philibert13" discussion : 47a86336$0$6843$

Salut

Merci pour ton aide et tes fichiers.

Un peu compliqué pour moi mais j'ai compris celui-ci
"=INDIRECT(B6&"!k4")+K3"

Dans la cellule B6, je mets le nom du mois précédent, K4 est la cell ule
cumul du mois et K3 la cellule du mois en cours !!

et ça fonctionne

merci encore

Philibert


Maintenant pour parfaire l'automatisation, comment faire pour que la cellu le
A1 (qui contient "Janvier") de la feuille Janvier devienne Fevrier dans la
cellule A1 de la  feuille Fevrier  ??

Merci

Philibert



Philibert13
Le #5282981
Salut


"JB" discussion :

Donne le mois précédent:

=TEXTE(DATEVAL("01/"&STXT(CELLULE("filename";A1);TROUVE("]";CELLULE("filename";A1))
+1;99))-1;"mmmm")

http://cjoint.com/?cfq5RV4ziU

JB






Grand merci, c'est OK, ça fonctionne, je vais essayer de comprendre cette
formule !

Philibert

JB
Le #5282951
=STXT(CELLULE("filename";A1);TROUVE("]";CELLULE("filename";A1))+1;99)
donne le nom de l'onglet

=TEXTE(DATEVAL("01/" & xxxxx)-1;"mmmm") donne le mois précédent.

JB


On 5 fév, 18:43, "Philibert13"
Salut

"JB" discussion :


Donne le mois précédent:

=TEXTE(DATEVAL("01/"&STXT(CELLULE("filename";A1);TROUVE("]";CELLULE("f ilena­me";A1))
+1;99))-1;"mmmm")

http://cjoint.com/?cfq5RV4ziU

JB


Grand merci, c'est OK, ça fonctionne, je vais essayer de comprendre cett e
formule !

Philibert



Publicité
Poster une réponse
Anonyme