faire la somme d'une colonne en fonction des valeurs d'autres colo

Le
BARBARA-CABA
je veux faire le total d'une colonne X si la valeur de la colonne A est "C"
et la valeur de la conne B est "F" par exemple.
Pour cela, j'utilise la formule matricielle

{=somme(((A1:A100="C")*(B1:B100="D")*(X1:X100))}

cela fonctionne bien

Je voudrais maintenant que le critère de sélection de la colonne A puisse
être "toutes valeurs".
que dois-je mettre dans ma formule à la place de "C" ? existe-t-il un
caractère du type * ou # ?

merci de votre aide
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Modeste
Le #5377281
Bonsour® BARBARA-CABA avec ferveur ;o))) vous nous disiez :

je veux faire le total d'une colonne X si la valeur de la colonne A
est "C" et la valeur de la conne B est "F" par exemple.
{=somme(((A1:A100="C")*(B1:B100="D")*(X1:X100))}
cela fonctionne bien

Je voudrais maintenant que le critère de sélection de la colonne A
puisse être "toutes valeurs".


Heu ... ???
supprimer la reference à la colonne A ... Non ?
{=somme(((B1:B100="D")*(X1:X100))}




--
--
@+
;o)))

BARBARA-CABA
Le #5377161
oui bien sur, mais là, je laisse le choix à l'utilisateur de choisir les
critères qu'il souhaite. Il doit pouvoir sélectionner "TOUS" ou un critère
spécifique.
Sachant qu'il a le choix entre 5 critères, je ne veux pas faire autant de
formules que de combinaisons possibles.

je sais que cela est possible dans ACCES donc pourquoi pas dans EXCELL



Bonsour® BARBARA-CABA avec ferveur ;o))) vous nous disiez :

je veux faire le total d'une colonne X si la valeur de la colonne A
est "C" et la valeur de la conne B est "F" par exemple.
{=somme(((A1:A100="C")*(B1:B100="D")*(X1:X100))}
cela fonctionne bien

Je voudrais maintenant que le critère de sélection de la colonne A
puisse être "toutes valeurs".


Heu ... ???
supprimer la reference à la colonne A ... Non ?
{=somme(((B1:B100="D")*(X1:X100))}




--
--
@+
;o)))






Tatanka
Le #5377111
Bonjour,

Pour donner le choix d'un seul critère parmi 5,
tu pourrais par exemple, sélectionner Y1 et :
Données / Validation...
Autoriser : Liste
Source : A;B;C;D;E
et utiliser la formule :
=SOMME(((A1:A5=Y1)*(B1:B5="D")*(X1:X5)))
Quant au reste, je ne sais pas :-(

Serge


"BARBARA-CABA"
oui bien sur, mais là, je laisse le choix à l'utilisateur de choisir les
critères qu'il souhaite. Il doit pouvoir sélectionner "TOUS" ou un critère
spécifique.
Sachant qu'il a le choix entre 5 critères, je ne veux pas faire autant de
formules que de combinaisons possibles.

je sais que cela est possible dans ACCES donc pourquoi pas dans EXCELL



Bonsour® BARBARA-CABA avec ferveur ;o))) vous nous disiez :

je veux faire le total d'une colonne X si la valeur de la colonne A
est "C" et la valeur de la conne B est "F" par exemple.
{=somme(((A1:A100="C")*(B1:B100="D")*(X1:X100))}
cela fonctionne bien

Je voudrais maintenant que le critère de sélection de la colonne A
puisse être "toutes valeurs".


Heu ... ???
supprimer la reference à la colonne A ... Non ?
{=somme(((B1:B100="D")*(X1:X100))}




--
--
@+
;o)))








Tatanka
Le #5377091
Bonjour Barbara,

En Y2 :
Liste de validation pour les critères de la colonne A :
A;B;C;D;E;T

En Z2 :
Liste de validation pour les critères de la colonne B :
A;B;C;D;E

et la formule :
=SI(Y2="T";SOMME((B1:B5=Z2)*(X1:X5));SOMME((A1:A5=Y2)*(B1:B5=Z2)*(X1:X5)))
( à valider par Ctrl+MAj+Entrée )

Est-ce mieux ainsi ?

Serge

"Tatanka"
Bonjour,

Pour donner le choix d'un seul critère parmi 5,
tu pourrais par exemple, sélectionner Y1 et :
Données / Validation...
Autoriser : Liste
Source : A;B;C;D;E
et utiliser la formule :
=SOMME(((A1:A5=Y1)*(B1:B5="D")*(X1:X5)))
Quant au reste, je ne sais pas :-(

Serge


"BARBARA-CABA"
oui bien sur, mais là, je laisse le choix à l'utilisateur de choisir les
critères qu'il souhaite. Il doit pouvoir sélectionner "TOUS" ou un critère
spécifique.
Sachant qu'il a le choix entre 5 critères, je ne veux pas faire autant de
formules que de combinaisons possibles.

je sais que cela est possible dans ACCES donc pourquoi pas dans EXCELL



Bonsour® BARBARA-CABA avec ferveur ;o))) vous nous disiez :

je veux faire le total d'une colonne X si la valeur de la colonne A
est "C" et la valeur de la conne B est "F" par exemple.
{=somme(((A1:A100="C")*(B1:B100="D")*(X1:X100))}
cela fonctionne bien

Je voudrais maintenant que le critère de sélection de la colonne A
puisse être "toutes valeurs".


Heu ... ???
supprimer la reference à la colonne A ... Non ?
{=somme(((B1:B100="D")*(X1:X100))}




--
--
@+
;o)))












Modeste
Le #5377031
Bonsour® Tatanka avec ferveur ;o))) vous nous disiez :

et la formule :
=SI(Y2="T";SOMME((B1:B5=Z2)*(X1:X5));SOMME((A1:A5=Y2)*(B1:B5=Z2)*(X1:X5)))
( à valider par Ctrl+MAj+Entrée )


;o)))
je l'avais envisagé dans ce sens
=SI(CritA<>"";SOMME((A1:A100=CritA)*(B1:B100=CritB)*(X1:X100));SOMME((B1:B100=CritB)*(X1:X100)))
( à valider par Ctrl+MAj+Entrée )

mais :
.... Je voudrais maintenant AUSSI que le critère de sélection de la colonne
.... B puisse être "toutes valeurs".

;o))))
.... Je voudrais maintenant AUSSI ajouter une colonne C et que le critère de
sélection de la colonne
.... C puisse AUSSI être "toutes valeurs".
etc ...
etc ...

--
--
@+
;o)))

Tatanka
Le #5376981
T pour toutes valeurs.
Liste de validation en Y2 ( pour la colonne A ) : A;B;C;D;E;T
Liste de validation en Z2 ( pour la colonne B ) : A;B;C;D;E;T
Formule :
=SI(ET(Y2="T";Z2="T");SOMME(X1:X5);SI(ET(Y2="T";Z2<>"T");
SOMME((B1:B5=Z2)*(X1:X5));SI(ET(Y2<>"T";Z2="T");
SOMME((A1:A5=Y2)*(X1:X5));SOMME((A1:A5=Y2)*(B1:B5=Z2)*(X1:X5)))))

Serge


"Modeste"
Bonsour® Tatanka avec ferveur ;o))) vous nous disiez :

et la formule :
=SI(Y2="T";SOMME((B1:B5=Z2)*(X1:X5));SOMME((A1:A5=Y2)*(B1:B5=Z2)*(X1:X5)))
( à valider par Ctrl+MAj+Entrée )


;o)))
je l'avais envisagé dans ce sens
=SI(CritA<>"";SOMME((A1:A100=CritA)*(B1:B100=CritB)*(X1:X100));SOMME((B1:B100=CritB)*(X1:X100)))
( à valider par Ctrl+MAj+Entrée )

mais :
.... Je voudrais maintenant AUSSI que le critère de sélection de la colonne
.... B puisse être "toutes valeurs".

;o))))
.... Je voudrais maintenant AUSSI ajouter une colonne C et que le critère de sélection de la colonne
.... C puisse AUSSI être "toutes valeurs".
etc ...
etc ...

--
--
@+
;o)))




BARBARA-CABA
Le #5109341
J'essaye cela et vous tiens au courant

Merci




T pour toutes valeurs.
Liste de validation en Y2 ( pour la colonne A ) : A;B;C;D;E;T
Liste de validation en Z2 ( pour la colonne B ) : A;B;C;D;E;T
Formule :
=SI(ET(Y2="T";Z2="T");SOMME(X1:X5);SI(ET(Y2="T";Z2<>"T");
SOMME((B1:B5=Z2)*(X1:X5));SI(ET(Y2<>"T";Z2="T");
SOMME((A1:A5=Y2)*(X1:X5));SOMME((A1:A5=Y2)*(B1:B5=Z2)*(X1:X5)))))

Serge


"Modeste"
Bonsour® Tatanka avec ferveur ;o))) vous nous disiez :

et la formule :
=SI(Y2="T";SOMME((B1:B5=Z2)*(X1:X5));SOMME((A1:A5=Y2)*(B1:B5=Z2)*(X1:X5)))
( à valider par Ctrl+MAj+Entrée )


;o)))
je l'avais envisagé dans ce sens
=SI(CritA<>"";SOMME((A1:A100=CritA)*(B1:B100=CritB)*(X1:X100));SOMME((B1:B100=CritB)*(X1:X100)))
( à valider par Ctrl+MAj+Entrée )

mais :
.... Je voudrais maintenant AUSSI que le critère de sélection de la colonne
.... B puisse être "toutes valeurs".

;o))))
.... Je voudrais maintenant AUSSI ajouter une colonne C et que le critère de sélection de la colonne
.... C puisse AUSSI être "toutes valeurs".
etc ...
etc ...

--
--
@+
;o)))









Publicité
Poster une réponse
Anonyme