Férié WE hors T

Le
Manu
Bonjour,

Malgrés deja toute l'aide apporter par diverses personnes dont Daniel,
Misange, Sam, je ne m'en sort pas encore totalement.

J'espere y parvenir à condition de réussir cette formule avec laquelle je
galere et que je vous détail sur le cijoint (ce sera + clair). Merci pour
toutes aides, j'en ai besoin.
http://www.cijoint.fr/cjlink.php?file=cj201004/cijmesyLSw.xls
Merci

Manu
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 5
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Daniel.C
Le #21579591
Bonjour.
Pourquoi tu ne comptes pas le 17/01 ?
Daniel

Bonjour,

Malgrés deja toute l'aide apporter par diverses personnes dont Daniel,
Misange, Sam..., je ne m'en sort pas encore totalement.

J'espere y parvenir à condition de réussir cette formule avec laquelle je
galere et que je vous détail sur le cijoint (ce sera + clair). Merci pour
toutes aides, j'en ai besoin.
http://www.cijoint.fr/cjlink.php?file=cj201004/cijmesyLSw.xls
Merci

Manu
Misange
Le #21580171
Bonjour Manu

ce qui n'est pas clair pour moi c'est ce que tu cherches
ta formulation
"il n'y a que 2 cellules pleines dans mes criteres de dates qui ne sont
pas un T et dont le jour ferié tombe un samedi ou dimanche" n'est pas
limpide pour moi...

d'après ton tableau :

en janvier, tu as 1 jour férié : le 1° (pourquoi le 15 janvier est en
jaune ? c'est un jour férié ?)
tu as 8 jours tombant un samedi ou un dimanche

je reprends ta formulation :

il y a en tout 16 cellules non vides
2 sont des T
les 2 T tombent un samedi ou un dimanche
aucun T ne tombe un jour férié

donc "et dont le jour férié tombe un samedi ou un dimanche = 0 quel que
soit le contenu de la cellule. Déjà là je coince.
Je ne vois pas du tout comment tu trouves 2 !

J'ai beau prendre toutes les combinaisins possibles je n'arrive pas à 2
sauf si je cherche exactement l'inverse de ce que tu dis : il y a 2
jours T tombant un week end dans tes dates. Bref si tu ne t'y retrouves
déjà pas dans ce que tu cherches, on ne risque pas de trouver la formule :-)


Misange migrateuse
http://www.excelabo.net


Manu a écrit :
Bonjour,

Malgrés deja toute l'aide apporter par diverses personnes dont Daniel,
Misange, Sam..., je ne m'en sort pas encore totalement.

J'espere y parvenir à condition de réussir cette formule avec laquelle je
galere et que je vous détail sur le cijoint (ce sera + clair). Merci pour
toutes aides, j'en ai besoin.
http://www.cijoint.fr/cjlink.php?file=cj201004/cijmesyLSw.xls
Merci

Manu


Manu
Le #21580161
Désolé pour le retard,

Parce qu'il n'est pas dans la liste des jours fériés.

Manu

"Daniel.C" %
Bonjour.
Pourquoi tu ne comptes pas le 17/01 ?
Daniel

Bonjour,

Malgrés deja toute l'aide apporter par diverses personnes dont Daniel,
Misange, Sam..., je ne m'en sort pas encore totalement.

J'espere y parvenir à condition de réussir cette formule avec laquelle je
galere et que je vous détail sur le cijoint (ce sera + clair). Merci pour
toutes aides, j'en ai besoin.
http://www.cijoint.fr/cjlink.php?file=cj201004/cijmesyLSw.xls
Merci

Manu




Manu
Le #21580211
Bonjour Misange, les jours fériés sont ceux ci dessous, (c'est bien sur un
exemple) il est vrai que je les ais coloré en jaune mais que j'ai oublié de
mettre en jaune egalement les 25 et 30


01/01/2010
02/01/2010
10/01/2010
15/01/2010
23/01/2010
25/01/2010
30/01/2010


Mon resultat de 2 ce justifie ainsi : Si je regarde bien mon tableau, seul
les 10 et 23 janvier font partis de mes jours fériés mais ils tombent
egalement sur samedi / dimanche

Comme me damandais Daniel avant, le 17 ne peut etre compter car il ne fait
pas partis de mes jours fériés

Je ne peux pas non plus compter le 02 car malgres que ce soit un jour qui
fait partis de mes férié et qui tombe un samedi, il y a T dans la cellule
et donc ne peut etre comptabilisé.

Suis je plus clair ?
Merci

Manu


"Misange"
Bonjour Manu

ce qui n'est pas clair pour moi c'est ce que tu cherches
ta formulation
"il n'y a que 2 cellules pleines dans mes criteres de dates qui ne sont
pas un T et dont le jour ferié tombe un samedi ou dimanche" n'est pas
limpide pour moi...

d'après ton tableau :

en janvier, tu as 1 jour férié : le 1° (pourquoi le 15 janvier est en
jaune ? c'est un jour férié ?)
tu as 8 jours tombant un samedi ou un dimanche

je reprends ta formulation :

il y a en tout 16 cellules non vides
2 sont des T
les 2 T tombent un samedi ou un dimanche
aucun T ne tombe un jour férié

donc "et dont le jour férié tombe un samedi ou un dimanche = 0 quel que
soit le contenu de la cellule. Déjà là je coince.
Je ne vois pas du tout comment tu trouves 2 !

J'ai beau prendre toutes les combinaisins possibles je n'arrive pas à 2
sauf si je cherche exactement l'inverse de ce que tu dis : il y a 2 jours
T tombant un week end dans tes dates. Bref si tu ne t'y retrouves déjà pas
dans ce que tu cherches, on ne risque pas de trouver la formule :-)


Misange migrateuse
http://www.excelabo.net


Manu a écrit :
Bonjour,

Malgrés deja toute l'aide apporter par diverses personnes dont Daniel,
Misange, Sam..., je ne m'en sort pas encore totalement.

J'espere y parvenir à condition de réussir cette formule avec laquelle je
galere et que je vous détail sur le cijoint (ce sera + clair). Merci pour
toutes aides, j'en ai besoin.
http://www.cijoint.fr/cjlink.php?file=cj201004/cijmesyLSw.xls
Merci

Manu
michdenis
Le #21580301
Bonjour,

En supposant que j'ai compris ton problème, la formule
serait :

Validation matricielle : Ctrl + Maj + Enter
=SOMME(SI(ESTNUM(EQUIV(A2:A25;G2:G8;0))*(JOURSEM(A2:A25;2)>5)*(B2:B25<>"T");1))



"Manu" #
Bonjour,

Malgrés deja toute l'aide apporter par diverses personnes dont Daniel,
Misange, Sam..., je ne m'en sort pas encore totalement.

J'espere y parvenir à condition de réussir cette formule avec laquelle je
galere et que je vous détail sur le cijoint (ce sera + clair). Merci pour
toutes aides, j'en ai besoin.
http://www.cijoint.fr/cjlink.php?file=cj201004/cijmesyLSw.xls
Merci

Manu
Manu
Le #21580361
Bonjour Michdenis,

Ca ne fonctionne pas, car meme si je supprime tout ce qui est colonne B, la
formule trouve toujours 3

Le but etant de compter les cellules pleine de la col B hormis si c'est un T
et qui soit un jour férié et qui tombe un samedi / dimanche entre le critere
de date stipulé en E11:E12 (ces dates seront bien sur variable).

Manu


"michdenis"
Bonjour,

En supposant que j'ai compris ton problème, la formule
serait :

Validation matricielle : Ctrl + Maj + Enter
=SOMME(SI(ESTNUM(EQUIV(A2:A25;G2:G8;0))*(JOURSEM(A2:A25;2)>5)*(B2:B25<>"T");1))



"Manu" discussion :
#
Bonjour,

Malgrés deja toute l'aide apporter par diverses personnes dont Daniel,
Misange, Sam..., je ne m'en sort pas encore totalement.

J'espere y parvenir à condition de réussir cette formule avec laquelle je
galere et que je vous détail sur le cijoint (ce sera + clair). Merci pour
toutes aides, j'en ai besoin.
http://www.cijoint.fr/cjlink.php?file=cj201004/cijmesyLSw.xls
Merci

Manu

Manu
Le #21580351
J'en suis ave vos aides à ca, mais ca ne fonctionne toujours pas :
=SOMMEPROD((B2:B367<>"")*(B2:B367>=$E$11)*(B2:B367>=$E$12)*SOMME(SI(ESTNUM(EQUIV(A2:A367;G2:G8;0))*(JOURSEM(A2:A367;2)>5)*(B2:B367<>"T");1)))
en matricielle

Manu

"Manu"
Bonjour Michdenis,

Ca ne fonctionne pas, car meme si je supprime tout ce qui est colonne B,
la formule trouve toujours 3

Le but etant de compter les cellules pleine de la col B hormis si c'est un
T et qui soit un jour férié et qui tombe un samedi / dimanche entre le
critere de date stipulé en E11:E12 (ces dates seront bien sur variable).

Manu


"michdenis"
Bonjour,

En supposant que j'ai compris ton problème, la formule
serait :

Validation matricielle : Ctrl + Maj + Enter
=SOMME(SI(ESTNUM(EQUIV(A2:A25;G2:G8;0))*(JOURSEM(A2:A25;2)>5)*(B2:B25<>"T");1))



"Manu" discussion :
#
Bonjour,

Malgrés deja toute l'aide apporter par diverses personnes dont Daniel,
Misange, Sam..., je ne m'en sort pas encore totalement.

J'espere y parvenir à condition de réussir cette formule avec laquelle je
galere et que je vous détail sur le cijoint (ce sera + clair). Merci pour
toutes aides, j'en ai besoin.
http://www.cijoint.fr/cjlink.php?file=cj201004/cijmesyLSw.xls
Merci

Manu





Manu
Le #21580341
Oups,

il fallait lire :
=SOMMEPROD((B2:B367<>"")*(A2:A367>=$E$11)*(A2:A367>=$E$12)*SOMME(SI(ESTNUM(EQUIV(A2:A367;G2:G8;0))*(JOURSEM(A2:A367;2)>5)*(B2:B367<>"T");1)))

"Manu"
Bonjour Michdenis,

Ca ne fonctionne pas, car meme si je supprime tout ce qui est colonne B,
la formule trouve toujours 3

Le but etant de compter les cellules pleine de la col B hormis si c'est un
T et qui soit un jour férié et qui tombe un samedi / dimanche entre le
critere de date stipulé en E11:E12 (ces dates seront bien sur variable).

Manu


"michdenis"
Bonjour,

En supposant que j'ai compris ton problème, la formule
serait :

Validation matricielle : Ctrl + Maj + Enter
=SOMME(SI(ESTNUM(EQUIV(A2:A25;G2:G8;0))*(JOURSEM(A2:A25;2)>5)*(B2:B25<>"T");1))



"Manu" discussion :
#
Bonjour,

Malgrés deja toute l'aide apporter par diverses personnes dont Daniel,
Misange, Sam..., je ne m'en sort pas encore totalement.

J'espere y parvenir à condition de réussir cette formule avec laquelle je
galere et que je vous détail sur le cijoint (ce sera + clair). Merci pour
toutes aides, j'en ai besoin.
http://www.cijoint.fr/cjlink.php?file=cj201004/cijmesyLSw.xls
Merci

Manu





Manu
Le #21580431
Encore oups :
=SOMMEPROD((B2:B367<>"")*(A2:A367>=$E$11)*(A2:A367<=$E$12)*SOMME(SI(ESTNUM(EQUIV(A2:A367;G2:G8;0))*(JOURSEM(A2:A367;2)>5)*(B2:B367<>"T");1)))
Mais ca ne fonctionne tjrs pas...

"Manu"
Bonjour Michdenis,

Ca ne fonctionne pas, car meme si je supprime tout ce qui est colonne B,
la formule trouve toujours 3

Le but etant de compter les cellules pleine de la col B hormis si c'est un
T et qui soit un jour férié et qui tombe un samedi / dimanche entre le
critere de date stipulé en E11:E12 (ces dates seront bien sur variable).

Manu


"michdenis"
Bonjour,

En supposant que j'ai compris ton problème, la formule
serait :

Validation matricielle : Ctrl + Maj + Enter
=SOMME(SI(ESTNUM(EQUIV(A2:A25;G2:G8;0))*(JOURSEM(A2:A25;2)>5)*(B2:B25<>"T");1))



"Manu" discussion :
#
Bonjour,

Malgrés deja toute l'aide apporter par diverses personnes dont Daniel,
Misange, Sam..., je ne m'en sort pas encore totalement.

J'espere y parvenir à condition de réussir cette formule avec laquelle je
galere et que je vous détail sur le cijoint (ce sera + clair). Merci pour
toutes aides, j'en ai besoin.
http://www.cijoint.fr/cjlink.php?file=cj201004/cijmesyLSw.xls
Merci

Manu





michdenis
Le #21580421
Essaie cette formule et on en parle plus ;-))

=SI(NBCAR($B$2:$B$25)>0;SOMME(SI(ESTNUM(EQUIV($A$2:$A$25;$G$2:$G$8;0))*(JOURSEM($A$2:$A$25;2)>5)*($B$2:$B$25<>"T");1));0)



"Manu"
Bonjour Michdenis,

Ca ne fonctionne pas, car meme si je supprime tout ce qui est colonne B, la
formule trouve toujours 3

Le but etant de compter les cellules pleine de la col B hormis si c'est un T
et qui soit un jour férié et qui tombe un samedi / dimanche entre le critere
de date stipulé en E11:E12 (ces dates seront bien sur variable).

Manu


"michdenis"
Bonjour,

En supposant que j'ai compris ton problème, la formule
serait :

Validation matricielle : Ctrl + Maj + Enter
=SOMME(SI(ESTNUM(EQUIV(A2:A25;G2:G8;0))*(JOURSEM(A2:A25;2)>5)*(B2:B25<>"T");1))



"Manu" discussion :
#
Bonjour,

Malgrés deja toute l'aide apporter par diverses personnes dont Daniel,
Misange, Sam..., je ne m'en sort pas encore totalement.

J'espere y parvenir à condition de réussir cette formule avec laquelle je
galere et que je vous détail sur le cijoint (ce sera + clair). Merci pour
toutes aides, j'en ai besoin.
http://www.cijoint.fr/cjlink.php?file=cj201004/cijmesyLSw.xls
Merci

Manu

Publicité
Poster une réponse
Anonyme