fetchmail : connection refused

Le
m3t4linux
Bonsoir à tous!!

La consultation de /var/log/mail.err comporte les messages suivants :

"fetchmail[1709]: connection to localhost:smtp [::1/25] failed: Connection refused"

J'ai un compte gmail et voici ma config' "email" :
MTA/exim4 , MDA/procmail, MRA/fetchmail, MUA/mutt

J'envois et reçois correctement les emails mais je ne comprends pas ce
message d'avertissement.

J'ai configurer exim avec #dpkg-reconfigure exim4-config en optant pour
"Envois via relais ("smarthost") - réception SMTP ou fetchmail"

Mes faibles connaissances à ce sujet m'empêche de trouver une
solution

Merci pour vos aides éventuelles ;-)
--
m3t4linux

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Archive: http://lists.debian.org/20100806205136.GA11529@gmail.com
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Pascal Hambourg
Le #22450131
Salut,

m3t4linux a écrit :

La consultation de /var/log/mail.err comporte les messages suivants :

"fetchmail[1709]: connection to localhost:smtp [::1/25] failed: Connection refused"



Cela me semble limpide : la connexion au port 25 de localhost en IPv6
(adresse ::1) a été refusée. Soit parce que le jeu de règles ip6tables
(pare-feu IPv6) a bloqué la demande de connexion, soit plus probablement
parce que le MTA local n'écoute pas sur l'adresse de loopback IPv6.

Que raconte netstat -tnlp46 au sujet du port 25 ?

J'ai un compte gmail et voici ma config' "email" :
MTA/exim4 , MDA/procmail, MRA/fetchmail, MUA/mutt

J'envois et reçois correctement les emails mais je ne comprends pas ce
message d'avertissement.



C'est une erreur ou un simple avertissement ? Si tout fonctionne
correctement, on peut supposer que fetchmail, comme tout programme bien
écrit, tente de se connecter ensuite à localhost en IPv4 (127.0.0.1) et
réussit.

Par défaut (si on laisse local_interfaces vide), exim4 écoute sur toutes
les adresses locales en IPv4 et IPv6 si disponible. Tu as peut-être mis
127.0.0.1 pour qu'il n'écoute qu'en local ? Dans ce cas il faudrait
ajouter ::1 à la liste.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
m3t4linux
Le #22466181
Je n'ai plus le message d'avertissement.

J'ai donc reconfigurer exim4 avec dpkg-reconfigure.

J'étais loin de deviner que ::1 est l'adresse localhost en IPv6!!
Cela n'est pour moi pas limpide encore....

Bref merci à toi Pascal Hambourg et peut être à bientôt sur le forum
debian-fr.org ;-)

Le samedi 07 août 2010 à 01:05:31, Pascal Hambourg a écrit :
Salut,

m3t4linux a écrit :
>
> La consultation de /var/log/mail.err comporte les messages suivants :
>
> "fetchmail[1709]: connection to localhost:smtp [::1/25] failed: Connection refused"

Cela me semble limpide : la connexion au port 25 de localhost en IPv6
(adresse ::1) a été refusée. Soit parce que le jeu de règles ip6tables
(pare-feu IPv6) a bloqué la demande de connexion, soit plus probablement
parce que le MTA local n'écoute pas sur l'adresse de loopback IPv6.

Que raconte netstat -tnlp46 au sujet du port 25 ?

> J'ai un compte gmail et voici ma config' "email" :
> MTA/exim4 , MDA/procmail, MRA/fetchmail, MUA/mutt
>
> J'envois et reçois correctement les emails mais je ne comprends pas ce
> message d'avertissement.

C'est une erreur ou un simple avertissement ? Si tout fonctionne
correctement, on peut supposer que fetchmail, comme tout programme bien
écrit, tente de se connecter ensuite à localhost en IPv4 (127.0.0.1) et
réussit.

Par défaut (si on laisse local_interfaces vide), exim4 écoute sur toutes
les adresses locales en IPv4 et IPv6 si disponible. Tu as peut-être mis
127.0.0.1 pour qu'il n'écoute qu'en local ? Dans ce cas il faudrait
ajouter ::1 à la liste.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/





--
m3t4linux

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Publicité
Poster une réponse
Anonyme