FF-2.0.0.8 et accents sous Linux

Le
Hervé Autret
Bonjour,

Je rencontre souvent, depuis quelques jours, des pages où les caractères
accentués s'affichent mal dans FF sous Linux. En général, il s'agit
de pages dont le charset n'est pas spécifié dans la page (dans le css,
peut-être). Or, Seamonkey affiche correctement ces pages.

Tout bien considéré, ce serait FF-2.0.0.8 le coupable.
Coupable, pourquoi pas, mais de quoi ?
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Olivier Miakinen
Le #11079851
Le 01/11/2007 00:08, Hervé Autret a écrit :

Je rencontre souvent, depuis quelques jours, des pages où les caractères
accentués s'affichent mal dans FF sous Linux. En général, il s'agit
de pages dont le charset n'est pas spécifié dans la page (dans le css,
peut-être...). Or, Seamonkey affiche correctement ces pages.

Tout bien considéré, ce serait FF-2.0.0.8 le coupable.
Coupable, pourquoi pas, mais de quoi ?



Coupable d'être configuré différemment peut-être ?

Affichage
> Encodage des caractères
> Détection automatique
> Universel
Andreas Prilop
Le #11079841
On Thu, 1 Nov 2007, Hervé Autret wrote:

Je rencontre souvent, depuis quelques jours, des pages où les caractères
accentués s'affichent mal dans FF sous Linux. En général, il s'agit
de pages dont le charset n'est pas spécifié dans la page



En anglais:
Default Character Encoding: Western (Windows-1252)
http://www.mozilla.org/support/firefox/options

--
In memoriam Alan J. Flavell
http://groups.google.com/groups/search?q=author:Alan.J.Flavell
Olivier Miakinen
Le #11079831
Le 01/11/2007 16:27, Andreas Prilop a écrit :

Je rencontre souvent, depuis quelques jours, des pages où les caractères
accentués s'affichent mal dans FF sous Linux. En général, il s'agit
de pages dont le charset n'est pas spécifié dans la page



En anglais:
Default Character Encoding: Western (Windows-1252)
http://www.mozilla.org/support/firefox/options



Plutôt (toujours en anglais) :
View / Character Encoding / Auto-Detect / Universal
Jean-Marc Desperrier
Le #11079821
Andreas Prilop wrote:
On Thu, 1 Nov 2007, Hervé Autret wrote:

Je rencontre souvent, depuis quelques jours, des pages où les caractères
accentués s'affichent mal dans FF sous Linux. En général, il s'agit
de pages dont le charset n'est pas spécifié dans la page



En anglais:
Default Character Encoding: Western (Windows-1252)
http://www.mozilla.org/support/firefox/options



Le problème est que l'encodage par défaut n'est utilisé que sur une
nouvelle fenêtre, un nouvel onglet.
Quand ils suivent un lien, Firefox/Seamonkey réutilisent l'encodage de
la page précédente. C'est particulièrement génant quand on suit un lien
depuis une liste de résultat sur google, car google les affiche en
général en UTF8.

Il est donc plus efficace d'activer l'auto-détection, qui va essayer
d'auto-détecter le bon encodage pour les pages qui ne le précise pas et
se trompe rarement.
Pierre Goiffon
Le #11079741
Jean-Marc Desperrier wrote:
Le problème est que l'encodage par défaut n'est utilisé que sur une
nouvelle fenêtre, un nouvel onglet.
Quand ils suivent un lien, Firefox/Seamonkey réutilisent l'encodage de
la page précédente.



Euh, ceci à condition je suppose que la page que l'on ouvre n'ait aucune
indication de codage ?
Avez-vous une référence détaillant ce comportement ?
Olivier Miakinen
Le #11079731
Le 05/11/2007 09:34, Pierre Goiffon répondait à Jean-Marc Desperrier :

Le problème est que l'encodage par défaut n'est utilisé que sur une
nouvelle fenêtre, un nouvel onglet.
Quand ils suivent un lien, Firefox/Seamonkey réutilisent l'encodage de
la page précédente.



Euh, ceci à condition je suppose que la page que l'on ouvre n'ait aucune
indication de codage ?



Oui, bien sûr.

Avez-vous une référence détaillant ce comportement ?



Je n'en ai pas moi-même, mais je confirme avoir constaté plusieurs fois
le phénomène (en particulier à partir de Google, l'encodage par défaut
étant alors UTF-8).
Hervé Autret
Le #11079581
Bonjour,

Olivier Miakinen posta :

mais je confirme avoir constaté plusieurs fois le phénomène (en
particulier à partir de Google, l'encodage par défaut étant alors
UTF-8).



En fait l'option police "par défaut" n'a pas l'effet voulu.
Dans FF-2.0.0.9/Linux
Préférences ->
Contenu : Polices&couleurs : avancé

http://localhost:631 affiche des hiéroglyphes même en page d'accueil.
Publicité
Poster une réponse
Anonyme