FF et install flash player

Le
Hugolino
Salut,

Je viens de m'apercevoir d'un truc pénible avec le plugin Adobe Flash
Player de Firefox (version 2.0.0.18 sous Debian stable/etch à jour).
[supersedes: c'est sous KDE 3.5]

En tant qu'utilisateur principal (ID00, celui qui a installé la
distro et appartient donc aux sudoers), j'ai pu installer ce plugin et
je visite sans problème les sites utilisant du flash.

Seulement voilà: j'ai créé un nouveau compte sur ma machine, pour ma
Lulu chérie qui veut jouer sur des sites bourrés de flash.

Déjà, j'ai du mal à comprendre pourquoi firefox (iceweasel en fait,
puisqu'il s'agit d'une Debian) demande à nouveau d'installer le plugin.

Mais le problème est que la procédure semble se dérouler tout à fait
normalement, on redémarre FF et là, à nouveau, il est demandé
d'installer le plugin "Adobe Flash Player" et c'est reparti pour un
tour, tout semble correct, on redémarre, etc <endless loop detected>

Bref, comment faire pour le plugin d'Adobe s'installe correctement ?
J'imagine qu'il s'agit d'un problème de droits, mais je ne souhaite pas
donner des droits plus élevés que nécessaires à une gamine de 12 ans :/

Voici les groupes auxquels appartient ma fille:
grep lucille /etc/group:
8<--8<8<-8<-8<-8<-8<
cdrom:x:24:hugo,mael,lucille
audio:x:29:hugo,hug1,mael,lucille
video:x:44:hugo,lucille
plugdev:x:46:hugo,lucille
powerdev:x:110:hugo,mael,lucille
scanner:x:111:hugo,mael,lucille
lucille:x:1002:
8<--8<8<-8<-8<-8<-8<


Merci de votre aide.


--
Maintenant si je veux voir du BugsBunny, c'est ni windows ni Linux qui
conviennent, mais une TV et un abonnement à FoxKids.
Hugo (né il y a 1 408 493 871 secondes)
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
jp willm
Le #18144601
Salut

Hugolino a écrit :

En tant qu'utilisateur principal (ID00, celui qui a installé la
distro et appartient donc aux sudoers), j'ai pu installer ce plugin et
je visite sans problème les sites utilisant du flash.

Seulement voilà: j'ai créé un nouveau compte sur ma machine, pour ma
Lulu chérie qui veut jouer sur des sites bourrés de flash.

Déjà, j'ai du mal à comprendre pourquoi firefox (iceweasel en fait,
puisqu'il s'agit d'une Debian) demande à nouveau d'installer le plugin.



Et même si tu installes flashplugin-nonfree à partir des dépôts ?

--
jp willm
http://pagesperso-orange.fr/willms/
jp willm
Le #18144591
jp willm a écrit :

Et même si tu installes flashplugin-nonfree à partir des dépôts ?



Bon, même si ça peut fonctionner, cela ne répond pas à ta question :o(

--
jp willm
http://pagesperso-orange.fr/willms/
Cumbalero
Le #18144581
jp willm a écrit :
jp willm a écrit :

Et même si tu installes flashplugin-nonfree à partir des dépôt s ?



Bon, même si ça peut fonctionner, cela ne répond pas à ta quest ion :o(



Si, si...

Si tu installes le plugin avec un compte utilisateur, il est fort
probable que le plugin soit installé dans le HOMEDIR/.mozilla alors que
si tu installes à partir des dépôts, il sera dans
/usr/lib/mozilla/plugins ou quelque chose de ce genre, accessible à tou s
les utilisateurs de ton système.


A+
JF
remy
Le #18146061
Hugolino a écrit :
Salut,



bonjour en gros et pour faire simple
la solution réside dans la différence entre la

:~$ ls .mozilla/plugins/

et sur le compte où cela ne marche pas

une simple copie des fichiers suffit à faire fonctionner le tout
sur les 2 comptes

par contre pourquoi l'installation automatique ne marche pas
je ne sais pas mais j'ai eu le même problème

remy
jp willm
Le #18148051
Hello,

Cumbalero a écrit :
Si tu installes le plugin avec un compte utilisateur, il est fort
probable que le plugin soit installé dans le HOMEDIR/.mozilla alors que
si tu installes à partir des dépôts, il sera dans
/usr/lib/mozilla/plugins ou quelque chose de ce genre, accessible à tous
les utilisateurs de ton système.



Ben oui, au fait. c'est bien là qu'il va les chercher ses lib chez moi.
En mode "install utilisateur" il ne peut évidemment pas les mettre là.


--
jp willm
http://perso.orange.fr/willms/index.html
Hugolino
Le #18149731
Le Mon, 15 Dec 2008 14:32:31 +0100, Cumbalero a écrit:
jp willm a écrit :
> jp willm a écrit :
>> Et même si tu installes flashplugin-nonfree à partir des dépôts ?
> Bon, même si ça peut fonctionner, cela ne répond pas à ta question :o(

Si, si...
Si tu installes le plugin avec un compte utilisateur, il est fort
probable que le plugin soit installé dans le HOMEDIR/.mozilla alors
que si tu installes à partir des dépôts, il sera dans
/usr/lib/mozilla/plugins ou quelque chose de ce genre, accessible à
tous les utilisateurs de ton système.



J'avais récupéré install_flash_player_10_linux.tar.gz depuis le site
d'Adobe puis décompressé. Le script d'install, lancé bien sûr sous le
compte de r00t, foire (il refuse de voir /usr/lib/mozilla comme un
chemin valide d'installation). J'ai donc copié à la mimine
libflashplayer.so dans /usr/lib/mozilla/plugins et /usr/lib/
mozilla-firefox/plugins.

Mais ça persistait à ne pas fonctionner.

J'ai vérifié la présence d'un lien symbolique du répertoire
~/.mozilla/plugins/libflashplayer.so vers /usr/lib/mozilla/plugins, à la
fois dans mon home et celui de ma fille: ça persistait à fonctionner
pour moi (ID00) et pas pour ma fille (ID02).

Puisque j'arrivais à lire du flash, je n'avais pas pensé à vérifier que
le paquet flashplugin-nonfree n'était *pas* installé.
Donc je l'ai installé: maintenant, dans "about:config", j'ai deux
versions (9.0 r31 et 9.0 r151) du plugin flash. Mais toujours pas de
trace de la version 10.

Donc maintenant, ça marche, mais je me demande dans quelle mesure je
n'ai pas encore alourdi le fonctionnement de cette bouze de firefox,
et j'aimerais bien trouver de la doc pour faire le ménage sur ma
Debian/etch.

Accessoirement, je me demande comment le end-user moyen se serait tiré
de ce mauvais pas (et dans la série "Linux n'est pas prêt pour le
desktop", je place un xpost sans fu2 dans le cloaque aux trolls)


--
je copie le fichier rpm dans un répertoire et l'installe, maintenant
je ne sais pas lancer l'appli car elle ne s'est pas mise dans le menu
"Démarrer-Programmes".
-+- Stéph in Guide du linuxien pervers : "install.exe il est ou?" -+-
Hugolino
Le #18150951
Le Mon, 15 Dec 2008 22:45:14 +0100, Hugolino a écrit:

Donc maintenant, ça marche, mais je me demande dans quelle mesure je
n'ai pas encore alourdi le fonctionnement de cette bouze de firefox,
et j'aimerais bien trouver de la doc pour faire le ménage sur ma
Debian/etch.



Bon bin finalement, après avoir viré tous les libflashplayer.so du
système pour les remplacer par le libflashplayer.so de la version 10
provenant de l'archive téléchargée depuis le site d'Abode, il était
devenu inpossible de lire du flash.

Donc # aptitude purge iceweasel flashplugin-nonfree suivi d'une
réinstallation pour remettre le bouzin d'aplomb...

<ma vie>
J'ai vraiment horreur de ces bisouilles allahkon©®.
</ma vie>

Et il reste l'interrogation: comment se fait-il que je pouvais lire du
flash alors que le paquet flashplugin-nonfree, mais pas quand on était
connecté sur le compte de ma fille ?


--
People claim that the UNIX learning curve is steep, but at least you
only have to climb it once.
Hugo (né il y a 1 408 834 878 secondes)
jp willm
Le #18151331
Hello,

Hugolino a écrit :
Donc # aptitude purge iceweasel flashplugin-nonfree suivi d'une
réinstallation pour remettre le bouzin d'aplomb...



Il m'est arrivé de devoir désinstaller complètement iceweasel et de
supprimer les répertoires mozilla, firefox, mozilla-firefox dans
/usr/lib puis de réinstaller le navigateur et le plugin en tant que root.


Actuellement sur ubuntu, quand tu installes flashplugin à partir de
firefox on te demande le mot de passe. Or il me semble que ce n'était
pas le cas avant.



<ma vie>
J'ai vraiment horreur de ces bisouilles allahkon©®.
</ma vie>



Ça me rappelle quelque chose...

Pareil pour thunderbird qui compacte tous les message en un gros fichier
(à la mode outlook), alors que kmail par exemple les range séparément.
Et dire que j'utilise thunderbird :o|



Et il reste l'interrogation: comment se fait-il que je pouvais lire du
flash alors que le paquet flashplugin-nonfree, mais pas quand on était
connecté sur le compte de ma fille ?



Conflit de version ?

--
jp willm
http://pagesperso-orange.fr/willms/
Cumbalero
Le #18151661
Hugolino a écrit :
Et il reste l'interrogation: comment se fait-il que je pouvais lire du
flash alors que le paquet flashplugin-nonfree, mais pas quand on étai t
connecté sur le compte de ma fille ?



Si tu ne vois pas la même chose en faisant un about:config dans 2
comptes différents de la même machine alors que le plugin est au bon
endroit, c'est qu'il y a une différence entre ces 2 comptes, oui je
sais, c'est une lapalissade.

Ordre différent des répertoires où chercher les plugins par exemple .

Ou un problème de droits sur les fichiers de plugins par exemple (genre
toi tu as les droits en lecture et exécution (pas certain que ce soit
nécessaire) et pas ta fille...)

Bref, une installation du paquet de ta distribution a fonctionné, là où
l'installeur d'adobe a merdé...

<Café du commerce>
Donc, si, Linux est prêt pour le desktop, faut juste pas utiliser des
habitudes de kroteux d'aller chercher un soft sur un site web pour
l'installer à la main...
</Café du commerce>

A+
JF
remy
Le #18152211
Hugolino a écrit :


Accessoirement, je me demande comment le end-user moyen se serait tiré
de ce mauvais pas (et dans la série "Linux n'est pas prêt pour le
desktop", je place un xpost sans fu2 dans le cloaque aux trolls)





le "je clik partout "ne se pourrit pas la vie à vouloir
utiliser la version 2.x de mozila il utilise la 3
et là oh magique cela fonctionne tout seul avec 3 clik



remy
Publicité
Poster une réponse
Anonyme