Fichier plat pour import automatique d'un prix

Le
Michel
Bonjour tout le monde,

je sais cela fait longtemps que je n'etais pas sur le forum.. J'ai encore
besoin de votre aide. Et c'est une question que j'avais deja pose, mais
je suis a 8000km de chez moi et je n'ai pas l'exemple sur moi, desole.


Jai un prix qui peut etre n'importe quoi mais toujours du style :

1
12
123
1234
1.1
1.12
1.123
1.1234
12.1
12.12
etc
1234.1234


le but du jeux et de convertir ces exemples en :

Entier sur 6 positions et decimal en 6 positions (sachant que 6 positions
apres la virgule n'arriverra jamais)

selon les exemples ci-dessus cela devrait donner :

000001000000
000012000000
000123000000
001234000000
000001100000
000001120000
000001123000
000001123400
000012100000
000012120000
etc
001234123400

Sachant que en K14 = 8.62

Ce qui devait marcher pour les entiers c'est :

=TEXTE(ENT(K14);"000000")
000008

apres pour les decimales comment faire pour aligner le tout a gauche ?

=TEXTE(((K14*100)-(ENT(K14)*100));"000000")
000062

La solution ideal pour moi serait en VBA sinon via formule excel peut me
convenir.

Desole, et encore merci pour votre aide tout au long de ces annees.

En attendant de vous lire,

@+

Michel.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Philippe.R
Le #4865401
Bonjour Michel,
Dans une cellule tu saisis 1 000 000 et tu copies
tu sélectionnes ta plage / collage spécial / cocher multiplication
et tu appliques le format personnalisé 000000######
--
Philippe.R
"Michel" news:
Bonjour tout le monde,

je sais cela fait longtemps que je n'etais pas sur le forum..... J'ai
encore besoin de votre aide.... Et c'est une question que j'avais deja
pose, mais je suis a 8000km de chez moi et je n'ai pas l'exemple sur moi,
desole.


Jai un prix qui peut etre n'importe quoi mais toujours du style :

1
12
123
1234
1.1
1.12
1.123
1.1234
12.1
12.12
etc
1234.1234


le but du jeux et de convertir ces exemples en :

Entier sur 6 positions et decimal en 6 positions (sachant que 6 positions
apres la virgule n'arriverra jamais...)

selon les exemples ci-dessus cela devrait donner :

000001000000
000012000000
000123000000
001234000000
000001100000
000001120000
000001123000
000001123400
000012100000
000012120000
etc
001234123400

Sachant que en K14 = 8.62

Ce qui devait marcher pour les entiers c'est :

=TEXTE(ENT(K14);"000000")
000008

apres pour les decimales comment faire pour aligner le tout a gauche ?

=TEXTE(((K14*100)-(ENT(K14)*100));"000000")
000062

La solution ideal pour moi serait en VBA sinon via formule excel peut me
convenir....

Desole, et encore merci pour votre aide tout au long de ces annees.

En attendant de vous lire,

@+

Michel.






JB
Le #4865381
Bonjour,


=TEXTE(SUBSTITUE(A1;".";"");"0000000000")

en VBA

For Each c In Range("A1", [A65000].End(xlUp))
c.NumberFormat = "@"
c.Value = Format(Replace(c, ".", ""), "0000000000")
Next

http://cjoint.com/?hvhaSCQg6n

JB

On 21 juil, 03:30, "Michel"
Bonjour tout le monde,

je sais cela fait longtemps que je n'etais pas sur le forum..... J'ai encore
besoin de votre aide.... Et c'est une question que j'avais deja pose, mais
je suis a 8000km de chez moi et je n'ai pas l'exemple sur moi, desole.

Jai un prix qui peut etre n'importe quoi mais toujours du style :

1
12
123
1234
1.1
1.12
1.123
1.1234
12.1
12.12
etc
1234.1234

le but du jeux et de convertir ces exemples en :

Entier sur 6 positions et decimal en 6 positions (sachant que 6 positions
apres la virgule n'arriverra jamais...)

selon les exemples ci-dessus cela devrait donner :

000001000000
000012000000
000123000000
001234000000
000001100000
000001120000
000001123000
000001123400
000012100000
000012120000
etc
001234123400

Sachant que en K14 = 8.62

Ce qui devait marcher pour les entiers c'est :

=TEXTE(ENT(K14);"000000")
000008

apres pour les decimales comment faire pour aligner le tout a gauche ?

=TEXTE(((K14*100)-(ENT(K14)*100));"000000")
000062

La solution ideal pour moi serait en VBA sinon via formule excel peut me
convenir....

Desole, et encore merci pour votre aide tout au long de ces annees.

En attendant de vous lire,

@+

Michel.


Michel
Le #4864481
Bonjour,

le code en vba et formule excel ne marchent pas
3.25 me donne 0000000325
au lieu de 000003250000

Aurais-tu une autres idee ?


Merci deja de ta reponse

@+

Michel.
"JB" news:
Bonjour,


=TEXTE(SUBSTITUE(A1;".";"");"0000000000")

en VBA

For Each c In Range("A1", [A65000].End(xlUp))
c.NumberFormat = "@"
c.Value = Format(Replace(c, ".", ""), "0000000000")
Next

http://cjoint.com/?hvhaSCQg6n

JB

On 21 juil, 03:30, "Michel"
Bonjour tout le monde,

je sais cela fait longtemps que je n'etais pas sur le forum..... J'ai
encore
besoin de votre aide.... Et c'est une question que j'avais deja pose,
mais
je suis a 8000km de chez moi et je n'ai pas l'exemple sur moi, desole.

Jai un prix qui peut etre n'importe quoi mais toujours du style :

1
12
123
1234
1.1
1.12
1.123
1.1234
12.1
12.12
etc
1234.1234

le but du jeux et de convertir ces exemples en :

Entier sur 6 positions et decimal en 6 positions (sachant que 6 positions
apres la virgule n'arriverra jamais...)

selon les exemples ci-dessus cela devrait donner :

000001000000
000012000000
000123000000
001234000000
000001100000
000001120000
000001123000
000001123400
000012100000
000012120000
etc
001234123400

Sachant que en K14 = 8.62

Ce qui devait marcher pour les entiers c'est :

=TEXTE(ENT(K14);"000000")
000008

apres pour les decimales comment faire pour aligner le tout a gauche ?

=TEXTE(((K14*100)-(ENT(K14)*100));"000000")
000062

La solution ideal pour moi serait en VBA sinon via formule excel peut me
convenir....

Desole, et encore merci pour votre aide tout au long de ces annees.

En attendant de vous lire,

@+

Michel.






Michel
Le #4864471
Salut,
merci de ta reponse mais je ne comprend pas la manipulation, cela ne me
donne rien du tout....
3.25 coller special format 000000###### me donne 3.
C'est pas tout a fait ce que je voulais....
Merci quand meme,

@+

Michel.


"Philippe.R" news:
Bonjour Michel,
Dans une cellule tu saisis 1 000 000 et tu copies
tu sélectionnes ta plage / collage spécial / cocher multiplication
et tu appliques le format personnalisé 000000######
--
Philippe.R
"Michel" news:
Bonjour tout le monde,

je sais cela fait longtemps que je n'etais pas sur le forum..... J'ai
encore besoin de votre aide.... Et c'est une question que j'avais deja
pose, mais je suis a 8000km de chez moi et je n'ai pas l'exemple sur moi,
desole.


Jai un prix qui peut etre n'importe quoi mais toujours du style :

1
12
123
1234
1.1
1.12
1.123
1.1234
12.1
12.12
etc
1234.1234


le but du jeux et de convertir ces exemples en :

Entier sur 6 positions et decimal en 6 positions (sachant que 6 positions
apres la virgule n'arriverra jamais...)

selon les exemples ci-dessus cela devrait donner :

000001000000
000012000000
000123000000
001234000000
000001100000
000001120000
000001123000
000001123400
000012100000
000012120000
etc
001234123400

Sachant que en K14 = 8.62

Ce qui devait marcher pour les entiers c'est :

=TEXTE(ENT(K14);"000000")
000008

apres pour les decimales comment faire pour aligner le tout a gauche ?

=TEXTE(((K14*100)-(ENT(K14)*100));"000000")
000062

La solution ideal pour moi serait en VBA sinon via formule excel peut me
convenir....

Desole, et encore merci pour votre aide tout au long de ces annees.

En attendant de vous lire,

@+

Michel.









Mgr.Abile
Le #4864451
Bonsoir,
Reprenons :))
dans une cellule quelconque saisir 1 000 000
copier cette cellule
sélectionner la plage à convertir
Edition collage spécial en cochant multiplication
créer le format personnalisé 000000###### et l'appliquer à la plage
y a pas de raison que ça le fasse pas
;o)))
--
Philippe.R
"Michel" news:
Salut,
merci de ta reponse mais je ne comprend pas la manipulation, cela ne me
donne rien du tout....
3.25 coller special format 000000###### me donne 3.
C'est pas tout a fait ce que je voulais....
Merci quand meme,

@+

Michel.


"Philippe.R" news:
Bonjour Michel,
Dans une cellule tu saisis 1 000 000 et tu copies
tu sélectionnes ta plage / collage spécial / cocher multiplication
et tu appliques le format personnalisé 000000######
--
Philippe.R
"Michel" news:
Bonjour tout le monde,

je sais cela fait longtemps que je n'etais pas sur le forum..... J'ai
encore besoin de votre aide.... Et c'est une question que j'avais deja
pose, mais je suis a 8000km de chez moi et je n'ai pas l'exemple sur
moi, desole.


Jai un prix qui peut etre n'importe quoi mais toujours du style :

1
12
123
1234
1.1
1.12
1.123
1.1234
12.1
12.12
etc
1234.1234


le but du jeux et de convertir ces exemples en :

Entier sur 6 positions et decimal en 6 positions (sachant que 6
positions apres la virgule n'arriverra jamais...)

selon les exemples ci-dessus cela devrait donner :

000001000000
000012000000
000123000000
001234000000
000001100000
000001120000
000001123000
000001123400
000012100000
000012120000
etc
001234123400

Sachant que en K14 = 8.62

Ce qui devait marcher pour les entiers c'est :

=TEXTE(ENT(K14);"000000")
000008

apres pour les decimales comment faire pour aligner le tout a gauche ?

=TEXTE(((K14*100)-(ENT(K14)*100));"000000")
000062

La solution ideal pour moi serait en VBA sinon via formule excel peut me
convenir....

Desole, et encore merci pour votre aide tout au long de ces annees.

En attendant de vous lire,

@+

Michel.













Michel
Le #4864441
J'ai fais une formule qui me donne ce que je vaux, mais y a t'il plus court
ou peut-il y avoir un probleme avec cette formule ?
soit en A1 ma valeur

=(REPT("0";6-(NBCAR(ENT(A1))))&(GAUCHE(A1;(NBCAR(ENT(A1))))))&(STXT(A1;(NBCAR(ENT(A1)))+2;(NBCAR(A1)-1-(NBCAR(ENT(A1))))))&REPT("0";6-(NBCAR(A1)-1-(NBCAR(ENT(A1)))))

Merci pour vos commentaires.

@+

Michel.




"Michel" news:
Bonjour tout le monde,

je sais cela fait longtemps que je n'etais pas sur le forum..... J'ai
encore besoin de votre aide.... Et c'est une question que j'avais deja
pose, mais je suis a 8000km de chez moi et je n'ai pas l'exemple sur moi,
desole.


Jai un prix qui peut etre n'importe quoi mais toujours du style :

1
12
123
1234
1.1
1.12
1.123
1.1234
12.1
12.12
etc
1234.1234


le but du jeux et de convertir ces exemples en :

Entier sur 6 positions et decimal en 6 positions (sachant que 6 positions
apres la virgule n'arriverra jamais...)

selon les exemples ci-dessus cela devrait donner :

000001000000
000012000000
000123000000
001234000000
000001100000
000001120000
000001123000
000001123400
000012100000
000012120000
etc
001234123400

Sachant que en K14 = 8.62

Ce qui devait marcher pour les entiers c'est :

=TEXTE(ENT(K14);"000000")
000008

apres pour les decimales comment faire pour aligner le tout a gauche ?

=TEXTE(((K14*100)-(ENT(K14)*100));"000000")
000062

La solution ideal pour moi serait en VBA sinon via formule excel peut me
convenir....

Desole, et encore merci pour votre aide tout au long de ces annees.

En attendant de vous lire,

@+

Michel.






JB
Le #4864391
=SI(ESTNUM(CHERCHE(".";A1));TEXTE(SUBSTITUE(A1;".";",")*1000000;"00000000 0000");TEXTE(A1*100000;"000000000000"))

En VBA:

For Each c In Range("A1", [A65000].End(xlUp))
c.Offset(0, 1).NumberFormat = "@"
If InStr(c, ".") Then
c.Offset(0, 1).Value = Format(Val(c) * 1000000,
"000000000000")
Else
c.Offset(0, 1).Value = Format(c * 100000, "000000000000")
End If
Next

http://cjoint.com/?hwugpemc4F

JB


On 22 juil, 17:59, "Michel"
Bonjour,

le code en vba et formule excel ne marchent pas
3.25 me donne 0000000325
au lieu de 000003250000

Aurais-tu une autres idee ?

Merci deja de ta reponse

@+

Michel."JB"
news:



Bonjour,

=TEXTE(SUBSTITUE(A1;".";"");"0000000000")

en VBA

For Each c In Range("A1", [A65000].End(xlUp))
c.NumberFormat = "@"
c.Value = Format(Replace(c, ".", ""), "0000000000")
Next

http://cjoint.com/?hvhaSCQg6n

JB

On 21 juil, 03:30, "Michel"
Bonjour tout le monde,

je sais cela fait longtemps que je n'etais pas sur le forum..... J'ai
encore
besoin de votre aide.... Et c'est une question que j'avais deja pose,
mais
je suis a 8000km de chez moi et je n'ai pas l'exemple sur moi, desole.

Jai un prix qui peut etre n'importe quoi mais toujours du style :

1
12
123
1234
1.1
1.12
1.123
1.1234
12.1
12.12
etc
1234.1234

le but du jeux et de convertir ces exemples en :

Entier sur 6 positions et decimal en 6 positions (sachant que 6 positi ons
apres la virgule n'arriverra jamais...)

selon les exemples ci-dessus cela devrait donner :

000001000000
000012000000
000123000000
001234000000
000001100000
000001120000
000001123000
000001123400
000012100000
000012120000
etc
001234123400

Sachant que en K14 = 8.62

Ce qui devait marcher pour les entiers c'est :

=TEXTE(ENT(K14);"000000")
000008

apres pour les decimales comment faire pour aligner le tout a gauche ?

=TEXTE(((K14*100)-(ENT(K14)*100));"000000")
000062

La solution ideal pour moi serait en VBA sinon via formule excel peut me
convenir....

Desole, et encore merci pour votre aide tout au long de ces annees.

En attendant de vous lire,

@+

Michel.- Masquer le texte des messages précédents -



- Afficher le texte des messages précédents -




Gloops
Le #4629781
Mgr.Abile a écrit, le 22/07/2007 18:34 :
Bonsoir,
Reprenons :))
dans une cellule quelconque saisir 1 000 000
copier cette cellule
sélectionner la plage à convertir
Edition collage spécial en cochant multiplication
créer le format personnalisé 000000###### et l'appliquer à la pla ge
y a pas de raison que ça le fasse pas
;o)))


Salut,

Comme ça vite fait sans rien vérifier : est-ce vraiment sûr qu'il n 'y a
pas un séparateur de décimales à placer quelque part ?

Philippe.R
Le #4861051
Bonjour,
Bien vu, pour que ça fonctionne, il faut encore que le séparateur décimal
soit le point (comme dans l'exemple donné) ou bien remplacer le point par la
virgule dans les données avnat de les traiter.
--
Philippe.R
"Gloops" news:
Mgr.Abile a écrit, le 22/07/2007 18:34 :
Bonsoir,
Reprenons :))
dans une cellule quelconque saisir 1 000 000
copier cette cellule
sélectionner la plage à convertir
Edition collage spécial en cochant multiplication
créer le format personnalisé 000000###### et l'appliquer à la plage
y a pas de raison que ça le fasse pas
;o)))


Salut,

Comme ça vite fait sans rien vérifier : est-ce vraiment sûr qu'il n'y a
pas un séparateur de décimales à placer quelque part ?

JB
Le #4860961
Bonjour,

=SI(ESTNUM(CHERCHE(".";A1));TEXTE(SUBSTITUE(A1;".";",")*1000000;"00000000 0000");TEXTE(A1*100000;"000000000000"))

http://cjoint.com/?hBjp24ZUsM

JB

On 22 juil, 19:02, "Michel"
J'ai fais une formule qui me donne ce que je vaux, mais y a t'il plus cou rt
ou peut-il y avoir un probleme avec cette formule ?
soit en A1 ma valeur

=(REPT("0";6-(NBCAR(ENT(A1))))&(GAUCHE(A1;(NBCAR(ENT(A1))))))&(STXT(A1; (NBC­AR(ENT(A1)))+2;(NBCAR(A1)-1-(NBCAR(ENT(A1))))))&REPT("0";6-(NBCAR(A1 )-1-(NB­CAR(ENT(A1)))))

Merci pour vos commentaires.

@+

Michel.

"Michel"
news:



Bonjour tout le monde,

je sais cela fait longtemps que je n'etais pas sur le forum..... J'ai
encore besoin de votre aide.... Et c'est une question que j'avais deja
pose, mais je suis a 8000km de chez moi et je n'ai pas l'exemple sur mo i,
desole.

Jai un prix qui peut etre n'importe quoi mais toujours du style :

1
12
123
1234
1.1
1.12
1.123
1.1234
12.1
12.12
etc
1234.1234

le but du jeux et de convertir ces exemples en :

Entier sur 6 positions et decimal en 6 positions (sachant que 6 positio ns
apres la virgule n'arriverra jamais...)

selon les exemples ci-dessus cela devrait donner :

000001000000
000012000000
000123000000
001234000000
000001100000
000001120000
000001123000
000001123400
000012100000
000012120000
etc
001234123400

Sachant que en K14 = 8.62

Ce qui devait marcher pour les entiers c'est :

=TEXTE(ENT(K14);"000000")
000008

apres pour les decimales comment faire pour aligner le tout a gauche ?

=TEXTE(((K14*100)-(ENT(K14)*100));"000000")
000062

La solution ideal pour moi serait en VBA sinon via formule excel peut me
convenir....

Desole, et encore merci pour votre aide tout au long de ces annees.

En attendant de vous lire,

@+

Michel.- Masquer le texte des messages précédents -


- Afficher le texte des messages précédents -



Publicité
Poster une réponse
Anonyme