Filtre élaboré avec 2 critères

Le
Apitos
Bonsoir,

J'aimerais compté les numéros commençant par "11" ou "17" de la liste
A1:B41 sans doublons et sans ceux qui ont la valeur "TL" ou "TR" dans
la colonne B.

Merci.

http://cjoint.com/?cftzUd8cQL
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
cb60
Le #5282891
Bonsoir
regarde si cela te convient?
http://cjoint.com/?cftPLCZjsb


Bonsoir,

J'aimerais compté les numéros commençant par "11" ou "17" de la liste
A1:B41 sans doublons et sans ceux qui ont la valeur "TL" ou "TR" dans
la colonne B.

Merci.

http://cjoint.com/?cftzUd8cQL



Apitos
Le #5281871
Bonjour,

J'ai réussi à filtrer ma liste, mais le compte n'est pas bon !!!

http://cjoint.com/?cgnAC3tq0J

Merci d'avance.
Apitos
Le #5281771
Re,

Déja il y'a une erreur :

Avec un préfixe = 11 ça ne marche pas !

Avec un préfixe = 17 ça ramène les les 11* et les 17* ensemble.

Il faut corriger la formule en G2 :=GAUCHE($A$2;2)=TEXTE($K$2;"00")

Mettre à la place : =GAUCHE($A2;2)=TEXTE($K$2;"00")

(En a enlever un $ du $A$2).

S'il y'a d'autres précisions à apporter, merci de me la faire savoir.

Merci.
Brunos
Le #5281121
J'aimerais compté les numéros commençant par "11" ou "17" de la liste
A1:B41 sans doublons et sans ceux qui ont la valeur "TL" ou "TR" dans
la colonne B.


Je suppose que tes numéros ont tous 8 chiffres comme dans ton exemple.
J'ai nommé zoneA=[A2:A41] et zoneB=[B2:B41]

Nombre de n° 17xxxxxx avec "TL":
=SOMMEPROD((zoneB="TL")*(zoneA>000000)*(zoneA<18000000))

Nombre de n° 11xxxxxx avec "TR":
=SOMMEPROD((zoneB="TR")*(zoneA>000000)*(zoneA<12000000))

C'est difficile d'enlever en plus les doublons, car il y a des vides
dans la colonne B.

Mais tu peux calculer juste sur la colonne A :
Nombre de 17xxxxxx sans doublons:
=SOMMEPROD((1/(NB.SI(zoneA;zoneA)))*(zoneA>000000)*(zoneA<18000000))

--
Brunos

Apitos
Le #5280921
Je te remerci Brunos.
Publicité
Poster une réponse
Anonyme