Filtrer et compter des données

Le
Jean Bonbeurre
Bonjour,

Dans une feuille excel, j'ai une colonne qui reprend des valeurs. Certaines
valeurs peuvent se retrouver plusieurs fois dans le colonne. Par exemple,
j'ai 4 valeurs dans ma colonne mais le 2 revient 2 fois.
1
4
2
2

Comment faire pour compter le nombre de valeurs différentes de la colonne ?
Je voudrais avoir 3 car c'est le nombre de valeur différentes de la colonne ?

C'est bien sur un tableau qui comporte 3000 valeurs.

Merci
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
garnote
Le #4593171
Salut Jean,

Essaie cette formule :
=SOMME(1/NB.SI(plage;plage))
en la validant par Ctrl+Maj+Entrée.

Serge



"Jean Bonbeurre"
Bonjour,

Dans une feuille excel, j'ai une colonne qui reprend des valeurs. Certaines
valeurs peuvent se retrouver plusieurs fois dans le colonne. Par exemple,
j'ai 4 valeurs dans ma colonne mais le 2 revient 2 fois.
1
4
2
2

Comment faire pour compter le nombre de valeurs différentes de la colonne ?
Je voudrais avoir 3 car c'est le nombre de valeur différentes de la colonne ?

C'est bien sur un tableau qui comporte 3000 valeurs.

Merci


Daniel
Le #4593161
Bonjour.
Et si ta liste comporte des cellules vides :
=SOMME(SI(A1:A10<>"";1/NB.SI(A1:A10;A1:A10)))
(formule matricielle, à valider avec CTRL+Maj+Entrée)
Cordialement.
Daniel
"Jean Bonbeurre" message de news:
Bonjour,

Dans une feuille excel, j'ai une colonne qui reprend des valeurs.
Certaines
valeurs peuvent se retrouver plusieurs fois dans le colonne. Par exemple,
j'ai 4 valeurs dans ma colonne mais le 2 revient 2 fois.
1
4
2
2

Comment faire pour compter le nombre de valeurs différentes de la colonne
?
Je voudrais avoir 3 car c'est le nombre de valeur différentes de la
colonne ?

C'est bien sur un tableau qui comporte 3000 valeurs.

Merci


jean Berti
Le #4909361
Bonsoir

Pour compléter.
Avec valeurs de texte, numériques et vides.
=SOMME(SI(NBCAR(A1:A10)>0;1/(NB.SI(A1:A10;A1:A10));0))
Formule matricielle
à valider par Maj,Ctrl et entrée.

Jean Berti
"Jean Bonbeurre" message de news:
Bonjour,

Dans une feuille excel, j'ai une colonne qui reprend des valeurs.
Certaines
valeurs peuvent se retrouver plusieurs fois dans le colonne. Par exemple,
j'ai 4 valeurs dans ma colonne mais le 2 revient 2 fois.
1
4
2
2

Comment faire pour compter le nombre de valeurs différentes de la colonne
?
Je voudrais avoir 3 car c'est le nombre de valeur différentes de la
colonne ?

C'est bien sur un tableau qui comporte 3000 valeurs.

Merci


Jean Bonbeurre
Le #4909271
Merci à vous trois.


Bonsoir

Pour compléter.
Avec valeurs de texte, numériques et vides.
=SOMME(SI(NBCAR(A1:A10)>0;1/(NB.SI(A1:A10;A1:A10));0))
Formule matricielle
à valider par Maj,Ctrl et entrée.

Jean Berti
"Jean Bonbeurre" message de news:
Bonjour,

Dans une feuille excel, j'ai une colonne qui reprend des valeurs.
Certaines
valeurs peuvent se retrouver plusieurs fois dans le colonne. Par exemple,
j'ai 4 valeurs dans ma colonne mais le 2 revient 2 fois.
1
4
2
2

Comment faire pour compter le nombre de valeurs différentes de la colonne
?
Je voudrais avoir 3 car c'est le nombre de valeur différentes de la
colonne ?

C'est bien sur un tableau qui comporte 3000 valeurs.

Merci







Jean Bonbeurre
Le #4909251
J'ai malgré tout un petit problème. Dans une des colonnes je peux avoir du
texte ou des chiffres ou des caractères spéciaux ou un mélange des trois mais
c'est toujours 3 positions.

Par exemple :

25R
773
$15
V1V

Quand je compte avec la formule de Jean, j'ai un nombre avec une décimale
(152,12) ce qui nest pas possible.

A quoi est ce du ? Quel format doit avoir cette cellule (texte, nombre,
...) ?

Merci

Bonsoir

Pour compléter.
Avec valeurs de texte, numériques et vides.
=SOMME(SI(NBCAR(A1:A10)>0;1/(NB.SI(A1:A10;A1:A10));0))
Formule matricielle
à valider par Maj,Ctrl et entrée.

Jean Berti
"Jean Bonbeurre" message de news:
Bonjour,

Dans une feuille excel, j'ai une colonne qui reprend des valeurs.
Certaines
valeurs peuvent se retrouver plusieurs fois dans le colonne. Par exemple,
j'ai 4 valeurs dans ma colonne mais le 2 revient 2 fois.
1
4
2
2

Comment faire pour compter le nombre de valeurs différentes de la colonne
?
Je voudrais avoir 3 car c'est le nombre de valeur différentes de la
colonne ?

C'est bien sur un tableau qui comporte 3000 valeurs.

Merci







Jean Bonbeurre
Le #4909231
J'ai un problème avec ta formule.

Dans une colonne je peux avoir par exemple :

25R
125
V1v
$15

mais c'est toujours en 3 positions.

Quand j'utilise ta formule, j'obtiens une décimale (152,12) cde qui n'est
pas possible.

Quel est le problème ? Quel doit être le format de la cellule ?

Merci




Bonsoir

Pour compléter.
Avec valeurs de texte, numériques et vides.
=SOMME(SI(NBCAR(A1:A10)>0;1/(NB.SI(A1:A10;A1:A10));0))
Formule matricielle
à valider par Maj,Ctrl et entrée.

Jean Berti
"Jean Bonbeurre" message de news:
Bonjour,

Dans une feuille excel, j'ai une colonne qui reprend des valeurs.
Certaines
valeurs peuvent se retrouver plusieurs fois dans le colonne. Par exemple,
j'ai 4 valeurs dans ma colonne mais le 2 revient 2 fois.
1
4
2
2

Comment faire pour compter le nombre de valeurs différentes de la colonne
?
Je voudrais avoir 3 car c'est le nombre de valeur différentes de la
colonne ?

C'est bien sur un tableau qui comporte 3000 valeurs.

Merci







jean Berti
Le #4909161
Salut Jean

http://cjoint.com/?gCktazmjeg

C'est une matricielle.Je viens de vérifier et elle marche.
Jean Berti

"Jean Bonbeurre" message de news:
J'ai un problème avec ta formule.

Dans une colonne je peux avoir par exemple :

25R
125
V1v
$15

mais c'est toujours en 3 positions.

Quand j'utilise ta formule, j'obtiens une décimale (152,12) cde qui n'est
pas possible.

Quel est le problème ? Quel doit être le format de la cellule ?

Merci




Bonsoir

Pour compléter.
Avec valeurs de texte, numériques et vides.
=SOMME(SI(NBCAR(A1:A10)>0;1/(NB.SI(A1:A10;A1:A10));0))
Formule matricielle
à valider par Maj,Ctrl et entrée.

Jean Berti
"Jean Bonbeurre" le
message de news:
Bonjour,

Dans une feuille excel, j'ai une colonne qui reprend des valeurs.
Certaines
valeurs peuvent se retrouver plusieurs fois dans le colonne. Par
exemple,
j'ai 4 valeurs dans ma colonne mais le 2 revient 2 fois.
1
4
2
2

Comment faire pour compter le nombre de valeurs différentes de la
colonne
?
Je voudrais avoir 3 car c'est le nombre de valeur différentes de la
colonne ?

C'est bien sur un tableau qui comporte 3000 valeurs.

Merci









Jean Bonbeurre
Le #4909041
Bonjour,

Je dois avoir un problème dans une de mes cellules car quand j'utilise ta
formule en commencant à A2 (A1, c'est le titre) jusqua'à A2036 j'ai 167,16.
Si je commence à A10 jusqu'à A2036 j'ai 168,16.

=SOMME(SI(NBCAR(A2:A2036)>0;1/(NB.SI(A2:A2036;A2:A2036));0))

Ce qui n'est pas normal. Est ce que ca pourrait être car il y ades blancs
après les 3 positions.

Merci encore


Salut Jean

http://cjoint.com/?gCktazmjeg

C'est une matricielle.Je viens de vérifier et elle marche.
Jean Berti

"Jean Bonbeurre" message de news:
J'ai un problème avec ta formule.

Dans une colonne je peux avoir par exemple :

25R
125
V1v
$15

mais c'est toujours en 3 positions.

Quand j'utilise ta formule, j'obtiens une décimale (152,12) cde qui n'est
pas possible.

Quel est le problème ? Quel doit être le format de la cellule ?

Merci




Bonsoir

Pour compléter.
Avec valeurs de texte, numériques et vides.
=SOMME(SI(NBCAR(A1:A10)>0;1/(NB.SI(A1:A10;A1:A10));0))
Formule matricielle
à valider par Maj,Ctrl et entrée.

Jean Berti
"Jean Bonbeurre" le
message de news:
Bonjour,

Dans une feuille excel, j'ai une colonne qui reprend des valeurs.
Certaines
valeurs peuvent se retrouver plusieurs fois dans le colonne. Par
exemple,
j'ai 4 valeurs dans ma colonne mais le 2 revient 2 fois.
1
4
2
2

Comment faire pour compter le nombre de valeurs différentes de la
colonne
?
Je voudrais avoir 3 car c'est le nombre de valeur différentes de la
colonne ?

C'est bien sur un tableau qui comporte 3000 valeurs.

Merci














Jean Bonbeurre
Le #4909011
Il semblerait que ce soit *21 qui pose un problème car quand j'exclu cette
valeur de ma colonne c'est bon, j'ai un entier. Si je la comprends dedans,
j'ai des décimales.

Par exemple, je l'ai mis comme dernier élément. Si je prends cette cellule
j'ai un décimal. Si je ne la prends pas j'ai un entier.

Par contre dans ton exemple, j'ai ajouté le *21 et ça fonctionne.

Je ne comprends pas.

Merci


Salut Jean

http://cjoint.com/?gCktazmjeg

C'est une matricielle.Je viens de vérifier et elle marche.
Jean Berti

"Jean Bonbeurre" message de news:
J'ai un problème avec ta formule.

Dans une colonne je peux avoir par exemple :

25R
125
V1v
$15

mais c'est toujours en 3 positions.

Quand j'utilise ta formule, j'obtiens une décimale (152,12) cde qui n'est
pas possible.

Quel est le problème ? Quel doit être le format de la cellule ?

Merci




Bonsoir

Pour compléter.
Avec valeurs de texte, numériques et vides.
=SOMME(SI(NBCAR(A1:A10)>0;1/(NB.SI(A1:A10;A1:A10));0))
Formule matricielle
à valider par Maj,Ctrl et entrée.

Jean Berti
"Jean Bonbeurre" le
message de news:
Bonjour,

Dans une feuille excel, j'ai une colonne qui reprend des valeurs.
Certaines
valeurs peuvent se retrouver plusieurs fois dans le colonne. Par
exemple,
j'ai 4 valeurs dans ma colonne mais le 2 revient 2 fois.
1
4
2
2

Comment faire pour compter le nombre de valeurs différentes de la
colonne
?
Je voudrais avoir 3 car c'est le nombre de valeur différentes de la
colonne ?

C'est bien sur un tableau qui comporte 3000 valeurs.

Merci














jean berti
Le #4908301
Salut

Sur l'exemple que j'ai mis sur Cijoint, j'ai rajouté 21 et la fonction
marche bien.
Format standard .
Jean Berti

"Jean Bonbeurre" message de news:
Il semblerait que ce soit *21 qui pose un problème car quand j'exclu cette
valeur de ma colonne c'est bon, j'ai un entier. Si je la comprends
dedans,
j'ai des décimales.

Par exemple, je l'ai mis comme dernier élément. Si je prends cette cellule
j'ai un décimal. Si je ne la prends pas j'ai un entier.

Par contre dans ton exemple, j'ai ajouté le *21 et ça fonctionne.

Je ne comprends pas.

Merci


Salut Jean

http://cjoint.com/?gCktazmjeg

C'est une matricielle.Je viens de vérifier et elle marche.
Jean Berti

"Jean Bonbeurre" le
message de news:
J'ai un problème avec ta formule.

Dans une colonne je peux avoir par exemple :

25R
125
V1v
$15

mais c'est toujours en 3 positions.

Quand j'utilise ta formule, j'obtiens une décimale (152,12) cde qui
n'est
pas possible.

Quel est le problème ? Quel doit être le format de la cellule ?

Merci




Bonsoir

Pour compléter.
Avec valeurs de texte, numériques et vides.
=SOMME(SI(NBCAR(A1:A10)>0;1/(NB.SI(A1:A10;A1:A10));0))
Formule matricielle
à valider par Maj,Ctrl et entrée.

Jean Berti
"Jean Bonbeurre" dans
le
message de news:
Bonjour,

Dans une feuille excel, j'ai une colonne qui reprend des valeurs.
Certaines
valeurs peuvent se retrouver plusieurs fois dans le colonne. Par
exemple,
j'ai 4 valeurs dans ma colonne mais le 2 revient 2 fois.
1
4
2
2

Comment faire pour compter le nombre de valeurs différentes de la
colonne
?
Je voudrais avoir 3 car c'est le nombre de valeur différentes de la
colonne ?

C'est bien sur un tableau qui comporte 3000 valeurs.

Merci
















Publicité
Poster une réponse
Anonyme