Filtrer une liste déroulante

Le
Albert
Bonjour

Voir cijoint http://www.cijoint.fr/cjlink.php?file=cj200904/cijCYf8nMJ.xls

Si possible pas de VBA ni liste en cascade, on essaie d'utiliser les options
et fonctions de base d'EXCEL seulement, ou macro facile pour la formation de
débutants.

C'est un bon de commande avec une liste déroulante des produits en ordre
ascendant.

Le premier article sur la liste détermine à quel vendeur ce bon sera
adressé.
Tous les articles choisis suivants doivent parvenir de ce même vendeur.

Comment afficher le liste des articles 2 à 10 provenants uniquement de ce
fournisseur?

La liste est sur la feuil "Données" plage "prod" et "base" les vendeurs
dans la colonne "F"

Merci


--
albertri-at-videotron.ca.invalid
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
JB
Le #19184271
Bonsoir,

Voir PJ

http://cjoint.com/?eAk7TTdMuM

=SI(LIGNES($1:1)<=NB.SI(Fourn;$D$3);
INDEX(prod;PETITE.VALEUR(SI(Fourn=$D$3;LIGNE(INDIRECT("1:"&LIGNES
(prod))));LIGNES($1:1)));"")

Fourn =Données!$F$1:$F$35
prod =Données!$A$1:$A$35
prod2 ÞCALER('Bon-Commande'!$K$6;;;SOMMEPROD(--('Bon-Commande'!$K
$6:$K$13<>"")))


JB
http://boisgontierjacques.free.fr/
On 24 avr, 18:57, "Albert"
Bonjour

Voir cijoint  http://www.cijoint.fr/cjlink.php?file=cj200904/cijCYf8n MJ.xls

Si possible pas de VBA ni liste en cascade, on essaie d'utiliser les opti ons
et fonctions de base d'EXCEL seulement, ou macro facile pour la formation de
débutants.

C'est un bon de commande avec une liste déroulante des produits en ordr e
ascendant.

Le premier article sur la liste détermine à quel vendeur ce bon sera
adressé.
Tous les articles choisis suivants doivent parvenir de ce même vendeur.

Comment afficher le liste des articles 2 à 10 provenants uniquement de ce
fournisseur?

La liste est sur la feuil "Données"  plage "prod"  et "base" les ve ndeurs
dans la colonne "F"

Merci

--
albertri-at-videotron.ca.invalid


Albert
Le #19184521
"JB" news:
Bonne nuit et bon week-end
Merci encore une fois, cela rencontre nos besoins, c'est dans l'esprit de ma
demande.
À l'automne on se lance dans le VBA, mais en attendant il me faut digérer
les six lignes que vous avez envoyées.
Merci http://cimbcc.ca/

Albert

http://cjoint.com/?eAk7TTdMuM

=SI(LIGNES($1:1)<=NB.SI(Fourn;$D$3);
INDEX(prod;PETITE.VALEUR(SI(Fourn=$D$3;LIGNE(INDIRECT("1:"&LIGNES
(prod))));LIGNES($1:1)));"")

Fourn =Données!$F$1:$F$35
prod =Données!$A$1:$A$35
prod2 ÞCALER('Bon-Commande'!$K$6;;;SOMMEPROD(--('Bon-Commande'!$K
$6:$K$13<>"")))


JB
http://boisgontierjacques.free.fr/
On 24 avr, 18:57, "Albert"
Bonjour

Voir cijoint http://www.cijoint.fr/cjlink.php?file=cj200904/cijCYf8nMJ.xls

Si possible pas de VBA ni liste en cascade, on essaie d'utiliser les
options
et fonctions de base d'EXCEL seulement, ou macro facile pour la formation
de
débutants.

C'est un bon de commande avec une liste déroulante des produits en ordre
ascendant.

Le premier article sur la liste détermine à quel vendeur ce bon sera
adressé.
Tous les articles choisis suivants doivent parvenir de ce même vendeur.

Comment afficher le liste des articles 2 à 10 provenants uniquement de ce
fournisseur?

La liste est sur la feuil "Données" plage "prod" et "base" les vendeurs
dans la colonne "F"

Merci

--
albertri-at-videotron.ca.invalid


Albert
Le #19189771
Bonjour / Bonsoir pour vous

J'ai des soucis avec la plage Prod2.
Je n'arrive pas à la déplacer, je la veux dans la colonne P3:P12
ÞCALER('Bon-Commande'!$P$3;;;SOMMEPROD(--('Bon-Commande'!$P$3:$P$13<>"")))
alie de
ÞCALER('Bon-Commande'!$K$6;;;SOMMEPROD(--('Bon-Commande'!$K$6:$K$13<>"")))
Voir le fichier modifié à
http://www.cijoint.fr/cjlink.php?file=cj200904/cijfrMMDkE.xls

Qu'est-ce que je ne fais pas correctement, ou que je n'ai pas compris.
Si je recrée la plage Prod2 dans le gestionnaire de nom et je tape le tout,
ça fonctionne pour une ou deux fois ensuite^ça chanje,
je ne comprend pas bien.
Merci pour vos explications.

albert

"JB" news:
Bonsoir,

Voir PJ
http://cjoint.com/?eAk7TTdMuM

=SI(LIGNES($1:1)<=NB.SI(Fourn;$D$3);
INDEX(prod;PETITE.VALEUR(SI(Fourn=$D$3;LIGNE(INDIRECT("1:"&LIGNES
(prod))));LIGNES($1:1)));"")

Fourn =Données!$F$1:$F$35
prod =Données!$A$1:$A$35
prod2 ÞCALER('Bon-Commande'!$K$6;;;SOMMEPROD(--('Bon-Commande'!$K
$6:$K$13<>"")))


JB
http://boisgontierjacques.free.fr/
On 24 avr, 18:57, "Albert"
Bonjour

Voir cijoint http://www.cijoint.fr/cjlink.php?file=cj200904/cijCYf8nMJ.xls

Si possible pas de VBA ni liste en cascade, on essaie d'utiliser les
options
et fonctions de base d'EXCEL seulement, ou macro facile pour la formation
de
débutants.

C'est un bon de commande avec une liste déroulante des produits en ordre
ascendant.

Le premier article sur la liste détermine à quel vendeur ce bon sera
adressé.
Tous les articles choisis suivants doivent parvenir de ce même vendeur.

Comment afficher le liste des articles 2 à 10 provenants uniquement de ce
fournisseur?

La liste est sur la feuil "Données" plage "prod" et "base" les vendeurs
dans la colonne "F"

Merci

--
albertri-at-videotron.ca.invalid


Albert
Le #19190721
Résolu..... j'ai confirmé avec CTRL / MAJUS / ENTER
albert
"Albert" news:
Bonjour / Bonsoir pour vous

J'ai des soucis avec la plage Prod2.
Je n'arrive pas à la déplacer, je la veux dans la colonne P3:P12
ÞCALER('Bon-Commande'!$P$3;;;SOMMEPROD(--('Bon-Commande'!$P$3:$P$13<>"")))
alie de
ÞCALER('Bon-Commande'!$K$6;;;SOMMEPROD(--('Bon-Commande'!$K$6:$K$13<>"")))
Voir le fichier modifié à
http://www.cijoint.fr/cjlink.php?file=cj200904/cijfrMMDkE.xls

Qu'est-ce que je ne fais pas correctement, ou que je n'ai pas compris.
Si je recrée la plage Prod2 dans le gestionnaire de nom et je tape le
tout, ça fonctionne pour une ou deux fois ensuite^ça chanje,
je ne comprend pas bien.
Merci pour vos explications.

albert

"JB" news:
Bonsoir,

Voir PJ
http://cjoint.com/?eAk7TTdMuM

=SI(LIGNES($1:1)<=NB.SI(Fourn;$D$3);
INDEX(prod;PETITE.VALEUR(SI(Fourn=$D$3;LIGNE(INDIRECT("1:"&LIGNES
(prod))));LIGNES($1:1)));"")

Fourn =Données!$F$1:$F$35
prod =Données!$A$1:$A$35
prod2 ÞCALER('Bon-Commande'!$K$6;;;SOMMEPROD(--('Bon-Commande'!$K
$6:$K$13<>"")))


JB
http://boisgontierjacques.free.fr/
On 24 avr, 18:57, "Albert"
Bonjour

Voir cijoint
http://www.cijoint.fr/cjlink.php?file=cj200904/cijCYf8nMJ.xls

Si possible pas de VBA ni liste en cascade, on essaie d'utiliser les
options
et fonctions de base d'EXCEL seulement, ou macro facile pour la formation
de
débutants.

C'est un bon de commande avec une liste déroulante des produits en ordre
ascendant.

Le premier article sur la liste détermine à quel vendeur ce bon sera
adressé.
Tous les articles choisis suivants doivent parvenir de ce même vendeur.

Comment afficher le liste des articles 2 à 10 provenants uniquement de ce
fournisseur?

La liste est sur la feuil "Données" plage "prod" et "base" les vendeurs
dans la colonne "F"

Merci

--
albertri-at-videotron.ca.invalid





Albert
Le #19195641
Bonjour
MEA CULPA
___tout, ça fonctionne pour une ou deux fois ensuite ça change,_____

J'ai trouvé, durant mes essais je vérifiais la dimension de la plage PROD2,
en entrant Prod2 dans la zone de noms. Quand la dimension de la plage était
nulle, cette action créait une nouvelle plage PROD2 dans la dernière cellule
active de la plage, remplaçant la plage dynamique créée par ÞCALER(etc....

Merci de votre aide
albert

J'ai des soucis avec la plage Prod2.
Je n'arrive pas à la déplacer, je la veux dans la colonne P3:P12
ÞCALER('Bon-Commande'!$P$3;;;SOMMEPROD(--('Bon-Commande'!$P$3:$P$13<>"")))
alie de
ÞCALER('Bon-Commande'!$K$6;;;SOMMEPROD(--('Bon-Commande'!$K$6:$K$13<>"")))
Voir le fichier modifié à
http://www.cijoint.fr/cjlink.php?file=cj200904/cijfrMMDkE.xls

Qu'est-ce que je ne fais pas correctement, ou que je n'ai pas compris.
Si je recrée la plage Prod2 dans le gestionnaire de nom et je tape le
tout, ça fonctionne pour une ou deux fois ensuite ça change,
je ne comprend pas bien.
Merci pour vos explications.

albert

"JB" news:
Bonsoir,

Voir PJ
http://cjoint.com/?eAk7TTdMuM

=SI(LIGNES($1:1)<=NB.SI(Fourn;$D$3);
INDEX(prod;PETITE.VALEUR(SI(Fourn=$D$3;LIGNE(INDIRECT("1:"&LIGNES
(prod))));LIGNES($1:1)));"")

Fourn =Données!$F$1:$F$35
prod =Données!$A$1:$A$35
prod2 ÞCALER('Bon-Commande'!$K$6;;;SOMMEPROD(--('Bon-Commande'!$K
$6:$K$13<>"")))


JB
http://boisgontierjacques.free.fr/
On 24 avr, 18:57, "Albert"
Bonjour

Voir cijoint
http://www.cijoint.fr/cjlink.php?file=cj200904/cijCYf8nMJ.xls

Si possible pas de VBA ni liste en cascade, on essaie d'utiliser les
options
et fonctions de base d'EXCEL seulement, ou macro facile pour la
formation de
débutants.

C'est un bon de commande avec une liste déroulante des produits en ordre
ascendant.

Le premier article sur la liste détermine à quel vendeur ce bon sera
adressé.
Tous les articles choisis suivants doivent parvenir de ce même vendeur.

Comment afficher le liste des articles 2 à 10 provenants uniquement de
ce
fournisseur?

La liste est sur la feuil "Données" plage "prod" et "base" les vendeurs
dans la colonne "F"

Merci

--
albertri-at-videotron.ca.invalid








Publicité
Poster une réponse
Anonyme