Firefox - Recherche de mot dans la page

Le
capfree
Bonjour

Toujours avec Firefox 12.0, sous Kmint quand je fais Ctrl + F avec le
mot inverseur dans cette page :

http://www.hellopro.fr/COMAP-142984-noprofil-fr-societe.html

l’ascenseur la positionne plus bas, mais il n'y a pas le mot surligné,
Pourtant dans les sources se retouve bien :

http://www.hellopro.fr/images/produit-2/4/3/0/coupleur-inverseur-165-b-nf-m-88-770-ref-0165b00-163034.gif

C'est un problème récurrent et vraiment mal-pratique, c'est normal ça ?
Solution ou pas ?

Merci de vos avis.


--
capfree
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
geo cherchetout
Le #24986152
Le 23/11/2012 09:32, *capfree* a écrit fort à propos :
Bonjour

Toujours avec Firefox 12.0, sous Kmint quand je fais Ctrl + F avec le
mot inverseur dans cette page :

http://www.hellopro.fr/COMAP-142984-noprofil-fr-societe.html

l’ascenseur la positionne plus bas, mais il n'y a pas le mot surligné,
Pourtant dans les sources se retouve bien :

http://www.hellopro.fr/images/produit-2/4/3/0/coupleur-inverseur-165-b-nf-m-88-770-ref-0165b00-163034.gif

C'est un problème récurrent et vraiment mal-pratique, c'est normal ça ?



Je pense que c'est normal puisque « inverseur » n'est affiché nulle part
dans la page. L'outil de recherche n'est pas censé regarder dans le code
source tant que ce n'est pas celui-ci que tu affiches.

Une autre bizarrerie m'étonne d'avantage : Chaque fois que le pointeur de la
souris a survolé et quitte un lien « Tous les fournisseurs », celui-ci
disparaît. C'est normal ça ?
geo cherchetout
Le #24986142
Le 23/11/2012 10:51, j'ai écrit :

Une autre bizarrerie m'étonne d'avantage : Chaque fois que le pointeur de la
souris a survolé et quitte un lien « Tous les fournisseurs », celui-ci
disparaît. C'est normal ça ?



Euh, pardon, j'ai oublié de préciser que ce phénomène se manifeste avec
Seamonkey 2.13.2 mais pas avec Firefox (10.0.10).
capfree
Le #24986182
Le 23/11/2012 10:51, geo cherchetout a écrit :
Le 23/11/2012 09:32, *capfree* a écrit fort à propos :
Bonjour

Toujours avec Firefox 12.0, sous Kmint quand je fais Ctrl + F avec le
mot inverseur dans cette page :

http://www.hellopro.fr/COMAP-142984-noprofil-fr-societe.html

l’ascenseur la positionne plus bas, mais il n'y a pas le mot surligné,
Pourtant dans les sources se retouve bien :

http://www.hellopro.fr/images/produit-2/4/3/0/coupleur-inverseur-165-b-nf-m-88-770-ref-0165b00-163034.gif


C'est un problème récurrent et vraiment mal-pratique, c'est normal ça ?



Je pense que c'est normal puisque « inverseur » n'est affiché nulle part
dans la page. L'outil de recherche n'est pas censé regarder dans le code
source tant que ce n'est pas celui-ci que tu affiches.



Ben oui, mais le code source a bien généré la page, mystère des
/htmlistes/
Et si je mets un mot introuvable «abracadabra» par exemple, l'ascenseur
ne bouge pas et la fenêtre de recherche rougit fortement, et là c'est
très bien !


Une autre bizarrerie m'étonne d'avantage : Chaque fois que le pointeur
de la souris a survolé et quitte un lien « Tous les fournisseurs »,
celui-ci disparaît. C'est normal ça ?




J'avais remarqué, encore une astuce de programmeur ;-)

--
capfree
geo cherchetout
Le #24986262
Le 23/11/2012 10:51, j'ai écrit trop vite :

Je pense que c'est normal puisque « inverseur » n'est affiché nulle part
dans la page. L'outil de recherche n'est pas censé regarder dans le code
source tant que ce n'est pas celui-ci que tu affiches.



Désolé, j'ai oublié que mon navigateur habituel est Seamonkey et que le
problème signalé concerne Firefox.
En fait, avec Firefox 10.0.10 sous Linux, le mot inverseur est bien trouvé
alors qu'il ne l'est pas avec Seamonkey ! Cela s'explique peut-être par le
fait que le rendu de la page diffère considérablement d'un navigateur à
l'autre :
Seamonkey 2.13.2 s'efforce d'afficher côte à côte sur une même ligne
horizontale les produits de la sélection et, comme ces produits sont trop
nombreux, le seul contenant le mot INVERSEUR (en majuscules) est déporté
hors page et donc invisible :
http://pix.toile-libre.org/upload/original/1353666087.png

En revanche, Firefox répartit tous les produits sur cinq lignes et tous sont
donc bien affichés, illustration et légende :
http://pix.toile-libre.org/upload/original/1353665901.png

Pour conclure, j'ajoute mon grain de sel mais n'apporte aucune réponse à la
question originale.
Olivier Miakinen
Le #24986252
Le 23/11/2012 10:51, geo cherchetout répondait à capfree :

Toujours avec Firefox 12.0, sous Kmint quand je fais Ctrl + F avec le
mot inverseur dans cette page :

http://www.hellopro.fr/COMAP-142984-noprofil-fr-societe.html

l’ascenseur la positionne plus bas, mais il n'y a pas le mot surligné,
Pourtant dans les sources se retouve bien :

http://www.hellopro.fr/images/produit-2/4/3/0/coupleur-inverseur-165-b-nf-m-88-770-ref-0165b00-163034.gif

C'est un problème récurrent et vraiment mal-pratique, c'est normal ça ?





J'ai la même chose dans SeaMonkey 2.14 et Firefox 17.0 sur Windows. Ça
ne me semble pas normal, même si je n'ai pas cherché de quelle manière
ce mot est caché (display:none ou visibility:hidden ?)

Je pense que c'est normal puisque « inverseur » n'est affiché nulle part
dans la page. L'outil de recherche n'est pas censé regarder dans le code
source tant que ce n'est pas celui-ci que tu affiches.



Eh bien justement, ce qui n'est pas normal, c'est qu'il *trouve* le mot,
alors qu'il n'est pas affiché. Tu peux faire l'expérience en tapant (par
exemple) « /inverser ». Tant que tu n'as écrit que « inverse », la zone
de recherche reste en blanc, mais dès que tu saisis le dernier « r » au
lieu de « u » elle passe en rouge car ce mot-là n'est pas trouvé.
Sergio
Le #24986852
Le Fri, 23 Nov 2012 11:27:46 +0100, Olivier Miakinen a écrit :

Je pense que c'est normal puisque « inverseur » n'est affiché nulle
part dans la page. L'outil de recherche n'est pas censé regarder dans
le code source tant que ce n'est pas celui-ci que tu affiches.



Eh bien justement, ce qui n'est pas normal, c'est qu'il *trouve* le mot,
alors qu'il n'est pas affiché. Tu peux faire l'expérience en tapant (par
exemple) « /inverser ». Tant que tu n'as écrit que « inverse », la zone
de recherche reste en blanc, mais dès que tu saisis le dernier « r » au
lieu de « u » elle passe en rouge car ce mot-là n'est pas trouvé.



Il est possible que le mot soit bien "affiché" mais caché de fait, par
exemple dans un cadre trop petit, ce qui semble le cas par cette mise ne
page "fixe".

Par exemple la rubrique " Sélection de produits de la société :" déborde
et une partie n'est pas affichée (serait-ce dans cette partie que se
cache l'inverseur ?).
Olivier Miakinen
Le #24986922
Le 23/11/2012 14:07, Sergio a écrit :

Il est possible que le mot soit bien "affiché" mais caché de fait, par
exemple dans un cadre trop petit, ce qui semble le cas par cette mise ne
page "fixe".

Par exemple la rubrique " Sélection de produits de la société :" déborde
et une partie n'est pas affichée (serait-ce dans cette partie que se
cache l'inverseur ?).



C'est très possible en effet. Si quelqu'un a le temps de regarder...
capfree
Le #24986952
Le 23/11/2012 14:41, Olivier Miakinen a écrit :
Le 23/11/2012 14:07, Sergio a écrit :

Il est possible que le mot soit bien "affiché" mais caché de fait, par
exemple dans un cadre trop petit, ce qui semble le cas par cette mise ne
page "fixe".

Par exemple la rubrique " Sélection de produits de la société :" déborde
et une partie n'est pas affichée (serait-ce dans cette partie que se
cache l'inverseur ?).



C'est très possible en effet. Si quelqu'un a le temps de regarder...




Je venais de vérifier, il doit être placé dans la partie cachée de la
ligne d'appareils,
(vu dans les sources) c'est ça :

http://www.hellopro.fr/images/produit-2/4/3/0/coupleur-inverseur-165-b-nf-m-88-770-ref-0165b00-163034.gif

que je retrouve ici :

http://www.domix.com/gaz/fr/gaz/inverseur_650125.htm

il ne fait détendeur final, et il est *cher*, comme il ne fuit pas,
seulement le basculement automatique ne se fait plus, je verrais plus tard.


--
capfree
JC_Et
Le #24987212
*Bonjour*, Le 23/11/2012 09:32, capfree a écrit :

Toujours avec Firefox 12.0, sous Kmint quand je fais Ctrl + F avec le
mot inverseur dans cette page :

http://www.hellopro.fr/COMAP-142984-noprofil-fr-societe.html



Le site en NON valide suivant le validateur W3c alors ...

--
JC E.
Publicité
Poster une réponse
Anonyme