FireFox et tableau pour menu déroulant

Le
pat-joke
Bonjour,

Je suis un novice et je suis à mes premier pas pour la création d'un site web et j'ai un problème avec un tableau que je créer pour mon menu,

Lorsque que je ne met pas de tableau mon menu déroulant fonctionne très bien avec IE, Firefox et Safari, mais lorsque je mets le tout dans un tableau pour l'ajusté mon menu déroulant ne fonctionne plus avec Firefox et safari.

voici mon bout de code:
<!-- Liste imbriquée de liens qui fera office de menu -->
<table width="100%" border="0" cellpadding="0" cellspacing="0" bgcolor="#990000">
<td>
<tr>
<ul id="menu">
<td><li><a href="#menu2">Notre école</a></li></td>
<td><li><a href="#menu3">Le Taekwondo</a>
<ul>
<li><a href="#">élément 1</a></li>
<li><a href="#">élément 2</a></li>
<li><a href="#">élément 3</a></li>
</ul>
</li></td>
<td><li><a href="#menu5">Photos / Vidéos</a>
<ul>
<li><a href="#">élément 1</a></li>
<li><a href="#">élément 2</a></li>
</ul>
</li></td>
</ul>

<script type="text/javascript">
initMenu();
</script>
</td>
</tr>
</table>

Merci à l'avance de votre aide
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
SAM
Le #19671681
Le 6/30/09 7:39 PM, pat-joke a écrit :
Bonjour,

Je suis un novice et je suis à mes premier pas pour la création d'un site web
et j'ai un problème avec un tableau que je créer pour mon menu,

Lorsque que je ne met pas de tableau mon menu déroulant fonctionne très bien
avec IE, Firefox et Safari, mais lorsque je mets le tout dans un tableau pour
l'ajusté mon menu déroulant ne fonctionne plus avec Firefox et safari....



Ça ne m'étonne pas.
à mon idée, on n'a pas le droit de mettre un LI dans un TD
(un LI se met dans un UL)

Il n'y a que IE qui peut accepter de genre de déviation.

Ne reste qu'à ajouter des "commentaires conditionnels" chaque fois qu'on
veut glisser au milieu des UL-LI les trucs de TABLE dont a besoin IE
pour s'y retrouver.
(voir le site 'cssplay' qui utilise bp ces commentaires)
(voir Google ou la BdD de M$ pour ces trucs-machins)

--
sm
pat-joke
Le #19675521
SAM a écrit le 30/06/2009 à 21h42 :
Le 6/30/09 7:39 PM, pat-joke a écrit :
Bonjour,

Je suis un novice et je suis à mes premier pas pour la création
d'un site web
et j'ai un problème avec un tableau que je créer pour mon menu,

Lorsque que je ne met pas de tableau mon menu déroulant fonctionne
très bien
avec IE, Firefox et Safari, mais lorsque je mets le tout dans un tableau pour
l'ajusté mon menu déroulant ne fonctionne plus avec Firefox et
safari....




Ça ne m'étonne pas.
à mon idée, on n'a pas le droit de mettre un LI dans un TD
(un LI se met dans un UL)

Il n'y a que IE qui peut accepter de genre de déviation.

Ne reste qu'à ajouter des "commentaires conditionnels" chaque
fois qu'on
veut glisser au milieu des UL-LI les trucs de TABLE dont a besoin IE
pour s'y retrouver.
(voir le site 'cssplay' qui utilise bp ces commentaires)
(voir Google ou la BdD de M$ pour ces trucs-machins)

--
sm


Merci pour ton aide

Je vais aller voir le site :-)

Pat_Joke
Publicité
Poster une réponse
Anonyme