FireFox et validateur W3C

Le
Jean Le Brun
Bonjour à toutes et à tous,

Je me suis lancé dans la validation des pages de mon site grâce au
validateur du W3C.
Sur les pages validées j'ai donc apposé l'icone de validation en
introduisant dans mon code la procédure suivante :
ooooooooooooooooooooooooooooooooooooooooooooooooooooo
<p>
<a
href="http://validator.w3.org/check?uri=http%3A%2F%2Fwww.cyranorion.fr%2Feta_sam%2F"><img
src="http://www.w3.org/Icons/valid-html401-blue"
title="Page validée [HTML 4.01 Transitional]
par le W3C)."
alt="Page validée [HTML 4.01 Transitional] par le W3C
." height="31" width="88">
</a>
</p>
ooooooooooooooooooooooooooooooooooooooooooooooooooooo

Je travaille sous Win XP SP2 et FireFox 3.6

Le problème :

- sous IE, tout marche correctement : l'icône W3C est en place, son
survol à la souris fait bien apparaître le texte "Page validée [HTML
4.01 Transitional] par le W3C)." et le clic sur l'icone charge la page
de validation du W3C,

- sous FireFox, l'icône est bien en place mais ni le survol, ni le
clic ne déclenchent la moindre réaction..

Quelqu'un sait-il si ce dysfonctionnement est connu (je n'ai rien
trouvé sur le net) et quelle en est la solution ?

Merci de m'avoir lu.

Cordialement,
Jean Le Brun
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Olivier Miakinen
Le #21179891
Bonjour,

Le 12/02/2010 01:09, Jean Le Brun a écrit :

[
- sous IE, tout marche correctement : l'icône W3C est en place, son
survol à la souris fait bien apparaître le texte "Page validée [HTML
4.01 Transitional] par le W3C)." et le clic sur l'icone charge la page
de validation du W3C,

- sous FireFox, l'icône est bien en place mais ni le survol, ni le
clic ne déclenchent la moindre réaction..



J'ai l'impression que c'est ton pied de page ( qui cache l'icône en question. Essaye pour commencer d'échanger le
paragraphe contenant l'icône W3C avec celui contenant escalier.gif, ça
risque de marcher. Pour aller plus dans le détail il faudrait étudier
les CSS (quand on désactive tous les CSS dans Firefox, ça marche).

--
Olivier Miakinen
Jean Le Brun
Le #21181901
Le Fri, 12 Feb 2010 01:56:19 +0100, Olivier Miakinen

Bonjour Olivier et merci pour ta prompte réponse,

J'ai l'impression que c'est ton pied de page ( qui cache l'icône en question. Essaye pour commencer d'échanger le
paragraphe contenant l'icône W3C avec celui contenant escalier.gif, ça
risque de marcher. Pour aller plus dans le détail il faudrait étudier
les CSS (quand on désactive tous les CSS dans Firefox, ça marche).



Banco ! Tu as vu juste, çà fonctionne parfaitement en intervertissant
les deux §.

Je vais aller retorturer la feuille CSS ;o)

Un grand merci pour tes judicieux conseils.
Très cordialement,
Jean
--
Publicité
Poster une réponse
Anonyme