flash player

Le
Patrice Desrues
Bonjour à tous. J'ai un problème avec le plugin flashplayer sur
Iceweasel et aussi Iceape sur une distribution Debian stable, et ce
depuis l'effacement d'un des comptes de ma distribution(qui en comporte
3 en plus de root). Ce compte a été recréé ensuite. Mais maintenant je
n'ai plus le plugin flashplayer sur tous les comptes
J'ai bien entendu essayer de le réinstaller en allant sur le site Adobe
et j'ai télécharger l'archive tar.gz pour Linux. Après décompression on
dois lancer le script flashplayer-installer. Celui-ci démarre et me
demande d'entrer un path correspondant à mozilla dans ma distribution,
en mettant comme exemple /usr/lib/mozilla. Comme j'ai ce répertoire chez
moi, j'entre ce chemin et alors j'ai le message comme quoi je dois
entrer un chemin valide ! J'ai essayé tous les chemins possibles,en root
ou en utilisateur, rien n'y fait,le script refuse tout :o(
Là je dois dire que je bloque Si une âme charitable a une idée
Merci de me guider dans les arcanes des plugins car c'est la première
fois que j'ai ce genre de problème.
@+

--
patrice Desrues
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 3
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
bob
Le #18721561
Le Fri, 20 Feb 2009 19:23:49 +0100, Patrice Desrues a écrit :

Bonjour à tous. J'ai un problème avec le plugin flashplayer sur
Iceweasel et aussi Iceape sur une distribution Debian stable, et ce
depuis l'effacement d'un des comptes de ma distribution(qui en comporte
3 en plus de root). Ce compte a été recréé ensuite. Mais maintenant je
n'ai plus le plugin flashplayer sur tous les comptes... J'ai bien
entendu essayer de le réinstaller en allant sur le site Adobe et j'ai
télécharger l'archive tar.gz pour Linux. Après décompression on dois
lancer le script flashplayer-installer. Celui-ci démarre et me demande
d'entrer un path correspondant à mozilla dans ma distribution, en
mettant comme exemple /usr/lib/mozilla. Comme j'ai ce répertoire chez
moi, j'entre ce chemin et alors j'ai le message comme quoi je dois
entrer un chemin valide ! J'ai essayé tous les chemins possibles,en root
ou en utilisateur, rien n'y fait,le script refuse tout :o( Là je dois
dire que je bloque... Si une âme charitable a une idée... Merci de me
guider dans les arcanes des plugins car c'est la première fois que j'ai
ce genre de problème.
@+



Es-tu sur qu'en root ça ne fonctionne pas ?
Sinon cela m'est arrivé à moi aussi. J'ai donc déplacé le fichier
décompressé de FlashPlayer dans le repertoire cible et, j'ai lancé
l'install depuis ce repertoire. Et cela à fonctionné.
YBM
Le #18721701
Patrice Desrues a écrit :
Bonjour à tous. J'ai un problème avec le plugin flashplayer sur
Iceweasel et aussi Iceape sur une distribution Debian stable, [...]



Le paquet flashplugin-nonfree qui s'occupe de télécharger et installer
flashplayer n'est plus dans la partie non-free des dépôts ?

Sinon, il existe un paquet pour ubuntu 8.04 et au dessus, qui pourrait
bien marcher sur une Debian:

http://fpdownload.macromedia.com/get/flashplayer/current/install_flash_player_10_linux.deb
Patrice Desrues
Le #18721831
bob a écrit :
Le Fri, 20 Feb 2009 19:23:49 +0100, Patrice Desrues a écrit :

Bonjour à tous. J'ai un problème avec le plugin flashplayer sur
Iceweasel et aussi Iceape sur une distribution Debian stable, et ce
depuis l'effacement d'un des comptes de ma distribution(qui en comporte
3 en plus de root). Ce compte a été recréé ensuite. Mais maintenant je
n'ai plus le plugin flashplayer sur tous les comptes... J'ai bien
entendu essayer de le réinstaller en allant sur le site Adobe et j'ai
télécharger l'archive tar.gz pour Linux. Après décompression on dois
lancer le script flashplayer-installer. Celui-ci démarre et me demande
d'entrer un path correspondant à mozilla dans ma distribution, en
mettant comme exemple /usr/lib/mozilla. Comme j'ai ce répertoire chez
moi, j'entre ce chemin et alors j'ai le message comme quoi je dois
entrer un chemin valide ! J'ai essayé tous les chemins possibles,en root
ou en utilisateur, rien n'y fait,le script refuse tout :o( Là je dois
dire que je bloque... Si une âme charitable a une idée... Merci de me
guider dans les arcanes des plugins car c'est la première fois que j'ai
ce genre de problème.
@+



Es-tu sur qu'en root ça ne fonctionne pas ?
Sinon cela m'est arrivé à moi aussi. J'ai donc déplacé le fichier
décompressé de FlashPlayer dans le repertoire cible et, j'ai lancé
l'install depuis ce repertoire. Et cela à fonctionné.


Merci de votre proposition. J'ai essayé dans /usr/lib/mozilla en tant
que root de lancer flashplayer-installer : pareil, on me demande
toujours un chemin valide et /usr/lib/mozilla dans lequel je suis est
refusé :o(
Merci quand même ;o)

--
patrice Desrues
Patrice Desrues
Le #18721921
YBM a écrit :
Patrice Desrues a écrit :
Bonjour à tous. J'ai un problème avec le plugin flashplayer sur
Iceweasel et aussi Iceape sur une distribution Debian stable, [...]



Le paquet flashplugin-nonfree qui s'occupe de télécharger et installer
flashplayer n'est plus dans la partie non-free des dépôts ?

Sinon, il existe un paquet pour ubuntu 8.04 et au dessus, qui pourrait
bien marcher sur une Debian:

http://fpdownload.macromedia.com/get/flashplayer/current/install_flash_player_10_linux.deb



Merci de votre réponse :
je n'ai pas le paquet flashplugin-nonfree et pourtant j'ai non-free dans
ma source-list.
Le paquet ubuntu bloque à l'installation car plein de dépendances ne
sont pas remplies : bibliothèques trop ancienne sur la Debian stable que
j'ai et que je met à jour fréquemment.
@+

--
patrice Desrues
Fabien LE LEZ
Le #18722361
On Fri, 20 Feb 2009 20:31:28 +0100, Patrice Desrues

Debian stable



Note que "Debian stable" signifie "Lenny" depuis une semaine.
Quelle distribution est mentionnée dans /etc/apt/sources.list ? Etch ?
Lenny ? Stable ?
Jacques Lav!gnotte
Le #18722991
Patrice Desrues a écrit :
Fabien LE LEZ a écrit :
Note que "Debian stable" signifie "Lenny" depuis une semaine.





Salut. C'est marqué stable.




As-tu mis à jour (apt-get update etc) ta machine depuis moins
de 8 jours ?

patrice Desrues


Jacques
Patrice Desrues
Le #18722981
Fabien LE LEZ a écrit :
On Fri, 20 Feb 2009 20:31:28 +0100, Patrice Desrues

Debian stable



Note que "Debian stable" signifie "Lenny" depuis une semaine.
Quelle distribution est mentionnée dans /etc/apt/sources.list ? Etch ?
Lenny ? Stable ?



Salut. C'est marqué stable.

--
patrice Desrues
Hugolino
Le #18723741
Le 20-02-2009, Patrice Desrues
YBM a écrit :
> Patrice Desrues a écrit :
>> Bonjour à tous. J'ai un problème avec le plugin flashplayer sur
>> Iceweasel et aussi Iceape sur une distribution Debian stable, [...]
>
> Le paquet flashplugin-nonfree qui s'occupe de télécharger et installer
> flashplayer n'est plus dans la partie non-free des dépôts ?
>
> Sinon, il existe un paquet pour ubuntu 8.04 et au dessus, qui pourrait
> bien marcher sur une Debian:
>
> http://fpdownload.macromedia.com/get/flashplayer/current/install_flash_player_10_linux.deb
>
Merci de votre réponse :
je n'ai pas le paquet flashplugin-nonfree et pourtant j'ai non-free dans
ma source-list.
Le paquet ubuntu bloque à l'installation


C'est heureux. Installer un paquet ubuntu sur une debian (ou l'inverse)
est un bon moyen de casser sa distribution.

Vérifie que le fichier '/etc/apt/sources.list' contient bien la ligne
8<-----------8<---------8<----------8<----------8<----------8<----------8<
deb http://ftp.fr.debian.org/debian/ lenny main non-free contrib
8<-----------8<---------8<----------8<----------8<----------8<----------8<

Ainsi qu'on te l'a fait remarquer "lenny" est équivalent à "stable"
depuis une semaine.

Lance un aptitude update pour mettre à jour la liste des paquets
disponibles, un 'aptitude show flashplugin-nonfree' doit alors raconter:
8<-----------8<---------8<----------8<----------8<----------8<----------8<
Paquet : flashplugin-nonfree
Nouveau: oui
État: non installé
Version : 1:2.5
Priorité : optionnel
Section : contrib/web
Responsable : Bart Martens [cut]
8<-----------8<---------8<----------8<----------8<----------8<----------8<

Et un 'aptitude install flashplugin-nonfree' devrait résoudre le
problème. Je dis "devrait" car il n'est bien sûr pas normal que la
suppression d'un compte utilisateur plante le player flash, et puisqu'on
ne connaît pas la cause du problème...

Le plus simple: Faire un 'locate libflashplayer' et supprimer tous les
fichiers qui répondent présents à l'appel. Récupérer le fichier
'libflashplayer.so' qui est dans l'archive que tu as téléchargé depuis
le site d'adobe et le copier dans le répertoire
'/usr/lib/mozilla/plugins/' avant de relancer firefox.
Ça marche puisque comme tu peux le voir ci-dessus, le paquet
flashplugin-nonfree n'est pas installé chez moi et pourtant l'url
'about:config' affiche dans iceweasel:
8<-----------8<---------8<----------8<----------8<----------8<----------8<
Shockwave Flash
Nom de fichier : libflashplayer.so
Shockwave Flash 10.0 r12
8<-----------8<---------8<----------8<----------8<----------8<----------8<



--
En informatique, ne pas installer Windows c'est déjà s'y connaître...
Hugo (né il y a 1 414 618 238 secondes)
Fabien LE LEZ
Le #18724101
On Fri, 20 Feb 2009 22:52:00 +0100, Patrice Desrues

C'est marqué stable.



Pas bon. Tu as probablement une Etch, et tu essaies d'installer des
paquets Lenny.

Mieux vaut y indiquer le nom de la distribution ("etch" ou "lenny").

Si tu as bien une Etch, je t'invite donc à remplacer "stable" par
"etch" partout, puis à relancer aptitude pour vérifier s'il n'y a pas
de problème.

Ensuite, tu peux décider, ou non, de passer à Lenny :
http://www.debian.org/releases/lenny/i386/release-notes/ch-upgrading.en.html
bob
Le #18725511
Le Fri, 20 Feb 2009 20:04:55 +0100, Patrice Desrues a écrit :

bob a écrit :
Le Fri, 20 Feb 2009 19:23:49 +0100, Patrice Desrues a écrit :

Bonjour à tous. J'ai un problème avec le plugin flashplayer sur
Iceweasel et aussi Iceape sur une distribution Debian stable, et ce
depuis l'effacement d'un des comptes de ma distribution(qui en
comporte 3 en plus de root). Ce compte a été recréé ensuite. Mais
maintenant je n'ai plus le plugin flashplayer sur tous les comptes...
J'ai bien entendu essayer de le réinstaller en allant sur le site
Adobe et j'ai télécharger l'archive tar.gz pour Linux. Après
décompression on dois lancer le script flashplayer-installer. Celui-ci
démarre et me demande d'entrer un path correspondant à mozilla dans ma
distribution, en mettant comme exemple /usr/lib/mozilla. Comme j'ai ce
répertoire chez moi, j'entre ce chemin et alors j'ai le message comme
quoi je dois entrer un chemin valide ! J'ai essayé tous les chemins
possibles,en root ou en utilisateur, rien n'y fait,le script refuse
tout :o( Là je dois dire que je bloque... Si une âme charitable a une
idée... Merci de me guider dans les arcanes des plugins car c'est la
première fois que j'ai ce genre de problème.
@+



Es-tu sur qu'en root ça ne fonctionne pas ? Sinon cela m'est arrivé à
moi aussi. J'ai donc déplacé le fichier décompressé de FlashPlayer dans
le repertoire cible et, j'ai lancé l'install depuis ce repertoire. Et
cela à fonctionné.


Merci de votre proposition. J'ai essayé dans /usr/lib/mozilla en tant
que root de lancer flashplayer-installer : pareil, on me demande
toujours un chemin valide et /usr/lib/mozilla dans lequel je suis est
refusé :o(
Merci quand même ;o)



De rien. Essayez aussisi vous avez un répertoire /Iceweasel/ C'est peut-
être là que vous devriez installer le package... Mais comme cela à éré
dit plus haut c'est impossible parceque votre distrib n'accepte pas ces
packages. Dernier espoir allez sur le site www.lepoint.fr et en haut à
gauche essayez "cliquer pour installer le plugin"... Ensuite si cela ne
fonctionne pas il reste Ubuntu. Ca ressemble à du Debian ;-)

Bon courage.
Publicité
Poster une réponse
Anonyme