Fonction BDNB : critère avec contenu d'une cellule?

Le
Alex_P
Bonjour,

Je suis sur Excel 2003. Je souhaite utiliser la fonction BDNB pour sommer
des lignes avec (entre autres) un critère sur le champ date.

La fonction marche avec le critère >01/11/2007

Elle ne marche pas avec le critère >A1 où la cellule contient la valeur
01/11/2007

Merci d'avance
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
JB
Le #5392511
Bonjour,

=">" &A1

JB

On 26 nov, 17:36, Alex_P
Bonjour,

Je suis sur Excel 2003. Je souhaite utiliser la fonction BDNB pour sommer
des lignes avec (entre autres) un critère sur le champ date.

La fonction marche avec le critère >01/11/2007

Elle ne marche pas avec le critère >A1 où la cellule contient la valeu r
01/11/2007

Merci d'avance


Alex_P
Le #5392101
Bonjour et merci de m'aider.

Avec la fonction BDNB, la saisie du ou des critères se fait directement dans
les cellules, il n'y a pas de signe = avant la condition. On définit ensuite
la plage de critères qui contient la colonnes et la condition.

J'ai essayé différentes combinaisons avec le & mais ça ne fonctionne pas!

Voici un exemple:
le tableau de données A1:B6
le tableau de critères B8:B9
A B
1 Num Date
2 18 26/11/2007
3 25 20/10/2007
4 31 15/10/2007
5 48 12/10/2007
6 55 18/09/2007
7
8 Date
9 >01/11/2007
et la fonction (dans une autre cellule)
½NB(A1:B6;"Date";B8:B9)


Bonjour,

=">" &A1

JB

On 26 nov, 17:36, Alex_P
Bonjour,

Je suis sur Excel 2003. Je souhaite utiliser la fonction BDNB pour sommer
des lignes avec (entre autres) un critère sur le champ date.

La fonction marche avec le critère >01/11/2007

Elle ne marche pas avec le critère >A1 où la cellule contient la valeur
01/11/2007

Merci d'avance






JB
Le #5392081
Bonjour,

http://cjoint.com/?lBjztug3BS

JB

On 27 nov, 09:09, Alex_P
Bonjour et merci de m'aider.

Avec la fonction BDNB, la saisie du ou des critères se fait directement dans
les cellules, il n'y a pas de signe = avant la condition. On définit e nsuite
la plage de critères qui contient la colonnes et la condition.

J'ai essayé différentes combinaisons avec le & mais ça ne fonctionne pas!

Voici un exemple:
le tableau de données A1:B6
le tableau de critères B8:B9
A B
1 Num Date
2 18 26/11/2007
3 25 20/10/2007
4 31 15/10/2007
5 48 12/10/2007
6 55 18/09/2007
7
8 Date
9 >01/11/2007
et la fonction (dans une autre cellule)
½NB(A1:B6;"Date";B8:B9)




Bonjour,

=">" &A1

JB

On 26 nov, 17:36, Alex_P
Bonjour,

Je suis sur Excel 2003. Je souhaite utiliser la fonction BDNB pour som mer
des lignes avec (entre autres) un critère sur le champ date.

La fonction marche avec le critère >01/11/2007

Elle ne marche pas avec le critère >A1 où la cellule contient la v aleur
01/11/2007

Merci d'avance- Masquer le texte des messages précédents -



- Afficher le texte des messages précédents -




Filochard
Le #5392061
Avec la fonction BDNB, la saisie du ou des critères se fait directement dans
les cellules, il n'y a pas de signe = avant la condition. On définit ensuite
la plage de critères qui contient la colonnes et la condition.


Cette fonction et ses consoeurs ne présentent strictement aucun intérêt et
seront très avantageusement remplacées, dans la majorité des cas, par SOMME PROD
Pour le cas qui vous préoccupe, pour dénombrer les dates > ou = au 15/10/2007 :

=SOMMEPROD((lesDates>ÚTE(2007;10;15))*1)

Alex_P
Le #5391321
Merci à vous 2

La solution de JB répond bien à mon besoin.
J'étudierai la fonction SOMMEPROD quand j'aurai un peu de temps libre


Avec la fonction BDNB, la saisie du ou des critères se fait directement dans
les cellules, il n'y a pas de signe = avant la condition. On définit ensuite
la plage de critères qui contient la colonnes et la condition.


Cette fonction et ses consoeurs ne présentent strictement aucun intérêt et
seront très avantageusement remplacées, dans la majorité des cas, par SOMME PROD
Pour le cas qui vous préoccupe, pour dénombrer les dates > ou = au 15/10/2007 :

=SOMMEPROD((lesDates>ÚTE(2007;10;15))*1)






Publicité
Poster une réponse
Anonyme