fonction choisir

Le
daniel
Bonjour,
Le but du jeu est de rapprocher 2 listes (1 de 2000 lignes, l'autre de 6000
lignes).
Dans chaque liste il y a des noms, mais pas forcément identiques (MARTIN
DUPOND et liste 2 MARTIN.M DUPOND.T RAYMOND H.)
Pour essayer de faire le rapprochement, j'ai isolé chaque nom dans une
cellule sur la même ligne dans les 2 listes.
Colonne F MARTIN, Col.G DUPOND, dans la 2 e liste, même chose Col.E MARTIN,
Col.G DUPOND , Col.I RAYMOND.
Donc je souhaite faire un calcul :
Afin d'éviter de recopier j'aimerais utiliser la fonction choisir, qui
utilisera la formule voulue, de 1 à 7.
B1 = SOMMEPROD(--(C1=_1NIJ))
B2 = SOMMEPROD((C2=_1NIJ)*(E2=_1NIJ))
B3 = SOMMEPROD((C3=_1NIJ)*(E3=_1NIJ)*(G3=_1NIJ))
etc
=CHOISIR(2;$B$1;$B$2;$B$3;$B$4;$B$5;$B$6;$B$7)
mais cela me renvoie la valeur de la cellule B2 et non le calcul sur la
ligne 7.
Si vous pouvez m'aiguiller et me dire où je fais des erreurs ?
J'espère être assez clair :-O
Merci de vos prochaines réponses.
DanielH
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Philippe.R
Le #21328161
Bonjour,
La fonction indirect() renvoie le contenu d'une cellule donnée en référence.
Regarde de ce côté (non testé) :
=CHOISIR(2;indirect($B$1);indirect($B$2);indirect($B$3);...)
à adapter
--
Avec plaisir
http://dj.joss.free.fr/trombine.htm
http://jacxl.free.fr/mpfe/trombino.html
Philippe.R
Pour se connecter au forum :
http://www.excelabo.net/web/mpfe
News://news.microsoft.com/microsoft.public.fr.excel
"daniel" news:
Bonjour,
Le but du jeu est de rapprocher 2 listes (1 de 2000 lignes, l'autre de
6000 lignes).
Dans chaque liste il y a des noms, mais pas forcément identiques (MARTIN
DUPOND et liste 2 MARTIN.M DUPOND.T RAYMOND H.)
Pour essayer de faire le rapprochement, j'ai isolé chaque nom dans une
cellule sur la même ligne dans les 2 listes.
Colonne F MARTIN, Col.G DUPOND, dans la 2 e liste, même chose Col.E
MARTIN, Col.G DUPOND , Col.I RAYMOND.
Donc je souhaite faire un calcul :
Afin d'éviter de recopier j'aimerais utiliser la fonction choisir, qui
utilisera la formule voulue, de 1 à 7.
B1 = SOMMEPROD(--(C1=_1NIJ))
B2 = SOMMEPROD((C2=_1NIJ)*(E2=_1NIJ))
B3 = SOMMEPROD((C3=_1NIJ)*(E3=_1NIJ)*(G3=_1NIJ))
etc...
=CHOISIR(2;$B$1;$B$2;$B$3;$B$4;$B$5;$B$6;$B$7)
mais cela me renvoie la valeur de la cellule B2 et non le calcul sur la
ligne 7.
Si vous pouvez m'aiguiller et me dire où je fais des erreurs ?
J'espère être assez clair :-O
Merci de vos prochaines réponses.
DanielH

daniel
Le #21328231
Bonjour,
Merci, mais cela me renvoie un joli #REF!...



"Philippe.R"
Bonjour,
La fonction indirect() renvoie le contenu d'une cellule donnée en
référence.
Regarde de ce côté (non testé) :
=CHOISIR(2;indirect($B$1);indirect($B$2);indirect($B$3);...)
à adapter
--
Avec plaisir
http://dj.joss.free.fr/trombine.htm
http://jacxl.free.fr/mpfe/trombino.html
Philippe.R
Pour se connecter au forum :
http://www.excelabo.net/web/mpfe
News://news.microsoft.com/microsoft.public.fr.excel
"daniel" news:
Bonjour,
Le but du jeu est de rapprocher 2 listes (1 de 2000 lignes, l'autre de
6000 lignes).
Dans chaque liste il y a des noms, mais pas forcément identiques (MARTIN
DUPOND et liste 2 MARTIN.M DUPOND.T RAYMOND H.)
Pour essayer de faire le rapprochement, j'ai isolé chaque nom dans une
cellule sur la même ligne dans les 2 listes.
Colonne F MARTIN, Col.G DUPOND, dans la 2 e liste, même chose Col.E
MARTIN, Col.G DUPOND , Col.I RAYMOND.
Donc je souhaite faire un calcul :
Afin d'éviter de recopier j'aimerais utiliser la fonction choisir, qui
utilisera la formule voulue, de 1 à 7.
B1 = SOMMEPROD(--(C1=_1NIJ))
B2 = SOMMEPROD((C2=_1NIJ)*(E2=_1NIJ))
B3 = SOMMEPROD((C3=_1NIJ)*(E3=_1NIJ)*(G3=_1NIJ))
etc...
=CHOISIR(2;$B$1;$B$2;$B$3;$B$4;$B$5;$B$6;$B$7)
mais cela me renvoie la valeur de la cellule B2 et non le calcul sur la
ligne 7.
Si vous pouvez m'aiguiller et me dire où je fais des erreurs ?
J'espère être assez clair :-O
Merci de vos prochaines réponses.
DanielH




Philippe.R
Le #21329481
Bonjour,
Peux tu publier, via cijoint, un classeur représentatif de tes données et de
ce que tu veux obtenir ?
Il sera ainsi plus "zezedede"
;o)
--
Avec plaisir
http://dj.joss.free.fr/trombine.htm
http://jacxl.free.fr/mpfe/trombino.html
Philippe.R
Pour se connecter au forum :
http://www.excelabo.net/web/mpfe
News://news.microsoft.com/microsoft.public.fr.excel
"daniel" news:
Bonjour,
Merci, mais cela me renvoie un joli #REF!...



"Philippe.R"
Bonjour,
La fonction indirect() renvoie le contenu d'une cellule donnée en
référence.
Regarde de ce côté (non testé) :
=CHOISIR(2;indirect($B$1);indirect($B$2);indirect($B$3);...)
à adapter
--
Avec plaisir
http://dj.joss.free.fr/trombine.htm
http://jacxl.free.fr/mpfe/trombino.html
Philippe.R
Pour se connecter au forum :
http://www.excelabo.net/web/mpfe
News://news.microsoft.com/microsoft.public.fr.excel
"daniel" news:
Bonjour,
Le but du jeu est de rapprocher 2 listes (1 de 2000 lignes, l'autre de
6000 lignes).
Dans chaque liste il y a des noms, mais pas forcément identiques (MARTIN
DUPOND et liste 2 MARTIN.M DUPOND.T RAYMOND H.)
Pour essayer de faire le rapprochement, j'ai isolé chaque nom dans une
cellule sur la même ligne dans les 2 listes.
Colonne F MARTIN, Col.G DUPOND, dans la 2 e liste, même chose Col.E
MARTIN, Col.G DUPOND , Col.I RAYMOND.
Donc je souhaite faire un calcul :
Afin d'éviter de recopier j'aimerais utiliser la fonction choisir, qui
utilisera la formule voulue, de 1 à 7.
B1 = SOMMEPROD(--(C1=_1NIJ))
B2 = SOMMEPROD((C2=_1NIJ)*(E2=_1NIJ))
B3 = SOMMEPROD((C3=_1NIJ)*(E3=_1NIJ)*(G3=_1NIJ))
etc...
=CHOISIR(2;$B$1;$B$2;$B$3;$B$4;$B$5;$B$6;$B$7)
mais cela me renvoie la valeur de la cellule B2 et non le calcul sur la
ligne 7.
Si vous pouvez m'aiguiller et me dire où je fais des erreurs ?
J'espère être assez clair :-O
Merci de vos prochaines réponses.
DanielH








daniel
Le #21356901
Bonsoir,
Désolé pour le retard.
Je revois tout ça et je posterai un message d'ici peu.
Encore merci.
DanielH

"Philippe.R"
Bonjour,
Peux tu publier, via cijoint, un classeur représentatif de tes données et
de ce que tu veux obtenir ?
Il sera ainsi plus "zezedede"
;o)
--
Avec plaisir
http://dj.joss.free.fr/trombine.htm
http://jacxl.free.fr/mpfe/trombino.html
Philippe.R
Pour se connecter au forum :
http://www.excelabo.net/web/mpfe
News://news.microsoft.com/microsoft.public.fr.excel
"daniel" news:
Bonjour,
Merci, mais cela me renvoie un joli #REF!...



"Philippe.R" news:
Bonjour,
La fonction indirect() renvoie le contenu d'une cellule donnée en
référence.
Regarde de ce côté (non testé) :
=CHOISIR(2;indirect($B$1);indirect($B$2);indirect($B$3);...)
à adapter
--
Avec plaisir
http://dj.joss.free.fr/trombine.htm
http://jacxl.free.fr/mpfe/trombino.html
Philippe.R
Pour se connecter au forum :
http://www.excelabo.net/web/mpfe
News://news.microsoft.com/microsoft.public.fr.excel
"daniel" news:
Bonjour,
Le but du jeu est de rapprocher 2 listes (1 de 2000 lignes, l'autre de
6000 lignes).
Dans chaque liste il y a des noms, mais pas forcément identiques
(MARTIN DUPOND et liste 2 MARTIN.M DUPOND.T RAYMOND H.)
Pour essayer de faire le rapprochement, j'ai isolé chaque nom dans une
cellule sur la même ligne dans les 2 listes.
Colonne F MARTIN, Col.G DUPOND, dans la 2 e liste, même chose Col.E
MARTIN, Col.G DUPOND , Col.I RAYMOND.
Donc je souhaite faire un calcul :
Afin d'éviter de recopier j'aimerais utiliser la fonction choisir, qui
utilisera la formule voulue, de 1 à 7.
B1 = SOMMEPROD(--(C1=_1NIJ))
B2 = SOMMEPROD((C2=_1NIJ)*(E2=_1NIJ))
B3 = SOMMEPROD((C3=_1NIJ)*(E3=_1NIJ)*(G3=_1NIJ))
etc...
=CHOISIR(2;$B$1;$B$2;$B$3;$B$4;$B$5;$B$6;$B$7)
mais cela me renvoie la valeur de la cellule B2 et non le calcul sur la
ligne 7.
Si vous pouvez m'aiguiller et me dire où je fais des erreurs ?
J'espère être assez clair :-O
Merci de vos prochaines réponses.
DanielH











Publicité
Poster une réponse
Anonyme