Fonction MAX

Le
Michel MTO
Bonjour à toutes et à tous,

j'utilise ceci : =MAX($D$17;$L$17;$D$35;$K$35;$Q$35) en E40

Cela me ramène le nombre le plus grand. Jusque là tout va bien.

Je voudrais récupérer l'adresse relative de ce nombre ($D$17 ou $L$17 ou
$D$35 ou $K$35 ou $Q$35) pour la réutiliser dans la fonction suivante :

=INDEX({"Méthode 1";"Méthode 2";"Méthode 3";"Méthode 4";"Méthode
5"};EQUIV(E40;{"$D$17";"$L$17";"$D$35";"$K$35";"$Q$35"};0)) => je
remplacerai E40 par cette adresse :

J'ai essayé ceci :

=INDEX({"Méthode 1";"Méthode 2";"Méthode 3";"Méthode 4";"Méthode
5"};EQUIV(MAX($D$17;$L$17;$D$35;$K$35;$Q$35);{"$D$17";"$L$17";"$D$35";"$K$35
";"$Q$35"};0))

mais cela me retourne #N/A

Quelqu'un peut il m'éclairer

merci

Michel MTO
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Fredo P.
Le #21642621
Peut être cette solution, mettre cette formule dans un module
Function trouv(x) As String
trouv = Cells.Find(What:=x, After:¬tiveCell, LookIn:=xlFormulas, LookAt:=
_
xlPart, SearchOrder:=xlByRows, SearchDirection:=xlNext,
MatchCase:úlse _
, SearchFormat:úlse).Address
End Function
et dans une cellule:
=trouv(MAX($D$17;$L$17;$D$35;$K$35;$Q$35))
"Michel MTO" hr6og7$jrl$
Bonjour à toutes et à tous,

j'utilise ceci : =MAX($D$17;$L$17;$D$35;$K$35;$Q$35) en E40

Cela me ramène le nombre le plus grand. Jusque là tout va bien.

Je voudrais récupérer l'adresse relative de ce nombre ($D$17 ou $L$17 ou
$D$35 ou $K$35 ou $Q$35) pour la réutiliser dans la fonction suivante :

=INDEX({"Méthode 1";"Méthode 2";"Méthode 3";"Méthode 4";"Méthode
5"};EQUIV(E40;{"$D$17";"$L$17";"$D$35";"$K$35";"$Q$35"};0)) => je
remplacerai E40 par cette adresse :

J'ai essayé ceci :

=INDEX({"Méthode 1";"Méthode 2";"Méthode 3";"Méthode 4";"Méthode
5"};EQUIV(MAX($D$17;$L$17;$D$35;$K$35;$Q$35);{"$D$17";"$L$17";"$D$35";"$K$35
";"$Q$35"};0))

mais cela me retourne #N/A

Quelqu'un peut il m'éclairer

merci

Michel MTO


Tatanka
Le #21642851
Salut Michel,

Une suggestion :
1) Dans un module :
Function ref(plage As String) As String
Application.Volatile
For Each c In Range(plage)
If c.Value = Application.Max(Range(plage)) Then
ref = c.Address
Exit Function
End If
Next c
End Function
2) Dans une cellule
=ref("D17,L17,D35,K35,Q35")

Serge


"Michel MTO"
Bonjour à toutes et à tous,

j'utilise ceci : =MAX($D$17;$L$17;$D$35;$K$35;$Q$35) en E40

Cela me ramène le nombre le plus grand. Jusque là tout va bien.

Je voudrais récupérer l'adresse relative de ce nombre ($D$17 ou $L$17 ou
$D$35 ou $K$35 ou $Q$35) pour la réutiliser dans la fonction suivante :

=INDEX({"Méthode 1";"Méthode 2";"Méthode 3";"Méthode 4";"Méthode
5"};EQUIV(E40;{"$D$17";"$L$17";"$D$35";"$K$35";"$Q$35"};0)) => je
remplacerai E40 par cette adresse :

J'ai essayé ceci :

=INDEX({"Méthode 1";"Méthode 2";"Méthode 3";"Méthode 4";"Méthode
5"};EQUIV(MAX($D$17;$L$17;$D$35;$K$35;$Q$35);{"$D$17";"$L$17";"$D$35";"$K$35
";"$Q$35"};0))

mais cela me retourne #N/A

Quelqu'un peut il m'éclairer

merci

Michel MTO


Charabeuh
Le #21645221
Bjr,

Et pourquoi pas ?:
=SI(D17ä0;"Méthode 1";SI(L17ä0;"Méthode 2";SI(D35ä0;"Méthode
3";SI(K35ä0;"Méthode 4";SI(Q35ä0;"Méthode 5")))))

avec en E40
=MAX(D17;L17;D35;K35;Q35)



"Michel MTO" discussion : hr6og7$jrl$
Bonjour à toutes et à tous,

j'utilise ceci : =MAX($D$17;$L$17;$D$35;$K$35;$Q$35) en E40

Cela me ramène le nombre le plus grand. Jusque là tout va bien.

Je voudrais récupérer l'adresse relative de ce nombre ($D$17 ou $L$17 ou
$D$35 ou $K$35 ou $Q$35) pour la réutiliser dans la fonction suivante :

=INDEX({"Méthode 1";"Méthode 2";"Méthode 3";"Méthode 4";"Méthode
5"};EQUIV(E40;{"$D$17";"$L$17";"$D$35";"$K$35";"$Q$35"};0)) => je
remplacerai E40 par cette adresse :

J'ai essayé ceci :

=INDEX({"Méthode 1";"Méthode 2";"Méthode 3";"Méthode 4";"Méthode
5"};EQUIV(MAX($D$17;$L$17;$D$35;$K$35;$Q$35);{"$D$17";"$L$17";"$D$35";"$K$35
";"$Q$35"};0))

mais cela me retourne #N/A

Quelqu'un peut il m'éclairer

merci

Michel MTO


Michel MTO
Le #21647041
Merci à tous les 3,
je vais opter pour la solution de Charabeuh, je voulais éviter le Vba sur
cette affaire.

Certaines fois on veut vraiment se compliquer l'existence, alors que l'on
peut faire simplement.
merci encore et bonne journée

Michel MTO

"Charabeuh" news:OjcY%
Bjr,

Et pourquoi pas ?:
=SI(D17ä0;"Méthode 1";SI(L17ä0;"Méthode 2";SI(D35ä0;"Méthode
3";SI(K35ä0;"Méthode 4";SI(Q35ä0;"Méthode 5")))))

avec en E40
=MAX(D17;L17;D35;K35;Q35)



"Michel MTO"

de
discussion : hr6og7$jrl$
> Bonjour à toutes et à tous,
>
> j'utilise ceci : =MAX($D$17;$L$17;$D$35;$K$35;$Q$35) en E40
>
> Cela me ramène le nombre le plus grand. Jusque là tout va bien.
>
> Je voudrais récupérer l'adresse relative de ce nombre ($D$17 ou $L$17 ou
> $D$35 ou $K$35 ou $Q$35) pour la réutiliser dans la fonction suivante :
>
> =INDEX({"Méthode 1";"Méthode 2";"Méthode 3";"Méthode 4";"Méthode
> 5"};EQUIV(E40;{"$D$17";"$L$17";"$D$35";"$K$35";"$Q$35"};0)) => je
> remplacerai E40 par cette adresse :
>
> J'ai essayé ceci :
>
> =INDEX({"Méthode 1";"Méthode 2";"Méthode 3";"Méthode 4";"Méthode
>


5"};EQUIV(MAX($D$17;$L$17;$D$35;$K$35;$Q$35);{"$D$17";"$L$17";"$D$35";"$K$35
> ";"$Q$35"};0))
>
> mais cela me retourne #N/A
>
> Quelqu'un peut il m'éclairer
>
> merci
>
> Michel MTO
>
>
Publicité
Poster une réponse
Anonyme